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About this book

This book explains how to access and utilize software configuration managers
(SCMs) using Common Access Repository Manager (CARMA) from within
WebSphere® Developer for zSeries® (WD/z). It includes the following topics:

¢ How to establish a connection to an SCM
* How to extract repository content to a project
* How to perform common SCM tasks with CARMA

You can use this document as a guide or reference to these tasks.

Who should read this book

This book is intended for WD/z users who would like to learn how to use
CARMA from within WD/ z.

To use this book, you need basic knowledge of or experience with SCMs.
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Chapter 1. CARMA concepts

Many mainframe user organizations store their source code in proprietary software
configuration management systems, also known as software configuration
managers (SCMs). The source code is locked in the SCM, in a native format that
WD/z cannot access in an integrated manner. The Common Access Repository
Manager (CARMA) toolkit for WD/z facilitates customer access to SCMs from
within WD/z by providing a common interface for accessing SCMs.

To leverage this common access framework, a CARMA client (such as the one
integrated into WD/z) must connect to a CARMA host, which manages SCM
access using repository access managers (RAMs). RAMs are plug-ins that help the
CARMA host communicate with individual SCMs. In order to access a given SCM
through CARMA, the CARMA host must first have the appropriate RAM installed
on it. CARMA currently ships with only one RAM, which provides access to
partitioned data sets (PDSs). Access to other SCMs through CARMA can be
achieved if the appropriate RAM is obtained or developed.

CARMA host

A CARMA host is a host machine that runs a CARMA server. CARMA hosts have
a set of repository access managers, which define the types of repository
connections the host is capable of making.

Repository access manager

A repository access manager (RAM) provides connections to a specific type of
SCM, such as SCLM.

Repository instance

A repository instance (RI) represents a project or component that exists in an SCM.
The connection to each repository instance is based on a RAM. In the following
illustration, there are four Rls (each representing a PDS data set in this example)
that use the PDS RAM to define their connections.
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Figure 1. Repository instances

You can perform the following actions on repository instances:
* Extract a repository instance to a project
* Add a repository instance to project

Related information

[‘Extract” on page 1§|
["Add to Project” on page 15]

Repository content

Repository content represents members held by an SCM. Content can be individual
files or containers that contain other content. The nature of repository content
depends on the SCM it originates from and the RAM used to connect to the SCM.
For example, for the PDS RAM shown in the illustration below, the repository
content is consists of individual PDS members.
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Figure 2. Repository content

You can perform the following actions on repository content:
* Refresh the content
¢ Lock the content to prevent access by other users
* Unlock the content to allow access by other users
* Check the content into the repository
¢ Check the content out of the repository
Related information
[‘Refresh” on page 15
[‘Lock” on page 17|

[‘Unlock” on page 18|
[‘Check In” on page 1§
[‘Check Out” on page 18|
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Chapter 2. CARMA actions

CARMA actions are available in the context menus for the CARMA Repositories
view as well as for WD/ z projects that have been extracted from CARMA
repositories (see ““Extract” on page 16[").

Opening the CARMA Repositories view

Users access the CARMA system in WD/z from the CARMA Repositories view. In
order to access CARMA, it is necessary to create a connection to the CARMA host.
Once the host connection is established, users can view the available repository
access managers, repository instances, and repository content.

To open the CARMA Repositories view, follow these steps:
1. From the Window menu, click Show View > Other. The Show View dialog
opens.

2. In the Show View dialog, expand the CARMA folder, select CARMA
Repositories, and click OK.
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Figure 3. Selecting the CARMA Repositories view

The CARMA view opens in the lower-right corner of the current perspective.
This view lists the existing connections to CARMA hosts and can be included
in any perspective available within WD/ z.
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Figure 4. CARMA Repositories view

Connecting to CARMA

CARMA requires a connection to a CARMA host in order to retrieve SCM
information from the host. CARMA uses the connection services of the WD/z
Remote System Explorer (RSE) to connect to the host. To create a new CARMA
connection, follow these steps:

1. In the CARMA Repositories view do one of the following:

¢ (Click the New Connection button .
* Right-click inside the view and click New Connection.
The New CARMA Connection wizard opens.
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Figure 5. New CARMA connection wizard

2. Choose one of the options from the list and click Next.

3. If you chose to create a new CARMA connection from an existing RSE
connection the following dialog opens:
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Figure 6. New CARMA connection wizard

Choose the RSE connection you want to create a CARMA connection from
using the drop-down list and provide a name for the new CARMA
connection. By default, the name of the existing RSE connection is used for the
name of the CARMA connection. This is the label that will be used for the
connection in the CARMA repositories view. Skip to step 8.

4. If you chose to create a new RSE and CARMA connection the New Remote
z/0S System Connection wizard opens.

Note: If this is the first time that you have attempted to create a connection in
RSE, you will not see the dialog below yet, but will instead be prompted to
create a profile before you can create the new connection.
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Figure 7. New connection dialog

5. Complete the following fields in this dialog:

Parent profile
The profile named after your workstation appears by default. To
choose a different profile, select a predefined profile from the
drop-down list. After you create the connection, you can share this
profile to allow other users to have this connection in their RSE
perspective.

Connection name
A unique name to identify your connection in the Remote Systems
view. For example, Development System or Test System. The label that
you assign to this connection will help you to differentiate between
multiple connections to the same type of remote system.

Host name
The hostname or IP address of the z/OS system that your RSE server
is installed on.

Description
A short description of the z/OS system that you want to connect to,
for example, Development System or Test System. The description that
you assign to this remote system will help you to differentiate
between multiple remote systems of the same type.
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Verify host name (optional)
To verify that the hostname or IP address in the Host name field is
valid, select the Verify host name check box.

6. Do one of the following:

 If you don’t need to configure any JES or USS files subsystem properties,
skip to step 8.

* Click Next to proceed to the JES SubSystem Properties page.

JES

Define subswstem information I |

...........

JES Job Monitor Port | 6715

Maix Murnber of Lines to Download | a000

< Back Mext = Finish Cancel

Figure 8. JES subsystem properties dialog

In the JES tab:

a. In the JES Job Monitor Port field, type the port on which the Remote Job
Monitor is listening.

b. In the Max Number of Lines to Download field, type the number of
lines to download before prompting you to specify if you want to
download all of the lines in the dataset.

7. Do one of the following:

* If you don’t need to configure any USS files subsystem properties, skip to
step 8.

* Click Next to proceed to the USS Files SubSystem Properties page.

Chapter 2. CARMA actions 11
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Figure 9. USS files subsystem properties dialog

In the Server Launcher Settings tab, specify the default method for
launching the remote server:

— To automatically start the RSE host server using a server daemon:
a. Click the Remote daemon radio button.

Note: You must start the server daemon using the root user ID. If you
do not start the server using the root user ID, it cannot authenticate
users who are trying to connect to the server.

b. In the Daemon Port field, type the port number that is used by the
server daemon on the remote host. By default, port 4035 appears.

— To automatically start the RSE host server using an REXEC command:
a. Click the REXEC radio button.
b. In the Path to installed server on host field, type the path where the
RSE host server is installed on the remote host. You can specify a
path that is relative to the directory where you run the REXEC

command or the full path to the location where the server is installed.
For example, dstore or /usr/bin/dstore.

. In the Server launch command field, type the name of the script file
to run when you use the REXEC command to start the RSE host
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server. By default, server.zseries appears; this is the sample script file
that is shipped with IBM TPF Toolkit for WebSphere Studio to start
the RSE host server.

d. In the Port field, type the port number that is used by the REXEC
daemon on the remote host. By default, port 512 appears.

— To connect to an RSE host server that you start manually:

a. Click the Connect to running server radio button. If your remote
system is not configured to use REXEC to start the RSE host server,
this option allows you to connect to an RSE host server that you start
manually.

Note: When you start the RSE host server manually on the remote

host, you can configure it to receive connection requests at a specified

port or to use the next available port on the system. The port number

used by the server is displayed when you start the server. After you

start the server, you must specify that port number in the Subsystem

properties page before you can connect. To access the Subsystem

properties page:

1) Switch to the RSE perspective.

2) In the Remote Systems view, double-click the z/OS connection to
expand it and reveal the USS Files subsystem.

3) Right-click the USS Files node and select Properties from the
pop-up menu to open the Properties for USS Files dialog box.

4) In the left navigation pane, click Subsystem to open the
Subsystem properties page.

8. Click Finish to create the new CARMA connection and add it to the CARMA
Repositories view.
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Figure 10. New CARMA connection

9. To activate the connection, do one of the following:
* Right-click on the connection and select the Connect menu item.
 Alternatively, you can activate a connection by expanding the connection by
clicking the + next to the connection name. Note that this method will only
work the first time you are connecting to this CARMA host. Use the

previous method to explicitly connect to the CARMA host for subsequent
connection attempts.

Note: Attempting to perform any action on the elements under a CARMA
connection will automatically activate the connection.
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10. In the Enter Password dialog, type a valid user name and password and click
OK. A list of repository access managers (RAMs) appears under the CARMA
host in the CARMA Repositories view.
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Figure 11. Repository access managers

Related information

‘Disconnecting from CARMA]|
‘Connecting to a RAM” on page 15
‘Disconnecting from a RAM” on page 15|

Disconnecting from CARMA

It is possible to disconnect from a CARMA host after connecting to it. To
disconnect from a CARMA host, follow these steps:

1. Right-click on the CARMA host in the CARMA Repositories view.
2. Click Disconnect in the context menu. The icon next to the CARMA host name
should change to ‘j .
Related information
[‘Connecting to CARMA” on page 7|
[‘Connecting to a RAM” on page 15
[‘Disconnecting from a RAM” on page 15

Deleting a CARMA connection

To delete a CARMA connection, do one of the following actions from the CARMA
Repositories view:
* Select the connection you want to delete and press the Delete key.

* Right-click the connection name and click Delete. The connection is removed
from the CARMA Repositories view.
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Connecting to a RAM

Before you can perform actions on repository content, you must connect to the
RAM used to access that repository content. The CARMA system will attempt to
automatically connect to the appropriate RAM whenever an operation on
repository content is performed. Alternatively, you can explicitly connect to a RAM
by following these steps:

1. Right-click on the RAM in the CARMA Repositories view.

2. Click Connect in the context menu. If you are not already connected to the
CARMA host for the RAM, the Enter Password dialog opens.

3. In the Enter Password dialog, type a valid user name and password and click
OK.
4. The icon next to the RAM name should change to o .
Related information
[‘Connecting to CARMA” on page 7|
[‘Disconnecting from CARMA” on page 14|
[‘Disconnecting from a RAM”|

Disconnecting from a RAM

It is possible to disconnect from individual RAMs within a CARMA host. To
disconnect from a RAM, follow these steps:

1. Right-click on the RAM in the CARMA Repositories view.
2. Click Disconnect in the context menu. The icon next to the RAM name should

change to [J .

Related information

[‘Connecting to CARMA” on page 7|
[‘Disconnecting from CARMA” on page 14|
[‘Connecting to a RAM”|

Refresh

Users can refresh any item displayed in the CARMA Repositories view. The
Refresh task contacts the CARMA host to obtain the most recent information
relating to:

 List of RAMs

» List of RIs

* New respository content

The Refresh task adds and removes any content that has been changed in the SCM
by other users since the last refresh action, and refreshes the names and properties

of the content.
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Extract

Repository instances can be extracted to a WD/z project to provide a copy of the
RI content that users can manipulate locally without updating host contents. To
extract a repository instance to a WD/z project follow these steps:

1. Right-click the repository instance in the CARMA repositories view.
2. Click Extract on the context menu.
The Extract dialog opens.

Extract

Please name the project which will hold vour extracted files,

Project name: | SMYERS,MYPDS

Project contents
[v Use default

[Ciooaime _ -

| Einish | Zancel

Figure 12. Extract dialog

3. Type the name of the project to create and the directory in which the files will
be stored locally.

4. Click Finish.
The directory structure and file contents are copied to the local file system. The
WD/ z project containing the newly downloaded repository content is available
in the WD/z Navigator view.

The PDS RAM currently supports extracting files with a record format of “Fixed
Block”.
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Add to Project

Repository instances can be added to an existing WD/z project to provide a copy
of the repository instance content that users can manipulate locally without
updating host contents. To add a repository instance to a WD/z project follow
these steps:

1. Right-click the repository instance in the CARMA repositories view.
2. Click Add to Project .
The Add to Project dialog opens.

I Add to Project @

Add to Project

&dd selected resources to project,

Project: | SHEaalaye)=es ﬂ

| Cancel

Figure 13. Add to Project dialog

3. Select the project to add the repository content to from the drop-down list.
4. Click Finish.

The file hierarchy structure and file contents are copied to the local storage
location for the specified WD/z project. The WD/z project containing the
newly downloaded repository content is available in the WD/z Navigator view.

Lock

The Lock task makes repository content read-only for all users except for the user
who locked the content. To lock repository content, follow these steps:

1. Right-click the content to be locked.

2. Click Team > Lock.
The lock task is sent to the CARMA host and a request is submitted to the
repository to lock the selected content.
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The PDS RAM currently does not support the Lock task.

Unlock
The Unlock task makes repository content editable for all users. The Unlock task is
only available for repository content that is locked by the user. To unlock
repository content, follow these steps:
1. Right-click the content to be unlocked.
2. Click Team > Unlock.
The Unlock task is sent to the CARMA host and a request is submitted to the
repository to unlock the selected content.
The PDS RAM does not currently support the Unlock task.
Check Out
The Check Out task downloads content from the CARMA repository, marks the
content as checked out of the repository, and prevents other users from checking
out that content. The Check Out task is only available for repository content that is
not checked out by the user. To check out repository content, follow these steps:
1. Right-click the content to be checked out.
2. Click Team > Check Out.
The Check Out task is sent to the CARMA host and a request is submitted to
the repository to check out the selected content.
The PDS RAM does not currently support the Check Out task.
Check In

The Check In task updates content in the CARMA repository, marks the content as
checked into the repository, and allows other users to check out that content. The
Check In task is only available for repository content that is checked out by the
user. To check in repository content, follow these steps:

1. Right-click the content to be checked in.

2. Click Team > Check In.

The Check In task is sent to the CARMA host and a request is submitted to the
repository to check in the selected content.

The PDS RAM does not currently support the Check In task.

Upload Local File

The Upload Local File task updates the selected content in the CARMA repository.
The Upload Local File task is available on any repository content that has been
extracted from CARMA. In order to upload repository content:

1. Right-click the content to be uploaded.
2. Click Team > Upload Local File.

The local contents are sent to the CARMA host and stored in the associated
repository.
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The PDS RAM currently supports uploading content with a record format of
“Fixed Block”.

Replace Local File

The Replace Local File task updates the selected content in the local workspace.
The Replace Local File task is available on any repository content that has been
extracted from CARMA. to replace the local version of repository content, follow
these steps:

1. Right-click the content to be replaced.
2. Click Team > Replace Local File.

The repository content is retrieved from the CARMA host and overwrites the
local version of the selected content.

The PDS RAM currently supports replacing files with a record format of “Fixed
Block”.

Member information (metadata)

CARMA allows you to query the CARMA repository for metadata related to
members. To view metadata properties related to repository content, follow these
steps:

1. Right-click the content.
2. Click Properties .
The Properties dialog opens.
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Figure 14. Properties dialog

3. Optional: To retrieve the most recent property values from the repository, click
on the Refresh Properties button.

Disabling unsupported actions

Certain SCMs, due to their limitations, may not support all the actions offered by
CARMA. When users attempt to perform one of these actions, a dialog will open,
providing the option of disabling that action for that specific RAM. The example
dialog that follows is the result of attempting to execute the Lock action on a PDS
data member. Since the Lock action is not supported by the PDS RAM the
following dialog opens, offering the choice of disabling the action in the future.

Unsupported Operation Error [g|

The attempked action is unsupported on resources of this bype by PDS RAM,
Wiould wou like to disable this action in the Future?

....................................

Figure 15. Disable action dialog for the PDS RAM
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Clicking Yes in the example dialog above would disable the Lock action for all
repository instances that use the PDS RAM. The Lock action will still be displayed
in CARMA context menus for PDS RAM content, but it will be disabled.

Related information

[‘Re-enabling disabled unsupported actions”|

Re-enabling disabled unsupported actions

It is possible to re-enable unsupported actions once they have been disabled.
Follow these steps to enable those actions that have been disabled:

1. From the Window menu, click Preferences. The Preferences dialog opens.
2. In the list on the left, click Team > CARMA.
The CARMA preferences pane is displayed on the right.

I Preferences

+- Wworkbench CARMA

+- Ank

- Build Crder - CARMA Actions -
+|- Draka

‘- InskalliUpdate
+- Java

- Logging

+|- LPE¥ Editor

+- Remote Systems
5]

Clear Disabled Actions Memory

RunjDebug

File Cantent
Ignored Resources
+1- 2/035 Solutions

Restore Defaults I Apply |

Import... Export... a4 | Cancel J

Figure 16. CARMA preferences dialog

3. Click on the Clear Disabled Actions Memory button.
Related information

[“Disabling unsupported actions” on page 20|
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Notices

Note to U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP
Schedule Contract with IBM® Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the
products, services, or features discussed in this document in other countries. Consult your local IBM
representative for information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product, program, or service that
does not infringe any IBM intellectual property right may be used instead. However, it is the user’s
responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not give you any license to these patents. You can send
license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this
statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation

P.O. Box 12195, Dept. TL3B/B503/B313
3039 Cornwallis Rd.

Research Triangle Park, NC 27709-2195
US.A.
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Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided
by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or
any equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

This information contains examples of data and reports used in daily business operations. To illustrate
them as completely as possible, the examples may include the names of individuals, companies, brands,
and products. All of these names are fictitious and any similarity to the names and addresses used by an
actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrates
programming techniques on various operating platforms. You may copy, modify, and distribute these
sample programs in any form without payment to IBM, for the purposes of developing, using, marketing
or distributing application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples have not been thoroughly
tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or
function of these programs. You may copy, modify, and distribute these sample programs in any form
without payment to IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.

Each copy or any portion of these sample programs or any derivative work, must include a copyright
notice as follows:

(C) (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. (C)
Copyright IBM Corp. 2000, 2004. All rights reserved.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International Business Machines
Corporation in the United States, or other countries, or both:

+ IBM
* WebSphere
* zSeries

Other company, product, and service names, which may be denoted by a double asterisk(**), may be
trademarks or service marks of others.

(C) Copyright IBM Corporation 2000, 2004. All Rights Reserved.

24 1BM WebSphere Developer for zSeries Version 6.0: Common Access Repository Manager User’s Guide



Readers’ Comments — We’d Like to Hear from You

IBM WebSphere Developer for zSeries Version 6.0
Common Access Repository Manager User’s Guide

Publication No. SC31-6913-00

Overall, how satisfied are you with the information in this book?

Very Satisfied Satisfied Neutral Dissatisfied Very
Dissatisfied
Overall satisfaction O O] ] ] ]

How satisfied are you that the information in this book is:

Very Satisfied Satisfied Neutral Dissatisfied Very
Dissatisfied
Accurate ] | | ] O]
Complete O O ] ] U
Easy to find ] | [l ] ]
Easy to understand O] O | ] ]
Well organized ] [ 0] 0 0
Applicable to your tasks ] ] O] ] ]

Please tell us how we can improve this book:

Thank you for your responses. May we contact you? [] Yes [] No

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any
way it believes appropriate without incurring any obligation to you.

Name Address

Company or Organization

Phone No.
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