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Goals

� This session is intended to acquaint you with how 
to connect the WDI 3.3 Client to the WDI 3.3 
Server database.

� First, we will walk through an example of how to 
connect the WDI 3.3 Client to a WDI 3.3 Server 
database on the same machine.

� Then, we will walk through an example of how to 
connect the WDI 3.3 Client to a WDI 3.3 Server 
database on a different machine.

�Note: You cannot connect a WDI 3.3 Client to a 
WDI 3.2 or lower database.

This session is intended to acquaint you with how to connect the WDI 3.3 Client to the WDI 3.3 
Server database.

First, we will walk through an example of how to connect the WDI 3.3 Client to a WDI 3.3 Server 
database on the same machine.

Then, we will walk through an example of how to connect the WDI 3.3 Client to a WDI 3.3 
Server database on a different machine.

Note: You cannot connect a WDI 3.3 Client to a WDI 3.2 or lower database.
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WDI 3.3 Client / Server Database Connect Pre-Reqs

Pre-requisites, you must have: 

�WebSphere Data Interchange V3.3 Client installed.

�DB2 V8.2 (or higher) UDB Workgroup or Enterprise 
Edition installed

�WebSphere Data Interchange V3.3 MP Server for 
Windows installed and the Server (DB2) database 

setups successfully completed.

As a pre-requisite to beginning this process, you must have: 

1)WebSphere Data Interchange V3.3 Client installed.

2) DB2 V8.2 (or higher) UDB Workgroup or Enterprise Edition installed

3) and have WebSphere Data Interchange V3.3 MP Server for Windows installed and the Server 
(DB2) database setups successfully completed.
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WDI 3.3 Client / Same Server Database Connect

� Let’s begin by walking through an example of 
connecting the WDI 3.3 Client to a WDI 3.3 Server 
database on the same machine.  

�As the WDI 3.3 Client runs on Windows, then the 

WDI 3.3 Server in this case will also be on a 
Windows machine.

Let’s begin by walking through an example of connecting the WDI 3.3 Client to a WDI 3.3 Server 
database on the same machine.  

As the WDI 3.3 Client runs on Windows, then the WDI 3.3 Server in this case will also be on a 
Windows machine.
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WDI 3.3 Client / Same Server Database Connect

� If you are setting up the WDI Client on the same machine as the WDI Server; 

� On the menu bar, click Start > All Programs > IBM DB2 >  Set-up Tools > 
Configuration Assistant .

If you are setting up the WDI Client on the same machine as the WDI Server; 

On the menu bar, click Start > All Programs > IBM DB2 >  Set-up Tools > Configuration 
Assistant .
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WDI 3.3 Client / Same Server Database Connect

� This will result in the DB2 “Configuration Assistant” window being opened. 

� Select the WDI 3.3 database (default name is EDIEC33E) and double-click to open the 
Change Database Wizard. 

This will result in the DB2 “Configuration Assistant” window being opened. 

Select the WDI 3.3 database (default name is EDIEC33E) and double-click to open the Change 
Database Wizard. 



IBM Software Group Page 7 of 14

IBM Software Group

7

WDI Database Connection © 2007 IBM Corporation

WDI 3.3 Client / Same Server Database Connect

� This should result in the “Select a communications protocol” screen 

being displayed (as shown in the example below). Verify that the

“Local” radio button is selected and press the Next > button.

This should result in the “Select a communications protocol” screen being displayed (as 
shown in the example below). 

Verify that the “Local” radio button is selected and press the Next > button.
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WDI 3.3 Client / Same Server Database Connect

� This should result in the “Specify information for a database on this system”
screen being displayed (as shown in the example below). 

� Verify that the “Database in the current instance” radio button is selected and 
press the Next > button.

This should result in the “Specify information for a database on this system” screen being 
displayed (as shown in the example below). 

Verify that the “Database in the current instance” radio button is selected and press the Next 
> button.
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WDI 3.3 Client / Same Server Database Connect

� This should result in the “Specify the name of the database to which you want to 
connect” screen being displayed (as shown in the example below). 

� Verify that the Database Name and Database Alias are correct and press the Next >
button.

This should result in the “Specify the name of the database to which you want to connect”
screen being displayed (as shown in the example below). 

Verify that the Database Name and Database Alias are correct and press the Next > button.

Note: EDIEC33E is the default database name when setting up WDI 3.3.  

You may choose this name or use another unique value. An example of using a name that is 
different than the default name that may be of use would if you are running multiple (test, 
integration, production) WDI 3.3 databases on the same machine.
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WDI 3.3 Client / Same Server Database Connect

� This should result in the “Register this database as a data source”
screen being displayed (as shown in the example below). 

� Verify that the Data Source Name is correct and that the Register this 
database for ODBC is checked and press the Finish button.

This should result in the “Register this database as a data source” screen being displayed (as 
shown in the example below). 

Verify that the Data Source Name is correct and that the Register this database for ODBC is
checked and press the Finish button.
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WDI 3.3 Client / Same Server Database Connect

� Next, start up the WDI 3.3 Client. 

� This may be done via Start > All Programs > IBM WebSphere Data Interchange V3.3 Client > WDI 
V3.3 Client or by selecting the WDI 3.3 Client icon on your desktop. 

� This should result in the WDI 3.3 Client Main window being displayed.

Next, start up the WDI 3.3 Client. 

This may be done via Start > All Programs > IBM WebSphere Data Interchange V3.3 Client 
> WDI V3.3 Client or by selecting the WDI 3.3 Client icon on your desktop. 

This should result in the WDI 3.3 Client Main window being displayed.
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WDI 3.3 Client / Same Server Database Connect

� Next, select View > Administration > Systems… from the 
Toolbar on the WDI 3.3 Client.

Next, select View > Administration > Systems… from the Toolbar on the WDI 3.3 Client.
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WDI 3.3 Client / Same Server Database Connect

� This should result in the Configuration Systems window being displayed. 

� Select either File\New… or select the Create a New object icon/button to add 
the EDIEC33E WDI 3.3 system/database.

This should result in the Configuration Systems window being displayed. 

Select either File\New… or select the Create a New object icon/button to add the EDIEC33E
WDI 3.3 system/database.



IBM Software Group Page 14 of 14

IBM Software Group

14

WDI Database Connection © 2007 IBM Corporation

WDI 3.3 Client / Same Server Database Connect

� This should result in the Configuration - System - untitled
window being displayed. 

This should result in the Configuration - System - untitled window being displayed. 
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WDI 3.3 Client / Same Server Database Connect

� Input the value EDIEC33E in the System Name field or 
whatever value you will be referencing the system by in the 

future (example: My WDI 3.3).

� Input a value in the Description field if you wish to.

� Select a value of Windows in the dropdown list of the 

Server Platform field.

� Select the value EDIEC33E in the dropdown list of the Data 

Source Name field.

� Input a value of EDIENU33 in the Database Qualifier field.

� Select File\Save on the Tool bar or press the Save the 
Active object icon/button.

Input the value EDIEC33E in the System Name field or whatever value you will be referencing 
the system by in the future (example: My WDI 3.3).

Input a value in the Description field if you wish to.

Select a value of Windows in the dropdown list of the Server Platform field.

Select the value EDIEC33E in the dropdown list of the Data Source Name field.

Input a value of EDIENU33 in the Database Qualifier field.

Select File\Save on the Tool bar or press the Save the Active object icon/button.
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WDI 3.3 Client / Same Server Database Connect

� The WDI 3.3 Server database has now been defined to the 
WDI 3.3 Client.

� To access the database via the WDI 3.3 Client, select the 
value that you specified for the WDI 3.3 database (using 
our example of EDIEC33E) from the System dropdown list 
on the Tool bar.

� You may be prompted to logon to the WDI 3.3 Server 
database the first time that you access it. 

� You can set up in ODBC to have the User ID and Password 
already provided instead of being prompted. 

� However, you will need to update these values whenever a 
User ID or Password is changed for the DB2 database. 

The WDI 3.3 Server database has now been defined to the WDI 3.3 Client.

To access the database via the WDI 3.3 Client, select the value that you specified for the WDI 
3.3 database (using our example of EDIEC33E) from the System dropdown list on the Tool bar.

You may be prompted to logon to the WDI 3.3 Server database the first time that you access it. 

You can set up in ODBC to have the User ID and Password already provided instead of being 
prompted. 

However, you will need to update these values whenever a User ID or Password is changed for 
the DB2 database.
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WDI 3.3 Client / Same Server Database Connect

� This is the end of the WDI 3.3 Client to WDI 3.3 
Server Database Connect on the same machine 

walk through.

This is the end of the WDI 3.3 Client to WDI 3.3 Server Database Connect on the same machine 
walk through.
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WDI 3.3 Client / Remote Server Database Connect

�Now, let’s walk through an example of how to 
connect the WDI 3.3 Client to a WDI 3.3 Server 
database on a different/remote machine.  

�WDI 3.3 Client runs on Windows, but the WDI 3.3 

Server (DB2) database may on Windows, AIX or 
z/OS.

Now, let’s walk through an example of how to connect the WDI 3.3 Client to a WDI 3.3 Server 
database on a different/remote machine.  

WDI 3.3 Client runs on Windows, but the WDI 3.3 Server (DB2) database may on Windows, AIX 
or z/OS.
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WDI 3.3 Client / Remote Server Database Connect

� If you are setting up the WDI Client on a different machine than the WDI Server 
database; start by opening the DB2 Configuration Assistant. 

� On the menu bar, click Start > All Programs > IBM DB2 >  Set-up Tools > 
Configuration Assistant .

If you are setting up the WDI Client on a different machine than the WDI Server database; start 
by opening the DB2 Configuration Assistant. 

On the menu bar, click Start > All Programs > IBM DB2 >  Set-up Tools > Configuration 
Assistant .
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WDI 3.3 Client / Remote Server Database Connect

� This will result in the DB2 Configuration Assistant window 
being opened.

This will result in the DB2 Configuration Assistant window being opened.
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WDI 3.3 Client / Remote Server Database Connect

� Select the Selected option on the Tool bar and choose the 
“Add Database Using Wizard…” option.

Select the Selected option on the Tool bar and choose the “Add Database Using Wizard…”
option.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in starting the Add Database Wizard with the “Select how 
you want to set up a connection” screen being displayed (as shown in the 
example below). 

� Select the “Manually configure a connection to a database” radio button and 
press the Next > button.

This should result in starting the Add Database Wizard with the “Select how you want to set 
up a connection” screen being displayed (as shown in the example below). 

Select the “Manually configure a connection to a database” radio button and press the Next 
> button.
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WDI 3.3 Client / Remote Server Database Connect

• This should result in the “Select a communications protocol” screen being 
displayed (as shown in the example below). 

• Select the “TCP/IP” radio button and press the Next > button.

� Note: If the WDI 3.3 Server database resides on z/OS, check “The database 
physically resides on a host or OS/400 system” checkbox.

This should result in the “Select a communications protocol” screen being displayed (as 
shown in the example below). 

Select the “TCP/IP” radio button and press the Next > button.

Note: If the WDI 3.3 Server database resides on z/OS, check “The database physically 
resides on a host or OS/400 system” checkbox.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Specify TCP/IP communication parameters”
screen being displayed (as shown in the example below). 

� Input the hostname of the machine that the WDI 3.3 database resides 
on and port number and press the Next > button.

This should result in the “Specify TCP/IP communication parameters” screen being displayed 
(as shown in the example below). 

Input the hostname of the machine that the WDI 3.3 database resides on and port number and 
press the Next > button.

Note: Port Number - Windows default value is usually 50000, AIX might be 9050.  If you are not 
sure for the machine and database that you are attempting to connect to, consult your database 
administrator for the correct number.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Specify the name of the database to which you want to connect” screen 
being displayed (as shown in the example below). 

� Input the name of the WDI 3.3 database that you are attempting to connect to in the Database name
field and then specify a unique value for the Database alias field and press the Next > button.

� Note: You may want to identify the database in the Comments field.

This should result in the “Specify the name of the database to which you want to connect”
screen being displayed (as shown in the example below). 

Input the name of the WDI 3.3 database that you are attempting to connect to in the Database 
name field and then specify a unique value for the Database alias field and press the Next >
button.

Note: You may want to identify the database in the Comments field.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Register this database as a data source” screen 
being displayed (as shown in the example below).  

� Ensure that the Register this database for ODBC checkbox is checked, the 
As system data source radio button is selected, the Data source name field 
has the correct system name and press the Next > button.

This should result in the “Register this database as a data source” screen being displayed (as 
shown in the example below).  

Ensure that the Register this database for ODBC checkbox is checked, the As system data 
source radio button is selected, the Data source name field has the correct system name and 
press the Next > button.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Specify the node options” screen being displayed 
(as shown in the example below).  

� Select the appropriate value in the dropdown list of the Operating system 
(example: Windows), ensure that the Instance name field has a value of DB2 
and press the Next > button.

This should result in the “Specify the node options” screen being displayed (as shown in the 
example below).  

Select the appropriate value in the dropdown list of the Operating system (example: 
Windows), ensure that the Instance name field has a value of DB2 and press the Next >
button.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Specify the system options” screen being displayed (as shown 
in the example below).  

� Input the appropriate value in the System name, ensure that the Host name field has the 
correct value and the Operating system value is correct and press the Finish button.

This should result in the “Specify the system options” screen being displayed (as shown in the 
example below).  

Input the appropriate value in the System name, ensure that the Host name field has the 
correct value and the Operating system value is correct and press the Finish button.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the “Add Database 
Confirmation” screen being displayed 
(as shown in the example below). 

� Press the Test Connection button to 
verify connectivity to the specified 
Database.

� This will result in the “Test Connection”
window being displayed. Input a valid 
value for the User ID and Password and 
press the Test Connection button. If you 
setup correctly and provided valid User 
ID and Password values, you should get 
“CLI connection tested successfully.”

� After validating the Connection, press the 
Cancel button on the Test Connection
window.

� When completed, press the Close button 
on the Add Database Conformation
window.

This should result in the “Add Database Confirmation” screen being displayed (as shown in 
the example below). 

Press the Test Connection button to verify connectivity to the specified Database.

This will result in the “Test Connection” window being displayed. Input a valid value for the 
User ID and Password and press the Test Connection button. 

If you setup correctly and provided valid User ID and Password values, you should get “CLI 
connection tested successfully.”

After validating the Connection, press the Cancel button on the Test Connection window.

When completed, press the Close button on the Add Database Conformation window.
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WDI 3.3 Client / Remote Server Database Connect

� Next, start up the WDI 3.3 Client. 

� This may be done via Start > All Programs > IBM WebSphere Data Interchange V3.3 Client > WDI 
V3.3 Client or by selecting the WDI 3.3 Client icon on your desktop. 

� This should result in the WDI 3.3 Client Main window being displayed.

Next, start up the WDI 3.3 Client. 

This may be done via Start > All Programs > IBM WebSphere Data Interchange V3.3 Client 
> WDI V3.3 Client or by selecting the WDI 3.3 Client icon on your desktop. 

This should result in the WDI 3.3 Client Main window being displayed.
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WDI 3.3 Client / Remote Server Database Connect

� Next, select View > Administration > Systems… from the 
Toolbar on the WDI 3.3 Client.

Next, select View > Administration > Systems… from the Toolbar on the WDI 3.3 Client.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the Configuration Systems window being displayed. 

� Select either File\New… or select the Create a New object icon/button to add 
the remote WDI 3.3 system/database.

This should result in the Configuration Systems window being displayed. 

Select either File\New… or select the Create a New object icon/button to add the remote WDI 
3.3 system/database.
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WDI 3.3 Client / Remote Server Database Connect

� This should result in the Configuration - System - untitled
window being displayed. 

This should result in the Configuration - System - untitled window being displayed. 
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WDI 3.3 Client / Remote Server Database Connect

� Input the name that you wish to call the Remote System 
Database in the System Name field or whatever value you 
will be referencing the system by in the future (example: My 
WDI 3.3).

� Input a value in the Description field if you wish to.

� Select the correct value of Windows, AIX or z/OS in the 
dropdown list of the Server Platform field.

� Select the value of the Remote System (it’s Alias Name) in 
the dropdown list of the Data Source Name field.

� Input a value of EDIENU33 in the Database Qualifier field.

� Select File\Save on the Tool bar or press the Save the 
Active object icon/button.

Input the name that you wish to call the Remote System Database in the System Name field or 
whatever value you will be referencing the system by in the future (example: My WDI 3.3).

Input a value in the Description field if you wish to.

Select the correct value of Windows, AIX or z/OS in the dropdown list of the Server Platform 
field.

Select the value of the Remote System (it’s Alias Name) in the dropdown list of the Data Source 
Name field.

Input a value of EDIENU33 in the Database Qualifier field.

Select File\Save on the Tool bar or press the Save the Active object icon/button.
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WDI 3.3 Client / Remote Server Database Connect

� The WDI 3.3 Server database has now been defined to the 
WDI 3.3 Client.

� To access the database via the WDI 3.3 Client, select the 
value that you specified for the WDI 3.3 database from the 
System dropdown list on the Tool bar.

� You may be prompted to logon to the WDI 3.3 Server 
database the first time that you access it. 

� You can set up in ODBC to have the User ID and Password 
already provided instead of being prompted. 

� However, you will need to update these values whenever a 
User ID or Password is changed for the DB2 database. 

The WDI 3.3 Server database has now been defined to the WDI 3.3 Client.

To access the database via the WDI 3.3 Client, select the value that you specified for the WDI 
3.3 database from the System dropdown list on the Tool bar.

You may be prompted to logon to the WDI 3.3 Server database the first time that you access it. 

You can set up in ODBC to have the User ID and Password already provided instead of being 
prompted. 

However, you will need to update these values whenever a User ID or Password is changed for 
the DB2 database.
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WDI 3.3 Client / Remote Server Database Connect

� This is the end of the WDI 3.3 Client to Server 
Database Connect on a different/remote machine 

walk through.

This is the end of the WDI 3.3 Client to Server Database Connect on a different/remote machine 
walk through.
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