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Purpose

This guide provides all the information that you need to use Hyperion
Essbase Spreadsheet Add-in for Microsoft Excel. It explains the features and
options and discusses the concepts, processes, procedures, formats, tasks, and
examples that you need to use the software.

Hyperion Essbase is an online analytical processing (OLAP) solution that
satisfies the complex calculation requirements of financial, accounting, and
marketing professionals. Hyperion Essbase operates in a client-server
computing environment on a local area network (LAN). In this environment,
multiple users can use their desktop computers to retrieve and analyze
centralized data.

You can create reports from the data residing on Hyperion Essbase OLAP
Server in several ways:

* Generate database reports through a spreadsheet interface, called Hyperion
Essbase Spreadsheet Add-in, as explained in this guide.

* Use Hyperion Essbase Application Manager Report Writer to create a report
script and run a report. For more information, see the Hyperion Essbase
Database Administrator’s Guide.

* Use Hyperion Essbase Application Programming Interface (API) to create
and run database reports. For more information, see the Hyperion Essbase
online API Reference.

 Use reporting tools, such as Hyperion Reporting for Hyperion Essbase.

Audience

© Copyright IBM Corp. 1998, 2000

This guide is for Hyperion Essbase end users who are responsible for some or
all of the following tasks:

* Starting Hyperion Essbase and connecting and disconnecting from
Hyperion Essbase databases

* Retrieving data from a database into a worksheet

* Dirilling down, drilling up, and navigating through a worksheet to analyze
and arrange data from multiple viewpoints

* Working with linked reporting objects and linked partitions

¢ Updating data on the Hyperion Essbase server

* Using the worksheet to load and calculate data in the database
* Creating multiple sheets from data

¢ Working with currency conversions



Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Hyperion Essbase
Spreadsheet Add-in. This document contains the following information:

* ntroducing Release 6” on page id provides information on migrating from

previous versions of Hyperion Essbase to Release 6 and lists all new
features and enhancements.

7 : : ”

. introduces you to
basic concepts of retrieving and manipulating data through the spreadsheet
interface.

* [Chapter2 A Basic Hyperion EsshaseTutorial” on page 11l provides a

step-by-step tutorial of basic data navigation, ad hoc retrieval, and
reporting techniques.

. [’Chapter3 An Advanced Hyperion Esshaselu.tgual_gn_pa.ge_sﬂ' ” describes

advanced reporting and retrieval techniques for users that need special
reports or formatted data views.

. " . . . 12 7

provides a brief overview of the Hyperion Integration Server Drill-Through
product.

* The Indexcontains a list of terms and their page numbers. Select or look up
an index entry to view the page to which the entry refers.

Note: The Hyperion Essbase Spreadsheet Add-in online help provides a
comprehensive section on Hyperion Essbase Spreadsheet Toolkit. This
section enables you to customize and automate your use of Hyperion
Essbase by using Excel macros and Visual Basic for Applications (VBA)
functions. For more information on the Hyperion Essbase Spreadsheet
Add-in online help, see Chapter 2, “Accessing Online Help.”

The Spreadsheet Add-in User’s Guide for Excel is provided in the
\essbase\docs\client directory in .pdf format for online viewing and
printing in Adobe® Acrobat Reader® (Release 4 or higher). The .pdffile is
named Essexcel.pdf. You can download Adobe Acrobat Reader from the
Hyperion Essbase CD-ROM or from http://www.adobe.com. On the Hyperion
Essbase CD-ROM, the Acrobat Reader executable file is located in the Adobe
directory under the appropriate platform and language-version subdirectories.
To install Adobe Acrobat Reader, launch the executable file, follow the
prompts, and provide the information requested.

Sample Databases and Files

This book provides tutorial steps that are based on sample databases and files
that are provided with the Hyperion Essbase server software You use the
Sample Ba51c database for most tasks in

“ and “Chapter 3. An Advanced Hyperion Essbase
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[Cutorial” on page 85. You use a sample Hyperion Essbase Currency

Conversion application for the section on currency conversion. See W
i ial” . For information on the
Samgle Basic database, see I’(“hap’rm‘ 2 A Basic Hyperion EsshaseTutorial” orl

In addition to these sample applications and databases, you also use several
sample Excel files in the advanced tutorial in L

i ial” . The individual at your organization
who installs the server is responsible for making these applications, databases,
and files available to you. Contact the Hyperion Essbase system administrator
for more information.

Online Help

To access online help, click the Help button in any Hyperion Essbase dialog
box or select Essbase Help from the ExcelEssbaseHelp menu.

To print an online help topic, display the topic and select File > Print, or
right-click and select Print from the pop-up menu.

Conventions

The following table shows the conventions that are used in this document:

Purpose vii



Item

Meaning

Arrows indicate the beginning of a procedure, which consists of one
or more sequential steps.

Brackets [ |

In examples, brackets indicates that the enclosed elements are
optional.

Bold Bold text indicates words or characters that you type exactly as they
appear on the page. Bold in procedural steps highlight major interface
elements.

CAPITAL LETTERS Capital letters denote file names, functions, DOS commands, and

various IDs. For example, the text might refer to the GDC.INI file.

Example text

Text shown in this font indicates that the material shown is an
example for your use.

Ctrl + 0 Keystroke combinations indicate that you should press the keys
simultaneously (yet still somewhat sequentially) as shown.
Italics Italic text indicates a variable field in command syntax. Substitute

your own values in place of the variable shown in italics. Titles of
other books are also in italics. And italics indicate important terms
and special emphasis.

Ellipses (...)

Use of an ellipses indicates an omission of irrelevant material, which
is typically used in an example to show only the relevant material.

Mouse orientation

This document provides examples and procedures using a
right-handed mouse. If you are using a left-handed mouse, adjust the
procedures accordingly.

Menu commands

Menu commands are presented in the following format:Menu name >
Menu command > Extended menu command For example: File > Desktop
> Accounts

The variable n indicates that you must supply a generic number; the
variable x indicates that you must supply a generic letter.

viii OLAP Spreadsheet Add-in User’s Guide for Excel



Introducing Release 6

This chapter provides compatibility information for Hyperion Essbase Release
6 and previous releases of Hyperion Essbase, including migration information
and new feature descriptions and enhancements. It contains the following
sections:

Migrating to Release 6

As you migrate (upgrade) from previous releases of Hyperion Essbase to
Release 6, keep in mind that Release 6 of Hyperion Essbase Spreadsheet
Add-in is designed to work with Release 6 of Hyperion Essbase OLAP Server.
If the Hyperion Essbase system administrator upgrades the Hyperion Essbase
server to Release 6, Release 5.x of Hyperion Essbase Spreadsheet Add-in
works on only a limited basis. Upgrade to Hyperion Essbase Spreadsheet
Add-in to Release 6 as soon as possible.

Read the Hyperion Essbase Start Here booklet and the Hyperion Essbase
Installation Guide for detailed information about migrating from previous
releases of Hyperion Essbase.

What's New in Release 6

Hyperion Essbase Release 6 provides a number of enhancements and new
features for Hyperion Essbase Spreadsheet Add-in.

View attributes in reports by typing the name of the attribute directly into the
worksheet by using member selection, or by using Hyperion Essbase Query
Designer. You can also apply styles to attributes to identify the attributes in
the worksheet.

Hyperion Essbase Query Designer (EQD) replaces Retrieval Wizard. You use
EQD to create queries for reports. This new component enables you to do the
following functions:

* Design a layout for the report

* Select members (including attributes) for the report
¢ Perform member filtering

* Perform data filtering

* Perform data sorting

© Copyright IBM Corp. 1998, 2000 ix



New client platforms, Microsoft Excel 2000 and Lotus 1-2-3 Millennium
Releases 9 and 9.1, are supported.

X  OLAP Spreadsheet Add-in User’s Guide for Excel



Chapter 1. Introducing Hyperion Essbase

Hyperion Essbase is multidimensional database software that is optimized for
planning, analysis, and management reporting applications. Hyperion Essbase
uniquely blends an innovative technical design with an open, client-server
architecture. Hyperion Essbase enables you to extend your decision support
systems beyond ad hoc queries and reports on historical performance to
dynamic, operational systems that combine historical analysis and future
planning. By consolidating and staging historical and projected data for
detailed analysis, you gain perspectives about your business that enable you
to take appropriate actions.

Hyperion Essbase provides both power and flexibility.Thus, it can be used for
a broad range of online analytical processing (OLAP) applications including
the following:

* Budgeting

* Forecasting and seasonal planning

* Financial consolidations and reporting

* Customer and product profitability analysis
* Price, volume, and mix analysis

* Executive information systems (EIS)

Hyperion Essbase enables you and others in your organization to share,
access, update, and analyze enterprise data from any perspective and at any
level of detail without learning new tools, query languages, or programming
skills.

Typical Users of Hyperion Essbase

Hyperion Essbase is designed for use in many different applications. Financial
analysts have found Hyperion Essbase to be invaluable in budget analysis,
currency conversion, and consolidation. Cost accountants apply the powerful
capabilities of Hyperion Essbase to evaluate allocation and elimination
scenarios. Product managers and analysts use Hyperion Essbase to plan and
analyze multiple product lines and distribution channels. Hyperion Essbase
can also be used as a repository database for spreadsheet data. Anyone who
uses a spreadsheet is a potential user of Hyperion Essbase.

Because Hyperion Essbase is applicable to such a broad variety of

environments, individuals using it at your organization may fill one or more
roles in implementing and running applications. This guide refers to specific

© Copyright TBM Corp. 1998, 2000 1



roles by three titles. However, in actuality, a role may be performed by one
person or by several people working collaboratively.

* Hyperion Essbase system administrator. The Hyperion Essbase system
administrator typically has experience in networking, installing software
packages, and administering system functions. In addition to installing the
Hyperion Essbase software, the Hyperion Essbase system administrator
may also set up Hyperion Essbase user accounts, set up the security system,
and maintain Hyperion Essbase OLAP Server.

* Application designer. The application designer sets up the Hyperion Essbase
database, creates the database outline, and develops calculation and report
scripts. The responsibilities of the Hyperion Essbase system administrator
and the application designer may overlap in some areas. The application
designer has probably developed spreadsheet or database applications and
understands the operational problems and the tools being employed to
solve them.

* User. The user interacts with Hyperion Essbase databases through
spreadsheets, using Microsoft Excel for Windows or Lotus 1-2-3. Users are
typically analysts and managers who use spreadsheet programs as their
primary tool for viewing and analyzing data.

Components of the Client-Server Environment

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of a local area
network (LAN). The PC workstation acts as a client by requesting data from
the server. The server processes the request and returns the desired result to
the client.

Hyperion Essbase is built as a client-server system. System performance and
multiuser capabilities are greatly enhanced in the Hyperion Essbase
client-server environment.

The Server

Hyperion Essbase OLAP Server is a multidimensional database that supports
analysis of an unlimited number of data dimensions and an unlimited number
of members within these dimensions. Developed using a true client-server
architecture, all data, the database outline, the calculations, and the data
security controls reside on the Hyperion Essbase server.

The Hyperion Essbase server operates on Windows 95, Windows 98, Windows
NT, and UNIX operating systems.
Hyperion Essbase Spreadsheet Add-in

Hyperion Essbase Spreadsheet Add-in is a software program that merges
seamlessly with Microsoft Excel and Lotus 1-2-3. After Hyperion Essbase is
installed, a special menu is added to Excel. The menu provides enhanced

2 OLAP Spreadsheet Add-in User’s Guide for Excel



commands such as Connect, Pivot, Drill-down, and Calculate. Users can
access and analyze data on the Hyperion Essbase server by using simple
mouse clicks and drag-and-drop operations. Hyperion Essbase Spreadsheet
Add-in enables multiple users to access and update data on the Hyperion
Essbase server simultaneously.

The Network

Hyperion Essbase runs on PC-based LANSs that support the Named Pipes or
TCP/IP protocol.

Note: Supported network environments and technical requirements are
discussed in detail in the Hyperion Essbase Installation Guide, which is
included with the Hyperion Essbase OLAP Server package.

Hyperion Essbase Application Products

Several optional products, designed to extend and enhance the scope of OLAP
applications, can be addressed using the Hyperion Essbase server. The
following sections describe these products.

Hyperion Essbase Spreadsheet Toolkit

Hyperion Essbase Spreadsheet Toolkit includes over 20 macro and Visual
Basic for Applications (VBA) functions that enable you to build customized
Microsoft Excel and Lotus 1-2-3 applications. The applications incorporate
Hyperion Essbase commands. Commands such as EssCascade, EssConnect,
and EssDisconnect provide all of the functionality of their corresponding
Hyperion Essbase menu commands. For more information, see the Hyperion
Essbase Spreadsheet Add-in online help.

Hyperion Essbase Partitioning Option

Hyperion Essbase Partitioning option enables you to define areas of data that
are shared or linked between data models. Partitioning can affect the
performance and scalability of Hyperion Essbase applications. Partitioning
provides more effective response to organizational demands, reduced
calculation time, increased reliability and availability, and incorporation of
detail and dimensionality. For more information, see [!Accessing Tinked

Rartitions” on page 149 on page 204.
Hyperion Essbase Structured Query Language Interface

Hyperion Essbase SQL Interface enables access to PC and structured query
language (SQL) relational databases by making the Hyperion Essbase server
operate as an open database connectivity client. Using Hyperion Essbase SQL
Interface, data can be moved easily from these diverse corporate data sources
into the Hyperion Essbase server for user access and analysis. For more
information, see the Hyperion Essbase SQL Interface Guide.

Chapter 1. Introducing Hyperion Essbase 3



Hyperion Essbase Application Programming Interface

Hyperion Essbase Application Programming Interface (API) enables
application developers to create custom applications quickly by using
standard tools while taking advantage of the robust data storage, retrieval,
and manipulation capabilities of Hyperion Essbase. Hyperion Essbase API
supports Visual Basic and C. For more information, see the online API
Reference.

Hyperion Essbase Currency Conversion

Hyperion Essbase Currency Conversion translates, analyzes, and reports on
foreign financial data. Any exchange rate scenario can be modeled, and you
can even perform ad hoc currency conversions of data directly from the
spreadsheet. The Currency Conversion product is compliant with Financial
Accounting Standards Board 52 (FASB52). For more information, see

Hyperion Integration Server

Hyperion Integration Server works with Hyperion Essbase and Microsoft
Excel and Lotus 1-2-3. Hyperion Integration Server is a suite of tools and data
integration services that serve as a bridge between relational data sources and
Hyperion Essbase OLAP Server. Hyperion Integration Server Drill-Through is
one of the tools of Hyperion Integration Server. Using Drill-Through, you can
view and customize spreadsheet reports that display data retrieved from
relational databases. For more information, see L i i

Hyperion Objects
Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in

Hyperion Essbase servers. You can combine objects with other controls in a
visual design environment to construct new programs.

Hyperion Web Gateway

Hyperion Web Gateway is a multithreaded server application that enables
high-speed, interactive, read /write access to Hyperion Essbase for OLAP
applications over the World Wide Web. Combining Hyperion Essbase with
Hyperion Web Gateway provides a comprehensive Web-based solution that
delivers sophisticated management reporting, provides ad hoc
multidimensional analysis, and enables development of comprehensive
operational OLAP applications, including planning, budgeting, and
forecasting over intranets or the Internet.

4  OLAP Spreadsheet Add-in User’s Guide for Excel



The Multidimensional Database

The Hyperion Essbase multidimensional database stores and organizes data. It
is optimized to handle applications that have large amounts of numeric data
and are consolidation-intensive or computation-intensive. In addition, the
database organizes data in a way that reflects how the user wants to view the
data.

Definition of Multidimensional

A dimension is a perspective or view of a specific dataset. A different view of
the same data is an alternate dimension. A system that supports simultaneous,
alternate views of datasets is multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on
(see ). Each dimension contains additional categories that have various
relationships one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:

EE=

Sales
COGS

Margin

Marketing
Freight
Discounts

Total Expenses

Gross Profit

1465
401
1064
21
g5

978

Figure 1. Multiple Views from a Five-Dimensional Database

A Hyperion Essbase application contains an unlimited number of dimensions,
so you can analyze large amounts of data from multiple viewpoints. The
following illustration shows four views of multidimensional data. You can
retrieve and analyze the data with the Hyperion Essbase Spreadsheet Add-in
software:

Chapter 1. Introducing Hyperion Essbase 5
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Figure 2. Hyperion Essbhase Components

6  OLAP Spreadsheet Add-in User’s Guide for Excel




Database Outlines

Understanding the database outline is the key to understanding Hyperion
Essbase. To define a multidimensional database, you design its database
outline. The database outline contains the database organization (structure)
the database members, and the database rules, as shown in

[Database: Basic (Current Alias Table: Default)

—@Yeg Time (Active Dynarmic Time Series Members: H-T-D, Q-T-D, M-T-I}
Gtrl (+)
Qtr2 (+)
Qtr3 [+

Qtrd [+

sures Accounts

Profit (+)

Irventary (~)

Ratios (~)

uct {Caffeinated, Intro Date, Qunces, Pkg Type }
100 (+) (Alias: Colas)

200 (+) (Alias: Root Beer)

300 (+) (Alias: Cream Soda)

400 (+) (Alias: Fruit Soda)

Diet (~) (Alias: Diet Drinks)

et {Population }

East (+)

West (+)

South i+)
4

ario

Actual (+)

Budget (~)

— |_|vanance (~)

— |_|%ariance % (~)

— [ Caffeinated Attribute (Type: Boolean)
— [>]Intro Date Attribute (Type: Date)

— [ 0unces Attribute (Type: Nurneric)
— [|Pkg Type Attribute (Type: Text)

— || Population Attribute (Type: Nurmeric)

|
1Y)
2 K<<

|
l%l

K<L E K<L

|
B
5

|
B
g
& [KI<I<I<

Figure 3. Hyperion Essbase Database Outline

Note: The application designer or Hyperion Essbase system administrator
usually creates the database outline. For more information on creating
the database outline, see the Hyperion Essbase Database Administrator’s
Guide.

The components of the database outline are the following:
* Dimensions

* Members

* Attributes

* Formulas

* Aliases

* Consolidations

Refer to the following sections for descriptions of the outline components.

Chapter 1. Introducing Hyperion Essbase 7



Dimensions

Dimensions are the most basic categorical definitions of data within the
database outline. You need at least two dimensions to make any meaningful
reference to data; for example, a time dimension and an accounts dimension.
Other dimensions may categorize products, markets, and scenarios. Using
dimensional organization, you can define any consolidation structure or any
slice of data that is relevant to the application. Hyperion Essbase supports an
unlimited number of dimensions.

Members

Membersare the names of the elements within a dimension. A dimension can
contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Hyperion Essbase use the following terms to

describe members.
* Parents. A parent is a member with a consolidation branch below it. For

example, in the illustration below, Qtrl is a parent member because there is

a branch containing monthly members below it.

Database: Basic (Current Alias Takle: Default)

@ Year Time

=

&=

[Active Dynamic Time Series Members: H-T-D, Q-T-D, M-T-00 (Dynamic Calc)

— E|Gttr1 [+) (Dynamic Calc)

Jan (+]
Fehi+)
oar [+

— [l atr2 o+ (oynamic Cal)

Apr (+)
Mz (+)
Jun (+)

— || @S (+) (Dynamic Calc)

Jul [+
A (+]
Sep (+)

L E|Q‘tr4 [+) (Dynamic Calc)

Oct (+)
Mo [+
Dec (+]

Figure 4. Relationships Among Database Members

* Children. A child is a member with a parent above it. For example, Jan, Feb,

and Mar are children of the parent Qtrl.
 Siblings. A sibling is a child member of the same parent and on the same

branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not

a sibling of Jan, Feb, or Mar, however, because it has a different parent,
Qtr2.

* Descendants. A descendant is a member at any level below a parent. For

example, each member that falls in the Year branch is a descendant of Year.

The following members are all descendants of Year: Qtrl, Jan, Feb, Mar;
Qtr2, Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.
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e Ancestors. An ancestor is a member of a branch above a member. For
example, Qtr2 and Year are ancestors of Apr.

* Generations. The term generation describes the branch number of a member.
Generations count from the root of the tree (generation 1, which is the
dimension name) toward the leaf node.

* Levels. The term level describes the branch number of a member. Levels
count from the leaf node (level 0) toward the root (the dimension name).

Attributes

Attributes describe characteristics of data, such as the size and color of
products. Through attributes, you can group and analyze members of
dimensions based on their characteristics. Attribute dimensions must be
associated with base dimensions. For more information, see the Hyperion
Essbase Database Administrator’s Guide.

Formulas

Each database member can have one or more formulas associated with it in
the database outline. For example, the Variance members of the Scenario
dimension, as shown in Eigure 3 on page 7, contain formulas. Formulas can be
simple or complex. For more information, see the Hyperion Essbase Database
Administrator’s Guide.

Aliases

Hyperion Essbase supports alternative names, or aliases, for database
members. Aliases are useful when various labels are used for the same
member in various worksheets. One worksheet, for example, may refer to
Cost_of_Goods_Sold as COGS. Aliases also can be used for reporting in
alternative languages or for more formal output name sets, such as account
numbers.

Consolidations

Consolidations in Hyperion Essbase applications are defined by member
branches. The database outline determines consolidation paths. The
determination is based on the location of members within a dimension.
Indentation of one member below another indicates a consolidation
relationship. Indentingmembers is important for the drill-down capabilities in
Hyperion Essbase Hyperion Essbase Spreadsheet Add-in. As you navigate
your way through data, you can drill down through levels of consolidations.
The database outline is the roadmap that determines the levels of data
navigation.

Chapter 1. Introducing Hyperion Essbase 9
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Chapter 2. A Basic Hyperion EssbaseTutorial

When you add Hyperion Essbase Spreadsheet Add-in to Microsoft Excel, most
Excel operations remain unchanged; Hyperion Essbase Spreadsheet Add-in
simply adds a new menu, a Hyperion Essbase toolbar, and mouse shortcuts
with which you can access Hyperion Essbase OLAP Server.

The tasks described in this tutorial are basic tasks. That is, these are tasks that
you probably use often when working with Hyperion Essbase.
i ial” describes more advanced

tasks.

This tutorial chapter contains the following sections:

. ” . . . . .-y

Note: Each tutorial task builds upon the previous task. Therefore, tasks must
be completed in succession.

The examples used in this tutorial are based on the sample database (called
Sample Basic) that is included with the Hyperion Essbase installation. Contact
the Hyperion Essbase system administrator for information about accessing
the Sample Basic database or about accessing other databases on the Hyperion
Essbase server.

© Copyright TBM Corp. 1998, 2000 11



Getting Acquainted with Hyperion Essbase Spreadsheet Add-in

This section provides the following information to help you get acquainted
with Hyperion Essbase Spreadsheet Add-in:

. Ilédd]]ﬂg H;ZPEI]QD Essbase S.preadsheei édd-jn’j

Adding Hyperion Essbase Spreadsheet Add-in

If you manually update your environment settings or if you have removed
Hyperion Essbase Spreadsheet Add-in from the MicrosoftExcel environment,
you must use the Excel facility to add Hyperion Essbase Spreadsheet Add-in
into Excel. The facility adds the Hyperion Essbase menu to the Excel menu
bar and points Excel to the Hyperion Essbase Spreadsheet Add-in file in the
\essbase\bin directory. This file is on the hard drive of your PC, if that is
where you installed Hyperion Essbase Spreadsheet Add-in, or on the network
drive if that is where you set up your PC operating environment to run
Hyperion Essbase Spreadsheet Add-in.

Note: essexcIn.x11 is the add-in file for Excel 97 and Excel 2000. Adding
Hyperion Essbase Spreadsheet Add-in into Excel 97 and Excel 2000
modifies the Windows 95, Windows 98, or Windows NT Registry. The
.ini file and Registry point to where the Hyperion Essbase Spreadsheet
Add-in file is installed.

To add Hyperion Essbase Spreadsheet Add-in to Excel:
1. In Excel, select Tools > Add-Ins.

Excel displays the Add-Ins dialog box.
2. Click the Browse button.

Excel displays the Browse dialog box.

3. Select the file essexcIn.x11 in the bin directory where you installed
Hyperion Essbase Spreadsheet Add-in on your PC hard drive (if you
installed Hyperion Essbase Spreadsheet Add-in there) or in the bin
directory where the Hyperion Essbase system administrator installed
Hyperion Essbase Spreadsheet Add-in on a network drive (if you set up

your PC operating environment to run Hyperion Essbase Spreadsheet
Add-in there).

4. Click OK twice to close the dialog boxes and start Hyperion Essbase
Spreadsheet Add-in.
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The Hyperion Essbase startup screen is displayed.
If you do not see the Hyperion Essbase startup screen or if your system

does not list the Hyperion Essbase Spreadsheet Add-In menu options, see
the Hyperion Essbase Installation Guide for troubleshooting information.

Starting Hyperion Essbase Spreadsheet Add-in
Because Hyperion Essbase Spreadsheet Add-in software for Excel

is implemented as an Excel add-in, you must start Excel from Windows to use
Hyperion Essbase Spreadsheet Add-in software.

You must open a worksheet before attempting to connect to the Hyperion
Essbase server. An attempt to connect to the Hyperion Essbase server without
opening a worksheet results in an error message.

To begin a Hyperion Essbase session:
1. Start Excel.

After the Excel startup screen disappears, the Hyperion Essbase startup
screen is displayed.

The Hyperion Essbase menu should be displayed in the Excel menu bar. If
you do not see the Hyperion Essbase menu, you may need to use the
Excel add-in facility to add Hyperion Essbase Spreadsheet Add-in into
Excel. For more information, see L i i

Add-in” on page 19.

The Hyperion Essbase toolbar should also be visible. If you do not see the
Hyperion Essbase toolbar, see I’Tnc’raﬂing the Hyperion Fsshase Toalbar’]

ﬁ&ﬂ and [/ i =in”

2. From the Excel menu bar, select Essbase to open the menu.

Chapter 2. A Basic Hyperion EssbaseTutorial 13
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Figure 5. The Essbase Menu

Note: If the Excel status bar is not displayed, you can display it by selecting
View > Status Bar.

Installing the Hyperion Essbase Toolbar

Hyperion Essbase Spreadsheet Add-in provides a convenient toolbar that
displays buttons for accessing most of the common Hyperion Essbase
commands without having to open the Essbase menu. Prior to using the
Hyperion Essbase toolbar, you must install the toolbar by opening an Excel
file that is provided as part of the default Hyperion Essbase installation. For

more information on using the toolbar, see [llsing the Hyperion Fsshasd
To install the Hyperion Essbase toolbar:

1. Start Excel.

2. Select File > Open.

3. From the \essbase\client\sampledirectory, open the esstoolb.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

A blank worksheet opens.
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Figure 6. esstoolb.xls File

Note: If you are using Excel 97, two dialog boxes may be displayed when
you open the esstoolb.x1s file. If so, click the Enable Macros
button on the first dialog box, and click OK on the second dialog
box.

4. Select File > Close to close the esstoolb.x1s file. You do not need to
modify or save the file.

You should not have to perform the toolbar installation procedure again
unless you delete the Hyperion Essbase toolbar from the Toolbars dialog box
in Excel. If you delete the toolbar, perform the installation procedure again.

Note: If you have toolbars turned off in Excel, you do not see the Hyperion
Essbase toolbar immediately. You must first enable toolbars. For more
information, see LI Ising the Hyperion Hsshase Toolbar”]

Using the Hyperion Essbase Toolbar

Hyperion Essbase Spreadsheet Add-in for Excel features a convenient toolbar
that displays buttons for accessing most of the common Hyperion Essbase
commands without having to open the Essbase menu. You can view a short
description of a button in a pop-up on the toolbar by moving your cursor
over the button.

Note: Before you can view the Hyperion Essbase toolbar, you must install it.

See lInstalling the Hyperion Essbase Toolbar” on page 14.

To view the Hyperion Essbase toolbar, select View > Toolbars > Essbase from
the Excel menu bar. A check box must be displayed next to Essbase in the
menu.

Note: If you click the Essbase check box and click Delete, you must reinstall
the toolbar. See L i i Z
for instructions.

The toolbar provides the following buttons:
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Table 1. Hyperion Essbase Toolbar Fm Variable:Table Continuation

Button

Purpose

Description

Connect

Enables you to connect to a Hyperion Essbase server. When
you click the Connect button on the toolbar, Hyperion Essbase
displays the Hyperion Essbase System Login dialog box.

Navigate with or without
data

Toggles the Navigate Without Data feature, which tells
Hyperion Essbase to retrieve or not to retrieve data when you
perform navigational operations, such as pivot, zoom in, zoom
out, keep only, and remove only. This button serves the same
function as the Navigate Without Data check box in the
Essbase Options dialog box (Global tab).

Retrieve

Retrieves data into the active worksheet. A retrieve request
places data at the beginning of the active worksheet. When
you click the Retrieve button, if you are not already connected
to a Hyperion Essbase server, the Hyperion EssbaseSystem
Login dialog box is displayed. If you have mouse actions
enabled, you can retrieve data by double-clicking the primary
mouse button in any empty cell in the worksheet. To enable
double-click support, select Essbase > Options, select the
Global tab, and select the Enable Double-Clicking option. For

more information, see IEnabling Mouse Actions” on page 17.

Keep only

Retains only the selected member (the active cell) or member
range in the worksheet. When you click the Keep Only button,
all unselected members are removed from the worksheet.

Remove only

Removes the selected member (the active cell) or member
range from the worksheet. When you click the Remove Only
button, all unselected members are retained in the worksheet.

Zoom in

Retrieves and expands data from the Hyperion Essbase server
according to the options specified in the Essbase Options
dialog box. If you have mouse actions enabled, you can drill
down on data by double-clicking the primary mouse button in
the cell that contains the member you want to expand. To
enable double-click support, select Essbase > Options, select
the Global tab, and select the Enable Double-Clicking option.

For more information, see Enabling Monse Actions” od

Zoom out

Collapses the view according to the options specified in the
Essbase Options dialog box in the cell that contains the
member that you want to collapse. To enable double-click
support for drilling up, select Essbase > Options, select the
Global tab, and select the Enable Double-Clicking option.

Open Hyperion Essbase
Query Designer

Opens the Hyperion Essbase Query Designer, which makes it
easy to define a page orientation for dimensions and selected
database members. You can also save queries for later use.
Hyperion Essbase Query Designer is a new feature designed to
create report queries, view attributes, and perform calculations
based on attributes.

@ OLAP Sp
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Accessing Online Help

Hyperion Essbase Spreadsheet Add-in includes a context-sensitive online help

system. You access the Hyperion Essbase Spreadsheet Add-in online help in

one of three ways. Which way you choose depends on the type of information

that you need,

* Access the entire online help system for browsing or searching for
information. To access the entire help system, select Help > Essbase Help.

After you access online help, you can browse or search through the system

to view general information on Hyperion Essbase Spreadsheet Add-in,
Essbase command descriptions, procedural information for completing

tasks, Spreadsheet Toolkit macros, and Visual Basic for Applications (VBA)

function descriptions.

* Access context-specific information from dialog boxes in Hyperion Essbase

Spreadsheet Add-in. Each dialog box in Hyperion Essbase Spreadsheet
Add-in features a Help button that accesses online help topics that are

specific to the particular dialog box. The buttons enable you to find the
information you need without having to search through the entire help
system.

Figure 7. Excel Help Button

A

Note: The Hyperion Essbase Spreadsheet Add-in online help also provides

a comprehensive section on Hyperion Essbase Spreadsheet Toolkit,

which enables you to customize and automate your use of Hyperion

Essbase by using Excel macros and VBA functions.
e Access information on a specific Hyperion Essbase Query Designer function.

Access What's This? Help in the Hyperion Essbase Query Designer dialog
box, and then click an item in the dialog box to access information on that

item.

Figure 8. EQD Help Button

Enabling Mouse Actions

The following terms are used throughout this guide to describe mouse
operations:

* Primary mouse button and secondary mouse button describe the buttons on a
two- or three-button mouse. Usually, right-handed users configure the left

mouse button as the primary button and the right mouse button as the

Chapter 2. A Basic Hyperion EssbaseTutorial
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secondary mouse button. The primary mouse button is the one that you use
to start Windows applications, such as Excel; the secondary mouse button is
used for auxiliary operations. The term click refers to use of the primary
mouse button. The term right-click refers to use of the secondary mouse
button.

Select chooses the object that is under the cursor when you press and
release the primary mouse button. You can select a worksheet cell, for
example, by moving the cursor to the cell and pressing and releasing the
primary mouse button.

Click (that is, both click and right-click) describes a quick press-and-release
action on a command object. You can click a button, for example, to execute
a command.

Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example,
to start a Windows application.

Drag describes a press, hold, and move action. You place the cursor on an
object, press a mouse button, hold the mouse button and move the object,
and release the mouse button when you reach your goal. For example, you
can highlight a range of cells in an Excel worksheet by dragging the cursor
over the cells.

Note: Hyperion Essbase uses a drag operation called a pivot. A pivot
requires use of the secondary mouse button. To execute a pivot, you
must press and hold the secondary, rather than the primary, mouse
button while dragging the selection.

Hyperion Essbase offers enhanced mouse actions in Excel. You can use the
mouse to do any of the following:

Retrieve data

Drill down and drill up on database members
Pivot (move or transpose) data rows and columns
Access linked reporting objects

Access linked partitions

To enable double-clicking to retrieve, drill down, and drill up on Hyperion
Essbase data:

1.
2.
3.

Select Essbase > Options.
In the Essbase Options dialog box, select the Global tab.
Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up
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to less detailed data (secondary mouse button). When the double-clicking
option is enabled, the Excel in-cell editing feature is overridden.

Essbase Oplions
Displayl Zoom I Mode I Style

— Mouse Actions

v a

V¥ Enable Linked Object Brawsing

Global |

— Memory
IV Enable Flashback

— Member Select

™ Display Save Dialog

— Display Messages
' Information
© Wamings
& Emors

' Mone

™ Display Unknown Members

—Log File

¥ Boute Messages to Log File
V¥ Purge Log File Every Session

—Mode
™ Mavigate withaut Data

Add-ns |

o]

Cancel |

Help

Figure 9. Essbase Options Dialog Box—Global Tab

4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the
Hyperion Essbase Spreadsheet Add-in online help.

Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:

. r’QP’r’ring Hyperion Essbase Opfinn<’1

° ’

. v

Setting Hyperion Essbase Options

Before you begin the tutorial steps, make sure that the worksheet options are

set to the initial settings as illustrated in Figures 2-6 through 2-9. If the option
settings are different, the illustrations presented in this chapter may not match
the worksheet view.
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Note: For information about each option in the Essbase Options dialog box,
see the Hyperion Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.

3. Select the appropriate check boxes and option buttons so that your
display of the Display tab matches the following illustration:

Essbase Options [ %]

Display |Zoom I tode I Globall

Indentation———— [~ Replacement
" Mone #higzing Label: I
' Subitems
8 #Mo Access Label: I
o
— Suppre — Aliaze:
™ #iMizsing Rows I Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
el Alias:
— Cells
™ Use Styles I j

V' Adiust Columng

I™ | Auto Sort Fows Query Designer
I Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic: Time S erie:
™ Latest Time Period I j

ak I Cancel Help

Figure 10. Initial Settings for Display Options

4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your
display of the Zoom tab matches the following illustration:
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Cancel

Help

Figure 11. Initial Settings for Zoom Options

6. Select the Mode tab.

7. Select the appropriate check boxes and option buttons so that your

display of the Mode tab matches the following illustration:
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Figure 12. Initial Settings for Mode Options

Note: If you are already connected to a Hyperion Essbase database, the

Essbase Options dialog box also displays a Style tab. You can skip
this tab for now.

8. Select the Global tab.

9. Select the appropriate check boxes and option buttons so that your
display of the Global tab matches the following illustration:
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Figure 13. Initial Settings for Global Options

Note: You should have already selected the appropriate boxes for Mouse
Actions, as described in K i ions”
10. Click OK to save the settings for this session and close the Essbase
Options dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:

* Tasks that should not be performed as part of the tutorial are displayed in
gray boxes. These tasks are included only for your future reference. You can
find more information on these tasks in the Hyperion Essbase Spreadsheet
Add-in online help.

* You must be connected to the Sample Basic database during the tutorial. If
you are not connected to this database, the illustrations presented in this
chapter will not match the worksheet view.

* You can access many Hyperion Essbase commands in any one of these
ways:

— By selecting the command from the Hyperion Essbase menu
— By clicking the appropriate button on the Hyperion Essbase toolbar

— For the Zoom In and Zoom Out commands, by double-clicking either the
primary mouse or the secondary mouse button
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* You must set the options in the Hyperion Essbase Options dialog box as

described in ['Setting Hyperion Fsshase Options” on page 19. If the option

settings are different, the illustrations presented in this chapter may not
match the worksheet view.

* After you change a worksheet option in the Hyperion Essbase Options
dialog box, you must perform a retrieval or a drill-down operation to have
the new setting take effect.

* Be sure to follow each step in the tutorial. Each tutorial task builds upon
the previous task. Do not skip the final steps at the end of sections, because
these steps are often necessary to prepare you for the next tutorial task.

* If you make a mistake during the tutorial, you can select Essbase >
FlashBack to return to the previous worksheet view.

* The values in the Sample Basic database that represent ratios or percentages
are calculated to a very high level of precision (for example, 55.26162826).
In Excel, you can apply a cell format to control the number of decimal
places that are displayed in data values. For more information, see the
Excel documentation.

* The numeric values that are shown in the illustrations used throughout this
tutorial may not match the values stored in your database. The values
shown in these illustrations reflect a freshly loaded database.

* Some worksheet columns have been adjusted for clarity in the illustrations.
You do not need to change the width of columns in the worksheet to follow
the tutorial steps. The Adjust Columns option in the Hyperion Essbase
Options dialog box (Display Tab) adjusts columns for you.

Reviewing the Sample Basic Database

The Sample Basic database that you use for the tutorial is based on a
hypothetical company in the beverage industry. The major products of the
company are various kinds of sodas. These products are sold in U.S. markets,
which are categorized by state and region. Financial data for the company is
collected monthly and is summarized by quarter and by year. The company
uses Hyperion Essbase to calculate financial and accounting data, such as
sales, cost of goods sold, and payroll. The company tracks both actual and
budget data, as well as the variance and percent variance between the two.

Retrieving Data

Now that you are more familiar with the Hyperion Essbase environment, you
can connect to the Hyperion Essbase server and start using Hyperion Essbase
and Hyperion Essbase Spreadsheet Add-in. The following section guides you
through a typical Hyperion Essbase session where you connect to a database

and retrieve data in various ways.

This section outlines the following basic retrieval tasks:
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Note: Make sure that you followed the steps in I'Setting Hyperion Esshasd

Z . If the settings in the Hyperion Essbase Options
dialog box are different from the settings previously illustrated, the
worksheet view will differ from the illustrations shown in this chapter.

Remember that you can perform common data retrieval tasks by doing any of
the following:

* Selecting commands from the Essbase menu on the Excel menu bar
* Clicking the appropriate buttons on the Hyperion Essbase toolbar
* Double-clicking the primary or the secondary mouse button in the
appropriate cell (for Retrieve, Zoom In, and Zoom Out commands)
Connecting to a Database

To access Hyperion Essbase data, you must first connect to a database on the
server. This tutorial assumes that you have the appropriate privileges to
connect to a server, an application, and a database.

Note: Hyperion Essbase does not support multiple instances of Excel.
1. Select Essbase > Connect
Hyperion Essbase displays the Essbase System Login dialog box.

Chapter 2. A Basic Hyperion EssbaseTutorial 25



Esshase System Login E

Server. ILocthost j ] 4 I
Usemame: W ﬂl
Password: l— Help |

LEhange Fasswond... |

Application/D atabaze:

[Ipdate |
Hote... |

Figure 14. Essbase System Login Dialog Box

Note: To complete the steps that follow, you need to know the name of
the Hyperion Essbase server, your username, and your password. If
you do not have this information, contact the Hyperion Essbase
system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want does not appear in the list, you can type in the
name of the server you want to access.)

3. Press Tab to move to the Username text box; type your username in the
text box.

4. Press Tab to move to the Password text box; type your password in the
text box.

Note: You can change your password when you are connected to a server.
To change your password, see I i ”

5. To connect to the server, click OK.

Hyperion Essbase displays a list of available application/database pairs in
the Application/Databaselist box. A Hyperion Essbase server allows
simultaneous access to multiple applications. An application can contain
multiple databases. Only the databases to which you have security access
are shown in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Hyperion Essbase installation, it is
shown in the list. If Sample Basic is not shown in the
Application/Database list box, ask the Hyperion Essbase system
administrator to install it.
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Figure 15. Available Application and Database Pairs

6. In the Application/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.

If the application is not already running, Hyperion Essbase automatically
starts it. There may be a brief pause as the application loads. The time
required to start an application depends on the number of databases, the sizes
of the databases, and the sizes of the indexes of the databases contained
within the application.

Changing a Password
You can change your password only if you are connected to a server.

Note: Remember, tasks that you should not perform as part of the tutorial are
shown in gray boxes.

To change your password:

In the Essbase System Login dialog box, select the Change Password button.

In the Change Password dialog box in the New Passwordtext box, type your new password.
In the Confirm Password text box, type the password again.

The passwords must be identical.

Click OK to change your password.

o g ks wbdhPE

Click OK again to close the Essbase System Login dialog box.

Retrieving Data from a Database

Each time you retrieve information from a Hyperion Essbase server, the
following actions occur:

* Hyperion Essbase Spreadsheet Add-in requests data from the server.
* The server processes the request and prepares the data.
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* The server transmits the data to Hyperion Essbase Spreadsheet Add-in.

* Excel receives the data from Hyperion Essbase and organizes it in a
worksheet.

To help you monitor these operations, Hyperion Essbase uses three custom
cursors.

Table 2. Hyperion Essbase Custom Cursor

This cursor: Is displayed when:

N Hyperion Essbase requests information from the server.

The server is processing the request.

The server returns the data.

Note: Small retrieval actions display the cursors very quickly; you may not
notice changes in the direction of the arrow when retrieving small
amounts of data.

To retrieve data into an empty worksheet:
1. Open a new worksheet by selecting File > New or by clicking the

]

button.

Note: You should be connected to the Sample Basic database. If you are

not connected, follow the steps in ‘Connecting to a Database” on

2. Select Essbase > Retrieve.

Hyperion Essbase retrieves data into the Excel worksheet.

A | B | ¢ | b | E | F
Measures Product  Market Scenatio
Year 106522

o on] e ]

Figure 16. Initial Data Retrieval from Sample Basic
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Because you clicked the Enable Double-Clicking box in the Essbase
Options dialog box (Global Tab), you can double-click in an empty cell to
retrieve data. You can also click the Retrieve button on the Hyperion
Essbase toolbar.

When you retrieve data into an empty worksheet, Hyperion Essbase returns
data from the top levels of each database dimension. The top level is used as
a starting point to navigate, or drill down, into levels of detailed data. In the
Sample Basic database, the following five dimensions are retrieved: Measures,
Product, Market, Scenario, and Year.

For the remainder of tasks in this tutorial, you can retrieve data by
double-clicking in a data cell, selecting Essbase > Retrieve, or by clicking the
Retrieve button on the Hyperion Essbase toolbar.

Canceling a Data Retrieval Request

Occasionally, you may want to cancel a retrieval request. For instance, you
may want to stop a request if a retrieval is taking longer than expected or if
you mistakenly double-click.

Because Hyperion Essbase returns data so quickly to the worksheet, you may
not be able to cancel a retrieval before the retrieval is complete. The cancel
feature is most useful when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.

Note: You can cancel a retrieval only while Hyperion Essbase is processing in
Hyperion Essbase Spreadsheet Add-in. You cannot cancel a retrieval
when Hyperion Essbase is processing from the server.

Restoring the Previous Database View

The FlashBack command restores the previous database view. A database view
is simply what you see in the worksheet after a retrieval or navigation
operation. FlashBack is similar to the Excel Edit > Undocommand, which
reverses the last action. The FlashBack command uses the memory of your
machine to store the current view before processing a Hyperion Essbase
retrieval request. You can use FlashBack to undo only the most recent
operation. FlashBack cannot undo multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are
presented. If you make a mistake or find yourself out of step with the tutorial,
you can use the FlashBack command from the Essbase menu or toolbar to
undo the last command and return to the previous database view. If you want
to start the tutorial over from the beginning, select the entire worksheet and
select Edit > Clear > All. Then press Enter or click OK to empty the worksheet
and start again.
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You can disable FlashBack during normal operations to conserve memory on
your local machine. Do not disable FlashBack for this tutorial.

To disable Flashback:
1. Select Essbase > Options and click the Global tab.
2. Clear the Enable FlashBack check box.

Drilling Down to More Detail

With Hyperion Essbase, you can drill down to various levels of
multidimensional data in the worksheet. For example, if you want to view
data for a specific quarter or month rather than an aggregate data value for
the whole year, you can drill down on the Year dimension to see more
detailed data.

You have three options for drilling down on a member:
* Select the member and select Essbase > Zoom In.
* Select the member and double-click the primary mouse button.

* Select the member and click the Zoom In button on the Hyperion Essbase
toolbar.

To drill down to lower levels of the Year dimension:
1. On Year in cell A2, double-click the primary mouse button.

The drill-down action retrieves data for the level below (the children of)
Year: Qtrl, Qtr2, Qtr3, and Qtr4.

Y ear

105522

A | B [ c [ o] E | F | &

1 Measures Product Market Scenario
2 |ain | 24703
L3 |Gt 27107
L4 |Gt 27912
L5 |Gitrd 25500
| 6 |

7

Figure 17. Result of Drilling Down on the Year Dimension

Note: For a discussion of the relatlonshlps among Hyperion Essbase
database members, see on page 29.

With Hyperion Essbase, you can retrieve members into grouped, or nested,
columns or rows. Row groups containing more than one level of data are
nested within single-member row groups. For example, a row group
containing Qtrl, Qtr2, Qtr3, and Qtr4 may be nested within a
single-member row for a specific region, such as East (see the following
illustration). Drilling down to lower levels of database members is one
way to retrieve data into nested groups.
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2. In cell D1, double-click to drill down on Market and create nested groups
of rows down the worksheet.

A

[ B

[ C

[ D

[ E

[ F ]

-
=

East

YWest

Qtr1
Qtr2
Qtr3
Citrd
Year
Qtr1
Qtr2
Qtr3
Citrd
fear

Measures|Pr0duct!Scenari0

53580
6459
6346
5936
24161
7137
7515
7939
7270
29861

Figure 18. Result of Drilling Down on the Market Dimension (Nested Rows)

Because worksheets can accommodate more rows than columns, Hyperion
Essbase is preset to retrieve data into rows when you drill down on a
member. You can change this default behavior and display the results of a
drill-down across columns. Drilling across columns applies only to the
top-level member of a dimension (for example, Market or Scenario).

Follow these steps to drill down on Scenario and retrieve its respective
members into columns rather than rows:

Hyperion Essbase displays the data in columns across the worksheet.

1. Press and hold the Alt key.
2. Double-click Scenario (in cell E1).
3. Release the Alt key.
A | B [ €©€ [ b | E ] F [ 6 | H
1] Measures Product | 1
L2 | Actual Budget ‘Variance “ariance % Scenario
| 3 [East Qtrl 5380  B500 -11200 -17.23076923 5380
L 4| Qtr2 6499 7850 -1081 -13.9205295 6499
L5 | Qtr3 6346 7550 -1204 -15.94701957 6346
L6 | Qtrd 5936 6790 -854  -12.577315989 5936
L7 | ‘fear 24161 28350 -4229 -14.89609017 . 24161
| 8 |West Qtr1 7137 8980 -1823) -20.345583214 7137
19| Qtr2 7815 9290 -1775 0 -19.1065662 7515
|10 | Qtr3 7939 9870 -15931 -19.56433637 7939
L11] Qtrd 7270 9060 -1790  -19.75717439 7270
12 ‘fear 29861 37180 -7319 -19.68531469 29861

Figure 19. Result of Drilling-Down on the Scenario Dimension (Nested Columns)

Drilling Down on Attribute Members
You can use the Hyperion Essbase attribute feature to retrieve and analyze in

terms of characteristics, or attributes, of dimensions. For example, you can
analyze product profitability based on size or packaging. Attribute dimensions
are associated with base dimensions.
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You can use an attribute dimension to drill down on the base dimension with
which it is associated. In the Sample Basic database, the Product base
dimension is associated with several attribute dimensions, such as
Caffeinated, Ounces, and Pkg_Type. Each attribute dimension consists of level
0 attribute members. Level 0 attribute members are the lowest level attributes
that are associated with members of a base dimension. The Pkg_Type attribute
dimension, for instance, has two level 0 members, Bottle and Can.

You can extract information on all products sold in a can by entering
manually the name Can in the worksheet. You can also use Hyperion Essbase
Query Designer or the Essbase Member Selection dialog box to select the
attribute and display it in the worksheet.

Open a worksheet, connect to the Sample Basic database, and select Essbase >
Retrieve. Select Product and replace it with Can by typing Can manually.
Click anywhere outside of cell C1 and select Essbase > Retrieve again. The
result is displayed below:

A,

B

[ ¢ J o [ E

Year

Measures Can Market  Scenario
39578

Figure 20. An Attribute Member in a Report

Drill down to all products sold in a can by double-clicking Can in cell C1.
Cola, Diet Cola, and Diet Cream are the members of Product that have the
Can attribute. The result is displayed below:

A [ B | € | o | E [ F
1] l Wieasures Market  Scenario
| 2 |Year Can Cala 2577
| 3 | Diet Cala 5708
4 Diet Cream 11093

Figure 21. Result of Drilling Down on an Attribute Member

Drilling Down on Level 0 Attribute Members: The following is a
description of the general behavior of Hyperion Essbase Spreadsheet Add-in
when you drill down on a level 0 attribute member:

* If the level 0 attribute member is in a column, a drill-down pivots the
attribute to the innermost row of the worksheet.

e If the level 0 attribute member is in a row, a drill-down does not change the
position of the attribute in the worksheet.

* A drill-down on a level 0 attribute member displays the associated base
members to the right of the level 0 attribute.

e If there is more than one level 0 attribute member in a worksheet, a
drill-down on one attribute displays other attributes to the left of the level 0
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attribute member. Level 0 attribute members in columns pivot to rows, and
level 0 attribute members already in rows remain in rows.

e A drill-down on non-level 0 attribute members is the same as the current
drill- down behavior for other types of members.

The drill-down behavior for non-level 0 attribute members is the same as the
current drill-down behavior for other types of members. See the Hyperion
Essbase Spreadsheet Add-in online help for examples of drilling down on
level 0 attribute members. For more information on attributes, refer to the
Hyperion Essbase Database Administrator’s Guide, Volume 1.

Drilling Up to Less Detail

With Hyperion Essbase, you can drill up to higher levels in the
multidimensional database outline by collapsing the current member tree. For
example, if you previously drilled down on a dimension, such as Scenario, to
view data for Actual and Budget, you may need to drill up to view aggregate
data for the Scenario dimension.

You have three options for drilling up on a member:
* Select the member and select Essbase > Zoom Out.
* Select the member and double-click the secondary mouse button.

* Select the member and click the Zoom Out button on the Hyperion Essbase
toolbar.

To drill up on the Scenario dimension in the current worksheet:

1. On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or
G2), double-click the secondary mouse button.

Hyperion Essbase collapses the members of the Scenario dimension.

A | B [ € [ o [ E ] F [ 6 | H

L1 Measures Product

| 2 | Scenario 1

|3 [East Qtrl 5380

L4 | Qtr2 5493

15 | Qtr3 G346

L6 | Qtrd 5536

7 ‘Year 24161

Figure 22. Result of Drilling Up On the Scenario Dimension

2. In cell A3, double-click the secondary mouse button to drill up on East.

Hyperion Essbase collapses East, West, South, and Central into the single
Market dimension and keeps the dimension in the A column.
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A [ B | ¢ [ o J E J F J 6 [ H
L1 Measures Product
2 Scenario
3 [Market  lotr 24703
L4 | Qtr2 2ro7
L5 | Qtr3 2z
| 6 | Qtrd 25800
7 Year 108522

Figure 23. Result of Drilling Up On East

Customizing Drill-Down and Drill-Up Behavior

You can customize the behavior of the Zoom In and Zoom Out commands in
the Hyperion Essbase Options dialog box. The following steps illustrate some
drill-down and drill-up techniques.

To retrieve all members of a dimension with a single drill-down operation:

1.

Al Levels

= Bottom Level

" Sibling Level

" Same Level

" Same Generation

' Eomulas

— Member Retention

¥ Include Selection

™ ‘within Selected Group

™ Remove Unselected Groups

Select Essbase > Options and select the Zoom tab.
Hyperion Essbase displays the Zoom Tab.

Figure 24. Zoom In and Member Retention Option Settings

The Zoom In option group contains items that enable you to customize
drilling behavior. You can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select
Bottom Level, Hyperion Essbase retrieves data for the lowest level of
members in a dimension. With this option, a drill-down on Year retrieves
Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retains the selected member along with the other members
retrieved as a result of a drill down. For example, if you drill down on
Qtrl, Hyperion Essbase retrieves data for Jan, Feb, and Mar, as well as for
Qtrl. When this option is disabled, Hyperion Essbase retrieves data only
for Jan, Feb, and Mar; Qtrl is eliminated.
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Note: For more information on the Zoom In and Member Retention
option groups, see the Hyperion Essbase Spreadsheet Add-in online
help.

2. In the Zoom In option group, select the All Levels option and click OK to
save the setting.

3. In cell A3, drill down (double-click) on Market.
4. In cell C2, drill down (double-click) on Scenario.

Hyperion Essbase retrieves all members of Market and Scenario. For the
Market dimension, Hyperion Essbase drilled down two levels to get to the
bottom-most members, which are individual states. The Scenario
dimension has only one member level, so the members of Scenario would
also be retrieved if you selected Next Level in the Zoom In option group.

I i B | ¢ [ o | E | F [ & |
1 1 | Weasures Product
2 Actual  Budget Varance Variance % Scenario
3 [Mew York Gt 1656 2000 -344 -17.2 1656
4 Gitr2 2363 2610 247 -9.46360153 2363
5 Gitra 1943 2290 -347 -16.1528384 1943
6 Gitrd 2240 2320 -80 -3.44827586 2240
7 Year 8202 9220 1018 -11.0412148 g202
g8 M husetts Gt 1532 1690 -168 -9.34911243 1632
9 Gitr2 1750 1900 -180 -7.89473684 1750
10 Gitra 1936 2100 -164 -7.809523 1936
11 Gitrd 1494 1610 116 -7.20496894 1494
12 Year 712 F300 588 -8.05479452 6712

Figure 25. Result of Drilling Down to All Member Levels

5. Select Essbase > Options and select the Zoom tab.
6. Return the Zoom In option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected
Group in the Member Retention option group.

To drill up only on Qtrl:

1. In the Member Retention option group on the Zoom Tab, click the Within
Selected Group check box and click OK.

Make sure that Include Selection is also still checked.
2. To drill up on Qtr 1 (in cell B3), double-click the secondary mouse button.

Notice that drilling up to the Year dimension affects only New York. All
other states show data for all four quarters.
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I A [ B | ¢ | o | E | F [ & |
1 | | Measures Product
2 Actual  Budget  Mariance Wariance % Saenario
3 [Mew York Year g202 9220 1018 -11.04421475 8202
4 M husetts Gt 1632 1690 -168 -9.348112426 1632
5 Gitr2 1750 1900 -180 -7.894 736842 1750
6 Gitra 1936 2100 -164 -7.8085231 1936
7 Gitrd 1494 1610 116 -7.204968544 1494
8 Year 6712 700 588 -8.054794521 6712
9 |Florida Gt 1070 1300 -230 -17.689230769 1070
10 Gitr2 1339 1670 -2 -14.7133758 1339
11 Gitra 1495 1730 235 -13.68381503 14985
12 Citrd 1125 1300 178 -13.46153844 1128

Figure 26. Result of Drilling Up Within a Selected Group

3. Before moving on with the tutorial, disable the Within Selected Group
option:
a. Select Essbase > Options and select the Zoom tab.

b. In the Member Retention option group, clear the Within Selected
Group check box.

4. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Pivoting, Retaining, and Suppressing Data

36

After you retrieve data into the worksheet, you may want to manipulate the
data in various ways. For example, you may want to move rows and columns
to different positions in the worksheet, or you may want to tell Hyperion
Essbase to suppress or retain specific data during data retrievals.

To help you manipulate worksheet data, this section steps you through the
following procedures:

. l’lZi:zotmg Rows and Columns’

Pivoting Rows and Columns

With the Pivot command, you can change the orientation of worksheet data.
Use the Pivot command to do any of the following;:

* Move a row group to a column group
* Move a column group to a row group
* Change the order of row groups

* Change the order of column groups
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You can execute the Pivot command in two ways:

* Select the member cell that you want to pivot, and select Essbase > Pivot.
This method applies only to moving a row group to a column group or a
column group to a row group.

* Click in the center of the member cell that you want to pivot, press and
hold the secondary mouse button, and drag the group to the desired
location. This method applies to swapping row and column groups and to
changing the order within groups.

To pivot Year data from a row group to a column group:

1. To open a new worksheet, select File > New or click the

ol

icon.

Note: You should already be connected to the Sample Basic database. If
you are not connected, follow the steps in i
2. Select Essbase > Retrieve.
3. Dirill down (double-click) on Measures and Product (in cells B1 and C1,

respectively).
4. Press and hold the Alt key, and, in cell E1, drill down (double-click) on
Scenario.
A ] B [c] D [ E [ F [ G [ H

L1 tarket
L2 | Actual Budget “ariance “ariance % Scenario
3 |100 Profit Year 30468 41940 1472 -27.35336195 30468
1] Inventary  Year 29447 31500 2142 B.7E0B26761 29447
5 | Ratios Year 5727200145 576240049 -0.351123447 -0.G09335377 57.27208145
6 | Measures Year 30468 41940 1472 -27.35336195 30468
7 |200 Profit Year 77954 35960 7OGR 22 24200278 77954
8 | Inventary  Year 33000 31000 1910 -6.143454467 33000
EX Ratios Year 5553956595 57 4BBT4162 -1.927075664 -3.353375551 5553066505
K Measures Year 27954 35550 7996 2224200278 27954
(11300 Profit Year 25799 29360 -3561 | -12.12674659 25799
(12 ] Inventary  Year 28665 27140 725 -6.356932203 28665
(13 Ratios Year 5423795671 57.13960487 -2.901548161 -5.078007162 54.23795671
(14 Measures Year 25799 29360 -3561 | -12.12674659 25799
[15 |400 Profit Year 21301 22130 -629 -3.74R046091 21301

Figure 27. View Before Pivoting

5. In cell C3, select Year and select Essbase > Pivot.
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[ B [ C D [ E [ F

L1 ‘fear tarket

L2 | Actual Budget Wariance Wariance %

| 3 [100 Profit 30468 415840 -11472 -27 35336195
| 4 | Inventary 29448 31590 2142 6.780626751
|5 | Ratios 5727288145 57 6240043 -0.351123447 -0.609335377
|6 | Measures 30468 415840 -11472 -27 35336195
| 7 [200 Profit 27554 35540 7996 2224200278
|8 | Inventary 33000 31090 -1910) -6.143454457
19 | Ratios 55 53966595 57 46674162 -1.927075664 -3.353375551
|10 Measures 27554 35540 7996 2224200278
| 11 [300 Profit 25799 29360 3861 -12.12874659
|12 | Inventary 26865 27140 -1725 -6.355932203
|13 | Ratios 54.2379567 1 5713950457 -2.901545161 -6.075007152
|14 | Measures 25799 29360 3861 -12.12874659

Figure 28. Result of Pivoting a Row Group to a Column Group

Hyperion Essbase pivots the Year dimension to a column group next to
Market (above the Scenario members).

6. As another example, in cell C2, select Actual.
7. Right click and drag Actual to product 100 in cell A3.

[ B [ C [ D [ E [ F
L1 ‘fear tarket

2 Actual Budget Variance “ariance %

3 100 [sctual Budget Yariance Yariance% Scenario| 11472 -27.35336135
L 4 | Trventary EEt 3TaE0 2142 B.7B0626751
|5 | Ratios 5727288145 57 6240043 -0.351123447 -0.609335377
|6 | Measures 30468 415840 -11472 -27 35336195
| 7 [200 Profit 27954 35950 7996 -22.24200278
| 8 | Inventary 33000 31090 -1910) -6.143454457
19 | Ratios 55 53966595 57 46674162 -1.927075664 -3.353375551
|10 Measures 27554 35540 7996 2224200278
| 11 [300 Profit 25799 29360 3861 -12.12874659
|12 | Inventary 26865 27140 -1725 -6.355932203
|13 | Ratios 54.2379567 1 5713950457 -2.901545161 -6.075007152
|14 | Measures 25799 29360 3861 -12.12874659

Figure 29. Pivoting a Column Group to a Row Group

Note:

The member label box that is displayed under the cursor during the
pivot operation displays the names of the members that you are
pivoting. The orientation of the member label box, however, does not
determine the orientation of the pivot result. Hyperion Essbase
determines the data orientation by the location of the destination
cell.

Hyperion Essbase pivots the Scenario members (Actual, Budget, Variance,
and Variance%) from a column group to a row group that is displayed to
the left of the Product members.
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Figure 30. Result of Pivoting a Column Group to a Row Group

A [ C [ D [ E ]
L1 ‘fear tarket
2 |Actual 100 Profit 30465
3 I Inventary 29448
4| Ratios 57.27288145
L9 | Measures 30465
|6 | 200 Profit 27954
L7 | Inventary 33000
L8 | Ratios 55.53966595
L 9] Measures 27954
|10 300 Profit 25799
L11] Inventary 28065
|12 Ratios 54.2379567 1
113 | Measures 267599
|14 | 400 Profit 2130

To transpose the order of row groups:
1. In cell A2, select Actual.
2. Right-click and drag Actual to Profit (cell C2).

Figure 31. Pivoting the Order of Row Groups

A ] [ ¢ [ o [ e[ F 6]
L1 ‘fear tarket
| 2 |Actual 100 [Eroft_Betual Budget Variance Variance% Scenario|
L3 | Inventary
4| Ratios 57.272868145
L9 | Measures 30465
|6 | 200 Profit 27954
L7 | Inventary 33000
L8 | Ratios 55.539665595
L 9] Measures 27954
|10 300 Profit 25799
L11] Inventary 28865
|12 Ratios 54.23795671
113 | Measures 26759
|14 | 400 Profit 21301
115 | Inventary 2R052
|16 | Ratios 53.59966758

The pivot changes the order of the row groups.
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A | B [ C [ D [ E ] F
L1 ‘fear tarket
| 2 [100 Profit IActuaI _| 30465
3 | Budget 415840
L 4 | Yariance -11472
1 9 | Yariance % -Z7 35336195
| 6 | Scenario 30465
L7 | Inventary Actual 25445
| 8 | Budget 31590
|9 | Yariance 2142
|10 | Yariance % 6780526751
11| Scenario 25445
|12 | Fatios Actual a7 27285145
|13 | Budget 576240049
|14 | Yariance -0.381123447
115 | Yariance % -0.609335377
|16 | Scenario . 57 27285145

Figure 32. Result of Pivoting the Order of Row Groups

In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are
members of different row groups, Hyperion Essbase exchanges the
member groups. You must select a destination cell that contains a member
name to exchange row members. You can also exchange column members
by choosing a destination cell in another column that contains a member
name.

Retaining a Data Subset

The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete
individual cells.

To keep only Actual and Budget data in the current worksheet:
1. In cell C2, select Actual and, in cell C3, select Budget.

A B [ C [ D [ E T F ]
L1 ‘fear tarket
| 2 [100 Profit Actual 30465
3 | I} 415840
L 4 | “ariance -11472
1 9 | “arance % -27. 35336155
| 6 | Scenario 30465
L7 | Inventary Actual 25445
|8 | Budget 31520
|9 | “ariance 2142
|10 | “arance % 670626751
11| Scenario 25445
|12 | Fatios Actual a7 27285145
|13 | Budget 57.6240049
|14 | “ariance -0.351123447
115 | “arance % 0609335377
|16 | Scenario 57 27285145

Figure 33. Selecting Members for the Keep Only Command
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2. Select Essbase > Keep Only.

Hyperion Essbase removes the Variance, Variance%, and Scenario rows
from the worksheet and retains only Actual and Budget data.

Budget  57.46674162

Measures Actual

275954

[ B [c[] o [EJ] F ]

L1 ‘fear Market
|2 [100 Profit Actual 30468

|3 | 1) 41940

| 4 | Inventary Actual 29448

5 | Budget 31580

L6 | Fatios Actual | &7 27288145

L7 | Budget 576240049

L8 | Measures Actual 30465

19 | Budget 41940

|10 200 Profit Actual 27954

|11 | Budget 35950

12 | Inventary Actual 33000

|13 | Budget 31080

| 14 | Ratios Actual | 5553966595

115 |

116 |

Figure 34. Result of Retaining a Data Subset (Adjacent Cells)

Occasionally, the data that you want to remove from the worksheet does
not lie in an adjacent range of cells.

To select and retain nonadjacent cells.

1. Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.
2. Select Qtr2 (in cell E2).

3. Press and hold the Ctrl key and select Qtr4 (in cell G2).

B [ cC D [ G
1
2] atrt
|3 |100 Prafit Actual 7048 7872 8511 7037
4| Budget g7e0 10660 11440 10050
L9 | Inventary Actual 25445 25860 36461 35811
|6 | Budget 315490 29550 34830 32340
L7 | Ratios Actual | 57 40178857 57 28473167 &7.395509978 5699467561
|8 | Budget 577376566 57 39041794 57 45231167 57.96344648
19| Measures Actual 7048 7E72 3511 7037
|10 | Budget g7e0 10660 11440 10050
|11 |200 Prafit Actual 6721 7030 70045 7158
112 | Budget 8480 8540 8530 9800
113 | Inventary Actual 33000 31361 35243 327E0
|14 | Budget 31090 28040 30260 26460
|15 | Ratios Actual | 5538738874 55.49797453 55.06764011 56.21773123
|16 | Budget 57 36255206 57 40396375 57.111436%6 67 9954955
L17 | Measures Actual G721 7030 7005 7193

Figure 35. Selecting Nonadjacent Members for the Keep Only Command

4. Select Essbase > Keep Only.
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Hyperion Essbase retains only Qtr2 and Qtr4 data and deletes the other
Year members.

A | B [ € ] D [ E [ F [ G

L1 tarket

L2 | Qtr2 Oitrd

| 3 [100 Profit Actual 7872 7037
|4 | Budget 10660 10050
19 | Inventory Actual 29560 3581
|6 | Budget 29550 32340
L7 | Ratios Actual | 5728473167 56.99467561
|8 | Budget 5739041794 57 56344548
|9 | Measures Actual 7E72 7037
|10 | Budget 10660 10050
|11 |200 Profit Actual 7030 7198
|12 | Budget 8540 9800
113 | Inventary Actual 31361 32760
|14 | Budget 28040 26460
|19 | Ratios Actual | 5549757453 56.21773123
|16 | Budget 57 40395375 579554955
L17 | Measures Actual 7030 7198

Figure 36. Result of Retaining a Data Subset (Nonadjacent Cells)

Removing a Data Subset

The Remove Only command is the counterpart to the Keep Only command.
With Remove Only, you can remove selected member rows or columns and
retain all other data in the worksheet view.

To remove a data subset from the current worksheet view:
1. In cell B7, select Ratios.

2. Press and hold Ctrl, and, in cell B9, select Measures.

3. Select Essbase > Remove Only.

Hyperion Essbase removes data for Ratios and Measures but retains data
for Profit and Inventory.

A [ B T €I p | E JF[G[HTI
Market
Qtr2 Citrd
100 Profit Actual 7avz2 7037

Budget 10860 10050

Irventory Actual | 29860 35811

Budget 29950 32340

200 Prafit Actual JO30 7158
Budget 5840 9800

Inventory Actual | 31361 32760

Budget 25040 26460

300 Prafit Actual G769 G403
Budget 7880 7000

Inventory Actual | 30334 358142

Budget 25460 35460

R

Figure 37. Result of Removing a Data Subset
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Navigating Through the Worksheet Without Retrieving Data

With the Navigate Without Data feature, you can perform navigational
operations, such as pivot, zoom in, zoom out, keep only, and remove only,
without retrieving any data into the worksheet.

This feature is especially useful when dealing with dynamic calculation
members, which are usually specified by the application designer. By
activating Navigate Without Data, you are effectively telling Hyperion Essbase
not to dynamically calculate values (that is, calculate the database at retrieval
time) while you are creating the spreadsheet report. Dynamic calculation is
discussed in more detail in [Retrievi i i Z

on page 169.

To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.
Hyperion Essbase displays a check mark next to the menu item.

Note: You can also enable Navigate Without Data by selecting the
appropriate option in the Essbase Options dialog box (Global Tab)

or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2.

Hyperion Essbase shows the collapsed Year dimension but withholds
retrieving any data that is changed as a result of drilling up. The cells
where data would normally be displayed are blank.

A | B [ € [ b E JE[JG[HT
L1 tarket
L2 | ‘fear
L3 |100 Prafit Actual
L 4| Budget
L5 | Inventary Actual
L6 | Budget
Lf |200 Prafit Actual
L8 | Budget
19| Inventary Actual
|10 | Budget
|11 |300 Prafit Actual
112 | Budget
113 | Inventary Actual
|14 ] Budget

Figure 38. Result of Zooming Out (Navigate Without Data Enabled)
3. In cell D2, drill down (double-click) on Year by pressing and holding the
Alt key.

Hyperion Essbase drills down without retrieving data.
4. In Cell C3, select Actual and select Essbase > Pivot.
Hyperion Essbase executes the pivot but does not retrieve data.
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Note: You get the same result by pivoting any of the other Scenario
members.

A [ B [c[p[EJF] 6 [H[I] J [K[L]
Market
I _lActuaI Budget
Ctrl Otr2 Qi3 Oted Year  Otrl Q2 Q3 Otrd Year

100 Profit
Irventory

200 Profit
Irventory

300 Profit
Irventory

400 Profit
Irventory

Diet Profit
Irventory

Product Profit

TEEEE

Figure 39. Result of Pivoting (Navigate Without Data Enabled)

5. In cell G1, click the secondary mouse button on Market and drag Market
to product 100 (cell A4).

Hyperion Essbase executes the pivot without retrieving data.

A [ B [ ¢ [p[EJ]FJGJH]I[J] K [L|
Actual Budget
Ctrl Qt2 Otr3  Otrd Year Qtrl Qb2 O3 Otrd

Warket 100 Profit
I Inventory

200 Profit
Irventory

300 Profit
Irventory

400 Profit
Irventory

Dist Profit
Irventory

Product Profit
Irventory

=

Figure 40. Result of Pivoting (Navigate Without Data Enabled)

Navigating without data also works with the Keep Only and Remove
Only commands.

To navigate without data when using the Keep Only or Remove Only
command:

1. Select Qtrl (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Hyperion Essbase retains only the selected members and does not retrieve
data.
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C [DJE]FJG[H]I]J]

Market 100

200

300

400

=
=

-
=y

Diet

-
M

-
w

Figure 41. Result of Keep Only (Navigate Without Data Enabled)

Qtr2

Prafit
Inventory
Prafit
Inventory
Prafit
Inventory
Prafit
Inventory
Prafit
Inventory

Product Profit

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select
Essbase > Remove Only.

Hyperion Essbase executes the Remove Only command without actually

querying the database for information.

C [ D JE] FJG[H[TI[J]

Market 100

200

Figure 42. Result of Remove Only (Navigate Without Data Enabled)

Actual Budget
Qi1 Gtr2 Gtrl Qtr2
Profit
Irventory
Profit
Irventory

Product _F'roﬁt

Irventory

To turn off Navigate Without Data when you are ready to retrieve data:
1. Select Essbase > Navigate Without Data.
Hyperion Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the

appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase

toolbar.

2. In cell A3, drill down (double-click) on Market.
Hyperion Essbase drills down on the Market dimension and also retrieves

data into the worksheet.
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A | B [ € [ b [ ETJF 6 [H]I1]

L1 Actual Budget

2 Qtrl Qtr2  Gtrl Qtr2
3 |East l100 Prafit 2747 3352 2880 5480
L4 | Invertory 5354 4420 5200 3530
L5 | 200 Prafit 562 510 950 1070
L6 | Invertory 5257 G442 8610 5510
L7 | Product Profi 5380 6499 G500 7S50
L8 | Invertory 26744 26214 24710 24030
9 |West 100 Prafit 1042 849 2350 2130
|10 | Invertory 8552 9856 10250 10950
|11 ] 200 Prafit 2325 2423 2570 FFA0
|12 | Invertory 11755 11643 11070 10500
|13 | Product Profi 7137 7515 8960 5280
14 | Invertory 38751 41574 39020 42820

Figure 43. Result of Drilling down (Navigate Without Data Disabled)

Note: If you want to retrieve data without changing the current worksheet
view, you can also retrieve data by simply double-clicking in any
data cell or by selecting Essbase > Retrieve (after disabling Navigate
Without Data).

Suppressing Missing Values, Zero Values, and Underscore Characters
Several types of data can be returned to a worksheet view:
* Numeric data values

* #NoAccess strings, which are displayed when you do not have the proper
security access to view a data value

* #Missing strings, which indicate that no data exists for that member
intersection

e Zero data values

A missing value is not the same as a zero value that is loaded into the
Hyperion Essbase database. When data does not exist for a data cell in
Hyperion Essbase, a value of #Missing is returned to the worksheet. If any
cell in a row contains a value, that row is not suppressed on a retrieval.

With Hyperion Essbase, you can suppress missing and zero values from the
display in the worksheet. In addition, you can tell Hyperion Essbase to
suppress underscore characters that are in some member names.

To suppress rows that contain missing values from displaying in the
worksheet:

1. In cell C3, double-click the secondary mouse button to drill up on Profit.
2. Pivot Measures (in cell C3) to Actual (in cell D1).
3. In cell B4, drill down (double-click) on product 100.

46  OLAP Spreadsheet Add-in User’s Guide for Excel



Notice that, in the South, the product 100-30 row contains all missing
values, indicating that this product is not sold in the South. You may need
to scroll down the worksheet to see this row.

Figure 44. Worksheet View Displaying Missing Data Values

A B [ € T o [ E [ F
L1 Measures
L2 | Actual Budget
L3 | Qtrt Qtr2 Qtrt Qtr2
| 4 [East 100-10 2461 25940 2580 3050
15 | 100-20 212 303 220 300
L6 | 100-30 74 109 110 130
L7 | 100 747 3352 2880 3480
L8 | 200 562 510 250 1070
19 | Product 5380 5493 5500 7580
|10 [VWest 100-10 1047 1189 1720 1200
|11 100-20 £7 177 320 200
112 | 100-30 52 -163 310 30
113 | 100 1042 849 2350 2130
|14 | 200 2325 2423 2570 2720
115 | Product 7137 7515 8560 9290
|16 |South 100-10 745 835 1160 1280
|17 | 100-20 306 363 570 GE0
|18 | 100-30 #dissing #lissing  #Mlissing #issing

4. Select Essbase > Options, and select the Display tab.

5. In the Suppress option group, click the #Missing Rows check box and click

OK.

Note: The Suppress #Missing Rows and Zero Rows options are not
available when any of the Formula Preservation options are selected
in the Essbase Options dialog box. For more information on

”

Formula Preservation, see [‘Preserving Formulas When Retrieving

on page 158.

Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog
box, you must perform a retrieval or drill operation to have the new

setting take effect.

Hyperion Essbase suppresses product 100-30 from the South member

group.
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A B [ €] b [ EJFJG[HT]I]
| 4 |East 100-10 2461 2040 2550 3050
15 | 10020 212 303 2200 300
| 6 | 100-30 74 109 110 130
| 7 | 100 2747 3382 2850 3480
| 8 | 200 562 610 950 1070
ER Product 5350 £499 5500 7550
[ 10 |wvest 100-10 1047 1189 1720 1900
[11] 10020 57 77 3200 200
112 ] 100-30 62 163 3100 30
[13] 100 1042 849 2350 2130
| 14 | 200 2325 2423 2570 2720
115 | Product 7137 7515 8950 92490
[ 16 |South 100-10 745 835 1160 1280
117 | 10020 306 363 570 660
|18 | 100 1051 1198 1730 1940
119 ] 200 1465 1540 1640 1700
| 20 | Product 3077 3267 4180 4410
|21 |Central  100-10 843 928 1080 1180
Figure 45. Result of Suppressing Missing Data Values

7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data
retrieval are not retrieved again by simply disabling the feature. If
you disable the feature in the Essbase Options dialog box, missing
values are retrieved from only that point on. For example, in the
tutorial task described above, Hyperion Essbase could not go back
and return the missing values for product 100-30. To return these
missing values to the worksheet, you disable the Suppress #Missing
Rows feature, drill up on a Product member, and then drill down
again.

You can also suppress zeros and underscore characters as described in the
task above by clicking the appropriate options in the Suppress option group
in the Essbase Options dialog box (Display tab).

In addition to suppressing specific values and characters during retrieval,
Hyperion Essbase enables you to define a label for missing values (#Missing)
or for data you do not have access to (#NoAccess). If you define a
replacement label for these values, Hyperion Essbase displays the replacement
labels instead of the default labels. For more information on defining
replacement labels for the #Missing and #NoAccess labels, see the Hyperion
Essbase Spreadsheet Add-in online help.
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Formatting the Worksheet

Hyperion Essbase provides you with various ways to customize the
worksheet view. For example, you may want to apply visual cues, or styles, to
certain member names or to data cells in the worksheet, or you may want to
display alternative names, or aliases, for member names. This section steps
you through the following formatting procedures:

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells

In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the
text and cells in the worksheet, you can easily keep track of specific database
members, dimensions, and cell functions. Styles are a great way to help view
and distinguish data in Hyperion Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during

a retrieval request. For more information, see 'Remaving Styles” onl

This section of the tutorial describes the following:

Note: For a discussion of the relationships among Hyperion Essbase database

members, see 'Database Outlines” on page 7 on page 29.

Applying Styles to Parent Members
Each dimension in a database may contain a large number of hierarchical

levels. As you view data in the worksheet, you may not be familiar with all
the hierarchical levels of the database outline. To indicate which members
have underlying children, you can apply formatting styles to parent members,
including those with attributes.

To apply styles to parent members:
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1. To open a new worksheet, select File > New or click the

ol

icon.
2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you

are not connected, follow the steps in !‘Connecting to a Database’]

3. In cell A2, drill down (double-click) on Year.
4. Select Essbase > Options.
5. In the Essbase Options dialog box, select the Style tab.

Note: The Style tab is available only when you are connected to a
database.

Hyperion Essbase displays the Styletab.

Essbase Options [ %]
Display I Zoom I Mode  Style | Glabal I
— Member
— Sample

v

™ Child Favan?

™ Shared
— Dimensiar

= — Sample

v Measures Year

v Product LI

W Cell Border

Background Color: I Mone j Format... |
— Data Cell

Sample———————

[WLirked Objects S

I Integration Server Dnill-Through

™ Read Only LI

Farmat... |

Connection Information:

’7 Localhost: S ample: B asic ‘

Figure 46. Essbase Options Dialog Box, Style Tab

In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. In the Members group box, click the Parent check box.
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Clicking this box defines a font and color style for parent member names.
Hyperion Essbase defines a default color of navy for all parent members.
You can select a font format by clicking the Format button to the right of
the Members box and using the Font dialog box.

7. Click the Format button.
Hyperion Essbase displays the Font dialog box.
Font HE .
Font: Font style:
| Bold [1]:4 I
M Albertuz Extia Bold & [Fegular
T Albertuz Medium talic: Camee |
Anna old
T Antique Olive old Italic
% Avial
Avial Black
T Arial Narrow LI
— Effect: — Sampl
™ Stikeout
™ Underline
Lolor:
I- Mavwy - l Script:

Figure 47. Font Dialog Box

8.

10.
11.

12.

13.

In the Font style list box, select Bold and then click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

Click OK again.

Even though you have defined styles, they are not enabled until you click
the Use Styles check box from the Essbase Options dialog box and
refresh the worksheet.

Select Essbase > Options, and select the Display tab.

In the Cells option group, click the Use Styles check box to enable your
styles, and then click OK.

Select Essbase > Retrieve to refresh the worksheet and apply the styles.
Hyperion Essbase displays parent member names in bold, navy font.
In cell A2, drill down (double-click) on Qtr1.

Hyperion Essbase displays Jan, Feb, and Mar in a regular font, because
these members do not have underlying children.
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A [ B [ ¢ [ o | E ]
|1 Measures Product Market  Scenario
| 2 |Jan 8024
| 3 |Feb 8346
| 4 |Mar 8333
|5 | a1 24703
|6 | Qw2 2ro7
| 7| Qu3 iz
18| ot 25800
| 9| Year 105522

Figure 48. Styles Applied to Parent Members

Applying Styles to Dimension Members
In addition to applying styles to parent members (as you did in the previous

section), you can also apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Hyperion Essbase Spreadsheet Add-in.

To apply styles to dimensions:
1. Select Essbase > Options and select the Style tab.
2. In the Dimensions group box, select Year.

3. Select the Cell Border check box to create a border around each cell that
contains a member from the selected dimension.

4. From the Background Color list box, select Yellow.

Essbase Options

Displayl Zoom I Mode  Style |GIObaI|

— Member
Attribute: — Sample
o Parent
[ Chid
Shared -
L _I Faormat... |
— Dimensiar
Dimension:  Sample
v
™ Measures Year
™ Praduct LI
¥ Cell Border
Background Color: ||:| ellow - Format... |
—Data Cells =
Altribute: — Sample
Farmat... |

Connection Information:
’7 Poplar. 5 ample:B azic

o]

Cancel |

Help

Figure 49. Selecting a Background Color from the Style Tab
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10.
11.

12.

13.
14.

15.
16.

17.

Click the Format button that is to the right of the Dimensions list.
Hyperion Essbase displays the Font dialog box.

From the Font style list box, select Bold, and then click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

From the list of dimensions, select the Measures dimension and, from the
Background Color list box, select Fuschia.

From the list of dimensions, select Product, and clear the Cell Border
check box.

From the Background Color list box, select Aqua.
Scroll down the list of dimensions, and select Market.

Select the Cell Border check box, and click the Format button that is to
the right of the Dimensions list.

When the Font dialog box is displayed, from the Font style list box select
Italic, and then click OK.

From the list of dimensions, select Scenario, and from the Background
Color list box, select Red.

Click the Format button, and from the Color list box, select White.
Click OK twice to return to the worksheet.

Note: When you define styles, your choices are saved to the essbase.ini
file on your local machine. You can define one set of styles per
database.

In cell D1, drill down (double-click) on Market.

Press and hold the Alt key and drill down (double-click) on Scenario (in
cell E1).

Select Essbase > Retrieve to refresh the worksheet.

Hyperion Essbase redisplays the worksheet and implements the newly
defined styles. For example, members of the Scenario dimension are
displayed with a red background.

Chapter 2. A Basic Hyperion EssbaseTutorial 53



A [ B C 0 | E [ F [ &6 |
| 1| Product
| 3 |East Jan 1732 2080 -16.7308 1732
| 4| Feb 1843 2230 -17.3543 1843
|5 | Mar 1805 2190 -17.5799 1805
| B | Q1 5380 500 -17.2308 5330
| 7 | Q2 5499 7550 -13.9205 54599
| 8 | Q3 5345 7550 -15.947 6346
| 9 | Qird 5935 £790 12 5773 5336
|10 Year 24161 25390 -14.8951 24161
| 11 |West Jan 2339 2980 -21.5101 2339
12| Feb 2394 2990 -19.9331 2394
|13 Mar 2404 2990 -19.5987 2404
| 14 | Q1 7137 B9ED 1823 20346 7137

Figure 50. Dimensions with Styles Applied

Applying Styles to Data Cells
You can apply styles to data cells, such as read-only cells, read /write cells,

linked object cells, and Hyperion Integration Server Drill-Through cells to
distinguish them from other cells in the worksheet. The Sample Basic database
that you are using for this tutorial does not contain data cells with any of
these characteristics. In the advanced tutorial presented in Chapter 3, you
attach a linked reporting object to a data cell and apply a style to the cell.

Note: You cannot perform the actions in shaded boxes.

In general, you apply styles to data cells by following these steps:
1. Select Essbase > Options, and select the Style tab.
2. In the Data Cells option group, click the Linked Objects, Integration Server Drill-Through, Read
Only, or Read/Write check box.
3. Click Format.
4. In the Font dialog box, specify the font, font size, font style, color, and effects, and click OK.
Note: Hyperion Essbase displays an example of the selected style in the Sample box.
Data Cells
[EdLinked Objects Sample
I Integration Server Drill-Through Linked Objects
I Read Only LI
5. Repeat steps 2—4 to set styles for other data cells.
6. Select the Display tab and select the Use Styles check box to apply styles to the worksheet.
7. Click OK to close the Essbase Options dialog box.
8. Select Essbase > Retrieve to display the new styles in the worksheet.
Determining the Precedence of Overlapping Styles
The only way you can apply a background color to data is to define a style
for dimensions. If dimension styles are defined, and the Use Styles setting is
turned on, members of a dimension always have the background color
defined for their dimension.
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The text styles that you can apply to members, dimensions, and data cells
have a hierarchy that determines which characteristics are applied. Member
styles are at the top of that hierarchy. Thus, member styles are always applied
(as long as styles are turned on). Note that in Figure 48 on page 53, the Qtrl
label in cell B6 is in bold, navy font, and has a yellow background. The navy
font comes from the style defined for parent members, and the yellow
background comes from the style defined for Year.

Hyperion Essbase uses the following order of precedence when applying
multiple text styles:

 Linked object cells

¢ Integration Server Drill-Through cells
* Read-only cells

* Read/write cells

* Parent member cells

* Child member cells

* Shared member cells

¢ Cells containing formulas

* Dynamic calculation member cells

* Attribute cells

e Dimension cells

If you want to see a child member style, make sure that the parent member
style is turned off. If you want to see a shared member style, make sure that
both parent and child member styles are turned off.

Removing Styles
Styles can be very helpful tools for keeping track of data in Hyperion Essbase

Spreadsheet Add-in. Applying styles, however, involves additional processing
time during a retrieval request. This additional processing has a slight impact
on the speed of Hyperion Essbase retrievals.

If you do not want to apply styles to the worksheet view, you can clear them.
You can also turn off styles so they are not displayed when you refresh the
view (by selecting Essbase > Retrieve, for example). So that the worksheet
matches the illustrations presented in the following tasks, do not remove styles
if you are stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the
FlashBack command, these styles are temporarily removed from the
current view. The styles are re-applied whenever you initiate a retrieval.
You cannot perform the actions in shaded boxes.
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To remove all styles from a worksheet:
1. Select all cells in the worksheet.

2. From the Excel menu bar, select Edit > Clear > Formats.

To disable styles:
1. Select Essbase > Options and, select the Display tab.

2. In the Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the
styles remain in the current worksheet view when you refresh the view.
The styles remain to avoid removing any styles that you may apply to
individual cells using native worksheet formatting options.

Displaying Aliases for Member Names

Aliases are alternate names for database members. You can create reports that
use the database member name, which is often a stock number or a product
code, or an alias name, which can be more descriptive. Aliases are defined by
the Hyperion Essbase application designer. Each database can contain one or
more alias tables.

For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product,
such as Colas and Root Beer, is defined in an alias table. In some cases, alias
names may vary depending on the combination of other database members.
For example, a Product member may have a different alias for each market in
which it is sold. For more information, see the Hyperion Essbase Spreadsheet
Add-in online help or the Hyperion Essbase Database Administrator’s Guide.

To display the alias of a member rather than its database name:
1. In cell C2, double-click the secondary mouse button to drill up on Actual.

2. Press and hold the Alt key and drill down (double-click) on Product (in
cell D1).

3. Select Essbase > Options, and select the Display tab.

4. In the Aliases option group, click the Use Aliases check box to display
member aliases.

5. Select Default from the Alias list box.
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Essbase Oplions [ %]

Display |Zoom I tode I Style I Globall

~ Indentation — Replacement

 Nagne #higzing Label: I

' Subitems — e

& Totals Mo Access Label: I
— Suppre — Aliaze:

™ #Missing Fows V' Use Aliases

™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions

&l Aliaz:
— Cells

V Use Styles IDefauIt j
V' Adiust Columng

™| Auto Sort Fows Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie
[ Latest Time Period IJan

|

QK I Cancel | Help |

Figure 51. Enabling Aliases in the Essbase Options Display Tab

6. Click OK.

7. Select Essbase > Retrieve to refresh the worksheet and display the alias

names.

Hyperion Essbase changes the Product codes (100, 200, and so forth) to
their predefined aliases (Colas, Root Beer, Cream Soda, and so forth). In

the Sample Basic database, Product is the only dimension with predefined

Figure 52. Result of Displaying Aliases

aliases.
A [ B [ ¢ [ D E F G
1

| 2 Colas Root Beer Cream Soda Frait Sod: Diet Drinks
13|

| 4 |East Jan 184 466 181
|5 | Feh A5 242 200 513 1848
| 6 | Mar 935 162 207 501 189
| 7| Qur1 2747 562 591 1480 555
| 8 | Q2 3382 610 922 1615 652
| 9 | Qi3 3740 372 522 1712 G44
| 10 | Qted 2817 930 592 1537 567
|11 Year 12656 2534 2627 6344 2408
| 12 | West Jan 378 762 785 454 BE3
| 13 | Feh 337 781 797 479 6683
| 14 Mar 327 792 811 474 679

Notice that Hyperion Essbase is still displaying the styles that you created
and applied in the previous sections.
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Displaying Both Member Names and Aliases

In addition to displaying aliases for database members, you can also tell
Hyperion Essbase to display both aliases and database member names in
Hyperion Essbase Spreadsheet Add-in.

To display the name and alias of a member:

1. In cell B8, double-click the secondary mouse button to drill up on Qtr2.
2. In cell C2, click Colas, and then select Essbase > Pivot.

3. In cell C3. click Year, and then select Essbase > Pivot.

4. Select Essbase > Options, and select the Display tab.
5

In the Aliases option group, select the check box for Use Both Member
Names and Aliases for Row Dimensions.

Be sure that Use Aliases is already checked.
6. Click OK to return to the worksheet, and select Essbase > Retrieve.

Hyperion Essbase displays both member names and their aliases for row
dimensions. Because the only row dimension in this example that has
preassigned aliases is Product, only the Product members display their
aliases. Region members simply repeat the member name instead of
displaying an alias.

A [ B e o E F

| 1| Year

| 2 |

| 3 [T00 Colas East East 12656
| 4 | West West 3549
| 5 | South South 4773
| 6 | Central  Central 2490
| 7 | Market  Market 30465
| 8 [200 RootBeer  East East 2534
| 9 | West West 9727
| 10| South South G114
|11 Central  Central 9573
| 12 | Market  Market 27954
| 13 |300 Cream Soda Fast East 2627
| 14 | West West 10731
| 15 ] South South 2350

Figure 53. Result of Displaying Both Member Names and Aliases

Repeating Member Labels

By default, Hyperion Essbase displays member labels only once for each
nested row and column group. If you are connected to a large database when
using Hyperion Essbase Spreadsheet Add-in, you may have to scroll down or
across the worksheet to see additional data rows and columns. In some cases,
as you scroll down or across, member labels may disappear from view.
Hyperion Essbase provides a feature for repeating member labels in each row
or column cell that represents a data point so that you can always see a
member label in the worksheet view.
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To repeat member labels down and across the worksheet:
Select Essbase > Options, and select the Display tab.

In the Aliases option group, clear the Use Both Member Names and
Aliases for Row Dimensions check box.

In the Cells option group, select the Repeat Member Labels check box,

1.
2.

Essbase Oplions

Display |Zoom I Mode I Style

and then click OK.

I | st Sort Fiows
¥ Bepeat Member Labels

| Global |

~ Indentation — Replacement

" Nane tiigsing Label  [Né&

' Subitems — e

& Totals Mo Access Label: I
— Suppre — Aliaze:

™ #iMizsing Rows I Use Aliases

™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions

el Alias:
— Cells

V Use Styles IDefauIt j
v

Query Designer
’7|7 Usze Sheet Options with Query Designer

— Dynamic Time Serie

I Latest Time Period IJan

=

oK I Cancel |

Help

Figure 54. Enabling the Repeat Member Labels Option

4. In cell E1, drill down (double-click) on Year.

Hyperion Essbase displays a member label in every column and row cell.
For the Sample Basic database that you are using for this tutorial,
repeating member labels is probably not necessary because the database is
relatively small. This feature is particularly helpful for keeping track of
member labels when scrolling through large worksheets.
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A [ B [ ¢© D
1
=3 h—
| 3 |Qurd Colas East 2747
| 4 |Qurd Colas West 1042
| 5 |Qurd Colas South 1051
| B |Qurd Colas Central 2208
| 7 |Qurd Colas Market 7048
| 8 |Qurd Root Beer  Fast 562
| 9 |Qurf Root Beer  West 2325
| 10 | Qtrd Root Beer  South 1465
| 11 |Gerd Root Beer  Central 2369
|12 | Qtrd Root Beer Market 6721
| 13 |Qtrd Cream Soda  Fast 591
| 14 |Qtrd Cream Soda West 2363
| 15 |Qtrd Cream Soda  South 561
| 16 |Qtrd Cream Soda  Central 2414

Figure 55. Result of Repeating Member Labels

Note: Even if you clear the Repeat Member Labels check box in the
Essbase Options dialog box, Hyperion Essbase retains the repeated
member labels in the worksheet view. To remove the repeated
labels, you need to do one of the following: (1) clear the check box
and open a new worksheet; (2) clear the check box and pivot the
row group to a column group and then pivot it back to a row group
(or vice versa); or (3) select Essbase > FlashBack and clear the check
box.

5. Before returning to the tutorial, complete the following actions:
a. Select Essbase > Options, and select the Display tab.

b. In the Cells option group, clear the Repeat Member Labels check box,
and then click OK.

c. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Creating Queries Using Hyperion Essbase Query Designer

So far, you have seen how easy it is to retrieve data and navigate through
Hyperion Essbase Spreadsheet Add-in in an ad hoc fashion. Hyperion Essbase
also provides a query designer so that you can define a database query for
retrieving dimensions and database members into the worksheet. Hyperion
Essbase Query Designer (EQD) is a new feature that replaces Retrieval
Wizard, used to define queries in previous versions of Hyperion Essbase
Spreadsheet Add-in.

Before Hyperion Essbase actually retrieves data, Hyperion Essbase Query
Designer provides a series of panels so you can request the data that you
want to view in the worksheet. It is particularly helpful when you know
exactly which data you want to retrieve from the server. In addition, you can
save a query and use it again.
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The Hyperion Essbase Query Designer window consists of the following
panels:

* The navigation panel provides access to the various features in Hyperion
Essbase Query Designer. You can display all the dimensions used in a
particular query and access the various properties of each dimension
member.

* The hint panel provides a brief description of the feature that is selected
from the navigation panel.

* The properties panel provides access to the following functions:

Layout: Design the layout of the spreadsheet report. To change the
default layout, select a dimension tile and drag it to one of the other
dimension boxes. To access the member select panel and to define a
member for a query, double-click a dimension tile.

Member Select: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click a member to add
it to the selection rules.

Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

Data Filter: Retrieve rows of data. The retrieval is based on the ranking of
the rows within certain columns. Use this panel to access the data
restriction panel.

Data Restriction: Filter data by comparing it to a fixed data value, a set of
data values, or #Missing data values.

Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

Messages and Confirmation: Turn on and turn off certain messages from
Hyperion Essbase Query Designer.

Help: Access documentation about Hyperion Essbase Query Designer.

Creating and Changing Queries

To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an
open query, click on the specific dimension or member in the query outline
that is displayed in the navigation panel. Selected members are displayed in
the member selection panel on the right.
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You can also revise an existing query in the member selection panel. For
example, you can delete a member or add a member to the query by selecting
a member in the navigation panel and making the appropriate changes in the
properties panel.

Note: Files created in Retrieval Wizard can be opened in Hyperion Essbase
Query Designer. However, if a query contains more than two member
filters per selection rule or more than two data restrictions, the member
filters may be out of order. To ensure correct results, rearrange the
member filters in the navigation panel, if necessary. For complete
information on Hyperion Essbase Query Designer options, see the
Hyperion Essbase Spreadsheet Add-in online help.

CAUTION:

Manipulation of worksheets in VBA such as naming worksheets or moving
worksheets may not work when EQD is running.

Creating Queries

D Spreadsheets - Excel

To create a query using Hyperion Essbase Query Designer:
1. Select Essbase > Query Designer.

Hyperion Essbase displays the Hyperion Essbase Query Designer
welcome panel.

r'} Hyperion Essbase Query Designer EHE I
ONE | Hyperion Esshase Query Designer -
teplaces the Retrieval Wizard to create
o], o] H ;
repotts using a more advanced user
O o

Help

B Messages & Confirmations

intetface. se this feature to:

HyperiOn #  Create and modify spreadsheet

gueties.
*  Specify which dimensions display in LI

To start a new gquety: -

1. Fromthe navigation panel (the screen to the left of this
panel), select the name of the worksheet; for example,
[Eookl]3heet] in Excel, or <<Untitled.123>>4 in Lotus 1-2-3.

2. With the wotksheet selected, click the right mouse button,
and from the pop-up menn, select New > Query.

Hote: If wou have not logged into a database, the Esshase
System Login dialog boxis displayed. Youneedto loginto a
database before proceeding.

[Flefer to the hint panel (the panel above this screen) for help on
other panels.

(Click the gquestion mark icon in the navigation panel (the screen
to the left of this nanell to access a tutorial and online helo for T

Figure 56. Hyperion Essbase Query Designer Displaying Welcome Panel

2. To create a new query, select [Book1]Sheetl, right-click, and select New >
Query.
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Hyperion Essbase displays the layout panel of Hyperion Essbase Query
Designer.

7+ Hyperion Essbase Query Designer HE
=] Spreadshests - Lotus 1-2:3
2] <o Motusiworkh 1 203 ntlsd 123>

B) <cotlolusuiark 12 nited 1224 - Queryl

Use this layout panel to design the layout of the
report

1. Select a dimension tile from a dimension hox,

2. Drag the dimension tile to a page, 10w, or column

B Page dimension ox
o Produet 3. Double-cliek a dimension tile to access the
@ Mabe! sttt selsct panel b define memhsts for the
ol Scenario query.
Riews o have completed designing the layout of the
Measures query.

Ava\\ab\e.Dlmer\slnns Page Dimensions
Caffeinated (Base:Product]

tro Diate (Base:Product] Product ‘ Market | Scenario
unces (Base:Producl] 5 »
ka Type (Base:Product)

opulation [Base:Market) Row Dimensions: Column Dimersions:
------ T4 Attribute Caloulations |
& Data Filtering Year
=] Data Sorting
B Messages & Confimations
-F Help
o
@
£
5
]
1
a2
=
L I -]

Figure 57. Hyperion Essbase Query Designer Displaying Layout Panel

3. Define the worksheet layout by dragging the dimension tiles as follows:
a. Drag Market and Product to the Row location.
b. Drag Measures to the Page location.

c. Drag Scenario below Year (in the Column location).
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Spreadsheets - Euel [ s this layout panel to design the layout of the report.

1. Selsct a dimension tile from a dimension box:

[2. Dragthe dimension tile to a page, row, or colunm
dimension box
A [3.  Double-click a dimension tile to access the meniber select
ol Measures panel to define members for the query.

=-F Row ¥ ou have completed designing the layout of the quary.

Book1]Shest - Query!
o Dimensions
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1 B Available Dimensions
Cafteinated [Base: Product]

Intio Date [Base:Product] I—,Teasu,es ‘
4

Page Dimensions

Dunces [BaseProduct]
Pkg Type [Base:Product)
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Z4, Attributs Calculations
B Data Fitering Year
=1 Data Sorting )
Book1Sheet2 Scenario
Book1]Sheetd

1 Messages & Canfimalians

Help

Market
Product

=
Lx

Figure 58. Changing the Worksheet Layout

4. To select the Measures dimension in the navigation panel, click the
Measures icon. Alternatively, double-click the Measures tile in the layout
panel.

Hyperion Essbase displays the member select panel, where you can select
a member from the Measures dimension.

Note: You can select only one member from the dimension in the Page
location.

5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.

Profit is displayed in the selection rules list.
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1. Hyperion Essbase Query Designer
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ntros D ate [Base:Product]
Ounces [Base:Product]
Pka Type [Base:Product)
B Population [Base:Market]
T4 Attribute Caleulations

& Data Fitering

=1 Data Sorting
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[Book1]Shest3

ages & Confirmatiors
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- Help
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page dimension. You can selact only one menber par
page dimension,

k. 1. Select a menberin the "IMembers ist box
a 2. With the memiber selected, click the right mouse
button, and from the pop-up meny, select Addto
Selection Rules
3. Select the member in the "Selection Rules” st box.
o hiave complated defining the menber for the page
dimension,
Members:
5 Messures
- Profit
- Iventory
- Ristios

Selection Rules:

Profit

Figure 59. Hyperion Essbase Query Designer Displaying the Member Select Panel

Note: In Hyperion Essbase Query Designer, after you make your

selections, you do not need to confirm them; for example, you do
not have to click OK. If you do not select members from any given
dimension, Hyperion Essbase uses the top member of the
dimension.

6. To select members of the Year dimension, complete the following actions:

a. In the navigation panel, click the Year icon. Alternatively, double-click

the Year tile in the layout panel.

Hyperion Essbase displays the member select panel for the Year
dimension.

Select Qtr1, right-click, and select Add to Selection Rules.

Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.
Because Year is in a Column location, you can select one or more
members.
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to Selection Rules

3. Select the memberin the "Selection Rules" list
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Member Filter

L
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Selection Rules:
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Figure 60. Adding Members to the Selection Rules

7. To select members of the Scenario dimension, complete the following
actions:

a.

C.

In the navigation panel, click Scenario. Alternatively, double-click the
Scenario tile in the layout panel.

The members of the Scenario dimension are displayed in the member
select panel.

Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.
In the same manner, add Budget to the Selection Rules box.

8. To select members of the Product dimension, complete the following
actions:

a.

In the navigation panel, click Product. Alternatively, double-click the
Product tile in the layout panel.

The members of the Product dimension are displayed in the member
select panel.

Select product code 100, right-click, and select Add to Selection Rules.
Repeat the process for product codes 200, 300, and 400.

In the Selection Rules list box, select product code 100, right-click, and
then, from the popup menu, choose Select > Children.

This action selects all children of 100. Hyperion Essbase displays All
Children next to 100 in the Selection Rules list box.

In the Selection Rules list box, select product code 400, right-click, and
choose Select > Descendants.
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Hyperion Essbase displays All Descendants next to 400 in the Selection
Rules list box.

7 Hyperion Essbase Query Designer HE
=] Spreadshests - Excel
ER -]

|»

Use this memiber select panel to select a memberfor =
ths row dimension
I > 1. Select a menberin the "Members" list box
o Dimensions 2. TWith the member selected, click the right mouse
=[] Page button, and from the pop-up memy, select Add

-3 Measures to Selection Rules

O Profit 3. Select the member in the "Selection Rulss" list

B Row box
Market 4. TWith the meniber selected, click the ight mouse
Praduct hutton, and from the pop-up men, select
O 100, Al Childrer Member Filter =l
o7 200
o7 300 Mermbers:
O 400, &l Descendants T Frodut
= :‘Eu\umn 0

-G Year poe
o ot a0
o5 Q2 a0
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By Actual
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B Available Dimensions
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[Book1]Shest] - uery!

pou

Selection Rules,
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Figure 61. Selecting Members of Product

f. To view the list of all product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box (for
example, 200), right-click, and select Preview.

Hyperion Essbase displays the Member Selection Preview dialog box.
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Member Selection Preview E I

Selected Members:

100-10 -
100-20 _I
100-30

200

300

400-10

400-20

400-30

The selected rule returned 8 members.

Figure 62. Selected Members of Product Dimension

g. Click Close to close the Member Selection Preview dialog box.

9. To select members of the Market dimension, complete the following
actions:
a. In the navigation panel, click Market. Alternatively, double-click the
Market tile in the layout panel.

The members of the Market dimension are displayed in the member
select panel.

b. In the Member list box, select East, right-click, and select View by >
Generation.

c. To pick the second generation of the Market dimension, in the Member
list box, select Region, right-click, and select Add to Selection Rules.
Alternatively, double-click Region to add it to the selection rules.

Region is displayed in the Selection Rules list box.

d. To view the list of members that will be retrieved into the worksheet,
in the Selection Rules list box, select Region, right-click, and select
Preview.

Hyperion Essbase displays East, West, South, and Central in the
Member Selection Preview dialog box.
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Selected Members:

East ;I
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The selected rule returned 4 members.

Figure 63. Generation Name Selection

e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic Hyperion Essbase query. The outline of the
query is displayed in the navigation panel.

10. In the navigation panel, select [Book1]Sheetl, Queryl, and then

right-click and select Save Query.

Hyperion Essbase displays the Hyperion Essbase Query Designer Save

As Query dialog box. You can save your query to the server or to your

own client machine. To save to the server, you must have a security level

of database designer or higher. Contact the Hyperion Essbase system

administrator for more information.

11. Select Client.

Hyperion Essbase Query Designer Save As Query [=]
i Application:
Lacation
ok
€ Server |Sample -]
& Cliert D atabaze: Cancel |
Query name: I[aII dhs] vl Help |
I Guery Type:
File Spstem...
Guery objects: IEQD vl |

=

Connection information:

Server: Localhost
LI Application: Sample
Database: Basic

Figure 64. Hyperion Essbase Query Designer Save As Query Dialog Box
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12. Click the File System button.
Hyperion Essbase displays the Save As dialog box.

Save As HE

Save i IaTemD j gl E

Wbe

File name: IBasic‘I Save I
Save as ype: IEQD[".eqd] j Cancel |

Figure 65. Save As Dialog Box

13. Select a location, in the File nametext box, type Basicl and then click
Save.

You will use the Basicl query again in Chapter 3.
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= [ Pace Iate: When you initially create a new query, most of
-3 Messures ths Fields will be enpty. When you open an existing
o Profit query, the fields will be filled with the sppropriate
=] Row information.
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[ =
- Produet
O 100, &Ml Children
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g 300
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=-[ Column Location; Localhost:sample:
- Yoot
OF ow Current Connection:  Localhost:3 ample:Basic
2'% g:’i Crested For
i
78 e Modiied: No
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o fetual Locked: Yes, Spamidi
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%8 Data Filering
=! Data Soiting =l

Figure 66. Hyperion Essbase Query Designer Displaying Query Information Panel

14. In the navigation panel, select [Book1]Sheetl, Basicl. then right-click, and
select Apply Query.

The result of the query is displayed in the worksheet.

70  OLAP Spreadsheet Add-in User’s Guide for Excel



m

ast Cola
Diet Cala
Caffeine Free Cola
Root Beer
Cream Soda
Graps
Orange
Stramberry
West Cola
Diet Cala
Caffeine Free Cola
Root Beer
Cream Soda
Grape
Crange
Strawherry
South Cola

o

(o]

w

=

m

m

|

|D:l

| —
(=1{=}

Qtr2

2680
220
10
960
77
G40
360
700

1720
320
310

2570

2620
20
a10

-310

1160

2940
303
109
610
922
B76
327
612

1189

-177
-163

2423

2739

1167

1120

-783
835

30a0
300
130
1070
1010
960
360
70
1900
200
30
2720
2970
960
390
-380
1280

[ H

J

Otrd

3440
310
190
30
B0
920
420
a0

2120
250

-130

2820

3230

1020

1000

-440

1480

2430
287
100
280
a2
618
a4
525

1018

-136
-123

2439

2592

1218
a40

779
9E5

2410
290
150

1500
530
a0a
440
670

1780
320

70

2840

2850
920
G0

-400

1510

]
=

Diet Caola 570 363 BE0 570 247 550

Figure 67. Results of a Hyperion Essbase Query Designer Query

Note: In the Display tab under Essbase > Options, if you select UseUse Styles
and Use Sheet Options with Query Designer, the styles you selected
for dimension members will be applied to the initial query results. If
you do not select Use Sheet Options with Query Designer, even if you
have selected Use Styles, they will not be applied to the initial query
results. To apply styles, select Essbase > Retrieve. When Hyperion
Essbase returns the data to the worksheet, you are free to further
investigate the data by performing Zoom, Keep Only, Remove Only,
and Pivot operations.

Deleting Queries
You can delete a query only from the location where you saved that query.
For example, if you save a query in the /essbase/client/sample directory,
you can delete the query from within the sample directory. You cannot delete
the query from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations

Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations
panel.

To turn on or turn off messages and confirmations:
1. Select the Messages and Confirmations icon in the navigation panel.

2. To turn on (enable) a message, select the check box that is displayed next
to that message.

3. To turn off (disable) a message, select the check box again (clear the check
box).
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Figure 68. Messages and Confirmations Panel

Accessing Help

Access online help or the tutorial for Hyperion Essbase Query Designer by
using the help panel. To access the help panel, in the navigation panel, select
Help. For more information on a particular topic, click the Online Help button
in the properties panel. To access the online tutorial, click the Tutorial button
in the properties panel.
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Figure 69. Hyperion Essbase Query Designer Help Panel

Connecting to Multiple Databases from Hyperion Essbase Query Designer

You can connect to several databases and create separate queries on each
database from Hyperion Essbase Query Designer.

To connect to multiple databases from Hyperion Essbase Query Designer:
1. Logon to Hyperion Essbase and connect to the server you want to access.

2. Select Essbase > Query Designer to open Hyperion Essbase Query
Designer.

3. Select [Book1]Sheetl, right-click, and select Connect.
Hyperion Essbase displays the Essbase System Login dialog box.

Note: The book may be a number other than 1. For example, it may be
[Book5], if four worksheets are already open.

4. Type your password, and click OK. Select Sample Basic, and click OK.
5. Select [Book1]Sheet2 (or Sheet3), right-click, and select Connect.

Hyperion Essbase displays the Essbase System Login dialog box.
7. Type your password, and click OK. Select Samppart Company, and click
OK.
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10.

Note: You are restricted to one connection per worksheet. The connection
information is displayed in the query information panel of the
Hyperion Essbase Query Designer only when you open an existing
query or create a new query.

To create a new query based on Sample Basic, select [Book1]Sheetl, right
click, and select New > Query.

To create a new query based on Samppart Company, select
[Book1]Sheet2, right-click, and select New > Query.

To open an existing query, right click, and select Open Query.

You are now ready to proceed with the process of creating queries or opening
existing queries.

Applying Worksheet Options to Hyperion Essbase Query Designer

Results

You can also apply any of the worksheet options you have previously set
from the Essbase Options dialog box to the results of a query created in
Hyperion Essbase Query Designer.

To enable Hyperion Essbase Query Designer to use your previously set
worksheet options:

1.
2.
3.

Select Essbase > Options.
In the Essbase Options dialog box, select the Display tab.

Select the Use Sheet Options with Query Designer check box, and select
OK.

Select Essbase > Retrieve to refresh the worksheet.

Hyperion Essbase displays the results of the query you created in
Hyperion Essbase Query Designer and implements your previously set
worksheet options. For example, note that aliases, instead of the numeric
codes, are now displayed for the Product dimension.
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Figure 70. Results of Query with Options Applied

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Selecting Members

A Hyperion Essbase database may contain hundreds or even thousands of
members, making it difficult to remember each member name. You can use
the Essbase Member Selection dialog box to find and select members and to
define the layout of members in the worksheet. In addition, you can use
Boolean operators, such as AND, OR, and NOT, or other search parameters to
specify criteria and conditions that members must meet for the member
selection. Member selection is an important method of creating a spreadsheet
report for the data you want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box,
see the Hyperion Essbase Spreadsheet Add-in online help.

To view specific members from the Product dimension:

1. To open a new worksheet, select File > New or click the

ol

icon.

Note: You should be connected to the Sample Basic database. If you are

not connected, follow the steps in tConn.ectm.g_to_a_Da.tahaSPLod

2. Select Essbase > Retrieve.
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3. Select Product and select Essbase > Pivot to display Product as a row,
rather than a column, dimension.

n_| B [ [} E F
M arket
frear 105622

Product

[SaliF -SSR

Figure 71. Initial Worksheet for Member Selection

4. Select Product again, and select Essbase > Member Selection.

Hyperion Essbase displays the Essbase Member Selection dialog box. In
the Essbase Member Selection dialog box, Hyperion Essbase displays

the Product dimension in the Dimension list box and its children, Colas,
Root Beer, Cream Soda, Fruit Soda, and Diet Drinks, in the Members list

box.
Eszsbase Member Selection [ %]
Dimensiorr: (A Bules: ok |
ok
Members
[ Product  (5) - Cancel |
M Colas (3)
B Roct Beer [4] Help |
[ Cream Soda [3]
[ Fruit Soda (31
[ Diet Drinks (3] pdd > | Open.. |
Save.. |
' Erewview..
. .r o |

Mote: Uge the right mouse button to apply
advanced selection rules.

0 of 22 Selected.

Find... | Ezpand|To Deseendants | e ltem Up | Fremove [tem |
Llear | Iember [nfarmation... | e ltem Do | Fremayve A |
Wiew Method Output Option;
& By Member Mame WV Use Aliases IDefauIt 'l

" By Generation Mame
' By Level Mame
1 By Dynamic: Time Seres

I | Suppress Shared hembers
¥ Place Down the Shest
™ Irsert List Before Active Cel

Figure 72. Essbase Member Selection Dialog Box

5. Select Colas and click the Member Information button.

Hyperion Essbase displays the Member Information dialog box. The
dialog box provides information about the selected member, such as
dimension, generation, level, storage setting, formula, UDAs, and
member comments.
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Member Information

Member Information for - Colas:

Dimenzian:
Generation:
Lewvel

Storage Setting:

Formula:

Uszer Defined
Attributes [UDA]:

Member Comment:

Product
2
1

Nomal
=
i of
=
i of
=
o of

ok || Hek

Figure 73. Member Information Dialog Box

6. To close the Member Information dialog box, click OK.
7. In the Essbase Member Selection dialog box, click Add to add Colas to

the Rules list box.

Note: Alternatively, you can double-click an item in the Members list
box to add the item.

Select Cream Soda, and click the Find button.
Hyperion Essbase displays the Find Member dialog box.

In the Find Member dialog box, you can do pattern-match searches for
members in the selected dimension. You can use Wildcard
patterns—(trailing asterisk, *) and (single-character match, ?). Hyperion
Essbase locates the members that match the text string (in alphabetical
order) and keeps them selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character
wildcard in the text string. The * wildcard replaces a string of
characters, whereas the ? wildcard replaces a single character. J?n
and 100+ are examples of valid wildcard strings; *-10 and J*n are
examples of invalid wildcard strings.

9. In the Find Member dialog box, type D* in the text box.
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Find Member

Enter Member Mame or Pattern in Field B elow:

P

End | Frdien |

Lloze | Help

Figure 74. Find Member Dialog Box

10.

11.
12.

13.

14.

15.

16.

17.

Click Find to locate all members that match D*.

Hyperion Essbase locates and selects Diet Cream. Its parent, Cream Soda,
is also selected because it was highlighted before the search.

To close the Find Member dialog box, click Close.

Clear Cream Soda, leaving only Diet Cream selected, and click Add.
Hyperion Essbase displays Colas and the new selection, Diet Cream, in
the Rules list box.

In the Essbase Member Selection dialog box, select Colas in the Rules
list box, and then right-click. From the pop-up menu, select All Children
and Member.

Hyperion Essbase displays All Children and Member next to Colas in the
Selection Rules list box.

In the Selection Rules list box, select Colas, All Children and Member,
and then right-click again.
From the pop-up menu, select Subset.

Hyperion Essbase displays the Subset Dialog box, where you can further
define conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog
box.

In the Subset Dialog box, in the first list box, select Caffeinated. In the
second list box, select Is. In the third list box select Caffeinated_True.

Click the Add as AND Condition button.

Hyperion Essbase displays Caffeinated = Caffeinated_True in the
Conditions list box.

When you use Add as AND Condition, the subsetting condition in the
Conditions list box is evaluated using AND logic. AND logic means that
the selection must meet the current condition and the following condition
in the Conditions list box.

78  OLAP Spreadsheet Add-in User’s Guide for Excel



Subset Dialog [ %]

Select member Colas and its children where: oK |

I Caffeinated j I is

Add as O Conditon | |

j I Caffeinated_True j Cancel |

LConditions:

Caffeinated = Caffeinated True

Femove lfem |

Add( add] |

Eemowve [ ] |

Remoye Il [ ] |

Freview... |

Figure 75. Subset Dialog Box (Before Adding Conditions)

18.

19.

20.

21.

22.

23.

24,

25.

In the first list box, select Ounces. In the second list box, select the logical
operator “=". In the third list box, select Ounces_12.

Click the Add as AND Condition button.

Hyperion Essbase displays Ounces = Ounces_12 in the Conditions box.
In the first list box, select Ounces. In the second list box, select the logical
operator “<=". In the third list box, select Ounces_32.

Click the Add as OR Condition button.

Hyperion Essbase displays Ounces <= Ounces_32 in the Conditions box.

When you use the Add as OR Condition, the subsetting condition in the
Conditions list box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in
the Conditions list box.

In the first list box, select Pkg Type. In the second list box, select Is. In
the third list box, select Bottle.

Click the Add as AND Condition button.
Hyperion Essbase displays Pkg Type = Bottle in the Conditions list box.

In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

Select Pkg Type = Bottle, and click the Add ) button.

The Add ( and Add ) buttons add a left parenthesis and right
parenthesis, respectively, to selected items. Use parentheses for grouping
multiple subsetting conditions to determine the order of priority for
analyzing the conditions. Each item in the Conditions list box can have
either the left or right parenthesis, but not both. In this example,
Hyperion Essbase first evaluates members that are equal to or less than
32 ounces and are packaged in a bottle. Hyperion Essbase then evaluates
the results from this condition against members that are 12 ounces.
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Note: Use the Remove () button to remove an individual group of
parentheses from a selected item in the Conditions list box. Use

the Remove All ()button to remove all parenthetical groupings
from the Conditions list box.

The Subset Dialog box is displayed as follows:

Subset Dialog [ %]
Select member Colas and its children where: oK |
IF'kg Type j Iis j IBottIe j Cancel |

AddasOF Condion | Add as AND Condition |

Help |
LConditions:

Caffeinated = Caffeinated_True
AND

Remaove ltem |
Ounces = Ounces_12

[ Ounces <= Ounces_32
AND fdd [ add] |
Pkg Tupe = Bottle |

Bemove [ ] |

Remove &l [ ] |

Figure 76. Subset Dialog Box (After Adding Conditions)

26. To open the Member Preview dialog box, click Preview.

In the Member Preview dialog box, you can view the member selection
that results from the conditions you defined.

Member Preview E I

Selected Members:

Cala
Diet Cala
Caffeine Free Cola

-]

The Selected rules returned 3 members

Figure 77. Member Selection That Results from Subsetting Conditions

27. To close the Member Preview dialog box, click Close.
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28. To close the Subset dialog box and return to the Essbase Member

Selection dialog box, click OK.

The conditions you set in the Subset dialog box are displayed in the

Selection Rules list box.

29. To change the order in which Diet Cream is displayed in the worksheet,

select Diet Cream and click the Move Item Up button.

Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Rules list box. You can move only the top-level

item (the item you added from the Members list box), not the individual
subset conditions.

Esshbase Member Selection

Dimenzion: IProduct j
Members
[ Product  (5) =
Mcoas (3
B4 Fioot Beer [4]
[A Cream Soda [3]
Doark Cream

[ Fruit Soda [3)
[ Diet Drinks (2]

Wl v

0 of 22 Selected.

Find... | Ezpand Tja Deseendants |

[lear | I ermten [ rfarmatior.. |
Wiew Method
& By Member Mame
" By Generation Mame
' By Level Mame
1 By Dynamic: Time Seres

“anilla Cream |
Diet Cream add

Bules:

Diet Cream
Calas, &ll Children and Member
Caffeinated = Caffeinated_True
AND

Ounces = Ounces_12
OR

[ Ounces <= Ounces_32
AND
Flka Tupe = Bottle |

Mote: Use the right mouse button to apply
advanced selection rules.

e ltem Up | Fremave [tem

e ltem Do | Femove &)l

Output Option
¥ Use Aliases m
I | Suppress Shared Memtiers
¥ Place Down the Sheet
™ Irsert List Before Active Cel

Cancel

Help

Open...

Save...

Freview...

B [efel

Figure 78. Selecting Members Completed

30. To preview the members that will be retrieved in the worksheet, click

Preview.

Hyperion Essbase displays the Member Preview dialog box.

31. After previewing the list, click Close.

Chapter 2. A Basic Hyperion EssbaseTutorial

81



Member Preview [ %] I

Selected Members:

Diet Cream
Cola

Diet Cola
Caffeine Free Cola &I

[

The Selected miles returned 4 members

Figure 79. Members to be Retrieved in Worksheet

32. To close the Essbase Member Selection dialog box and insert the new
members into the worksheet, click OK.

A [ B[ ¢ D E
| 1| Market
| 2 |Diet Cream Year 108522
| 3 |Cola
| 4 |Diet Cola
| & |Caffeine Free Cola

Figure 80. Result of Selecting Members

Note: The FlashBack command cannot undo a Member Selection action.
33. Starting with Diet Cream, type Year next to each product.

You need to do this step so that every product has a matching Year
dimension associated with it in the report.

A [B [ ¢ D E
Market

1
| 2 |Diet Cream Year 108522
| 3 |Cola Year
| 4 |Diet Cola Year
| & |Caffeine Free Cola Year

Figure 81. Worksheet After Adding the Year Dimension to All States

34. To update the values in the worksheet, select Essbase > Retrieve .

Hyperion Essbase retrieves data for the members that you selected and
also applies the styles you previously set.
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M

A [B C D E
|1 Market
Diet Cream Year 110921

| 3 [Cola Year 22777
| 4 |Diet Cola Year 4703
5 |Caffeine Free Cola Year 1983

Figure 82. Result After Retrieving with Member Selection

Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can
save worksheets and disconnect from Hyperion Essbase. This section instructs
you in the following procedures:

Saving a Worksheet

At any point during the Hyperion Essbase session, you can save the active
worksheet with the Excel commands, File > Save or File > Save As. Thus, you
can keep a personal library of database views. You can open the worksheet
during a later session and retrieve the latest data values to update the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog
box unless the worksheet is protected. Hyperion Essbase cannot save
option settings for a protected worksheet.

Disconnecting from Hyperion Essbase

When you finish retrieving and navigating through data, disconnect from the
Hyperion Essbase server to free up a port (or user count) on the server for
other Hyperion Essbase Spreadsheet Add-in users.

To disconnect from the server:
1. Select Essbase > Disconnect.

Hyperion Essbase displays the Essbase Disconnect dialog box, where you
can disconnect any worksheet that is connected to a database.
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Essbase Disconnect E

; - -_Disconnect
Azper:Sampl
[Sheet2]Sheetl  Asper:Sample-»Basic Cloze |

Help |

Sheet Serverépplication-» D atabase

< | I

Figure 83. Hyperion Essbase Disconnect Dialog Box

2. From the list, select a worksheet name, and then click Disconnect.
3. Repeat step 2 until you have disconnected all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Excel. An
abnormal termination of an Excel session, such as a power loss or
system failure, does not disconnect your server connection.

Logging Off

Hyperion Essbase provides two administrative facilities that control user
connections:

* Forced Logout, where an administrator disconnects users at any point in
time. This logoff usually occurs when maintenance operations are
performed on databases.

* Auto Logout, where Hyperion Essbase automatically disconnects users that
are inactive for a time interval specified by an administrator.

For further information, contact the Hyperion Essbase system administrator.

Moving on to Advanced Tasks

Now that you have completed the basic Hyperion Essbase tutorial, you are
ready to move on to more complex tasks. In the next chapter, you will use the
sample Excel files to see how to perform advanced tasks in Hyperion Essbase
Spreadsheet Add-in.
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Chapter 3. An Advanced Hyperion Essbase Tutorial

The tutorial you completed in EChapter 2 A Basic Hyperion EsshaseTutoriall

teaches basic data retrieval and navigation concepts for Hyperion
Essbase Spreadsheet Add-in. This chapter builds on your basic skills and
expands your knowledge of Hyperion Essbase and Hyperion Essbase
Spreadsheet Add-in.

This chapter provides the following sections on advanced tasks:

In this advanced tutorial, you use several sampleMicrosoft Excel files that

were installed as part of the default Hyperion Essbase installation. These files
are stored in the \essbase\client\sample directory. You also reconnect to the

Sample Basic database.

Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two

sections, LConn.ech.n.g_to_a_Da.ta.ba.SL’l and l'Setting Hyperion Esshase Options’]

bn page 87 In addition, be sure to read LEQ]loMun.g_Gm.d.ehnes_DJmng_tb.d
[utorial” on page 23 and ['Reviewing the Sample Basic Database” on page 24

for important information about what you should expect as you perform the

tutorial steps.

Connecting to a Database

To access Hyperion Essbase data for the advanced tutorial, first connect to the
Sample Basic database on the server. This tutorial assumes that you have the
appropriate privileges to connect to a server, an application, and a database.

1. Select Essbase > Connect.

Hyperion Essbase displays the Essbase System Login dialog box.

© Copyright IBM Corp. 1998, 2000
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Esshase System Login E

Server. ILocthost j ] 4 I
Usemame: W ﬂl
Password: l— Help |

LEhange Fasswond... |

Application/D atabaze:

[Ipdate |
Hote... |

Figure 84. Essbase System Login Dialog Box

Note: To complete the steps that follow, you need to know the name of
the Hyperion Essbase server, your username, and your password. If
you do not have this information, contact the Hyperion Essbase
system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the
server that you want to access.)

3. To move to the Username text box, press Tab and then, in the Username
text box, type your username.

4. To move to the Password text box, press Tab, and then, in the Password
text box, type your password.

Note: You can change your password when you are connected to a server.
See f . 4

5. To connect to the server, click OK.

Hyperion Essbase displays a list of available application/database pairs in
the list box. A Hyperion Essbase server allows simultaneous access to
multiple applications. An application can contain multiple databases. Only
the databases to which you have security access appear in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Hyperion Essbase installation, it is
shown in the list. If Sample Basic is not shown in the
Application/Database list, ask the Hyperion Essbase system administrator
to install it.
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Esshase System Login E

Server. ILocthost j oK I
Uzername: W ﬂl
Pazzword: lm Help |

LChange Password... |

Application/D atabaze:

Demo Basic Update |

S ampeast East

S ample Intemtl HNote... |
S ample Hchgrate

S amppart Company

5 ourcel Basic

Targetl Basic

Figure 85. Available Application and Database Pairs

6. In the Application/Database list, double-click Sample Basic, or, from the
Application/Database list select Sample Basic and then click OK.

If the application is not already running, Hyperion Essbase automatically
starts it. There may be a brief pause as the application loads; the time
required to start an application depends on the number of databases, the sizes
of the databases, and the sizes of the indexes of the databases that are
contained within the applications.

Setting Hyperion Essbase Options

Before you begin the tutorial, make sure that the worksheet options are set to
the initial settings shown in the figures in this section.

Note: For information on each option in the Essbase Options dialog box, see
the Hyperion Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches Figure 86 on page 88.
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Essbase Options [ %]

Display |Zoom I tode I Style I Globall

Indentation———— [~ Replacement
" MNaore HMigsingLabel  [N/&
' Subitems
#Mo Access Label: I
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
&l Aliaz:
— Cells
V Use Styles IDefauIt j

™ Adiust Columng

I™ | Auto Sort Fows Query Designer
" Bepeat Member Labels ’7|7 Use Sheet Options with Query Designer

— Dynamic Time S erie:
[ Latest Time Period IJan j

QK I Cancel Help

Figure 86. Initial Settings for Display Options

4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your
display matches Ei
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Essbase Oplions [ %]

Display Zoom | Mode | Giabal|

" Bottom Level
" Sibling Level
' Same Level

" Same Generation
' Fomulas

— Member Retention
¥ Include Selection
[~ ‘within Selected Group
™ Remove Unselected Groups

QK I Cancel Help

Figure 87. Initial Settings for Zoom Options

6. Select the Mode tab.

7. Select the appropriate check boxes and option buttons so that your
display matches Ei
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Essbase Options [ %]

Displayl Zoom  Mode |GIObaI|

— Retrieval

" Free Form
™| Tiemplate Fetrieyve

—Mode
™ Update Mode

— Formula Preservation

™ Retain on Fetrizval

™| Rietain arfesn and Femoye Dl
™| Betain onZooms:

I Formulz Fil

Mote: Certain options cannot be uzed in conjunction with Formula Preservation.
If any of these options are selected, the Formula Preservation options are grayed out and
canhot be selected, and vice versa. Click Help for mare infarmation.

QK I Cancel Help

Figure 88. Initial Settings for Mode Options

8. Skip the Style tab.
9. Select the Global tab.

10. Select the appropriate check boxes and option buttons so that your
display matches Ei
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Essbase Oplions

Displayl Zoom I Mode I Stle  Global |

Mo
Vi

— Display Messages
= Information

¥ Enable Double-Ciicking ' Warnings
¥ Enable Linked Dbject Browsing & Enars

' Mone

— Memory
IV Enable Flashback

™ Display Unknown Members

™ Display Save Dialog

—Member Select——————————————

—Log File

¥ Boute Messages to Log File
V¥ Purge Log File Every Session

—Mode

™ Mavigate withaut Data

Add-ng... |

o]

Cancel

Help

Figure 89. Initial Settings for Global Options

11. To save the settings for this session and close the Essbase Options dialog

box, select OK.

Note: The settings in the Essbase Options dialog box may change as you
access the various sample Excel files as part of the tutorial. Leave

the settings as they are unless the tutorial advises you to change

them. If you have different option settings, the illustrations
presented in this chapter may not match the worksheet view.

Performing Advanced Retrieval Tasks

The tutorial in I’Chapfpr 2 A Basic Hyperion FEsshaseTutarial” on page 1l
describes how to perform basic data retrieval and navigation tasks in
Hyperion Essbase Spreadsheet Add-in. This section walks you through
performing the following advanced retrieval tasks:

. 7wl . ”
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Remember that you can perform common data retrieval tasks in any of the
following ways:

* Selecting commands from the Essbase menu on the Excel menu bar
* Clicking the appropriate buttons on the Hyperion Essbase toolbar

* Double-clicking the primary or the right-mouse button in the appropriate
cell (for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data

Despite the ease and speed with which you can navigate through large
Hyperion Essbase databases, it is not practical to use the capabilities of Excel
to filter and sort very large databases; however, Hyperion Essbase OLAP
Server mcludes powerful data flltermg and sorting capabilities. In

Z , you learned to use Hyperion
Essbase Query Designer to define a dimensional layout and to select members
to view. Hyperion Essbase Query Designer also provides a powerful, yet
easy-to-use tool to define conditional retrievals.

To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basicl, that you saved in “C hapter 2 A Basic vaprinH

EsshaseTutorial” an page 11|, and perform the following steps:

Note: If you skipped the tutorial in IChapter 2 A Rasic Hyperion

[EsshaseTutorial” on page 11, follow the steps in LCl:ea.‘r.m.g_QJ.l.enP_cl
[Using Hyperion Fsshase Query Designer” on page (1

to create and save

the Basicl query.
1. Select Essbase > Query Designer.

Hyperion Essbase displays the query information panel of Hyperion
Essbase Query Designer.

2. [Bookl]Sheetl
3. Right-click and select Open Query.
Hyperion Essbase displays the Open Query dialog box.

4. From the location that you specified in I’Chapter 2_A Basic Hyperiod

[EsshaseTutorial” on page 11, select the Basicl file.

5. Click OK.

The member selection, displayed in the properties panel, remains
unaltered from the last Hyperion Essbase Query Designer session.

6. From the navigation panel, select Data Filtering.
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Hyperion Essbase displays the data filter settings in the data filter panel.
The filter controls the number of data rows that are retrieved. The
number is based on the column criteria that you define. You can define
data filtering criteria on data values that reside in one or more columns
of the view.

%~ Hyperion Essbase Query Designer HE

Tse this data filter panel to retrieve data hased onthe rank %
ozder that you have specified.

Eook1]3heet! - Basicl.eqd

g Dimensions 1. Selsctthe Top or Bottom check box, o hoth
[ Pace 2. Specify how many rows you want ba retrisve
g Measures 3. Select a dimension from the "Dimension being ranked"
B Profi drop-doven list box.
5[] Row 4. Select the column from the "Colurm used for ranking"
S Market drop-down list box
5] Region 5. Double-click in the "Data Restrictions” box to ereate
Praduct additional data filters
5 100, 40 Children Hote: Fallow Step 5 only if you wantto define additional = |
200
o 300 - -
O 400, & Descendants Rank: [ Tep [ —Jpows [ Botlom |5 =] Rows
E @ ;,E.D‘“Yme”a' Dimerrsion being rarked
53 aul [Product =l
o an2
g o Column used far ranking
g o4 [on. Actual =
- Seenaiio
By Actual Data Restrictiors:
OF Budget double click to create a new data restriction]
1) Available Dimensions

] Caffeinated (Base:Product]
] Intro Date [Base:Product]
Ounces [Base:Product]
Pkg Type [Base:Product]

Population (Base:Market]
ZZ Attribute Caleulations
&5 Data Filtering
=-%] Data Sorting

i1 Descending, QN1, Actual =

Figure 90. Data Filter Panel

7. The data filtering panel contains the following items:

* A check box for ranking so many of top rows or so many bottom rows
of data. You can select the highest or lowest rows. Your selection is
based on previously selected row dimension members. When using the
top or bottom criterion, you specify the number of rows, such as “top
10.” The default is the top 25 rows.

* A Dimension being ranked list box to specify the dimension to which
ranking should be applied.

* A Column used for ranking list box to specify the data column on
which data values are based.

* A Data Restrictions box to specify standard data comparison
operations, such as greater than, less than, and equal to. You can apply
the comparison operator to data values in one or more data columns;
you can even apply criteria to compare values between two columns.

* Buttons for OR and AND operators. If you define more than one
column criterion, you can use these operators to link the criteria.

8. Click the Top check box, and enter a value of 30 in the Rows text box.
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When you apply the query, Hyperion Essbase retrieves the top thirty
rows of the dimension.

9. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.
10. From the Column list box, select Qtrl, Actual. Qtrl, Actual is the column
on which data values are based.
11. In the navigation panel, select the Data Filtering icon. Right-click and
select Apply Query.
Your query results should look as shown below.
A B [ c [ D F 6 | H [ 1+ [T 4 —
; =
12 | Qtr1 Otr3 Otrd
EN Actual [Budget [Actus
| 4 |East Cala 2461 2550 3050 3298 3440 2430 2410
| 5| Grape Gd5 840 860 710 920 E18 800
| B | Cream Soda 591 70 1010 522 BED 592 530
[ 7 | Root Beer EE2 9E0 1070 372 830 990 1500
| 8 | Strawberry G45 700 a0 B25 80 525 E70
[ 9| Orange 290 350 380 377 420 394 440
[ 10 Diet Cala M2 220 300 32 310 287 290
[ 11] Caffeine Free Cola 74 110 130 130 190 100 150
[ 12 |West Cream Soda 2363 2620 2970 2937 3230 2E92 2850
[13] Root Beer 2325 2570 2720 2540 2820 2439 2840
| 14 | Grape 1143 920 960 1271 1020 1219 920
[ 15 Cala 1047 1720 1900 1339 2120 1018 1780
| 16 | Crange 1002 810 890 1192 1000 940 Ba0
[ 17 Caffeine Free Cola E2 30 30 -286 -130 -123 0
| 16 Diet Cala 67 320 200 -154 250 -136 320
[ 19 Strawberry -738 =30 =380 -900 -440 =779 -400
| 20 | South Root Beer 1465 1640 1700 1612 1710 1495 1330
[ 21] Cala Fd5 1160 1280 1031 1490 9E5 1510
| 22 Cream Soda 561 810 770 91 840 BE9 930
[ 23] Diet Cala 306 570 BEO 2 &70 247 550
| 24 |Central Cream Soda 2414 2770 2930 2E48 2980 2450 290
| 25 | Root Beer 2369 330 3350 2481 3470 el
| 26 | Grape 1050 1030 1120 1220 1150 970
| 27 | Crange 991 90 1020 1073 1010 1070
28 Diet Cala 08 1130 1320 1083 1340 fatae)
M4 [» b Sheetl § Sheetz f Sheets / |«]

Figure 91. Data Filtering Query Results
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12.

13.

14.

15.

16.
17.

You can further filter your data output by specifying data comparison
operations in the Data Restrictions box.

In the navigation panel, select the Data Filtering icon.

The data filters that you specified are displayed in the properties panel.

In the Data Restrictions box, double-click.

The data restriction settings are displayed in the properties panel.

Select the Value option and type 500 in the Value box.

Observe that the is option in the Data list box changed to =.

Click the down arrow of the Data list box and select <=.
Select Qtrl, Actual in the Column list box.

In the navigation panel, select the Data Filtering icon. Right-click, and
select Apply Query.



Notice that the query results now reflect only Actual and Budget data

that are less than or equal to 500.

18. In the navigation panel, select the Data Filtering icon to display the data
filter setting in the properties panel.

19. In the Data Restrictions box, select Qtrl, Actual <= 500, right-click and

select New Data Restriction.

20. In the Data box, click the down arrow and select <.

21. In the data values list box, select Qtr2, Actual. Under Combined With

Other Restrictions, click the Or button.

22. In the navigation panel, click the Data Filtering icon to access the data

filter panel.

23. In the Data Restrictions box, double click to create a new data restriction.

24, In the Data box, click the down arrow and select Is Not.
25. Click the button for the #Missing Value option.
This option instructs Hyperion Essbase to discard data that have

26.

#Missing values.

In the Column list box, select Qtrl, Actual. Under Combined With Other

Restrictions, select the And button.

The data restrictions should appear as follows:

T+ Hyperion Essbase Query Designer HE
=HE Row - Use this data filter panel to retrieve data basedon =~
the rank order that you have specified
- DE Riegion 1. Select the Top ot Bottom check box, or both
SR Product 2. 3pecify how many rows you want to tetrieve
-5 100, ANl Children 3. Select a dimension from the "Dimension being
ranked" drop-down list box,
4. Select the cohumn from the "Column used for
B 400, All Descendants ranking" drop-down list box
G Colurn 5. Double-click in the "Data Restrictions" boxto
E|"-‘. Year create additional data fitters
-0 A Note: Follow Step 5 only if you want to define ;I
- 0g auz
L. 3‘% g::i Rank: ¥ Top |3D _lj Rows | Bottom [25 _lj FRows
o X
E“ Soenatio Dimenzion being ranked:
B tual
B Budget I Product j
] Awailable Dimensions
- W Calfeinated [Base: Product] Calumn used for ranking
Intro Date [Base:Product) I Qrl, Actual j
Ounces [Bage:Product]
Flkg Type [Bage: Product] Data Restrictions:
[ Population (B ase:Market] O, Actual <= 500
B2 Attibute Caleulations .

ERE [ =i Filtering, Top 30
k1, Actual <= 500

- DR O, Actual < Or2, Actual
b AND O, Achual is not #missing
* [double click to create a new data restiction)

OR Gtrl, Actual < Qu2, Actual
AMND Qtr1, Actual is not #missing

=] Data Sorting

=l
4| v

Figure 92. Data Filtering

27. Select the Data Filtering icon, right-click, and select Apply Query.
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Hyperion Essbase retrieves data for all the quarters. Notice that the
retrieved data for Qtrl, Actual is less than or equal to 500 or is less than
Qtr2, Actual. The results should appear as follows:

A B [ ¢ [ D E F H b =

7 =
| 2 | Otr1
E Actual _|Budget 12
| 4 |East Cola 2451 2580 2340 3050 3440 2410
| 5| Grape 545 340 676 860 820 800
| 6 | Cream Soda 591 770 922 1010 B60 530
| 7| Root Beer 562 9E0 610 1070 B30 1500
| B | Strawberry 545 700 612 750 780 670
=R Orange 290 350 327 380 420 440
| 10 Diet Cola 212 20 303 300 310 290
| 11 ] Caffeine Free Cola 74 110 109 130 190 150
| 12 |West Cream Soda 2363 2620 2739 2970 3230 2650
| 13] Root Beer 2325 2570 2423 2720 2620 2840
| 14 Grape 1143 920 1167 960 1020 920
|15 Cola 1047 1720 1189 1900 2120 1780
| 16| Crange 1002 210 1120 390 1000 680
| 17 | Caffeine Free Cola 62 310 -163 30 -130 70
| 18] Diet Cola 57 320 177 200 250 320
RER Strawherry 738 -310 783 -380 -440 -400
| 20 |South Root Beer 1465 1640 1540 1700 1710 1330
|21 Cola 745 1160 835 1280 1480 1510
| 22| Diet Cola 308 570 383 B0 570 550
| 23 |Central Cream Soda 2414 2770 2579 2930 2980 2650
| 24 | Root Beer 2368 3310 2457 3350 3470 4130
125 Grape 1080 1030 1155 1120 1150 a0
| 26 | Orange 291 910 1075 1020 1010 a0
|27 | Diet Cola 208 130 1045 1320 1340 1180
128 | Cola B43 1080 928 1180 1170 1060
| 29 | Caffeine Free Cola 457 620 s00 610 680

30 Strawherry 7 90 a7 90 140
144 »[mlSheetl  sheetz £ Sheets / |41

Figure 93. Data Filtering Results

Note: To delete all data restrictions, select the Data Filtering icon in the

navigation panel, right-click, and select Delete All Data Restrictions.
Alternatively, select any data restriction in the Data Restriction box,
right-click, and select Delete All Data Restrictions.

To delete a particular data restriction, select the data restriction in the query
outline, right-click, and select Delete Data Restriction. Alternatively, select the
data restriction in the Data Restriction box, right-click, and select Delete Data
Restriction.

Sorting Data

Using the data sort panel, you can sort the output from the Basicl query in
ascending or descending order.

1.

From the navigation panel, select the Data Sorting icon.

The data sorting settings are displayed in the properties panel. You can
specify data sorting criteria that affect the order in which the selected
rows are retrieved in the data sorting panel.

The data sorting panel contains the following items:
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* A Dimension being sorted list box that lists the dimensions specified in

row format in the query.

¢ A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

* An Ordering list box that you use to apply an ascending or descending
sort order for the selected column. You can also specify sorting to
occur over a specific row dimension group. For example, you can sort

by Product or by Market.

By 200

o 300

©- B 400, Al Descendants

=] Column

- Year

B Qi

P Quz

L]

L0 i

EI-r". Scenario

B Atual

*5 Budget

-] Available Dimensions

W Caffeinated [Baze:Produc

Intro Date [Base:Product]

Ounces [Bage:Product]

Plkg Type [Bage: Product)

- B Population [Base:Market)

22 Attibute Caleulations

[—]%9 DataFiltering, Top 30
Qbr1, Actual < 500
0R Qi1 Actual < Qt2, Actua
AND Ot Actual is not #miss

#1+ Hyperion Essbase Query Designer E
=] 3 Maf;El = e this data sort panel ta sott rows in &

i o EP‘E y elgmn = ascending or descending order based on

ol Produc = column data values.

P 100. Al Children [— 1. Select a dimension from the

"Dimension being sorted" drop-
down list box
2. Click "Ordering" and select
Aarending nr Nearending from the LI

. =
1 ol

Dimension being sorted:

|F'|oducl ﬂ

Ordering | Column used for sort |
| [double click to create a new sort rule] |

Figure 94. Data Sorting Panel

2. In the Column used for sort list box, double-click.
The selection defaults to Qtrl, Actual. The sort order defaults to

Ascending in the Ordering

list box.

3. Click Ascending. A down arrow is displayed next to Ascending.

4. Click the down arrow. Desc

ending is displayed below Ascending.

5. In the Ordering list box, select Descending.
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.+ Hyperion E sshase Query Designer [ 7] x] I

E” Fiow - [Use this data sort panel to sort rows in ascending or +
E‘. Market . = descending order based on column data values.
u. ©F Region = 1. Select a dimension from the "Dimension being
Praduct = sorted" drop-down list box.
O 100, &l Children 2. Click"Ordering" and select A scending or
E Descending from the drop-down list box.
3. From "Column used for sort," select the column
O 400, All Descendants dimension
- Column 4. Double-click in "Column used for sort" to create
E|"-‘. Year atiother sort nule.
-0y am [You have completed defining the sort rles LI
B w2
H By ou3 Dimension being sorted:
n. g and IF'rnduct j
=g Scenario
B Actual =
"By Budget Orderin Column used for sort
-] Awalable Dimensions ‘Descendin ~ |Qtr1, Actual
- Cafteinated [Base:Product] [double click to create a new sort rule]
ntra Date [Baze:Praduct]
unces [Base:Product]
kg Type [Base:Product]
‘opulation [Base:Market]
B2 Attibute Calculations
D ata Filtering, Top 30
ZZ] . Actual <= 500
R O, Actual < Qu2, Actual
AND Qb Actual is not #missing
Data Sorting
] Descending, Gtrl, Actual -l
1] | o

Figure 95. Specifying Data Sorting Order

6. In the next row of the Column used for sort list box, double click.
The selection defaults to Qtrl, Actual.
7. Click the down arrow and select Qtrl, Budget.

Observe that the order in the Ordering list box has defaulted to
Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtr1,
Budget. Right-click and select Delete Sorting Rule.

The Ascending, Qtrl, Budget sorting rule is deleted from the query.

9. In the navigation panel, select the Data Sorting icon. Right-click and
select Apply Query.

Hyperion Essbase returns the results sorted in descending order for each
quarter, as shown below:
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Figure 96. Result of Filtering and Sorting Data

B ¢ [ o | E F 6 | H [ 1 T 0 =

7 =
| 2 | Otrl 0tr3
| 4 |Cola 2451 2550 3080 3298 3440 2410
| 5 |Grape Bd5 340 880 710 920 800
| 6 | Cream Soda 591 770 1010 522 BEQ 530
| 7 | PRootBeer 562 950 1070 372 830 1500
| B |Strawberry 545 700 750 525 780 670
| 9 |Orange 240 350 380 377 420 440
| 10 |Diet Cola 212 220 300 312 310 290
| 11 |Caffeine Free Cola 74 110 130 130 190 150
| 12| Cream Soda 2363 2620 2970 2937 3230 2650
| 13| PRootBeer 2325 2570 2720 2540 2620 2840
| 14 |Grape 1143 920 960 1271 1020 920
| 15 |Cola 1047 1720 1800 1339 2120 1780
| 16 |Qrange 1002 310 290 1192 1000 580
| 17 |Caffeine Free Cola 62 310 30 -266 -130 70
| 18 |Diet Cola 57 320 200 -154 250 320
| 19 | Strawberry 738 -310 -380 900 -440 -400
|20 RootBeer 1465 1640 1700 1612 1710 1330
| 21 |Caola 745 &0 1280 1031 1480 1510
| 22 |Diet Cola 306 570 [stsi] 261 570 550
23| Cream Soda 2414 2770 2930 2648 2980 2650
| 24|  PRootBeer 2368 3310 3380 2481 3470 4130
| 25 |Grape 1080 1030 1120 1220 1150 890
| 26 |Orange 291 910 1020 1073 1010 890
| 27 |Diet Cola 08 1130 1320 1089 1340

| 28 |Cola B43 1080 1180 215 170

| 29 |Caffeine Free Cola 457 620 610 556 650

30 | Strawberry 77 90 130 140

|44 » [pI}Sheet1 ¢ Sheetz £ sheets /

Note: The values that you are ranking and sorting must be the same. For
example, you cannot specify Product in the Dimension being
ranked box and Market in the Dimension being sorted box. If you
specify different values, Hyperion Essbase Query Designer
automatically changes both values to the last specified value.

10. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Retrieving Data into Asymmetric Reports

When you retrieve data into a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, shows a symmetric
report that contains Actual and Budget members nested below Year members
(Qtrl, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that
differ by at least one member. There can be a difference in the number of
members or in the names of members.

You can create asymmetric reports in one of the following ways:
* Enter member names into the worksheet in free-form retrieval mode.

* Use a drill action with the Within Selected Group option selected from the
Essbase Options dialog box (Zoom tab).
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* Suppress rows that contain missing values, zero values, or underscore
characters during data retrievals.

If you retrieve data into an asymmetric report, Hyperion Essbase must
perform additional internal processing to maintain the asymmetric layout.
This processing may increase the retrieval time on large reports. For more
information regarding optimizing reports, see the Hyperion Essbase Database
Administrator’s Guide, Volume II.

As part of the default Hyperion Essbase installation, Hyperion Essbase
provides a sample file, Asymm.x1s, that illustrates how to create asymmetric
reports.

To view the sample file Asymm.x1s:
1. Select File > Open.
2. From the \essbhase\client\sample directory, open the Asymm.x1s file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

A B [ c ] b | E | F |G|
L1 |Sales
2]
1 3 | Actvs! | Budgs?! | Svdgst | Bwdgs?
4] Ol Ow2 Otr3 Otr4
|5 [East Colas G292 G760 7300 5570
L6 | Fioot Beer 5726 5650 5600 5780
L7 | Fruit Soda 3735 4150 4350 3850
8
| 9 [\West RootBeer 8278 7970 4320 7820
|10 | Cream Soda 8043 7e0 4300 7570
11

Figure 97. Asymmetric Report

In Asymm.x1s, row and column dimension groups are asymmetric. Thus,
the nested member groups from the Product dimension differ in member
content within respective markets. For example, Colas and Fruit Soda are
included in East but not in West. In addition, Actual data is displayed for
Qtrl, whereas Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also
notice that the sample file displays styles for members of the Scenario and
Year dimensions.

3. Leave the Asymm.x1s file open for the next tutorial task.

Pivoting in Asymmetric Reports
When you pivot a group of members in an asymmetric report, Hyperion

Essbase keeps only unique members from dimensions that are not involved in
the pivot.
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To use the open Asymm.x1s file to illustrate this point:

1. Using the right-mouse button, drag East to the cell below Qtrl.

A [ B Jc] D [EJ F JG[ H 1]
L1 | Sales
2]
| 3 | Acts! Sudgs? Sudgs? Sudge?
4 | Otrl Otr2 Otr3 Otr4
| 5 | East [WestlFast West East West East Wiest
L6 |Colas G292 B450 G760 8800 7300 9100 5570 8430
| 7 |RootBeer 5726 8278 BEED 7970 5600 8320 5780 7820
| 8 |FruitSoda 3735 8403 4150 5840 4350 6070 3850 5280
|9 |Cream Soda 4868 8043 4030 770 3850 8300 3170 7570
10

Figure 98. Result of Pivoting in an Asymmetric Report

Hyperion Essbase combines the Product members into all unique
members. For example, Root Beer, which is displayed twice inqw

, is displayed only once in the current view. Colas, which is
displayed in only one market in [Eigure 97 on page 100, now appears in
East and West.

Hyperion Essbase also removes the blank line between Product row
groups. A pivot action always eliminates any rows or columns in which all
cells are empty.

2. Close Asymm.x1s without saving the changes.

Working with Formatted Worksheets

In addition to providing flexible, ad hoc retrievals, Hyperion Essbase supports
retrieving data into formatted worksheets. A worksheet can contain the
following formats:

Spaces between rows and columns

Cell values that contain text or data that is not defined in the database
outline

Member names in noncontiguous locations at the top of a worksheet

Excel formulas (see also [Preserving Barmulas When Retrieving Data” ol
page 10d)

Visual cues (styles)

After you format and save a worksheet, you may want to retrieve and
navigate through new data in the existing worksheet format. This section
provides the following information on working with formatted worksheets:

7 . . . 173
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Observing the Rules for Working with Formatted Worksheets
Observe the following rules when retrieving data into a formatted worksheet:

Rule 1

In the worksheet, no numeric cells can be located before the first Hyperion
Essbase data cell. For example, in Eigure 99 on page 103, the first Hyperion
Essbase data cell is B6. Neither any cell in rows 1 through 5 nor cell A6 can
contain numeric values. Also, these cells cannot contain formulas that resolve
to numeric values.

Rule 2

A cell that lies within a row or column of Hyperion Essbase data cannot
contain text or numeric values. For example, in Figure 99 on page 103, the
cells in columns B, C, D, and F and rows 6 through 9 and 11 through 14
cannot contain any nondata text or numbers, for such values may be
overwritten (or emptied) by the retrieved data. These cells can contain
formulas, however, if Formula Preservation options are used. For more

1nformat10n on Formula Preservation options, see [‘Preserving Formulas Whed

Tip: If you need to preserve text in a cell, define that text or value as an Excel
formula, and use the Formula Preservation options.
Rule 3

The Pivot command is not available when the Retain on Retrieval check box is
selected in the Essbase Options dialog box (Mode tab).

Rule 4

The Pivot command removes all cells that contain text other than database
member names.

Retrieving Data into Formatted Worksheets
As part of the default Hyperion Essbase installation, Hyperion Essbase

provides a sample file, P&1.x1s, that illustrates how to retrieve data into a
formatted worksheet. The P&1.x1s sample file illustrates how to retrieve data
into a worksheet that contains formatted text, formulas, and protected cells.

To view the P&1.x1s worksheet:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the P&1.x1s file.
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Depending on how software is installed on your machine, the file may
not be available or may be located in a different directory. Contact the
Hyperion Essbase system administrator for more information.

A [ B | ©€ [ o [ E T F G [ H

L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget

4
I—
6 |Misc 5 10 10 25 0.30

7 |Payrall 200 200 200 500 0.07

8 |Marketing 350 350 350 1050 12.47

9 Total Expenses 555 560 560 1675 19.89

10

1 |COGE 1170 1180 1200 3550 42.16

12 |Sales 2740 2520 2860 8420 100.00

13 Margin 1570 1640 1660 4570 57.84

14 Profit 1015 1080 1100 3195 3795

15

16

Ratio Analysis

17

Markup

57.3% 58.2% 55.0% 57.8%

18

Marketing %

12.68% 12.4% 12.2% 12.5%

Figure 99. A Sample Formatted Worksheet

o o &

Select Essbase > Options and select the Display tab.
In the Cells option group, make sure that Adjust Columns is checked.
Select the Mode tab.

In the Formula Preservation group, select the Retain on Retrieval check
box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay
in retrieval time.

Click OK.

By default, a Hyperion Essbase retrieval overwrites Excel formula with
data values in the retrieval area of a worksheet. The retrieval process also
eliminates formulas in cells outside the retrieval area. However, the
Retain on Retrieval option enables you to define retrievals that do not
overwrite formulas in any area of the worksheet.

Select Essbase > Retrieve to update the worksheet with the latest data
values.

Hyperion Essbase determines that some text cells in the worksheet do not
correspond to database member names. When Hyperion Essbase is
unable to resolve text in the worksheet, the following message is
displayed:
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Essbase Message [ ]

)

The sheet containg an unknown member: Market:.
This item will be ignored when you retrieve data from the server.

There may be additional cells that contain unknown databaze members.
Do pou want to display additional unknown members in this retiewval?

Figure 100. Hyperion Essbase Unknown Member Message

In this example, the first unknown member detected is Market: (in cell
Al). Hyperion Essbase does not recognize the colon (:) that follows
Market in the cell. If you click Yes, Hyperion Essbase displays the next
unknown member; if you click No, Hyperion Essbase continues with the
retrieval.

Note: If you work with formatted worksheets often, you may want to
tell Hyperion Essbase not to display this message. For more
information, see I‘Pivoti “

9. Click No to close the dialog box and continue with the retrieval.
Hyperion Essbase retrieves new data but retains the formatting and
formulas in the worksheet.
A [ B [ € [ o [ E [ F G [ H

L1 | Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
|3 | Scenario: Budget

4

5

6 |Misc #issing  BMissing #lissing .

7 [Payrol 210 210 210 630 0.07

8 [Marketing 300 310 320 930 11.05

9 Total Expenses 510 520 530 1560 18.53

10

11|cocs 1170 1180 1200 3550 4216

12 [Sales 2740 2820 2860 5420 100.00

13| Margin 1570 1640 166D 4570 57.84

14 Profit 106D 1120 1130 3310 39.31

15

16 [Ratio Analysis

17 [Markup 57.3%  58.2%  58.0% 57.8%

18 [Marketing % 109%  11.0%  11.2% 11.0%

Figure 101. Result of Retrieving on a Formatted Worksheet

10.

Close P&1.x1s without saving it.

Note: This Chagter’s section on f’Prprrving Formulas When Refrieving Data’l

provides additional tutorial tasks that show you how to
take advantage of all the Formula Preservation options.
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Pivoting Data on Formatted Worksheets
With the Pivot command, you can produce ad hoc reports in both formatted

and unformatted worksheets. However, a formatted worksheet may contain
labels and formulas that make the result of a pivot operation ambiguous. The
pivot is designed to compress and retain only the database elements
represented in the worksheet. The worksheet also retains labels in areas that
are not overwritten by pivoted data.

Note: Hyperion Essbase prevents pivot operations on worksheets that contain
formulas when Formula Preservation mode is active.

Inv.x1s, a sample file installed as part of the Hyperion Essbase installation
process, illustrates how to pivot data in a worksheet. It was saved with the
Retain on Retrieval option disabled so that you can pivot on its worksheets.

To view the Inv.x1s worksheet:
1. Select File > Open.
2. From the \esshase\client\sample directory, open the Inv.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

A 8 | ¢ [ o [ e [ F [ & |
1 [Market lmverion: Anahsis
2 |Actual
3 Jan Feb Mar Qtr
4
b |Sales 100 314 327 8407 26048
[} 200 8718 B9G0 8951 26627
¥ 300 7874 G046 gO7T 23997
8 400 G634 6736 G778 20148
9 Produst 3538 32069 32213 95820
10
11 Cipening Inventory 100 29448 28124 28829 289448
12 " Adjusted for Audit 200 33000 32100 31125 33000
13 300 28868 28964 20095 28865
14 400 26092 26246 26409 26082
15 Product 117405 116434 116558 117405
16
17 |Stockto Sales 3.72 3.63 3.59
18 ===== ===== =====

Figure 102. Formatted Worksheet Before Pivoting

3. Select Essbase > Options and select the Global tab.

4. In the Display Messages group, clear the Display Unknown
Memberscheck box to avoid seeing the Hyperion Essbase messages when
working with formatted worksheets.

5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested
below Jan (C4).
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Hyperion Essbase pivots the Sales member group so that it is nested
below the monthly members. However, during the pivot, Hyperion
Essbase retains only database elements. For example, all data for Stock to
Sales and Adjusted for Audit is deleted during the pivot.

n B c | b | E L F G
1 fmvemion: Analsis MWarket
2 Astual
3 Jan Feb Mar
4 Sales [Cpening Inventory  [Rales Opening InventorySales Cipening lrventory
5
B [100 8314 29448 9327 29124 8407 28929
¥ 200 8718 33000 o460 32100 051 31125
g [300 TaT4 28865 80446 28964 8077 29085
9 |00 G634 26092 G736 26246 G778 26409
10 Produst 3538 117406 32069 116434 32213 1165868
11
12 " Adjusted for Audit
13
14
15
16
17 |Stockto Sales
18 —===o :: ====o —==o

Figure 103. Result of Pivoting on a Formatted Worksheet

6. Close Inv.x1s without saving it.

Preservmg Formulas When Retrieving Data

In I'Retrieving Data into Asymmetric Reports” on page 99, you used the

Retain on Retrieval option to preserve formatting and formulas in an existing
worksheet. Collectively, the Formula Preservation options enables you to
retain formulas during data retrievals, keep and remove only operations, and
drill operations. In addition, Hyperion Essbase can replicate formulas for
additional members retrieved into the worksheet as part of a drilling
operation. This section steps you through using all of the Formula
Preservation options in a report that you create.

You must enable some options before you can enable other options. Keep in
mind the following guidelines and restrictions when using the Formula
Preservation options:

* On the Mode tab of the Essbase Options dialog box, you must have the
Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.

* You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

* You must enable Retain on Zooms to enable Formula Fill.

* When you select the Retain on Retrieval check box, the Suppress #Missing
Rows and Zero Rows options on the Display tab become disabled.
Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.
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When you select the Retain on Zooms check box, the Remove Unselected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

When Retain on Retrieval is enabled, there may be a slight delay in
retrieval time.

As a general rule, insert a blank row as the last row in the formula range to
ensure that the cell range in the formula expands properly when you drill
down on members with Retain on Zooms enabled. For more information,
see the Hyperion Essbase Spreadsheet Add-in online help.

Formula arrays are not supported in Hyperion Essbase Spreadsheet Add-in
when the preserve formula option is on. If you have formula arrays in the
worksheet, Hyperion Essbase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:

1.

To open a new worksheet, select File > New or click the

ol

icon.
Select Essbase > Retrieve.
In cell A2, drill down (double-click) on Year.

Press and hold the Alt key and, in cell E1, drill down (double-click) on
Scenario.

Select cell G3 and enter the following formula in the cell: =B3/B7%100

c [ o | E [ F T G [ H

A | B
1]
L2 | Actual
3 |Gt 24703
|4 |Gtr2 207
|8 |Gt 27912
|6 |Citrd 25800
L7 | ‘Year 105522
L8 |
19|
|10

Measures Product Market
Budget Variance Wariance % Scenario

30880 5877 1921844343 24703[=B3/E7100 |
32870 5763 1753270459 27107

33980 -GOBS -17.85756327 27912

31950 6150 -19.24852629 25300

129350 -23558 -18.44025352 105522

Figure 104. Entering an Excel Formula into a Cell

6.

Press Enter.

Excel calculates the formula that you entered in cell G3 and now reflects
Qtrl as a percentage of Year.

Chapter 3. An Advanced Hyperion Essbase Tutorial 107



A | B [ ¢ | D E [ F ] G [ H
L1 Measures Product Market
L2 | Actual Budget ‘Yariance “ariance % Scenario
|3 [Gtrl 24703 30580 -5877 -19.21844343  24703( 23410284111
| 4 |Gtr2 2707 32870 -&763 -17.53270458 27107
|5 [Gtr3 27912 33980  -BOGS -17.85756327 27912
| 6 [Gtrd 25800 31950 G150 -19.24882629 25800
|7 | Year 105522 129380 -23858 -185.44025352 105522
8
19 |
|10

Figure 105. Result of Excel Formula with Hyperion Essbase Data

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, select the check boxes for Retain on

Retrieval and Retain on Keep and Remove Only. Click OK.

In cells D2, E2, and F2, respectively, select Variance, % Variance, and
Scenario.

10. Select Essbase > Remove Only.

Hyperion Essbase removes the selected columns but retains the Excel
formula that you entered, keeping it with the retained dataset.

A [ B [ C ] D [  E [ F [ &
L1 Measures Product Market
L2 | Actual Budget
|3 [Gtrl 24703 30580 23410284111
| 4 |Gtr2 2707, 32870
|5 [Gtr3 27912 33580
| 6 [Gtrd 25800 315480
|7 | ‘ear 105522 1259380
| 8 |
19 |
K

Figure 106. Result of Removing Columns with Retain on Keep or Remove Only Enabled

108

11.
12.

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, click the box for Retain on Zooms and

click OK.

13.

In cell A3, drill down (double-click) on Qtr1.

Hyperion Essbase drills down on Qtrl and moves the formula down
with the Qtrl member.
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A [ B [ c ] D [ E [ F ] &
Measures Product Market
Actual Budget
Jan 8024 9940
Feb 8346 10350
Mar 8333 10290
Qtrl 24703 30580( 23410284111
Qtr2 27107 32870
Qtr3 27912 33980
Qtrd 25800 31950
Year 105522 129380

-
pry

Figure 107. Result of Drilling Down with Retain on Zooms Enabled

14. Select Essbase > FlashBack.
15. Select Essbase > Options and select the Mode tab.

16. In the Formula Preservation area, select the Formula Fillcheck box. Click
OK.

17. In cell A3, drill down (double-click) on Qtrl.
Hyperion Essbase drills down on Qtrl and replicates the formula for
each member of Qtrl (Jan, Feb, and Mar). To view the replicated
formulas, click in cells D3, D4, D5, and D6 and look at the new syntax in
the Excel formula bar.

A [ B [ € ] D [  E [ F
Measures Product Market
Actual Budget
Jan 8024 9940 2950121002
Feb 8346 10350 299011178
Mar 8333 10290 3229844961
Qtrl 24703 30580 23.41028411
Qtr2 27107 32870
Qtr3 27912 33980
Gitrd 26800 31950
Year 105522 129380

==

Figure 108. Result of Drilling Down with Formula Fill Enabled

18. Before moving on with the tutorial, complete each of the following
actions:

a. Select Essbase > Options and select the Mode tab.
b. Clear all of the Formula Preservation options.
C. Select File > Close to close the worksheet. You do not need to save the
worksheet.
Retrieving a Range of Data

In a typical Excel worksheet, you can select a range of cells by dragging the
mouse across the worksheet. You can also select a range of cells and tell
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Hyperion Essbase to restrict the data retrieval to the selected range in the
worksheet. Retrieving a range of data is particularly useful in the following
situations:

* A worksheet contains multiple reports.

* A worksheet contains extraneous information that is not supported in a
formatted report retrieval.

* You need to retrieve only a small subset of values from the server, thus
dramatically decreasing retrieval time for large datasets.

¢ You need to retrieve data to an area of the worksheet other than the first
column.

As part of the default Hyperion Essbase installation, Hyperion Essbase
provides a sample file, Profit.x1s, that illustrates how to retrieve a range of
data.

To view the Profit.x1s file:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Profit.x1s file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

Profit.x1s has already selected a range of cells (B2 through F9) for you.

A [ B [ ¢ [ b [ E ] F [ 6 [ H |
| 1]
2
I udget
| 4]
| 5 |
| 6 |
| 7]
| 8 |
| 3 |
LD |
1]
112 | Central  Actual Praofit 34
113 | Oitrl Otrz Otr3 Oitrd “rear
|14 | 100-10 220 22.0 220 220 220
|15 | 100-20 220 22.0 220 220 220
|16 | 100-30 220 22.0 220 220 220

Figure 109. Selected Range of Cells for Retrieval

3. Select Essbase > Retrieve to update the selected range.
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A [ B | C D E F G [ H |
|1
L2 |
| 3 |
| 4|
| 5 |
| & |
| 7 |
| 8 |
| 9 |
110 |
KN
112 | Central  Actual Praofit 34
113 | [y Otrz Otr3 Oitrd “rear
[ 14 | 100-10 22.0 22.0 22.0 22.0 22.0
[15 | 100-20 220 220 22.0 220 220
|16 | 100-30 22.0 22.0 22.0 22.0 22.0
Figure 110. Figure 112. Result of Retrieving First Range of Data
Hyperion Essbase updates only the data in the selected range of cells.
4. Select cells B12 through Gl16.
A [ B [ ¢ [ b [ E [ F [T G | H |
1
| 2 | 1an Central
1 3 | Actual Budget
4 | Sales Profit 3 Sales Praofit 34
[ 5 | Qtrl 8074 273 8200 345
| 6 | Qtr2 8701 28.4 8870 35.1
[ 7 | Qtr3 8694 28.8 9060 353
| 8 | Qtrd 81349 276 7800 38.1
ER Year 33608 281 33930 357
110 |
1|
112 |
113 |
|14 |
115 |

—
o,

Figure 111. Figure 113. Selecting Cells for Retrieval

5. Select Essbase > Retrieve once again to update the selected range.
Hyperion Essbase updates the data in the selected range.
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A [ B [ ¢ | b [ E [ F [ G [ H ]
1
12 | 1aa Central
1 3 | Actual Budget
4] Sales Frofit s Sales Praofit 34
|5 | Qitr 8074 273 G200 345
| 6 | Oitr2 8701 28.4 8870 381
L7 | Qtr3 G894 28.8 9060 383
| 8 | Citrd 6139 276 7800 381
19 | ‘Year 33608 281 33830 357
[0 ]
1]
2]
3]
4]
(15 ]
6]

Figure 112. Result of Retrieving Second Range of Data

6. Close Profit.x1s without saving it.

Retrieving Data by Using a Function

The Hyperion Essbase cell retrieve function, EssCell, retrieves a single
database value into a worksheet cell. Enter an EssCell function directly into a
worksheet or select an EssCell function from the Excel menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform a Hyperion Essbase retrieval or
when you recalculate a worksheet through Excel. As part of the default
Hyperion Essbase installation, Hyperion Essbase provides a sample file,
Summary.x1s. This file has EssCell functions already set in cells B16 and B17.

To view the Summary.xl1s file:
1. Select File > Open.
2. From the \essbhase\client\sample directory, open the Summary.x1s file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.
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A [ [ ¢ [ b [ E [ F | @
L1 |200
| 2 [Texas
3|
L4 | Budget
| 5 | Oitrl Otrz Otr3 Oitrd ear
| B |Sales 1460 1560 1630 1320 5870
|7 |COGS a1l 540 630 ha0 2280
| 8 | Margin qaa 370 100a G20 3640
| 9 |Marketing 160 160 170 120 610
10 |Payrall 1] 1] 1] 11a 280
|11 |Misc #Missing #Missing  #Missing  #Missing  #Missing
|12 | Total Expenses 2zn 2zn 230 230 300
113 | Praofit a0 750 770 540 2740
4]
5]
|16 | “rear Salesl #NEA .|
|17 | “earMargin®s  #MN/A

Figure 113. Worksheet Containing EssCell Functions

Cells B16 and B17 in Summary.x1s contain the EssCell function. If you
select either of these cells, you can view the syntax for the EssCell function
in the Excel formula bar at the top of the worksheet.

The EssCell function is defined in a cell as follows:

| =EssCell(mbrList)

mbrList is one of the following:

* A null value. If the parameters of the function are empty, Hyperion
Essbase returns the data value from the top of each dimension.

* A comma-delimited list of member names. Member names must be
enclosed in double quotes, with only one member per dimension
allowed. If you list no members from a particular dimension, the
function returns the data value from the top member of the unspecified
dimension. Furthermore, you can include aliases in the member list,
subject to the same rules as member names.

* An Excel cell reference. The reference must point to a cell that contains
a valid member name. Member names, such as 200 and 300-10, need to
be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B16 in the
Summary.x1s file is the following;:

|=EssCell(”Sa1es”, Al, A2, B4, F5)

When you open the worksheet, the values in these cells are #N/A. To
update the values with the data in your database, you must perform a
retrieval from Hyperion Essbase.
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3. Select Essbase > Retrieve.

Hyperion Essbase calculates the EssCell functions in cells B16 and B17.

A [ B [ ¢ [ b [ E | F [ @&
1 |200 1
| 2 |Texas
3]
4] Budget
15 | Oitrl Otrz Qitr3 Oitrd “rear
| 6 |Sales 1460 1560 1630 1320 5470
| 7 |COGS 5ED 540 30 500 2280
| 8 | Margin a00 970 1000 §20 3640
| 9 |Marketing 160 160 170 120 610
|10 |Payrall 60 60 60 110 240
|11 |Misc #Missing #Missing  #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 qaa
|13 | Prafit BE0 780 770 530 2740
4]
15 ]
|16 | “ear Sales 5470
117 | ‘“vrearMargin %% 1.81

Figure 114. Retrieval on a Worksheet Containing the EssCell Function

Now update the EssCell functions to retrieve data for a different state.
4. Change the contents of cell A2 from Texas to Florida.

The values in cells B16 and B17 are updated as soon as you update the
cell. The update occurs because Excel has recalculated the worksheet (if
you have configured Excel to calculate changes automatically). The
remaining data cells do not change. To completely update the worksheet,
you must retrieve data from the server.

A [ B [ ¢ [ b [ E [ F [ @&
1 200
2 |Florida I
3]
4] Budget
15 | Oitrl Otrz Qitr3 Oitrd “rear
| 6 [Sales 1460 1560 1630 1320 5970
| 7 [COGS 560 540 630 500 2280
L 8 [ Margin Jao0 370 1000 420 36490
| 9 [Marketing 160 160 170 120 610
|10 [Fayroll 1] 1] 1] 110 290
|11 |Misc #Missing #Missing  #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 qaa
113 | Profit Ga0 750 770 540 2740
4]
15 ]
|16 | “ear Sales 5030
117 | ‘“vrearMargin %% G004

Figure 115. Updating the EssCell Function

Note: If the worksheet contains many EssCell functions, change Excel to
manual calculation mode. This change prevents the cell retrieve
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from calculating until you retrieve data or calculate the worksheet
manually. For more information, see the Microsoft Excel
documentation.

5. Select Essbase > Retrieve to update the report.

Hyperion Essbase returns an error message if EssCell is unsuccessful. The
following table lists messages that Hyperion Essbase displays in the
EssCell cell and explains the conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double quotation marks.

6. Close Summary.x1s without saving it.

The sample file that you used for this tutorial task already had EssCell
functions defined. To enter your own EssCell function into a worksheet,
you do the following;:

a. From the Excel menu bar, select Insert > Function.

b. From the Function Category list, select Essbase Add-in.

The Excel Function Wizard steps you through defining the EssCell function.

Note: For more information on EssCell functions, see the Hyperion Essbase
Spreadsheet Add-in online help.

Retrieving Dynamic Calculation Members

Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation
time. The Hyperion Essbase Application Designer tags dynamic calculation
members in the database outline so that Hyperion Essbase knows not to
calculate those members until a data retrieval requests them. This process is
referred to as dynamic calculation. Dynamically calculating database members
benefits the Hyperion Essbase server in the following ways:

* Reduced disk usage
* Reduced database restructuring time
* Reduced time to back up the database

Database values that Hyperion Essbase calculates dynamically take slightly
longer to retrieve in Hyperion Essbase Spreadsheet Add-in because Hyperion
Essbase must perform calculations before retrieving data into the worksheet.
For more information on dynamic calculation, see the Hyperion Essbase
Database Administrator’s Guide.
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Tip: Enable the Navigate Without Data feature while you arrange the
spreadsheet report so that Hyperion Essbase does not dynamically
calculate the database when you are creating the report. For more
information on the Navigate Without Data feature, see

m@m&w&mﬂﬂﬂﬂw ” 8

Because there may be a performance impact on retrieving data for dynamic
calculation members, define visual cues, or styles, for these members so that
you can identify them in Hyperion Essbase Spreadsheet Add-in.

To illustrate how to use Dynamic Calculation members, use the Asymm.x1s file.

To view the Asymm.x1s file:
1. Select File > Open.

2. From the \essbase\client\sample directory, open the Asymm.x1s file.
3. Dirill up on Actual by double-clicking the right-mouse button in cell C3.
4. In cell C3, drill down on Scenario to display all members of Scenario.
Hyperion Essbase displays only the Scenario members for Qtrl.
A B [ € T o | E ] F [ G |

1 Sales

2

3 |,4mw' _l Sudgst | Vewance | Vewasos 5 Sosnsnc

4 Ol Ol Otrl Otrl Otrl

5 |East Colas 8292 5870 422 7189097104 6292

B RootBeer | 5726 5460 286 4871794872 5726

7 FrutSoda | 3735 3880 -145 3737113402 3736

8

9 |wWest RootBeer | 8278 7700 578 7508493508 8278

10 CreamSoda 8043 6890 1153 1673439768 8043

Figure 116. Displaying Scenario Members

5. Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the

Style tab. For more information on connecting to a database, see

1

In the Members group, scroll down until you see Dynamic Calculations.
Select the Dynamic Calculations check box and click the Format button.
In the Font style list, select Bold Italic.

In the Color list, select Gray.

10. Click OK and then select the Display tab.

11. In the Cells option group, click Use Styles. Click OK.
12. Select Essbase > Retrieve.

© o N o
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Hyperion Essbase displays the data and applies all the visual cues, or
styles, that you set, including the newly set styles for dynamlc calculation
members and the styles you set in

. You can tell that the columns for Variance
and Variance% are dynamically calculated because Hyperion Essbase
displays these members in gray, bold, italicized font. (Variance and
Variance% also have a red background because that style was previously
set for all members of the Scenario dimension.)

East Colas
Root Beer
Fruit Soda

e e

West Root Beer

=

|Budget| Varasce | vavasce 5 | |
Qtrl  Otrl Qtrl Qtrl Qtrl
52492 5B70 422 7.189097104 5292
5726 5460 266 4.871794872 5726
3735 3880 -145  -3.737113402 3735

g27g 7700 578 7.506493506 Be7g

Cream Soda 5043 68390 1153 16.73439768 8043

Figure 117. Result of Retrieving Dynamic Calculation Members

Note: Occasionally, other styles you have set may override a style for
dynamic calculation members. For example, if a parent member is
also a dynamic calculation member, and if you have styles set for
both parent and dynamic calculations, the style for the parent
member overrides the style for the dynamic calculation member. In
this case, you need to remove the style for parent members in
order to see the style for dynamic calculation members. For more

information on the precedence of styles, see ‘Determining thd

” on page 88.

13. Close the Asymm.x1s file without saving it.

Specifying the Latest Time Period for Dynamic Time Series

Dynamic Time Series members are predefined database members that are used
in dynamic, to-date reporting, such as year-to-date or month-to-date values.
Dynamic Time Series members do not appear as individual members in the
database outline; instead, they correspond to a generation name that uses a
key term for time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter
was created for generation 2 in the Year dimension. Generation 2 includes the
members for Qtrl, Qtr2, Qtr3, and Qtr4. When the generation name Quarter
was created, Hyperion Essbase created a Dynamic Time Series member called
Q-T-D, or quarter-to-date.

To take advantage of Dynamic Time Series in Hyperion Essbase Spreadsheet
Add-in, choose the latest time period for which you want data in a to-date
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calculation. The calculated value of the Dynamic Time Series member is
derived when you define the latest time period to be reported. In the Sample
Basic database, for example, the level 0 members of the Year dimension are
the months of the year: Jan, Feb, Mar, and so on. If the current month is
August, and you want to know the sales data for the quarter up to the current
month, a quarter-to-date calculation gives you the sales data for the months of
July and August.

To illustrate the concept of Dynamic Time Series:

1. To open a new worksheet, select File > New or click the New Worksheet
icon.

Select Essbase > Options and select the Zoom tab.

In the Zoom In option group, select Next Level.

Clear the Within Selected Group check box and click OK.
Select Essbase > Retrieve.

In cell B1, drill down (double-click) on Measures.

In cell B2, click Year.

Type Q-T-D in cell B2 and press Enter to enter a predefined Dynamic
Time Series member (Q-T-D):

© N o Ok wN

[ A [ B ] C [ D E
Product Market

Q-T-D 105522

Year 117405

Year 55.26152827

Year 106522

Figure 118. Entering a Dynamic Time Series Member into a Worksheet

Note: For a list of other possible Dynamic Time Series members, see the
Hyperion Essbase Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.
10. In the Dynamic Time Series area, select the Latest Time Period check box.
11. From the list box, select May. Click OK.
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Essbase Oplions [ %]

Display |Zoom I tode I Style I Globall

Indentation———— [~ Replacement
 Nagne #higzing Label: l—
' Subitems
& Totaks #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
o Aliaz:
™ Use Styles IDefauIt j
V' Adiust Columng
™| Auto Sort Fows Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie

¥ Latest Time Period IMH

QK I Cancel | Help |

Figure 119. Specifying Latest Time Period in a Dynamic Time Series

Note: If you do not specify a latest time period, Hyperion Essbase uses
the first level 0 member (Jan) as the default.

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not
supported with Dynamic Time Series members.

Hyperion Essbase displays data for the Q-T-D member. The data values
in the worksheet are the aggregated values for April and May, because
May is the month you specified as the latest month in the quarter-to-date
Dynamic Time Series.

[ A [ B ] C [ D E
1 Product Market
2 Q-T-D 17573
3 Year 117405
4 Year 5526152827
5 Year 105522

Figure 120. Result of Specifying Latest Time Period in a Dynamic Time Series

13. To close the worksheet, select File > Close. You do not need to save the
worksheet.
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Note: You can also create a report like the one shown above by simply typing
the name of the Dynamic Time Series member followed by the name of
latest time period in parentheses: for example, Q-T-D (May). If you are
using free-form retrieval mode, you must enter the Dynamic Time
Series member and the latest time period in separate, adjacent cells.
You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member
Selection.

Note: For more information on Dynamic Time Series, see the Hyperion
Essbase Spreadsheet Add-in online help.

Using Substitution Variables
The Hyperion Essbase application designer uses substitution variables to

define global variables to represent values that are specific to Hyperion
Essbase. For example, Latest can be a substitution variable representing the
latest time period in a Dynamic Time Series. Using Hyperion Essbase
Application Manager, Application Designer sets substitution variables and
their corresponding values for a specific application. Hyperion Essbase stores
these variables and their values on the Hyperion Essbase server. You can take
advantage of the predefined substitution variables in Hyperion Essbase
Spreadsheet Add-in during Dynamic Time Series reporting.

For example, say the application designer sets a substitution variable on the
server for the current month. The variable is called CurMnth and has a value
of August. If you use the substitution variable in the worksheet, a retrieval
returns values for August, because August is set as the current month on the
server. If, at a later date, the application designer changes the value of the
CurMnth substitution variable to October, a retrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a
substitution variable in the database you are using, you could enter a
substitution variable directly into a worksheet. For example, you could open a
blank worksheet and type member names as follows:

A

[ ¢ [ o[ E

afew|n]~

&Curhinth

Product Measures Market Scenario

Figure 121. Entering a Substitution Variable in a Worksheet

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an
ampersand (&).
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In this example, a retrieval produces the following results:

Al B [ ¢ [ p] E [ F |
Product Measures Market Scenario
Aug 9545

Figure 122. Result of Retrieval on a Substitution Variable

Hyperion Essbase queries the server for the value of the substitution variable
CurMnth, which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a
template, make sure that you save the worksheet before you retrieve
data. For example, if you save the worksheet shown in m as a
template, each time you retrieve the template, August rather than the
substitution variable CurMnth is displayed.

Using Free-Form Reporting to Retrieve Data

So far, you have learned how to retrieve Hyperion Essbase data into a
worksheet through ad hoc retrieval, Hyperion Essbase Query Designer
queries, and Member Selection operations. In addition to these retrieval
methods, Hyperion Essbase supports free-form reporting. Free-form reporting
enables you to tell Hyperion Essbase specifically what you want to retrieve by
simply typing data into the worksheet. Free-form reporting is especially useful
when you are familiar with the dimensions and members in the database
outline.

Hyperion Essbase provides two different retrieval modes for free-form
reporting:
¢ Advanced Interpretation

e Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode
The Hyperion Essbase server contains an advanced spreadsheet interpretation

engine that scans a worksheet and interprets its content when fulfilling
retrieval requests. When you construct a report by entering names directly
into a worksheet in Advanced Interpretation retrieval mode, Hyperion Essbase
interprets the member names and creates a default view that is based on the
location of the labels.
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Keep in mind the following guidelines when you are working in Advanced
Interpretation mode:

Precede all member names that consist of numbers with a single quotation
mark. For example, for Product dimension member 100, type 100 in the
worksheet.

If you define a report that does not contain all of the database dimensions,
you may need to enter a dummy value, such as 0, in the first data cell.
Hyperion Essbase overwrites this value with the contents of the database
cell upon retrieval. Be sure to use a numeric value as the dummy value.

To construct a free-form report in Advanced Interpretation retrieval mode:

1.

To open a new worksheet, select File > New or click the

ol

icon.
Select Essbase > Options and select the Mode tab.

In the Retrieval option group, select Advanced Interpretation(the default
setting) and click OK.

Enter member names and data as in the following illustration.

Note: If a member name consists of a number, such as 100, you must
precede the member name with a single quotation mark (for
example, "100). This rule also applies to member names with spaces
between words.

A

B

C [ D [ E [ F

100
200
300
400

Sales

East

Qitr1

Budget

Qtr2

Figure 123. Creating a New Free-Form Report

5. Select Essbase > Retrieve or double-click in a data cell.

Hyperion Essbase retrieves data for the members you entered into the
free-form report and implements the Use Aliasesoption that you set in the
Essbase Options dialog box in the beginning of this chapter.
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A [ B ] ¢ T o [ E T F ]

L1 |Sales East  Budget

2|

L3 | Qtrl G2

| 4 |Colas 5870 6760

| 9 |Foat Beer S4B0 SRE0

| 6 |Cream Soda 3630 4030

| 7 |Fruit Soda 3880 4150

8

Figure 124. Retrieving Data into a Free-Form Report

Now define a free-form report that does not contain all of the dimensions
from the database. In Advanced Interpretation mode, you may need to
enter a dummy data value, such as 0, into the first Hyperion Essbase data
cell to tell Hyperion Essbase where the data starts in the worksheet. Be
sure to use a numeric value as the dummy value.

For example:

a.
b.
c.

Select Essbase > FlashBack.
Delete cells A1, B1, and C1.

In cell B4, type 0 in cell B4 to provide Hyperion Essbase with a data
cell reference point.

Ot
100
200
300
400

Qtr2
]

Figure 125. Defining a Free-Form Report Without All Dimensions

6. Select Essbase > Retrieve.

Hyperion Essbase adds the dimensions that were omitted from the
free-form report to the worksheet and retrieves data.

A B | € | b [ E [ F
L1
12 |
| 3 | Measures Market Scenario
L 4| Qtrt Qtr2
|5 [Colas 7045 7EVZ
| 6 |Foat Beer G721 7030
¥ |Cream Soda o823 B7RES
| 8 [Fruit Soda 5005 5436
9

Figure 126. Retrieval in a Free-Form Report Without all Dimensions
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7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Free-Form Mode
Similar to Advanced Interpretation mode, Free-Form mode enables you to

enter member names into any location in a worksheet and then interprets the
contents of the worksheet when fulfilling the retrieval request. In addition,
with Free-Form mode, you can use Hyperion Essbase report script commands
to retrieve data into a worksheet.

Report script commands are most useful for defining member references that
can bring back the most current member information dynamically. For
example, if you need to create a report that shows every product, including
the products added since the last retrieval, standard retrieval mode reflects
changes only when you zoom in on the product. If you use the report script
command <IDESCENDANTS, Hyperion Essbase retrieves all descendants of a
specified member, including the specified member. For more information on
the syntax of report script commands and on guidelines for developing
reports, see the online Technical Reference and the Hyperion Essbase Database
Administrator’s Guide.

Keep in mind the following guidelines when working in Free-Form retrieval
mode:

* You must precede all member names that consist of numbers with a single
quotation mark. For example, for the Product dimension member 100, you
need to type 100 in the worksheet.

* You cannot cancel a retrieve in Free-Form mode.

* You cannot apply Hyperion Essbase styles in Free-Form mode.

* Hyperion Essbase removes blank rows and columns on any retrieval action.

* Do not use Report Writer formatting commands, such as {BRACKETS},
{DECIMAL}, and {EUROPEAN} in Free-Form mode, because they are
incompatible with Excel’s formatting features.

* When you are in Free-Form mode, an Auto Sort Rows option is enabled in
the Display tab of the Essbase Options dialog box. If you select this feature,
Hyperion Essbase retrieves data in symmetric rows. The rows are sorted
according to the order specified in the database outline.

* Not all Formula Preservation and Modes options (Essbase Options dialog
box, Mode tab) are available in Free-Form mode.

* To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb))
in the same cell. You need to type the Dynamic Time Series member, Q-T-D
in one cell, and the latest time period within parentheses, (Feb), in a
separate, adjacent cell.
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To construct a free-form report in Free-Form retrieval mode:

1. To open a new worksheet, select File > New or click the
o
icon.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Free Form.
4. Select the Display tab.
5. In the Cells option group, select Auto Sort Rows. Click OK.
6. Enter the member names into the worksheet as shown in wz
A [ B[ c[ o | E [ F |
L1 |Praoduct COGS
| 2 |Jan
|3 |East
|4 |Budget
5 |Actual
6 I
L7 ]
Figure 127. Typing Member Names In a Free-Form Report
7. Select Essbase > Retrieve.
Hyperion Essbase retrieves data for the members and creates a default
view according to the location of the labels. Note that three members were
pivoted from row groups to column groups.
A [ B[ ¢ [ o [ E [ F |
L1 Praduct COGE  Jan East
| 2 |Budget I 2590!
L3 |Actual 3007
| 4]
L9 ]
Figure 128. Result of Retrieving in Free-Form Retrieval Mode

8. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Now create a report by entering member names and a report script command:
1. To open a new worksheet, select File > New or click the

ol

icon.
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2. Enter the member names into the blank worksheet as shown in Figure
3-46.

A [ B [ C [D[E] F
Actual  Sales East
Jan Feb IMar.l

Figure 129. Typing Member Names in a Free-Form Report

3. In cell A3, type <IDESCENDANTS Product. Press Enter.

A [ B | © [ D
|1 Actual Sales East
| 2 Jan Feh tlar
| 3 |<IDESCENDANTS I _l

4
| 5 |

Figure 130. Typing a Report Script Command in a Free-Form Report

4. Select Essbase > Retrieve.

Hyperion Essbase retrieves data into the worksheet for all descendants of
Product and for the members you entered in the worksheet.

A [ B [ ¢ | b JEJ F

L1 Actual  Sales  East

12 | Jan Feb tlar

|3 [Cola 1512 1754 1805
| 4 [Diet Cola I 2DD_| 206 214
| 8 [Caffeine Free Cola 93 10 107
|6 | Caolas 2105 2061 2126
| 7 [Qld Fashioned 547 alais] 672
| 8 |Diet Roat Beer 310 310 312
| 9 [Sasparilla #issing #lissing #lissing
| 10 |Birch Beer 896 985 923
11| Root Beer 18483 15966 1807
|12 |Dark Cream 959 12 1026

Figure 131. Result of a Retrieve with a Report Script Command

Note: When Hyperion Essbase completes the retrieval, the report script
command is overwritten by the data it returns. You can use
FlashBack to restore the previous view in Free-Form mode.

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Attributes in Free-Form Reporting

Hyperion Essbase enables you to retrieve data selectively by specifying
attributes that are associated with a base dimension. For example, in the
Sample Basic database, the Product base dimension is associated with
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attributes such as packaging and size. You can enter an attribute name into
the worksheet to retrieve data that is associated with that attribute.

To use attributes in a free-form report:
1. To open a new worksheet, select File > New or click the

ol

icon.
2. Enter member names as shown in the [Figure 133,

Caffeinated is an attribute dimension associated with the Product base
dimension. Bottle is a level 0 member of the Pkg_Type attribute
dimension. The Pkg_Type dimension is associated with the Product base
dimension. A level 0 member is the lowest level member in a dimension.

A,

L B | ¢ | D

1

2 |

Caffeinated  Bottle Profit Qtr1

4[4[ [p]Sheet1 { Sheetz f sheats /4|

Figure 132. Using Attributes in Free-Form Reports

3. Click in any empty cell and select Essbase > Retrieve or double-click in an
empty data cell.

Hyperion Essbase retrieves information on profits for the first quarter of
the year for all members of the Product base dimension that are associated
with both the level 0 attribute members of the Caffeinated attribute
dimension (Caffeinated_True and Caffeinated_False) and the level 0
member Bottle of the Pkg_Type attribute dimension. The results should
appear as shown below:

A,

B [ C|ID[E]F

1
| 2 |
3

Scenatio

14 4 [ [pifssheett sheetz £5[]

Caffeinated Bottle Profit Gtrl East
2604
L]
&

Figure 133. Result of Using Attributes in Free-Form Reports

4. You can drill down to data on the level 0 attribute members of the
Caffeinated attribute dimension. The results should appear as shown
below:
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1
2
| 3 |

A [ B TC[DBJE[FIT
Bottle Profit Qtr1 East =3
Caffeinated_True  Scenario 142

Caffeinated_False Scenario 2462' _l

A

-

44

[» [»i],Sheet1 {sheetz £ Sheet: |4 | |

a1

Figure 134. Drilling Down on Attributes in Free-Form Reports

5. To drill down further for data on profits for the first quarter for all
members of the East base dimension, double-click on cell E1. The results
should appear as shown below:

A [ B e[ o [EJ] F |
1] 1 Bottle Profit Scenario
| 2 |Mew Yark Caffeinated_True “ear -2080
| 3 | Caffeinated_Falze Year £754
| 4 | Caffeinated  “ear 4704
| & |Massachusetts Caffeinated_True Year 30
| B | Caffeinated_False Year 1577
| 7 | Caffeinated  “ear 1607
| 8 |Flarida Caffeinated_True “ear 1727
| 9 | Caffeinated_Falze Year 534
| 10| Caffeinated  “ear 26G1
| 11 |Connecticut Caffeinated_True “ear 1134
| 12 | Caffeinated_Falze Year 742
| 13 | Caffeinated  “ear 1878
| 14 |Mew Hampshire Caffeinated_True  Year -84
| 15 | Caffeinated_Falze Year 842
| 16 | Caffeinated ‘fear 758
| 17| East Caffeinated_True “ear 747
| 18 | Caffeinated_Falze “Year 10543
19 Caffeinated  *fear 11608

Figure 135. Result of Drilling Down on East

Entering Generation and Level Names
In addition to entering database member names into a free-form report, you

can enter generation or level names directly into a worksheet to retrieve
specific members. The Hyperion Essbase application designer defines
generation and level names for database dimensions in the database outline.
You have two options for discovering what generation and level names are
defined in the database:

* View generation and level names in the Essbase Member Selection dialog
box or through Hyperion Essbase Query Designer.

* Contact the Hyperion Essbase application designer to see what generation
and level names are defined in the database outline.

To enter generation and level names directly into a free-form report:
1. To open a new worksheet, select File > New or click the

]

icon.
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2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation. Click OK.
4. Enter member names as shown in [Eigure 134:

A [ B T ¢ [ b [ E [ F
1] Zales  Budget West ear
2]
3
4]
5]
6|
Figure 136. Entering Member Names in a Free-Form Report
5. Enter a generation name as shown in w:
Family is a generation name in the Product dimension. The name is
already defined in the Sample Basic database.
A [ B[ c [ o [ E [ F |
L1 Sales  Budget ‘Wyest ‘fear
2 |Family
3 I
| 4]
15|
L6 ]
Figure 137. Entering a Generation Name in a Free-Form Report
6. Select Essbase > Retrieve.
Hyperion Essbase retrieves data for the member and generation names
that you entered. The Family generation name expands to its individual
members.
A [ B [ ¢ [ b [ E [ F |
L1 Sales Budget  West W ear
(2 |Colas 34830
| 3 |Foat Beer 3810
| 4 [Cream Soda 30480
(5 |Fruit Soda 22730
[ 6 |Dist Drinks 35690
7

Figure 138. Result of Free-Form Retrieval with Generation Name

7. Change Year to a level name (Lev0,Year) as shown in the following
illustration.
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A [ B [ © [ D

[ E T F
Sales Budget West  [Levd Year]

1
| 2 |Colas 34830
| 3 |Roat Beer 31810
|4 [Cream Soda 30480
| 9 [Fruit Soda 24730
|6 [Diet Drinks 35650
7

Figure 139. Entering a Level Name in a Free-Form Report

Note: Be sure not to insert a space between the comma after 0 and the
word Year. Generation and level names that are entered directly into
a worksheet must be precise.

8. Select Essbase > Retrieve.

Hyperion Essbase retrieves data for the level 0 members of the Year
dimension, which are the individual months (Jan, Feb, Mar, and so forth).

A | B [ ¢ [ o [ E | F
L1 Sales Budget  West
L2 [Jan Calas 2860
|3 | Foat Beer 2540
L 4 | Cream Soda 2220
1 9 | Fruit Soda 1340
| 6 | Diet Drinks 2810
L |Feb Colas 2820
| 8 | Foat Beer 2660
|9 | Cream Soda 2310
|10 | Fruit Soda 1340
11| Diet Drinks 2500
|12 |Mar Calas 2520

Figure 140. Result of Free-Form Retrieval with Level Name

9. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to a cell in a Hyperion Essbase database. The file, note,
or Web resource (indicated by a URL, or Uniform Resource Locator) can then
be retrieved by the Hyperion Essbase Spreadsheet Add-in users who have
access to the database.

Note: If your organization has licensed and implemented Hyperion Essbase
Partitioning option, you can also access linked partitions from cells in
Hyperion Essbase Spreadsheet Add-in. For more information on linked
partitions, see L i i itions”

This section describes the following procedures:

o I'T iﬂking a File to a Data Cell” on page 131
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e I1 inking a Cell Note to a Data Cell” on page 134

e ['T3

”

. ’

Note: For additional information on using linked reporting objects, see the

Hyperion Essbase Spreadsheet Add-in online help.

Linking a File to a Data Cell

With the linked reporting objects feature, you can link an external file to a

data cell in Hyperion Essbase Spreadsheet Add-in. Hyperion Essbase stores
the file on the Hyperion Essbase server. Users who have access to the

database can then retrieve the file and view the data contained in the cell.

The following example uses the Asymm.x1s sample worksheet with data from
the Sample Basic database. It links a sample file, Budasmp.txt, to a cell
containing the Budget figure. Budasmp.txt details the budgetary assumptions

for the current year.

Follow these steps to link a file to a data cell:
1. Select File > Open.

2. From the \essbase\client\sample directory, open the Asymm.x1s file.

3. Make sure that you are connected to the Sample Basic database. If you

are not connected, see L
4. Select cell D5.

”

Note: You can link objects only to data cells, not to cells containing
member names.

A | B [ c ] D E F [G] H
L1 |Sales
| 2 |
| 3 | Actsl | Sucgst | Budgst | Sudgst
L4 | Ol Otr2 Otr3 Otr4
[ 5 |East Colas g2o2[_6760] 7300 E570
|6 | RootBeer 5726 GBS0 GBO0 5780
17 | Fruit Soda 3735 4150 4350 3880
8
| 9 |west FootBeer Be7s 7970 @320 7820
110 | CreamSoda 8043 7720 8300 7570
11

Figure 141. Selecting a Data Cell for Linking an External File

5. Select Essbase > Linked Objects.
Hyperion Essbase displays the Linked Objects Browser dialog box.
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Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ 2 Sales,Colaz E ast,Budget

Linked Objects:

Object Type |Dbiect Dezcription File Mame Created By

Last Modified

fach.. || Edi. | viewtLaunch| | Delote

Help

Lloze

Figure 142. Linking a File

6. In the Linked Objects Browser dialog box, click the Attach button.
Hyperion Essbase displays the Attach Linked Object dialog box.
7. Under the Attachment Type option group, select File.

Attach Linked Object [ %]

ember Combination: IQ tr2 S ales,Colas E ast,Budget

Attachment Type
© Cell nate

© URL

File M ame:

I Browse. ..

File Description:

L i

£ 1]

o
Cancel

Help

Figure 143. Linking a File to a Data Cell

8. Click the Browse button (next to the File Name text box).
Hyperion Essbase displays the Browse Files dialog box.
9. Go to the \esshase\client\sample directory and select the Budasmp.txt

file.
10. Click Open.

11. Under File Description, enter a brief description for the file as indicated

in
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Attach Linked Object [ %]

ember Combination: IQ tr2,5ales Colas E ast,Budget

Attachment Type
Lo note

- Cancel |
© URL Hep |
File Mame:

IE:\ESSBASE\ELIENT\SAM FLE“Budasmp.txt Browsze... |

File Description:

Budgetary assumption report

£ 1]

Figure 144. Selecting and Describing a File to Link

12.

13.
14.

Note: Entering text in the File Description text box is optional.
Click OK to close the dialog box and link the file to the cell.

Hyperion Essbase copies the file to the server and establishes a link to
the current data cell.

Click Close to close the Linked Objects Browser dialog box.
Do not close the Asymm.x1s file. You use it in the next tutorial task.

To recognize cells that have linked reporting objects attached to them,
you may want to apply a visual cue, or style, to the cells.

To apply styles:

© N~ whRE

Select Essbase > Options and select the Style tab.

In the Data Cells area, select Linked Objects.

Click Format.

In the Font style list box, select Italic.

In the Color list box, select Purple. Click OK.

Select the Display tab.

In the Cells option group, select the Use Styles box. Click OK.

Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Cell D5 (the cell you just attached the linked file to) is now displayed in
purple, italic font. Hyperion Essbase also refreshes the worksheet with the
other options set in the Essbase Options dialog box.
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| n B [ e | D | E | F

1
2
3
4 Qtrl Qtr2 Qtr3 Qtrd
5 |[East [Colas 6292 T 7300 5570
6 RootBeer 5726 5650 5600 5780
7 Fruit Soda 3735 4150 4350 3850
8
9 cst |RootBeer | 5278 7970 8320 7820
10 Cream Soda 8043 7720 8300 7570
11

Figure 145. Result of Applying a Style to a Linked Reporting Object Cell

9. Leave the Asymm.x1s file open for the next tutorial task.

Linking a Cell Note to a Data Cell

In addition to linking external files to a data cell in Hyperion Essbase
Spreadsheet Add-in, you can also link individual cell notes that contain
information on particular data cells. Cell notes can have no more than 599
characters. If you need to link information to a data cell that is longer than
599 characters, you need to create and save an external file and then link the
file to the data cell.

To link a cell note to a data cell:
1. In the Asymm.x1s file, select cell C5.

Note: You can link objects only to data cells, not to cells containing
member names.

2. Select Essbase > Linked Objects.

Hyperion Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.

Hyperion Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select Cell Note.

5. In the Cell Note box, type the note as indicated in the following
illustration:
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Attach Linked Object [ %]

Member Combination: IQ trl,5ales Colas E astActual

Cancel |

Help |

LCell Mote:

Thiz number needs to be updated by the E astern Sales Manager. ;I

Figure 146. Creating a Cell Note to Link

6. To close the dialog box and link the cell note, click OK.

Hyperion Essbase copies the note to the server and establishes a link to
the current data cell.

7. To close the Linked Objects Browser dialog box, click Close.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style you
defined for linked objects.

Now Hyperion Essbase displays two data cells (C5 and D5) in purple,
italic font to represent a cell that contains a linked reporting object.

Linked Dbiects Browser - Poplar:S ample:Basic

Member Combination: [Qtr1.Sales. Colas East Actual

Linked Objscts:

Linked Object and Object

|

srh.. | Edt. | vewlanch| Deee | Hep | Cese |

Figure 147. Result of Creating a Linked Cell Note

9. Leave the Asymm.x1s file open for the next tutorial task.

Linking a URL to a Data Cell

A URL is an address string that identifies resources on the World Wide Web,
such as documents, images, and downloadable files. With the linked reporting
objects feature, you can link a URL to a data cell so that users who have
access to the database can link directly to the specified URL. When you access
the cell from Hyperion Essbase Spreadsheet Add-in, your default Web
browser opens and displays the specified URL.
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Note: For more information on URL syntax, see the Hyperion Essbase
Spreadsheet Add-in online help.

If you have a Web browser and Internet access, follow these steps to link a
data cell to the Hyperion Web site:

1. In the Asymm.x1s file, select cell E5.

Note: You can link objects only to data cells, not to cells containing
member names.

| A B [ ¢ [ o | € | & [ & ]
1
2
3 Budget Budget Budget
4 Qtrl Qtr2 Qtr3 Qtrd
5 |[East [Colas [EEE B 7300 5570
6 Root Beer 5726 56RO 5E00 5780
7 Fruit Soda 3738 4150 4350 3850
8
9 est  |RootBeer 8278 7970 8320 7820
10 Cream Soda 8043 7e0 8300 7570
11

Figure 148. Selecting a Data Cell for Linking to a URL

2. Select Essbase > Linked Objects.

Hyperion Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.

Hyperion Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select URL.

Attach Linked Object [ %]

ember Combination: IQ tr3, S ales,Colaz E ast,Budget

Help

Attachment Type
' Cell note

o Cancel |
& fiEt |

Location:
|

URL Description:

Figure 149. Linking a URL to a Data Cell

5. Enter a URL in the Location text box and a brief description in the URL

Description text box, as indicated in [Eigure 152 on page 13d.
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Attach Linked Object [ %]

ember Combination: IQ tr3.5ales Colaz E ast,Budget

Attachment Type

© Cell nate

I Cancel |
Help |

Location:

Ihttp:.-".-"www.hyperion.com

URL Description:
Hyperion Solutions' home page ;I

=

Figure 150. Entering and Describing a URL to Link

Note: Entering text in the URL Description text box is optional. The text
field for entering the URL location is limited to 512 characters. The
text field for entering the URL description is limited to 80
characters.
6. To close the dialog box and link the URL to the cell, click OK.

Hyperion Essbase copies the URL string to the server and establishes a
link to the current data cell.

Note: The syntax for the URL is not checked at creation time; Hyperion
Essbase checks the syntax when the user accesses the URL from the
worksheet. The default Web browser checks for the existence (or
validity) of the URL.

7. To close the Linked Objects Browser dialog box, click Close.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style that
you defined for linked objects.

9. Leave the Asymm.x1s file open for the next tutorial task.
Now that you have learned to create linked reporting objects, you are
ready to learn how to access them from Hyperion Essbase Spreadsheet
Add-in.
Accessing and Editing Linked Reporting Objects

You have two options for accessing and editing a linked reporting object that
is attached to a data cell:

¢ Select the cell (as identified by the style applied to it) and select Essbase >
Linked Objects.

* Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing,
double-clicking behavior changes for retrieving data and performing
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drill actions. For more information on these changes, see the Hyperion
Essbase Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in
the previous sections by using the Essbase menu item instead of the
double-clicking action.

Accessing a Linked File
Sometimes you want to check an external file that is linked to a data cell.

To access the external file that you previously linked to a data cell:

1. In the Asymm.x1s, select cell D5.

2. Select Essbase > Linked Objects.

3. In the Linked Objects Browser dialog box, select the Budasmp.txt file.

Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ 2 Sales,Colaz E ast,Budget

Linked Objects:
Object Type Object Description File Mame Created By Last Modified

Budgetary assumption report Budasmp. kst Sps Mon Oct 27 14:

« 2

Attach... | Edit.. |£iew.-"Launc:h| Delete | Help | Lloze |

Figure 151. Accessing a Linked External File

4. To view the linked file, click View/Launch.

The Budasmp.txt file is opened from the source application.
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E Budasmp.tzt - Notepad [_ (O] =] I

File  Edit Search Help

The Beverage Company ;I
1998 Budget Assumptions

The following factors were used to estimate our 1998 Corporate Budget:

1) Sales increases will be 5% in Large HMarkets, due to market maturity

2) Sales increases will be 16% in Small HMarkets, due to our focused advertising
3) Expenses will be reduced by 7% across the entire company

We are faced with the challenge of continuing to grow our business, in spite

of increasing competition. We will have to seek out and implement as many cost
saving measures as possible. =
4] 1

Figure 152. Viewing the Contents of a Linked External File

Note:

Edit the contents of a file in the source application. After the edits
are made and the file saved, you can re-attach the edited file by
clicking the Edit button in the Linked Objects Browser dialog box.
Hyperion Essbase displays the Re-attach Linked Object dialog box,
which you can use to re-attach, or relink, the edited file to the data

cell. For more information, see the Hyperion Essbase Spreadsheet
Add-in online help.

5. Close the Budasmp.txt file and click Close to close the Linked Objects
Browser dialog box.

6. Leave the Asymm.x1s file open for the next task.

Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

To access and edit the cell note that you previously created:
1. In the Asymm.xTs file, select cell C5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is
linked to the selected data cell.

3. In the Linked Objects Browser dialog box, select the cell note.
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Linked Objects Browser -- Poplar-5ample:Basic

Member Combination: IQ il S ales,Colas E ast.Actual

Linked Objects:
Object Type Object Description Linked Object and Object Created By |L.

This number needs tabe

Cell Maote

i

Lloze |

fach.. | Edt. | ViewtLaunch|  Delete Hep |

Figure 153. Accessing a Linked Cell Note

4. To edit the contents of the cell note, click Edit.
Hyperion Essbase displays the Edit Cell Note dialog box with the selected

cell note displayed.

Edit Cell Note

Member Combination: |utr1 Sales,100,E ast Actual

LCell Mote:

Ok

: updated by the

Cancel

diil)

Help

Figure 154. Editing the Contents of a Linked Cell Note

Note: If you simply want to view the contents of the cell note, click the
View /Launch button instead of the Edit button in the Linked

Objects Browser dialog box.
5. Edit the contents of the cell note as indicated in the following illustration:
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Edit Cell Hote [ x|

Member Combination: [Qtrl Sales, 100, E ast Actual

=] oK |
Cancel |
Help |

Lell Mote:
Thiz number waz updated on 8/26/97.

|

Figure 155. Result of Editing Cell Note Contents

6. Click OK to close the Edit Cell Note dialog box and save the edits you

made to the note.

Hyperion Essbase saves the edits to the cell note on the server.
7. To close the Linked Objects Browser dialog box, click Close.

Linked Objects Browser

8. Leave the Asymm.x1s file open for the next tutorial task.

Accessing a Linked URL

If you followed the steps in [Linking a TIRT to a Data Cell” on page 135, you

can access and edit the URL that you created.

To access the URL:
1. In the Asymm.x1s file, select cell E5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to

the selected data cell.

3. In the Linked Objects Browser dialog box, select the URL.

-- Poplar:5 ample:B asic

Member Combination: IQ tr3,5ales Colaz E ast,Budget
Linked Dbjects:

Object Type Object Description Linked Object and Object

Hyperion Solutions' home hittp: 4 A, hyperion. com

ftach.. | Edi. | Viewlaunch|  Delete

Lloze |

Figure 156. Accessing a Linked URL

4. To view the linked URL, click View/Launch.
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Hyperion Essbase checks the syntax of the URL. If there are syntax errors,
Hyperion Essbase displays an error message. If the URL syntax is correct,
the default Web browser launches and connects to the specified site. In this
case, the syntax for the URL is correct, so the default Web browser
launches and connects to the Hyperion Web site.

yperion - Hetscape [_ (O] =] I

File Edit “iew Go Communicator Help

I SRR T S Y B S |

Back Fopward Reload Home Search  Metscape Frint Security Stop

Solutions » Corporate - News - Events - Parinars - Support and Sarvices - Boftwara Downloads

@ Year 2000 O 'Worldwide Search ®Contact Us Site Map

308 —
Hy?)efi:‘on‘ r_aﬁialyze ﬂ .
s | mthe
Silicon Val

See the Future First™ R ey | Technology Fast 50
" 'SOLUTIONS 99

Hyperlon Burope's annualcho"n?e?e':g

e-Business | 1417 novemser 1208

Division | Hyperion ¢

Application o

Link

Applicaton

integration =

made easy
Careers st Hyperion Warldwide
Discourts offered on Wwired for OLAP software I Salect an International Location j @
and services in North America.

Products

Hyperion Essbase Spreadsheet Add-in End User CBT now
availsblel |Se|ect a Product j

@

| (== |Applet Home Page unring By N

Figure 157. Viewing a Linked URL

5. Close the Web browser.

To edit the URL:
1. In the Linked Objects Browser dialog box, select the URL.
2. To edit the linked URL, click Edit.

Hyperion Essbase displays the Edit URL dialog box with the selected URL
displayed.
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Edit URL []

Member Combination: IIJ tr3.5ales.Colas E ast. Budget

Location:

I hittp: 4 A, hyperion. com

URL Description:

Hyperion Solutions' home page

.

Cancel

Figure 158. Preparing to Edit the Contents of a Linked URL

3. Edit the URL location and description as show in the following

illustration:

Edit URL

Member Combination: |utr3,sales,Colas,East,Budget

Location:

Ihttp: £ fw. hwperion, comdsolutions. cfm

URL Description:

Hyperion Solutions' home page

:

Cancel

Figure 159. Editing the Contents of a Linked URL

4. To close the Edit URL dialog box and save the edits that you made, click

OK.
Hyperion Essbase saves the

edits to the URL on the server.

5. To view the new URL, click View/Launch.

The Web browser launches and connects to the new URL.
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|Document: Done

Figure 160. Viewing an Edited URL

6. Close the Web browser.

7. To close the Linked Objects Browser dialog box, click Close.
8. Close the Asymm.x1s file without saving it.

Connecting to Multiple Databases

Hyperion Essbase supports simultaneous access to multiple databases. The
databases can be in different applications and can be stored on different
servers. In Excel, you can open multiple worksheets, each of which can be
connected to a different database. An individual worksheet can access only
one database at a time. Use the Connect command from the Essbase menu to

switch the connection between databases.

Note: Depending on the status of production applications at your site, you
may not have access to additional applications or databases. Check
with the Hyperion Essbase system administrator if you need access to

other applications.

144 OLAP Spreadsheet Add-in User’s Guide for Excel




For this tutorial, you do not need to connect to another database.

To access multiple databases, use the following procedure:
1.
2.

Select Essbase > Connect.

In the Essbase System Login dialog box, select the server you want to access from the Server list
box (or type in the name of the server).

Press Tab to move to the Username text box and type your username.
Press Tab to move to the Password text box and type your password.
Click OK to connect to the server.

When the server connection is complete, a list of available application and database pairs appears
in the Application/Database list.

Double-click the Application/Database pair that you want to connect to in the
Application/Database list. Alternatively, you can select the Application/Database pair and click OK.

If the application is not already running, Hyperion Essbase automatically starts it. There may be a
brief pause as the application loads; the time required to start an application depends on number of
databases, the sizes of the databases, and the sizes of the indexes of the databases contained within
the application.

Open a new worksheet and repeat the steps to connect to additional databases. You can open one
database at a time per worksheet.

For information on connecting to multiple databases from Hyperion Essbase
Querzi Designer, refer to r’rhapfpr 3 An Advanced Hyperion Esshase Tutariald

Viewing Active Database Connections

If you frequently connect to multiple databases, you may need to check the
active database for each worksheet. There are two ways to view the database
connection status:

* The Style tab of the Essbase Options dialog box contains a Connection
Information text box. This box displays connection information for the
active worksheet.

* The Hyperion Essbase Disconnect dialog box lists all active worksheets and
their connection information. This dialog box also enables you to disconnect
one or more worksheets from their respective databases.

Accessing Linked Partitions

Linked partitions are part of the Hyperion Essbase Partitioning product. They
provide the ability to link Hyperion Essbase databases that contain different
dimensions without losing access to all dimensions of both databases. If your
organization has purchased and implemented the partitioning product, you
can take advantage of its powerful capabilities. The Hyperion Essbase Database
Administrator’s Guide describes how to design and implement a linked
partition. Hyperion Essbase Application Designer usually sets up partitioning.
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Note: The Partitioning product also allows the Hyperion Essbase application
designer to set up transparent or remote partitions. For more
information on partitioning, see the Hyperion Essbase Database
Administrator’s Guide .

You can set visual cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. You have
two options for accessing a linked partition from a data cell in Hyperion
Essbase Spreadsheet Add-in:

* Select the cell and select Essbase > Linked Objects.
* Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Hyperion Essbase Spreadsheet Add-in
online help.

When you select Essbase > Linked Objects from a linked partition cell,
Hyperion Essbase completes the following actions:

* Hyperion Essbase displays the Linked Objects Browser dialog box, which
contains a list of possible partitions to access. From this dialog box, select
the partition to connect to.

Note: The Linked Objects Browser dialog box may also contain a list of
linked reporting objects, such as cell notes and external files. For

more information, see [‘Using Tinked Reparting Ohjects” on page 130.

» After you select a partition, Hyperion Essbase creates a new worksheet that
contains corresponding members and dimensions for the cell in the linked
partition.

Note: Hyperion Essbase does not preserve formulas across partitions.

* Hyperion Essbase retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more
information on the new worksheet.

Note: The Sample Basic database that you are using for this tutorial does not
contain a linked partition.
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Linked Objects Browser -- Aspen:5ample:Basic

If the Hyperion Essbase application designer has a linked partition set up, use the following procedure
to access the linked partition in Hyperion Essbase Spreadsheet Add-in:

1. Locate a linked object cell, as indicated by the style applied to the cell.

2. Select Essbase > Linked Objects to open the Linked Objects Browser dialog box.
Note: Alternatively, select the Enable Linked Object Browsing check box in the Essbase Options
dialog box to enable double-clicking to view linked objects.

3. Select the partition that you want to connect to and click View/Launch.

Member Combination: IQ tr2,5 ales Colas E ast Budget
Linked Objects:

Object Description

Object Type
Linked Partition

fach.. | Edi. | ViewsLaunch|

File: M ame:

Created By

[elete |

Help

Last Modified
‘wed Dec 31 16

i

| Lloze |

the linked partition.

Hyperion Essbase creates a new worksheet that contains the dimensions and members for the cell in

Note: You need to have the proper privileges to access a linked partition. If
your user account and password match the account information for the
linked partition, Hyperion Essbase establishes a connection with the
linked partition. Otherwise, Hyperion Essbase displays the Essbase
System Login dialog box for you to enter the user account and

password information manually.

Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve data into the worksheet, you
can use Hyperion Essbase Spreadsheet Add-in to change values, enter
formulas, and format data. Hyperion Essbase is also designed to permit
multiuser, concurrent database access and update. Depending on your
security privileges, you may be able to modify all data values or a certain
subset of values. To recognize cells to which you have read/write access,
apply a visual cue, or style, to the cells. For more information, see

- . To update data from a worksheet, you must
lock the database area that contains the values that you want to change.
Locking prohibits other users from changing the data that you want to
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update. Other users can retrieve locked data but cannot lock or change the
data. You have exclusive update rights to that area.

Note: You cannot update attribute-related data on the server because attribute
data is always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:

* The Retrieve & Lock command retrieves data into the worksheet while
locking the corresponding data area on the server. When you perform a
subsequent retrieval, Hyperion Essbase automatically unlocks the previous
data values.

Note: The Retrieve & Lock command is not supported with Dynamic Time
Series members.

* The Lock command locks information that you have already retrieved.
When you perform a subsequent retrieval, Hyperion Essbase automatically
unlocks the previous data values.

* The Update Mode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send
command on the Hyperion Essbase menu. After updating the server, the Send
command automatically unlocks data (unless you are in Update Mode). You
must disable Update Mode to stop locking blocks automatically.

You can unlock data blocks in two ways:
* The Unlock command unlocks all blocks that you have locked.

* The server automatically unlocks data blocks that have been locked for the
maximum time allowed as defined by the Hyperion Essbase system
administrator. Automatic unlock ensures that blocks are not locked for
extended periods of time.

P&1.xTs, a sample Excel file installed as part of the default Hyperion Essbase
installation, illustrates how to update data on the server.

To view the P&1.x1s worksheet:

1. Select File > Open.

2. From the \essbhase\client\sample directory, open the P&1.x1s file.
3. Select Essbase > Retrieve & Lock.

Hyperion Essbase retrieves data and locks the appropriate area of the
database.
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A [ B C D [ F [ G [ H

L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget

4

5 —

6 [Misc #lissing  Missing  #lissing

7 [Payroll 210 210 210 630 0.07

B |Marketing 300 310 320 930 11.05

9 Total Expenses 510 520 530 1560 18.53

10

11 |COGS 1170 11580 1200 3550 42.16

12 |Sales 2740 2520 2860 8420 100.00

13 targin 1570 1640 1660 4870 57.84

14 Profit 1060 1120 1130 3310 39.31

15

16 |Ratio Analysis

17 |Markup 57.3% 58.2% 55.0% 57.8%

18 |Marketing % 10.9% 11.0% 1.2% 11.0%

Figure 161. P&L Worksheet After Retrieve & Lock

4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.
Hyperion Essbase changes the affected data values.
5. Select Essbase > Send to update the server with the new values.

Hyperion Essbase updates the server and unlocks the data blocks.

A [ B | ©€ [ o [ E T F G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
1 3 | Scenario: Budget
4
I—
6 [Misc 4} 10 10 25 0.30
7 [Payroll 200 200 200 600 0.07
8 |Marketing 350 350 350 1050 12.47
9 Total Expenses 555 560 560 1675 19.89
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 targin 1570 1640 1660 4870 57.84
14 Profit 1015 1080 1100 3185 37.95
15
16 |Ratio Analysis
17 |Markup 57.3% 58.2% 55.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.5%

Figure 162. P&L Worksheet After Sending New Values to the Server

6. Close P&1.x1s without saving it.

Note: Hyperion Essbase provides a worksheet update logging facility that
tracks and logs all data updates sent from Hyperion Essbase
Spreadsheet Add-in to the server. The Hyperion Essbase system
administrator enables this facility for extra protection against data loss.
For more information, see the Hyperion Essbase Database Administrator’s
Guide or contact the Hyperion Essbase system administrator.
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Calculating a Database

Sending updated data to the server does not automatically recalculate the
database. If you have the appropriate security privileges to perform database
calculations, you can calculate the database from Hyperion Essbase
Spreadsheet Add-in with the Calculation command. For this tutorial, you will
not actually calculate the Sample Basic database. For more information on
Hyperion Essbase calculations, see the Hyperion Essbase Database
Administrator’s Guide.

CAUTION:
Do not perform any calculation operations for this tutorial.

When you select Essbase > Calculation, Hyperion Essbase displays the
Essbase Calculation dialog box.
The Essbase Calculation dialog box contains the following items:

Essbase Calculation E I

Connection Infarmation
(Aspen:SampleoBasic

Select Calc Script:

D —
CalcOne
CalcRel
Calchdat ﬂl
Calcine

Calclane

CalcDes
CalciDes il
Stop Calc |

— Database State

Mo data values have been changed
since the last calculation.

Figure 163. Essbase Calculation Dialog Box

* The Connection Information text box displays the active database
connection.

* The Select Calc Script list box contains the server-based calculation scripts
to which you have access.

¢ The Database State text box indicates the current calculation state of the
database. The following states are possible:

— Calculating—indicates that a calculation is currently running on the
database.

— Data values have been modified since the last calculation—indicates that
data values have changed since the database was last calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.
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— No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or a calculation of any subset of the database.

CAUTION:

If the last calculation was performed on a subset of the data, the entire
database may not have been calculated since values last changed. To
ensure that the results of calculations are up-to-date, you may want to
run a calculation of the entire database. For more information, contact
the Hyperion Essbase system administrator.

Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applications is to send
worksheets to various functional areas of an organization. After the
worksheets have been distributed, the recipients can review the contents,
make modifications, and send updates back to the distributor. Using the
Hyperion Essbase Cascade feature, you can create multiple worksheet files
based on a single database view. You can specify at what level of detail you
want to replicate the worksheets to tailor the information to each recipient’s
needs.

The Sample Basic database contains data for beverage products sold in
different states across the U.S. For example, assume that you want all product
managers to review and respond to a proposed budget and to return their
changes to the finance department. We must create a worksheet for each
combination of budget and P&L data to distribute to the product managers
for their respective products.

To create this set of worksheets:
1. Select File > Open.

2. From the \essbase\client\sample directory, open the P&1.x1s file. This
file contains the data that you need to replicate for each worksheet.

3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set
for this file in the Essbase Options dialog box. In this example, product
200 changes to Root Beer, which is its preassigned alias.

4. Select Central (in cell B1) and Root Beer (in cell B2) as the members to be
represented in the resulting worksheets.

5. Select Essbase > Cascade.
Hyperion Essbase displays the Essbase Cascade Options dialog box.
6. Click the Cascade Information tab.
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The Cascade Information page contains the list of members that you
selected and the options for specifying the level at which the selected
members are retrieved into the cascaded worksheets.

Note: For more information on each option, see the Hyperion Essbase
Spreadsheet Add-in online help.

7. Select Central in the Member list box, and select Same levelin the
Choose Level for Selected Member option group.

8. Select Root Beer in the Member list box, and select Next level (the
default setting).

Cascade Information | Destination Dptionsl Format Dptionsl

— Cascade Or:

Member:

Choose Level for
Selected Member:

Central
iHoot Beer

Same level
et [yl

& Mewt Level
 All Levels

" Bottom Lewel
" Sibling Level
© Same Level
 Same Generation

 Fomulas

QK I Cancel Help

Figure 164. Cascade Information Tab

10.

11.

The replicated, or cascaded, spreadsheet reports now provide data for
members at the same level as Central (East, West, and South) and for
members at the level below Root Beer (Old Fashioned, Diet Root Beer,
Sarsaparilla, and Birch Beer).

Click the Destination Options tab.

In the Destination Directory text box, enter C:\temp as the name of the
directory where you want the cascaded worksheets to be stored.

You can also click Browse to select a destination directory from the
Browse dialog box.

In the Destination Types option group, select Separate Workbooks (the
default setting) to create separate Excel files for each cascaded worksheet.

You can also tell Hyperion Essbase to create only one workbook with
separate worksheets for each cascaded report, or you can send the
cascaded reports to the printer.
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12. In the File Information option group, click Overwrite Existing Files (the

default setting). This option tells Hyperion Essbase to overwrite any
cascaded worksheets with the same file name.

You can also select Open Created Files to open each cascaded file in Excel
as it is created.

CAUTION:

Depending on the number of replicated worksheets that you want to
create, the Cascade command can create more worksheets than can be
stored in the memory of your computer. Therefore, the Open Created
Files option should not be used when you are replicating large
numbers of worksheets.

13. In the Naming Information option group, enter BUD in the Prefix text box.

Essbase Cascade Options

Cascade Infarmation  Destination Options | Format Opticns I

r— Destination Directory:

— Destination Types

ctemp

Bl |  Printer Printer... |

' Separate Workbooks
" One Workbook, Separate Sheets

— File Infarmation
I~ Open Created Files
¥ Owvenarite Existing Files

— Maming Information

Prefix: BUD
Suffi:
Wwiorkbook: I

QK I Cancel Help

Figure 165. Destination Options Tab

When you assign a prefix or suffix in the Naming Information option
group, the worksheet files that are generated as a result of executing the
Cascade command are named with the prefix or suffix that you specify.
The default is to generate worksheet names that are numbered 1 through
n, where n is the total number of worksheets created. The syntax for the
file names is PrefixnSuffix.x1s. If you do not specify a prefix or suffix,
Hyperion Essbase creates the worksheets 1.x1s, 2.x1s, and so on. If you
are creating a single workbook, the same naming convention is used for
the worksheet tab names within the workbook.

CAUTION:

Do not specify a prefix and suffix combination that leaves no
characters free for Hyperion Essbase to create unique file names. If file
names are duplicated, Hyperion Essbase overwrites the duplicate file
name with the last cascaded worksheet.
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14.
15.

16.

17.

Ezsbase Cascade Options

Cascade Informationl Diestination Options ~ Format Options |

— Sheet to Sheet Replication
¥ Copy Formatting

Click the Format Options tab.

To copy the formatting of the source worksheet into each cascaded
worksheet, select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Hyperion
Essbase and the cell formatting that you set using the worksheet. It
does not copy formulas, column formatting, worksheet formatting,
or graphs.

In the Header and Footer text boxes, specify a header or footer name to
be used for all of the cascaded worksheets.

In the Sheet Formatting group, select the Suppress Missing Rows check
box so that rows containing only #Missing values are not replicated.

In the Table of Contents group, select the Include Table of
Contentscheck box to create a text file that lists all replicated worksheets,
their creation dates, and their member content.

By default, Hyperion Essbase names the Table of Contents file with the
extension .1st.

Header: I

Footer: I

— Sheet Formatting
V' Suppress Missing Rows

— Table of Content

QK I Cancel Help

Figure 166. Format Options Tab

18.

Click OK to create the cascaded worksheets.

Hyperion Essbase rapidly creates the cascaded worksheets (nine total
worksheets in this example). As each worksheet is created, it is
automatically saved, closed, and logged in the Table of Contents. Each
individual file is saved in the directory that you specified, named
Budl.x1s through Bud9.x1s. When the Cascade is completed, Hyperion
Essbase returns you to the original worksheet view (that is, the source
file).
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/**********##t##******##t##**********##***********#*********f
FEa
s

c

noooonoonan

File name:

Creation date: Mon Nov 10 11:48:34 1997 */

/**********XﬁXXX******XXXXX**********XX***********X*********/
YtemphBUDL .
\temphBUDZ .
N\ temphBUD3 .
N\temphBUD4 .
N\temphBUDS .
thtemphBUDA.
\temphBUDT .
:\temp\BUDS .
thLemphBUDS .
\temphBUDL0.x1ls

xls
®ls
®ls
®ls
xls
%ls
®ls
®ls
®ls

19. Using a text editing application, open the Table of Contents file from the
destination directory that you specified earlier. This file is named
BUDO.LST and contains a list of all cascaded worksheets.

cihbemph BUDD . 15t */

/* East, 0ld Fashioned #/
/* East, Diet Root Besr */
/* East, Sasparilla */

/* East, Birch Beer */

/* West, ©0ld Fashioned =/
/* West, Diet Root Besr  */
J* West, Sasparilla  */

/* South, ©ld Fashionsd */
/* South, Diet Root Beer */
/* gouth, Sasparilla =/

Figure 167. Table of Contents File for Cascaded Worksheets

20. Select File > Close to close the worksheet.
You do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a
product. Type in the attribute names in the top row of the
worksheet. Select the attribute names and select Essbase >
Cascade. Proceed as described in the above example.

Working with Currency Conversions

Organizations with offices in different countries generally do business in the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currencies to a common currency for
consolidation and analysis.

The Hyperion Essbase Currency Conversion product can be purchased
separately for Hyperion Essbase. If your organization has purchased this
product and has implemented a currency conversion application, you can take
advantage of the powerful capabilities of Hyperion Essbase Currency
Conversion. The Hyperion Essbase Database Administrator’s Guide describes how
to design and implement a currency conversion application.

The following sections provide a brief tutorial for working with currency
conversions:
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Retrieving Currency Conversion Data

This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
* A main database that contains data in local and converted values
* A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from
the main database to derive converted values.The Hyperion Essbase OLAP
Server product installation includes a sample currency conversion application
(installation options) that consists of two sample databases: a main database
called Interntl and a currency rates database called Xchgrate.

The Sample Internt]l database consists of five dimensions: Year, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions
are identical to the Sample Basic database. The Market dimension includes
Toronto, Vancouver, Montreal, France, Germany, Spain, and the UK. The
Scenario dimension handles different currency types (such as Actual and
Budget) in both local and converted currencies. In this database, all local
currencies are converted to the common currency of U.S. dollars.

The Sample Xchgrate database, which is a subset of the main database,
contains four dimensions:

* The CurTime dimension accommodates different exchange rates by month.

* The CurName dimension contains names of currencies from their respective
markets.

* The CurCategory dimension contains the names of the various currency
categories that may be applied to the categories of Measures. For example,
one rate is applied to Profit and Loss items and another rate is applied to
Balance Sheet items.

* The CurType dimension allows a currency database to contain rates for
different scenarios, such as Actual and Budget.
Connecting to the Sample Currency Databases

To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.

2. Select the Sample Interntl database and click OK to complete the
connection.
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The Hyperion Essbase installation also includes sample Excel files that

illustrate currency conversion concepts.

The worksheet contains actual (Act) and budget (Bud) data entered in

From the \esshase\client\sample directory, open Local.xls.

Total Expenses

Margin %%
Profit %2

#issing  #Missing #Missing #Missing

#issing  #Missing #Missing #Missing
#issing  #Missing #Missing #Missing

3.
local currencies for New York and Germany.
A [ B [ © ] D [ E F_ |
11| Jan 100-10
2
3 | Az Fend

4] MNew York Germany Mew York  Germany

L5 |Sales 678 210 640 140

B |COGS 27 34 260 a0

| # | Margin #hdissing  #Missing #Missing  #Missing

[i]

9 |Marketing 34 27 a0 20

|10 |Payroll 51 Kl 40 20

|11 |Misc i 0 #dissing  #Missing

2]

(13|

4]

5]

(16 |

(7]

-
=}

Figure 168. Retrieving Local Data

5. Select Essbase > Retrieve.

From the \essbase\client\sample directory, open Convert.xls.

The worksheet contains values for Actual and Budget as they appear after

conversion.

A [ B [ € ] D [ E [ F [ &
1 llJan 100-10
2
3 Actust Actual & Bed Xhe Bederet
4 Mew York Germany Mew York  Germany Mew York Germany
5 |Sales 678 130 678 210 640 133
B |COGS 21 52 271 84 260 56
7 Margin 407 78 407 126 380 77
8
9 |Marketing 94 17 94 27 a0 14
10 |Payroll 51 19 51 31 40 14
11 |Misc 1] 1] 1] 0 #Missing #Missing
12 | Taotal Expenses 145 36 145 58 120 28
13
14 Margin %% 60.03 60.00 60.03 60.00 59.38 57.89
15 Profit %2 38.64 32.38 38.64 32.38 40.63 36.84

Figure 169. Retrieving Converted Data Values

Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Hyperion Essbase converts the values by using the exchange rates from
the Sample Xchgrate database.
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6. From the \essbase\client\sample directory, open Rates.x1s. Connect to
the Sample Xchgrate database.

7. Select Essbase > Retrieve.

A | B Jc[ b [JETJTFJ[G [HTJTT1T® T J]
L1 ] Jan Feb  Mar  Apr May  Jun Jul
| 2 |US$  Actxchg PAEL 1 1 1 1 1 1 1
3 | B3 1 1 1 1 1 1 1
4| Bud xchg P&L 1 1 1 1 1 1 1
|5 | B3 1 1 1 1 1 1 1
| 6 |CN$  Actxchg P&L 153 1563 153 153 153 153 153
L7 | B3 185 185 185 155 155 185 185
| 8 | Bud xchg P&L 15 15 15 15 15 15 15
19 | B3 15 15 15 15 15 15 15
|10 |Mark  Actxchg P&L 062 062 062 062 062 062 0E2
|11 | B3 063 063 063 063 063 063 063
12 | Bud xchg P&L 0.7 0.7 0.7 0.7 0.7 0.7 0.7

Figure 170. Retrieving Exchange Rates from a Currency Database

The worksheet contains all possible combinations of exchange rate scenarios,
categories, and types by month. Because this example converts to U.S. dollars
(US$), the sample file contains a base rate of 1 for US$. Therefore, the local
and converted figures remain the same for New York. Hyperion Essbase
converts the figures for Germany, however, by using data values in the
currency database, as follows:

* Hyperion Essbase divides data values from Actual by values in the Act
xchg currency type.

* Hyperion Essbase divides data values from Actual @ Bud xchg by values in
the Bud xchg currency type.

* Hyperion Essbase divides data values from Budget by values in the Bud
xchg currency type.

* Hyperion Essbase bases all figures in Convert.x1s on the CurCategory of
P&L and the CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation
on exchange rates. The definition is determined by the application
designer.

Performing Ad Hoc Currency Reporting

A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. You may want to perform currency
conversions dynamically, as well. Hyperion Essbase provides this capability
with the Currency Report command. This command enables you to
interactively change the currency rates and types applied to the retrieval.

To perform an ad hoc conversion on data in the Convertl.x1s file:
1. From the \essbase\client\sample directory, open Convertl.xls.
The worksheet contains data that is already converted to U.S. dollars.
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Select Essbase > Connect and connect to the Sample Interntl database.
Select Essbase > Retrieve.

Select Essbase > Currency Report.

Hyperion Essbase displays the Essbase Currency Report dialog box.

Esshase Currency Report

" Current Setting: |
LClear |

Curkame CurType

I ENg jv Cancel |

Year CurCategory

I[none] j I[none] j Help |

Figure 171. Essbase Currency Report Dialog Box

The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains
options for currency settings, names, categories, and years. For more
information on these options, see the Hyperion Essbase Spreadsheet
Add-in online help.

Note: The dimension names CurName, CurType, and CurCategory are
default names for a currency database. The application designer can
use different names for any of these dimensions.

Select the currency settings that you want to apply.

For example, select CN$ from the CurName list box and Bud xchg from
the CurType list box.

Click Apply to apply the settings.

Select Essbase > Retrieve to refresh the data in the worksheet with the
results of the ad hoc conversion.
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A [ B | © | D [ E [ F [T &

1 IJan Cola
12
| 3 | Aciesl Actiat & Bed Xhe Bederet
| 4 | Mew York Germany Mew York  Germany Mew York Germany
| B Sales 452 61 452 69 427 62
| B |COGS 181 29 181 27 173 2h
| 7 | Margin 271 36 271 Ll 253 36
8
| 9 |Marketing 63 8 63 9 53 7
| 10 | Fayrall 34 9 34 10 27 7
| 11 |Misc 0 0 0 0 #tdissing #Missing
| 12 | Total Expenses 97 17 97 14 i 13
13
| 14 | Margin %2 60.03 £0.00 60.03 £0.00 59.38 57.89
| 16 | Profit 3 38.64 32.38 38.64 32.38 40.63 36.84
16

Figure 172. Performing an Ad Hoc Currency Conversion

Hyperion Essbase converts the New York and Germany figures to
Canadian dollars (CN$).

8. Click the Clear button in the Essbase Currency Report dialog box to
disable currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the
retrieval. Converted data values may not always balance, because
the ad hoc conversion is performed on values that were previously
calculated or previously consolidated in another currency.

If values must balance and verify, they must be converted to the target
currency in the database, calculated, and retrieved. This procedure differs
from the ad hoc currency conversion retrievals described in this section; see
the Hyperion Essbase system administrator for more information.
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Chapter 4. Using Hyperion Integration Server Drill-Through

Hyperion Integration Server is a product that works with Hyperion Essbase,
Microsoft Excel, and Lotus 1-2-3. Integration Server is a suite of tools and data
integration services that serve as a bridge between relational data sources and
the Hyperion Essbase OLAP Server. Hyperion Integration Server
Drill-Through is one of these tools. Drill-Through enables you to view and
customize spreadsheet reports that display data retrieved from relational
databases. Your organization must license Hyperion Integration Server for you
to use the Drill-Through tool.

This chapter provides:
* A brief overview of the Drill-Through feature

* A description of the sample database, Excel file, and Drill-Through report
used for the tutorial

* A tutorial that walks you through tasks for using Drill-Through

What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic
data, some data elements that are required for analysis are better suited to
remain in the relational structure, in a relational database. The scope of data
residing in a Hyperion Essbase database is typically at a summary level,
where data is summarized and calculated for planning and analysis. Detailed,
transactional data usually is not examined during the planning and analysis
of a business.

For example, say you are using Hyperion Essbase to analyze retail sales for
the first quarter in the Eastern region. Detailed data, such as a list of
customers who purchased a particular product in a particular size, is not used
during the normal course of analyzing business performance. However, as
you analyze sales results, you may want to view more detailed information.
Drill-Through is a tool that enables you to drill from the summarized and
calculated data stored in your organization’s Hyperion Essbase OLAP Server
into detailed data stored in a relational database.

The database administrator predefines a data mapping for you from Hyperion
Essbase to the relational source. For example, the Hyperion Essbase members
East, West, South, and Central might map to a field called Region in a
relational database. As you navigate through data in the spreadsheet,
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Hyperion Essbase knows how the current data maps to the relational source.
For example, suppose you select cell E4 in the following sheet:

A B [T & ] D [ETFITG] H [ 1 T 4 T kK ]
| 1| East
L2 | 19596 1957
| 3 Feb Jan Mar Feb Jan hdar
|4 |[MARKETING Bottles Retail Colas |3062_|9856 3693 384047 12348.64 461919
| & | Cream_Soda 1195 3750 1404 148685 4735.55 175013
| 6 | Foot_Beer 1222 3897 1456 152086 4883.07 1823.38
L7 | DIET 1752 5830 2146 224374 728831 267378
| & | Wholesale Colas 208 BS0 246 26463 81723 30169
| 9 | Cream_Soda 51 156 59 B5.71 19138 73
| 10| Root_Beer 85 264 102 11001 32543 13164
1 DIET g5 272 102 11001 34033 12584

[gul

|LAJ|

Figure 173. Example of Drill-Through Sheet

The dimensional attributes of the cell are: East, Feb, 1996, Marketing, Bottles,
Retail, and Colas. The combination of one or more of these attributes becomes
the basis of a Drill-Through query that returns data from the relational source.

From Hyperion Essbase Spreadsheet Add-in, you can access a predefined
Drill-Through report that is based on the dimension or member intersections
of Hyperion Essbase data cells in the sheet. Using an Integration Server tool
called Hyperion OLAP Desktop Model interface, an administrator at your
organization sets up Drill-Through reports for you to access; that is, each
Drill-Through report is already defined in terms of what to retrieve from the
relational source.

Access Drill-Through reports from the Hyperion Essbase Spreadsheet Add-in
Linked Objects Browser dialog box. When you select a Drill-Through cell in
the sheet and choose Essbase > Linked Objects, the Linked Objects Browser
dialog box displays an entry for Drill-Through that you can select and launch.
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: Linked Objects Browser — Nvarma2:DrillT QA:Basic

tdember Combination;  |1996.Colas Bottles East MARKETING Jan.Retail

Linked Objects:

Ohject Type [Ohject Description Linked Object and Ohject Created By

Dril-Through Hypetion Integration Server Hyperion Integration 2t Drill-Through Hyperion Integratior

Kl i

Attach... | Edlit.. | Eiew,ﬂ'Launchl Delete | Help | Close |

Figure 174. Linked Objects Browser Dialog Box with Drill-Through Entry

Identify which cells in the sheet have Drill-Through reports associated with
them, you can define a style for cells tagged as Drill-Through. For more
information, see L i ill- v

What Is the Drill-Through Wizard?

Integration Server Drill-Through reports are predefined by an administrator at
your organization for you to view or customize. The person who develops a
report determines whether or not the report can be customized by
Drill-Through users. If a report can be customized, use the Integration Server
Drill-Through Wizard to customize it. The Drill-Through Wizard is a graphical
user interface that steps you through the following customization tasks:

* Selecting columns to retrieve from the relational data source
Decide which columns from the predefined report you need to see.
* Selecting the display order for columns
Change the default display order of columns across the sheet.
* Selecting a sort order for data

Choose an ascending or descending sort order for a particular column for
example, sort a list of managers in alphabetical order.

* Selecting data filters

Define a filter on a column so that only data meeting certain criteria is
retrieved.
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Before You Start

Before starting the tutorial, you should have a working familiarity with the
Hyperion Essbase product through the use of the Hyperion Essbase
Spreadsheet Add-in interface. As a prerequisite, you should review

['Chapter 2. A Basic Hyperion EssbaseTutorial” on page 11 and [« hapter 3 Anl

3 of this guide.

”

A sample Hyperion Essbase database is the basis for the examples in this
tutorial. The database administrator creates this sample Hyperion Essbase
database using the sample metaoutline supplied with Integration Server. For
more information, see the Hyperion Integration Server Desktop OLAP Model
User’s Guide. A sample Excel file, Dtreport.xls, contains a sheet with the
appropriate member intersections for the sample Drill-Through report. For
more information on the sample database, Excel file, and Drill-Through

report, see ‘About the Samples Used in This Tutorial” on page 170,

If you plan to follow the examples in a live working session, check with the
person at your organization who installs the Hyperion Integration Server
product family for information on the sample database needed for
Drill-Through, and to which Hyperion Essbase server you should connect.

Before starting the tutorial, make sure you meet the following requirements:
* You must install the following components on your client PC:
— A 32-bit version of Excel (for example, Excel 97, or Excel 2000)
— Hyperion Essbase Spreadsheet Add-in for Excel
— Drill-Through
The Drill-Through module is installed automatically when you install
Hyperion Essbase Spreadsheet Add-in. This module is transparent until

you invoke it from the Linked Objects Browser. For more information on
installation, contact the Hyperion Essbase System Administrator.

* The Hyperion Essbase System Administrator must install the Hyperion
Essbase server.

* You must have access to the Hyperion Essbase Integration Server and to the
Hyperion Essbase server. For more information, contact the Hyperion
Essbase System Administrator or the person who administers Integration
Server at your organization.

* You must have access to the underlying relational database (typically using
a user name and password that are different from Hyperion Essbase). For
more information, contact the Hyperion Essbase System Administrator or
the person who administers Hyperion Essbase Integration Server at your
organization.

* Make sure that the sample Excel file, Dtreport.xls, is available in the
\Essbase\Client\Sample directory.
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The sample database that contains the Drill-Through report must be set up
and running. The sample Drill-Through report used in this tutorial (called
“Promotion Media Mix for Cities”) is available with the sample database.
Contact the person at your organization who installs Integration Server to
find out the name of the sample database needed for Drill-Through.

Note: For more information on Integration Server installations, see the

Hyperion Integration Server Desktop Installation Guide. For more
information on Hyperion Essbase installations, see the Hyperion Essbase
Installation Guide.

Keep in mind the following guidelines during the tutorial:

Each tutorial task builds upon the previous task and tasks must be followed
in succession.

Tasks that should not be performed as part of the tutorial appear in gray
boxes. These tasks are included for your reference. You can find more
information on these tasks in the Integration Server Drill-Through online
help.

The examples used in this tutorial are based on the sample database that is
included with the Integration Server installation. Contact the person at your
organization who installs Integration Server for information about accessing
the sample database.

Set the options in the Hyperion Essbase Options dialog box as described in

the following section, £'Setting Hyperion Esshase Options] If the option

settings are different, the illustrations presented in this chapter may not
match the spreadsheet view.

If you make a mistake during the tutorial, choose Essbase > FlashBack to
return to the previous spreadsheet view.

Setting Hyperion Essbase Options

Before you begin the tutorial, make sure that the spreadsheet options are set
to the initial settings as illustrated in the following figures. If the option
settings are different, the illustrations presented in this chapter may not match
the spreadsheet view.

Note: For information about each option in the Hyperion Essbase Options

dialog box, click Help to see the Hyperion Essbase Spreadsheet Add-in
online help.

1. From the Spreadsheet menu, choose Essbase > Options.
2. In the Essbase Options dialog box select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:
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Essbase Options [ %]

Display |Zoom I tode I Style I Globall

Indentation———— [~ Replacement
 Nagne #higzing Label: I
' Subitems — e
& Totals Mo Access Label: I
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
&l Aliaz:
— Cells
™ Use Styles IDefauIt j
¥ &djust Columns

I™ | Auto Sort Fows Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic: Time S erie:

¥ Latest Time Period IMH

QK I Cancel Help

Figure 175. Initial Settings for Display Options

4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Essbase Oplions
Display Zoom | Mode | Giabal|

—Zoom |n

Al Levels

" Bottom Level
" Sibling Level
' Same Level

" Same Generation

' Fomulas

— Member Retention

¥ Include Selection

[~ ‘within Selected Group

™ Remove Unselected Groups

Cancel

Help

Figure 176. Initial Settings for Zoom Options

6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:
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Essbase Options
Displayl Zoom  Mode |GIObaI|

— Retrieval

" Free Form
™| Tiemplate Fetrieyve

—Mode
™ Update Mode

— Formula Preservation

™ Retain on Fetrizval

™| Rietain arfesn and Femoye Dl
™| Betain onZooms:

I Formulz Fil

Mote: Certain options cannot be uzed in conjunction with Formula Preservation.
If any of these options are selected, the Formula Preservation options are grayed out and
canhot be selected, and vice versa. Click Help for mare infarmation.

QK I Cancel Help

Figure 177. Initial Settings for Mode Options

8. Select the Style tab.

9. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Essbase Oplions

Displayl Zoom I Mode Style |GIObaI|

[mlLirked Ob
I Integration Server DrillThrough

— Member
Attribute: — Sample
[ Chid
Shared -
L _I Farmat... |
— Dimensiar
Diimenszion: — Sample
™ Measures
™ Product LI
[~ | Cell Barder
Background Color: I Mone j Format... |
— Data Cell
Attribute: — Sample

[ Read Only =l Farmmat... |

Connection Information:
’7 Aszpen:Sample:Basic

QK I Cancel | Help |

Figure 178. Initial Settings for Style Options

10. Select the Global tab.

11. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Essbase Options

Displayl Zoom I Mode I Style  Global |

Mo — Display Messages
v '\Enable Secondary Buttor:g' " Information
= g & Wanings
V¥ Enable Linked Object Brawsing " Enars
" None
— Memory [+ Dizplay Unknown Members

[V Enable Flashback

— LogFile
— Member 5elect ¥ Route Messages to Log File

™ Display Save Dialog V¥ Purge Log File Every Session

—Mode
™ Mavigate withaut D ata

Add-ng... |

o]

Cancel Help

Figure 179. Initial Settings for Global Options

12. Click OK to save the settings for this session and close the Essbase

Options dialog box.
About the Samples Used in This Tutorial

The sample database used for this tutorial contains the following dimensions:
Scenario, Products, Package, Markets, Accounts, Time, and Channel. The

sample Excel file provides a particular view from this database:
For this spreadsheet view, detail-level data exists in a relational data

A [ B[ c© [ D0 TJ[TEJFTe] H [ 1T T a0 T kK ]
| 1| East
| 2 | 1996 1997
| 3 | Feb Jan Mar Feh Jan tlar
| 4 |MARKETING Enottles Retail Colas ISDEZ!QBSE 3653 3840.47 1234564 4619.19
| 5 | Cream_Soda 1195 3790 1404 148665 473855 17580013
| 6 | Root_Beer 1222 3897 1456 152066 4883.07 1823.35
| 7 | DIET 1792 5830 2146 224374 7288.31 267378
| & | Wholesale Colas 208 B0 246 2R4B3 81723 30169
| 9 | Cream_Soda 51 156 &9 6571 19133 7331
| 10| Root_Beer 85 264 102 11001 32543 131.64
| 11| DIET 88 272 102 11001  340.33 125.84
|12 |
| 13 |

Figure 180. View from Sample Database

source—data that is not available from Hyperion Essbase. For example, the
relational source contains columns of data for cities, seasons, and different
types of media (for example, print, radio, and so forth). This tutorial walks
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you through a sample Integration Server Drill-Through session, where you
will drill down from the data shown above into the detail data from the
relational source.

This tutorial uses a sample Hyperion Drill-Through report called “Promotion
Media Mix for Cities.” As with all Hyperion Drill-Through reports, this report
has been predefined to retrieve specific columns from the relational source.
You will use the Drill-Through Wizard to customize the predefined report.

Note: The sample file also contains a second sample report, called “City
Demographics,” that you can use for Drill-Through practice.

Using Drill-Through
Drill-Through consists of the following tasks:
¢ Accessing Drill-Through from Hyperion Essbase Spreadsheet Add-in
* Selecting Drill-Through Reports to View or Customize
¢ Selecting and Ordering Columns
* Sorting Data
* Filtering Data

The following sections describe each of these tasks and step you through a
live working Drill-Through session.

Accessing Drill-Through from the Spreadsheet

From Hyperion Essbase Spreadsheet Add-in, you can access detail-level
Drill-Through reports that are based on the member intersections of Hyperion
Essbase data cells in the sheet. Each Drill-Through report has been predefined
by an administrator at your organization; that is, each Drill-Through report is
already set up to retrieve specific columns from the relational source, sort data
in these columns in specific ways, and so forth. Using the Drill-Through
Wizard, you can customize these predefined Drill-Through reports to retrieve
only the data you want, displayed in a specific way.

To access the predefined Drill-Through report, double-click a Drill-Through
cell in the spreadsheet (or select a range of cells and choose Essbase > Linked
Objects). To help identify which cells in the sheet are associated with
Drill-Through reports, you can set styles for cells tagged as Drill-Through.
When you double-click a Drill-Through cell, Hyperion Essbase displays the
Linked Objects Browser dialog box, which displays a Drill-Through report
entry. A single cell can have multiple reports associated with it. The Linked
Objects Browser dialog box also displays entries for linked partitions and
other linked object types (for example, cell notes and application files). After
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you view or customize the Drill-Through report, the Hyperion Essbase
retrieves data from the relational source and displays the results in a new
spreadsheet.

Before starting the Drill-Through tutorial, you will:

1. Open a sample Excel file that contains the appropriate member
intersections from the sample database for the Drill-Through report. This
file, Dtreport.xl1s, is provided as part of the default Hyperion Essbase
installation

2. Set a style for data cells that have Drill-Through reports associated with
them.

To access the sample file and sample database:
1. Start Excel.

2. Choose File > Open and open the Dtreport.xls file from the
Esshbase\Client\Sample directory.

The sample file should look like this:

A B [ & ] D [ETFTG] H [ 1 [ 4 T kK |
| 1| East
| 2 | 1996 1997
| 3 | Feb Jan Mar Feh Jan tlar
| 4 |MARKETING Enottles Retail Colas 306219856 3693 3840.47 1234864 461919
| 5 | Cream_Soda 1195 3790 1404 148665 473855 17580013
| 6 | Root_Beer 1222 3897 1456 152066 4883.07 1823.35
| 7 | DIET 1792 5830 2146 224374 7288.31 267378
| & | Wholesale Colas 208 B0 246 2R4B3 81723 30169
| 9 | Cream_Soda 51 156 &9 6571 19133 7331
| 10 Root_Beer 85 264 102 11001 32543 13164
11 DIET 88 272 102 11001  340.33 125.84

[gul

a1}

Figure 181. Sample Excel File for Drill-Through

The sample file shows data for specific members of a Hyperion Essbase
database. From this view, a predefined Drill-Through report exists for all
member intersections in the sheet. Using Drill-Through, you can access
this report and customize it so that the Integration Server retrieves only
the data you need and displays the data in the desired format.

3. Select Essbase > Connect and connect to the appropriate sample database.

Note: For information on the sample database, contact the person at your
organization who installs Integration Server.

4. Select Essbase > Options and select the Style tab.

5. In the Data Cells option group, click the Integration Server
Drill-Through check box and click Format.

Hyperion Essbase displays the Font dialog box.
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6. Select Bold Italic from the Font style list box.
7. Select Red from the Color drop-down list, and click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

Diata Cell

Attribute: Sample————
I Linked Objects - i .
’ ntegration Server
v cer Dill-Through [ 4

[ Read Only LI Fomat |

Figure 182. Sample Style for Integration Server Drill-Through Data Cells

8. Click OK to close the Essbase Options dialog box.
9. Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample Drill-Through report is associated with every
member intersection in the sheet, so all cells are now displayed in red,
bold, italic font.

A B T & ] D [ETF T H ] [ J K]
| 1] East
| 2| 1996 1997
| 3 Febh Jan  Mar Feb Jan tlar
| 4 [MARKETING Bottles Retail Colas 306211 9856 3693 384047 12348.64 4679.79
|5 | Cream_Soda 7195 3700 1404 1486.65 4738.55 1750.13
| 6| Root_Beer | 7222 3807 71456 1520.66 4883.07 71823.318
1 7 DIET 1792 5830 2146 224374 72§8.37 267378
| & | Wholesale Colas 208 650 246 264.63  §77.23  301.69
19 Cream_Soda &7 156 59 6577 19139 7337
| 10 Root_Beer 85 264 102 T10.07 32543 13164
|11 DIET 88 272 102 110.07  340.33 12584
|12
|13

Figure 183. Sample Excel File with Drill-Through Style Applied

To access the sample Drill-Through report from the Hyperion Essbase
Spreadsheet Add-in:

10. Select any Drill-Through cell; for example, cell E4.
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A B [ & ] D [EJTF TG H ] [ J K
| 1| East
| 2 | 1996 1997
| 3 | Feb Jan Mar Feb Jan tlar
| 4 |MARKETING Eottles Retail Colas 30621 9856 3693 384047 12348.64 4679.79
| 5 | Cream_Soda | 7795 3700 71404 71486.65 4738.55 1750.13
| 6 | Root_Beer | 7222 3807 1456 1520.66 4883.07 1823.38
| 7 | DIET 1792 5830 2146 224374 7288.31 267378
| 8 | Wholesale Colas 208 650 246 264.63 877.23 ) 301.69
| 9 | Cream_Soda &7 156 50 6577 19139 7y
| 10| Root_Beer 85 264 102 T10.07T 32543 13164
| 11| DIET 88 272 102 110.07  340.33 12584
|12 |
| 13 |

Figure 184. Selecting a Drill-Through Cell

Note: You can also select a continuous range of cells in the sheet to
display all Drill-Through reports associated with cells you select.
In this example, we have only one Drill-Through report attached to

the range of cells.

11. Select Essbase > Linked Objects to open the Linked Objects Browser

dialog box.

Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to
double-click a linked object cell to open the Linked Objects Browser
dialog box. This option works only with single-cell selection. If you select
a range of cells, use the Essbase > Linked Objects menu command.

: Linked Objects Browser — Mvarma2:DrillT QA:Basic

Member Combination: 15996 Colas Bottles E ast MARKETING Jan Retail

Linked Objects:

Ohject Type [Ohject Description
Drill-Through i

Linked Ohject and Ohject

nln H rian Int

Kl

Atiach.. | Edli, |yiew;|_aunch| Deleie |

Drill-Through

Help |

Close

2

Figure 185. Linked Objects Browser Dialog Box with Drill-Through Entry Selected

12. Select the Drill-Through report entry and click View/Launch.
Hyperion Essbase launches Drill-Through and displays the Select

Drill-Through Report dialog box.
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Note: If the Integration Server is not running, Drill-Through does not
launch properly. For more information, contact the Hyperion
Essbase System Administrator.

Select Drill-Through Report !EIE

Available Reports Execute

Promotion Media Mix for Cities

Customize ...

LCancel

Al

Help

Figure 186. Select Drill-Through Report Dialog Box

13. If you are prompted with the Drill-Through Login dialog box to connect
to the Integration Server and the relational data source, enter the
appropriate connection information. The person at your organization who
administers Integration Server and develops Drill-Through reports should
provide you with this information.

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized,
Drill-Through generates the report and immediately displays the
results in the spreadsheet. The person at your organization who
develops Drill-Through reports specifies whether you can
customize a report and whether you need to log in to the
Integration Server and relational data source.

14. Follow the steps in the next section, I'Selecting Drill-Through Reparts td

View or Custamize’] to select a report to customize.

Selecting Drill-Through Reports to View or Customize

After you launch Drill-Through from the Linked Objects Browser dialog box,
the Integration Server displays the Select Drill-Through Report dialog box if:

* More than one Drill-Through report exists for the cell or cell range that you
select in the spreadsheet, or

* Only one report exists, but you have the option of customizing it using the
Drill-Through Wizard.

The Select Drill-Through Report dialog box displays the list of
Drill-Through reports available for the cells you select in the spreadsheet.
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Depending on how a report is defined in OLAP Desktop Model interface,
you may have access only to view, not customize, the report.

The sample report used for this tutorial is the Promotion Media Mix for Cities report. You will use the
Drill-Through Wizard to customize this sample report. To execute a predefined Drill-Through report
without customizing it, you would:

1. Select the report that you want to view from the Available Reports list box.
2. Click Execute.

The Integration Server retrieves the data from the relational source and displays the results in a new
spreadsheet. The new sheet is added before the current sheet.

To customize the sample Drill-Through report:

1. Select the Promotion Media Mix for Cities report from the Available
Reports list box.

Select Drill-Through Report !E[B

Available Reports Execute

Promotion Media Mix for Cities

Customize ...

Lancel

i

Help

Figure 187. Selecting the Sample Drill-Through Report

2. Click Customize.

Note: The Customize button may be enabled or disabled for any given
report, depending on how the report was defined in OLAP Builder.

The Integration Server displays the first screen of the Drill-Through
Wizard.
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Dirill-Through Wizard

Follow these steps to customize the transactional report
related to the OLAP intersections you have selected:

1. Select the columns to retrieve and define their
dizplay order.

2. Define a sort arder for columng.

3. Define filkers for columns.

Click the finizh button at any point to generate the report.

Mest » Cancel Help

Figure 188. Drill-Through Wizard Dialog Box, Introductory Screen

3. Click Next to display the Select Columns and Display Order dialog box.

Select Columns and Display Order

Fiepart Mame

|Pr0m0ti0n Media Mix for Cities

Available Columns Selected Columnz

+ 2 =
+- PRODUCTS
+- TIME

+- SALESINVALCT

M
FRODUCTS. FAMILYID
PRODUCTS. FAMILYDESC
FRODLUCTS.PRODID
PRODUCTS. PRODDESC
TIME.SEASON 4
TIME.MONTH

SALESINVACT SALES

SALESINVACT MARKETING

TIME.PRINTMEDIA

TIME TV

TIME.RADID

TIME.DIRECT

Move Down

ElE] =]

< Back Mest » | Finizh | Cancel Help

Figure 189. Select Columns and Display Order Dialog Box
4. Follow the steps in the next section, ['Selecting and Qrdering Columns’, to
select and order rows for the customized report.
Selecting and Ordering Columns

Using the Drill-Through Wizard, you can customize predefined Drill-Through
reports. The first task in the Drill-Through Wizard is selecting and ordering
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columns to retrieve from the relational database. These columns contain
detailed information that is not available in the Integration Server database.

In the Select Columns and Display Order dialog box, you can select which
columns you want the Integration Server to retrieve from the relational data
source. From this dialog box, you can also specify how the columns are
displayed in the resulting report.

The Available Columns list box displays a list of columns available from the
relational data source for this report (as defined in OLAP Desktop Model
interface). The Selected Columns list box displays the columns from the
Available Columns list box in expanded form. You can remove columns from
the Selected Columns list box to exclude them from the Drill-Through report.

In this example, the columns from the Available Columns list box are selected
for inclusion in the sample Promotion Media Mix for Cities report. These
columns are displayed in expanded form in the Selected Columns list box. In
this task, you will remove several of the selected columns from the
Drill-Through report:

1. In the Selected Columns list box, select the TIME.PRINTMEDIA,
TIME.TV, TIME.RADIO, and TIME.DIRECT columns.

Hold down the Ctrl key to select multiple columns at once.

Select Columns and Display Order

Fiepart Mame

IPromotion Media Mix for Cities

Available Columns Selected Columns
[+ MARKETS MARKETS.STATE
.. FRODUCTS MARKETS.CITY
- TIME PRODUCTS.FAMILYID

PRODLICTS FAMILYDESC
PRODLICTS.PRODID

PRODLICTS. PRODDESC

TIME SEASON Herelln

TIME.MONTH _I

[ SALESINVACT

SALESINVALCT SALES
SALESINVACT MARKETING
TIME.PRINTMEDIA

[imwve Davmn

Bl B ELE

< Back | Mest » | Finizh I Cancel | Help |

Figure 190. Selecting Columns to Remove From the Drill-Through Report

2. Click
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to move the selected columns from the Selected Columns list box back to
the Available Columns list box.

To move a column from one list box to another, click

or

. To move all columns from one list box to another, click

or

3. To rearrange the display order of columns, select each PRODUCTS column
(one at a time) in the Selected Columns list box and click Move Up twice
to move each column up above the MARKETS columns.

The customized report will display the columns in the Selected Columns
list box in the order in which they appear. The PRODUCTS columns will
appear as the first (left-most) columns, then the MARKETS columns, and
so forth.

Select Columns and Display Order

Fiepart Mame

IPromotion Media Mix for Cities

Available Columns Selected Columnz
+- MARKETS PRODUCTS.FAMILYID
- PRODUCTS FRODUCTS.FAMILYDESC
--TIME FRODUCTS PRODID

.PRODDESC
- SALESINVALCT B

MARKETS.CITY
TIME.SEASOM
TIME.MONTH
SALESINVALCT SALES

SALESINVACT MARKETING Maove Qownl

ElE]E=]

< Back | Mest » | Finizh | Cancel Help

Figure 191. Rearranging the Display Order of Columns
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4. Click Next to display the Select Data Sort Order dialog box, and follow
the steps in the following section, 'Ordering Data’l to further customize
the report.

Note: When you finish customizing the report, click Finish at any time to
generate the report and view the results in a new sheet. The new sheet
is placed before the current sheet.

Ordering Data

In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the data in a column. Sort order determines the
order in which rows will be displayed in the Drill-Through report. For
example, you can sort the contents of a MARKETS.CITY column in ascending
order, which presents the cities in alphabetical order in the Drill-Through
report.

To define the sort order of rows in the Drill-Through report:

1. In the Available Columns list box, select the SALESINVACT.MARKETING
column.

The columns in the Available Columns list box are those that you selected
in U'Selecting and Ordering Columns” on page 177, The columns in the
Column list box are those for which a sort order has already been defined

in OLAP Builder.

If a data sort order was selected when the report was created in OLAP
Desktop Model interface, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.

2. Click

to move the SALESINVACT.MARKETING column to the Column list box
so that you can define a sort order for the column.

To move a column from one list box to another, click

or

. To move all columns from one list box to another, click

or
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Select Data Sort Order

Fepart Mame

IPromotion Media Mix for Cities

Available Columng I Colurnn | Order By
PRODUCTS.FAMILYID MARKETS.STATE Agcending
PRODUCTS.PRODID SALESINVACT.SALES  Descending
TIME.SEASON PRODUCTS. FAMILYD...  Ascending
TIME.MONTH MARKETS.CITY Agcending

PRODUCTS.PRODDESC Ascending
SALESINVACT MARKE .. Ascending

ETEIT ]

1 | B

Move Up

Move Down

FLEE

Order By...

< Back | Mest » | Finizh | Cancel |

Help

Figure 192. Moving a Column to the Column List Box for Sorting

3. Rearrange the display order of columns in the Column list box so that the
columns are grouped as follows:

a. Click MARKETS.CITY and click Move Up twice.
b. Click SALESINVACT.MARKETING and click Move Up twice.

4. In the Column list box, double-click the SALESINVACT.SALES column to
change the data sort order from Descending to Ascending so that SALES

values are displayed in chronological order in the Drill-Through report.

The Integration Server now sorts the columns it retrieves first by state (in
alphabetical order), then by city (in alphabetical order), then by sales (in

chronological order).
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Select Data Sort Order

Fepart Mame

IPromotion Media Mix for Cities

Available Columng I Colurnn | Order By

FRODUCTS. FaMILYID M&RKETS.STATE Ascending
PRODUCTS.PRODID MARKETS.CITY Agcending
TIME.SEASDOM SALES ] Azcending

SALESINVACT MARKE... Ascending
FRODUCTS.FAMILYD...  Ascending
PRODUCTS PRODDESE Ascending

TIME.MONTH

Move Up

> Mave Down

<4 Order By...

£
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< Back | Mest » | Finizh I Cancel | Help

Figure 193. Selecting the Data Sort Order

5. Click Next to display the Select Data Filters dialog box, and follow the
steps in the following section, I'Filtering Data” to further customize the

report.

To change the data sort order for multiple columns at one time:

a. Hold down the Ctrl key and select the desired columns from the Column list box.
b. Click Order By. The Integration Server displays the Order By dialog box.
T |

ok I
Cancel |
Help |

C. Select Ascending or Descending and click OK to return to the Selecting Data Sort Order dialog
box.

Filtering Data

You can apply filters to determine what the Integration Server retrieves for the
Drill-Through report. For any given column, you may want to retrieve only
data that meets certain conditions. For example, the MARKETS.CITY column
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in the sample database contains many cities. In the sample Drill-Through
report, if you did not apply a filter to this list of cities, the Integration Server
would retrieve all cities in the East from the relational source, because the
sample Drill-Through report applies to the entire Eastern region. In this
section, you will apply a filter to the MARKETS.CITY column so that only

specific Eastern cities are included in the report.
To define a filter:
1. Select the MARKETS.CITY column from the Column list box.
The columns in the Column list box are those that you selected in

7

1

Select Data Filters

| Condition -

RKETS.STATE

Add

S CITY

PRODUICT S FAMILYID ﬂl
PRODUCTS.FAMILYDESC

PRODUCTS.PRODID |
PRODUCTS.PRODDESC

TIME.SEASON
TIME.MONTH
SALESINVACT SALES
SALESINVACT MARKETING

Clear Al

TIME.PRINTMEDIA

TIME. TV =

JTT | _>l_I
Condition

C

[

< Back | dEwt | Finizh I Cancel | Help

Figure 194. Select Data Filters Dialog Box

Note: If there is a filter already attached to the column, it is displayed in
the Condition list box. The full string of the filter is displayed in
the lower Condition text box.

2. With the MARKETS.CITY column selected, click Add.
The Integration Server displays the Set Filter on Column dialog box.
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Set Filter On Column : CITY

Filters |
Calumn:
r
fdd | Add Type
 And
(Ol

Filters:

Operator: Condition:

3 =

i

QK I Cancel | Help |

Figure 195. Set Filter on Column Dialog Box

3. Select the CITY column from the Column drop-down list box.

The column displayed in the Column drop-down list box is the one that

you selected in [Filtering Data” an page 182

Select the in operator from the Operator drop-down list box.

Note: For more information on filter operators, see the Integration Server
Drill-Through online help.

Click the Browse

-]

button to open the Select Filter Values from the List dialog box, which
lists all possible values for that column.

The Integration Server displays the Select Filter Values from the List
dialog box.

Note: The Integration Server retrieves these values directly from the
relational data source. If the relational data source contains many
values, the Integration Server confirms if you want to view them
all before it retrieves them from the data source.

Hold down the Ctrl key, select Andover, Boston, and Cape Cod, and click
OK.

You can select multiple values at one time only if you have selected In or
Not In as the filter operator.
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Select Filter Values from the List

Walue -
Acton

Akron LCancel
Albuguergue
Amarilla
Anchorage

did

Help

Andover

Appleton
Aszpen
Atlanta
Bakersfield
Bangor
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Big Sky
Buoise

Brunswick
Buffala
Burlington

Carzon City
Charlotte

Chirann hd
4 i

Figure 196. Selecting Filter Values from the List

7. Select And from the Add Type option group.
8. Click Add to add the condition to the Filters list box.

Note: For information on using multiple filter conditions, see the
Integration Server Drill-Through online help.

The Set Filter on Column dialog box should now look like this:

Set Filter On Column : CITY [ %]

Filters |
Colurnm: Operatar: Condition:
[ary = = [

Add Add Type

= & And

 0r

Filters:
MARKETS.CITY in [Andover,'Boston','Cape Cod'] ;I

-
A ¥

QK | Cancel | Help |

Figure 197. Defining a Filter for a Column

The filter defined above causes only Andover, Boston, and Cape Cod
data to show in the Drill-Through report.
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Select Data Filters

9. Click OK to return to the Select Data Filters dialog box.

Column

| Condition -

MARKETS.STATE
MARKETS.CITY
PRODUCTS FAMILYID
PRODUCTS FAMILYDESC
PRODUCTS.PRODID

MARKETS.CITY in [Andover','Boston',

Llear |
Clear All |

PRODUCTS. PRODDESC

TIME.SEASOM

TIME.MONTH

SALESINVALCT SALES

SALESINVACT MARKETING -
TIME.PRINTHEDIA

TIME. TV =
4 | _’I_I
Condition
MARKETS.CITY in [Andover', Boston','Cape Cod'] ;I
< Back | dEwt | Finizh | Cancel | Help

Figure 198. Result of Defining a Filter for a Column

Note: You can also create a filter by typing the filter conditions directly
into the Filters list box. For more information, see the Integration
Server Drill-Through online help. To delete a filter, select the filter
and click Clear. To delete all filters, click Clear All.

10. Click Finish.

The Integration Server generates the customized Drill-Through report and
displays the results in a new spreadsheet. The new sheet is added to the
workbook before the current sheet.

A | B [c 7 i} [ E T F [ 5o T H T 1 ] 1
1 [FAMILYIDIFAMILYDESC PRODID PRODDESC STATE CITY SEASON MOMNTH SALES MARKETING
| 2 |100 Colas 100-10 Kool Cala Massachusetts Andover ‘inter  Feb 70 15
| 3 |100 Colas 100-30  Caffeine Free Cola Massachusetts Boston  MWinter  Feb 143 ]
| 4 |100 Colas 100-10 Kool Cala Massachusetts Boston  Winter  Feb 248 60
| 5 |100 Colas 100-20  Diet Caola Massachusetts Boston  Winter  Feb 280 [<'a]
| B (100 Colas 100-10 Kool Cala Massachusetts Cape Cod Winter  Feb 97 23
7

Figure 199. Customized Drill-Through Report

In this sample, the customized Drill-Through report reflects the specifications
that you set using the Drill-Through Wizard:

e The TIME.PRINTMEDIA, TIME.TV, TIME.RADIO, and TIME.DIRECT
columns are excluded.

* The columns are displayed across the sheet in the order that you specified
in the Selected Columns list box in the Select Columns and Display Order
dialog box.
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» The STATE, CITY, SALES, MARKETING, FAMILYDESC, and PRODDESC
columns are sorted in ascending order, starting with the STATE column and
proceeding to the PRODDESC column. For example, the Integration Server
first sorts the STATE column in ascending order. Because there is only one
state represented in this column (Massachusetts), the Integration Server
moves on to the CITY column and sorts its contents in ascending
(alphabetical) order. Within the SALES column, the values are sorted in
ascending (chronological) order within each city. This process continues
until all specified columns are sorted first by CITY and then in ascending
order within CITY.

* The only cities retrieved from the relational source are Andover, Boston,
and Cape Cod, as you specified in the filtering part of the Drill-Through
Wizard.

Disconnecting from Hyperion Essbase

When you finish using Drill-Through, disconnect from the Hyperion Essbase
server to free up a port on the server for other Hyperion Essbase Spreadsheet
Add-in users.

To disconnect from the server:
1. Choose Essbase > Disconnect.

Hyperion Essbase displays the Essbase Disconnect dialog box, where you
can disconnect any sheet that is connected to a database.

Essbase Disconnect E

Cloze |

Help |

Sheet ServerApplication-> D atabaze

Il — i

Figure 200. Essbase Disconnect Dialog Box

Note: Hyperion Essbase may return an error message when you attempt
to disconnect after using Drill-Through. If an error message is
returned, choose Essbase > Retrieve from the sheet and then
disconnect.

2. Select a sheet name from the list and click Disconnect.

3. Repeat Step 2 until you have disconnected from all active sheets.
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4. Click Close to close the Essbase Disconnect dialog box.
Note: You can also disconnect from the server by closing Excel. An

abnormal termination of an Excel session, such as a power loss or
system failure, does not disconnect your server connection.
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Appendix. Using the DB2 Library

The DB2 Universal Database library consists of online help, books (PDF and
HTML), and sample programs in HTML format. This section describes the
information that is provided, and how you can access it.

To access product 1r1format10r1 onhne, you can use the Informatlon Center. For
more information, see d

. You can view task information, DB2 books, troubleshooting
information, sample programs, and DB2 information on the Web.

DB2 PDF Files and Printed Books

DB2 Information
The following table divides the DB2 books into four categories:

DB2 Guide and Reference Information
These books contain the common DB2 information for all platforms.

DB2 Installation and Configuration Information
These books are for DB2 on a specific platform. For example, there are
separate Quick Beginnings books for DB2 on OS/2, Windows, and
UNIX-based platforms.

Cross-platform sample programs in HTML
These samples are the HTML version of the sample programs that are
installed with the Application Development Client. The samples are
for informational purposes and do not replace the actual programs.

Release notes
These files contain late-breaking information that could not be
included in the DB2 books.

The installation manuals, release notes, and tutorials are viewable in HTML
directly from the product CD-ROM. Most books are available in HTML on the
product CD-ROM for viewing and in Adobe Acrobat (PDF) format on the DB2
publications CD-ROM for viewing and printing. You can also order a printed

copy from IBM; see !Ordering the Printed Books” on page 199. The following

table lists books that can be ordered.

On OS/2 and Windows platforms, you can install the HTML files under the
sq1Tib\doc\html directory. DB2 information is translated into different
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languages; however, all the information is not translated into every language.
Whenever information is not available in a specific language, the English
information is provided

On UNIX platforms, you can install multiple language versions of the HTML
files under the doc/%L/htm1 directories, where %L represents the locale. For

more information, refer to the appropriate Quick Beginnings book.

You can obtain DB2 books and access information in a variety of ways:

Table 3. DB2 Information

Name Description Form Number = HTML

Directory
PDF File Name

DB2 Guide and Reference Information

Administration Guide Administration Guide: Planning provides ~ SC09-2946 db2d0
an overview of database concepts, db2d1x70
information about design issues (such as
logical and physical database design),
and a discussion of high availability.

Administration Guide: Implementation SC09-2944
provides information on implementation Jp2d2x70
issues such as implementing your

design, accessing databases, auditing,

backup and recovery.

gy ) , S5C09-2945
Administration Guide: Performance db2d3x70

provides information on database
environment and application
performance evaluation and tuning.

You can order the three volumes of the
Administration Guide in the English
language in North America using the
form number SBOF-8934.

Administrative API Describes the DB2 application SC09-2947 db2b0
Reference programming interfaces (APIs) and data

structures that you can use to manage db2b0x70

your databases. This book also explains

how to call APIs from your applications.
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Table 3. DB2 Information (continued)

Name Description Form Number = HTML
Directory
PDF File Name
Application Building Provides environment setup information SC09-2948 db2ax
Guide and step-by-step instructions about how
db2axx70

to compile, link, and run DB2
applications on Windows, OS/2, and
UNIX-based platforms.

APPC, CPI-C, and SNA
Sense Codes

Provides general information about
APPC, CPI-C, and SNA sense codes that
you may encounter when using DB2
Universal Database products.

Available in HTML format only.

No form number db2ap

db2apx70

Application Development
Guide

Explains how to develop applications
that access DB2 databases using
embedded SQL or Java (JDBC and
SQLYJ). Discussion topics include writing
stored procedures, writing user-defined
functions, creating user-defined types,
using triggers, and developing
applications in partitioned environments
or with federated systems.

S5C09-2949 db2a0

db2a0x70

CLI Guide and Reference

Explains how to develop applications
that access DB2 databases using the DB2
Call Level Interface, a callable SQL
interface that is compatible with the
Microsoft ODBC specification.

5C09-2950 db210

db210x70

Command Reference

Explains how to use the Command Line
Processor and describes the DB2
commands that you can use to manage
your database.

5C09-2951 db2n0

db2n0x70

Connectivity Supplement

Provides setup and reference information
on how to use DB2 for AS/400, DB2 for
0S/390, DB2 for MVS, or DB2 for VM as
DRDA application requesters with DB2
Universal Database servers. This book
also details how to use DRDA
application servers with DB2 Connect
application requesters.

Available in HTML and PDF only.

No form number db2hl1

db2h1x70
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Table 3. DB2 Information (continued)

Name Description Form Number = HTML
Directory
PDF File Name
Data Movement Ultilities Explains how to use DB2 utilities, such ~ SC09-2955 db2dm
Guide and Reference as import, export, load, AutoLoader, and
DPROP, that facilitate the movement of ~ db2dmx70
data.
Data Warehouse Center Provides information on how to build SC26-9993 db2dd
Administration Guide and maintain a data warehouse using
the Data Warehouse Center. db2ddx70
Data Warehouse Center Provides information to help S5C26-9994 db2ad
Application Integration programmers integrate applications with
Guide the Data Warehouse Center and with the db2adx70
Information Catalog Manager.
DB2 Connect User’s Guide Provides concepts, programming, and SC09-2954 db2c0
general usage information for the DB2
Connect products. db2c0x70
DB2 Query Patroller Provides an operational overview of the SC09-2958 db2dw
Administration Guide DB2 Query Patroller system, specific
operational and administrative db2dwx70
information, and task information for the
administrative graphical user interface
utilities.
DB2 Query Patroller Describes how to use the tools and SC09-2960 db2ww
User’s Guide functions of the DB2 Query Patroller.
db2wwx70
Glossary Provides definitions for terms used in No form number db2t0
DB2 and its components.
db2t0x70
Available in HTML format and in the
SQL Reference.
Image, Audio, and Video Provides general information about DB2  SC26-9929 dmbu?
Extenders Administration  extenders, and information on the
and Programming administration and configuration of the dmbu?7x70
image, audio, and video (IAV) extenders
and on programming using the IAV
extenders. It includes reference
information, diagnostic information
(with messages), and samples.
Information Catalog Provides guidance on managing 5C26-9995 db2di
Manager Administration — information catalogs.
Guide db2dix70
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Table 3. DB2 Information (continued)

Name Description Form Number = HTML
Directory
PDF File Name

Information Catalog Provides definitions for the architected =~ SC26-9997 db2bi
Manager Programming interfaces for the Information Catalog )
Guide and Reference Manager. db2bix70
Information Catalog Provides information on using the 5C26-9996 db2ai
Manager User’s Guide Information Catalog Manager user )

interface. db2aix70
Installation and Guides you through the planning, GC09-2957 db2iy
Configuration Supplement installation, and setup of )

platform-specific DB2 clients. This db2iyx70

supplement also contains information on
binding, setting up client and server
communications, DB2 GUI tools, DRDA
AS, distributed installation, the
configuration of distributed requests,
and accessing heterogeneous data
sources.

Message Reference

Lists messages and codes issued by DB2, Volume 1 db2m0
the Information Catalog Manager, and GC09-2978

the Data Warehouse Center, and

describes the actions you should take. db2m1x70

Volume 2

You can order both volumes of the GC09-2979

Message Reference in the English

language in North America with the db2m2x70

form number SBOF-8932.
OLAP Integration Server ~ Explains how to use the Administration SC27-0787 n/a
Administration Guide Manager component of the OLAP

Integration Server. db2dpx70
OLAP Integration Server ~ Explains how to create and populate 5C27-0784 n/a
Metaoutline User’s Guide  OLAP metaoutlines using the standard

OLAP Metaoutline interface (not by db2upx70

using the Metaoutline Assistant).
OLAP Integration Server ~ Explains how to create OLAP models 5C27-0783 n/a
Model User’s Guide using the standard OLAP Model

Interface (not by using the Model db2lpx70

Assistant).
OLAP Setup and User’s ~ Provides configuration and setup 5C27-0702 db2ip
Guide information for the OLAP Starter Kit.

db2ipx70

OLAP Spreadsheet Add-in  Describes how to use the Excel 5C27-0786 db2ep
User’s Guide for Excel spreadsheet program to analyze OLAP

data. db2epx70
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Table 3. DB2 Information (continued)

Name Description Form Number = HTML
Directory
PDF File Name
OLAP Spreadsheet Add-in  Describes how to use the Lotus 1-2-3 5C27-0785 db2tp
User’s Guide for Lotus spreadsheet program to analyze OLAP
1-2-3 data. db2tpx70
Replication Guide and Provides planning, configuration, 5C26-9920 db2e0
Reference administration, and usage information
for the IBM Replication tools supplied db2e0x70
with DB2.
Spatial Extender User’s Provides information about installing, SC27-0701 db2sb
Guide and Reference configuring, administering,
programming, and troubleshooting the ~ db2sbx70
Spatial Extender. Also provides
significant descriptions of spatial data
concepts and provides reference
information (messages and SQL) specific
to the Spatial Extender.
SQL Getting Started Introduces SQL concepts and provides ~ SC09-2973 db2y0
examples for many constructs and tasks.
db2y0x70
SQL Reference, Volume 1~ Describes SQL syntax, semantics, and the Volume 1 db2s0
and Volume 2 rules of the language. This book also SC09-2974
includes information about
release-to-release incompatibilities, db2s1x70
product limits, and catalog views.
Volume 2
You can order both volumes of the SQL. ~ SC09-2975
Reference in the English language in
North America with the form number db2s2x70
SBOEF-8933.
System Monitor Guide and Describes how to collect different kinds =~ SC09-2956 db2f0
Reference of information about databases and the
database manager. This book explains db2f0x70
how to use the information to
understand database activity, improve
performance, and determine the cause of
problems.
Text Extender Provides general information about DB2  SC26-9930 desu9
Administration and extenders and information on the
Programming administration and configuring of the desu9x70

text extender and on programming using
the text extenders. It includes reference
information, diagnostic information
(with messages) and samples.
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Table 3. DB2 Information (continued)

Name Description Form Number = HTML
Directory
PDF File Name
Troubleshooting Guide Helps you determine the source of GC09-2850 db2p0
errors, recover from problems, and use
diagnostic tools in consultation with DB2 db2p0x70
Customer Service.
What's New Describes the new features, functions, 5C09-2976 db2q0
and enhancements in DB2 Universal
Database, Version 7. db2q0x70
DB2 Installation and Configuration Information
DB2 Connect Enterprise ~ Provides planning, migration, GC09-2953 db2c6
Edition for OS/2 and installation, and configuration
Windows Quick information for DB2 Connect Enterprise = db2c6x70
Beginnings Edition on the OS/2 and Windows 32-bit
operating systems. This book also
contains installation and setup
information for many supported clients.
DB2 Connect Enterprise ~ Provides planning, migration, GC09-2952 db2cy
Edition for UNIX Quick installation, configuration, and task
Beginnings information for DB2 Connect Enterprise ~ db2cyx70
Edition on UNIX-based platforms. This
book also contains installation and setup
information for many supported clients.
DB2 Connect Personal Provides planning, migration, GC09-2967 db2cl
Edition Quick Beginnings  installation, configuration, and task
information for DB2 Connect Personal db2c1x70
Edition on the OS/2 and Windows 32-bit
operating systems. This book also
contains installation and setup
information for all supported clients.
DB2 Connect Personal Provides planning, installation, GC09-2962 db2c4
Edition Quick Beginnings migration, and configuration information
for Linux for DB2 Connect Personal Edition on all ~db2c4x70
supported Linux distributions.
DB2 Data Links Manager  Provides planning, installation, GC09-2966 db2z6
Quick Beginnings configuration, and task information for
db2z6x70

DB2 Data Links Manager for AIX and
Windows 32-bit operating systems.
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Table 3. DB2 Information (continued)

Name

Description

Form Number

PDF File Name

HTML
Directory

DB2 Enterprise - Extended

Edition for UNIX Quick
Beginnings

Provides planning, installation, and
configuration information for DB2
Enterprise - Extended Edition on
UNIX-based platforms. This book also
contains installation and setup
information for many supported clients.

GC09-2964

db2v3x70

db2v3

DB2 Enterprise - Extended
Edition for Windows Quick

Beginnings

Provides planning, installation, and
configuration information for DB2
Enterprise - Extended Edition for
Windows 32-bit operating systems. This
book also contains installation and setup
information for many supported clients.

GC09-2963

db2v6x70

db2v6

DB?2 for OS/2 Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on the OS/2
operating system. This book also
contains installation and setup
information for many supported clients.

GC09-2968

db2i2x70

db2i2

DB2 for UNIX Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on
UNIX-based platforms. This book also
contains installation and setup
information for many supported clients.

GC09-2970

db2ixx70

db2ix

DB2 for Windows Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on Windows
32-bit operating systems. This book also
contains installation and setup
information for many supported clients.

GC09-2971

db2i6x70

db2i6

DB2 Personal Edition
Quick Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database Personal
Edition on the OS/2 and Windows 32-bit
operating systems.

GC09-2969

db2i1x70

db2il

DB2 Personal Edition
Quick Beginnings for
Linux

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database Personal
Edition on all supported Linux
distributions.

GC09-2972

db2i4x70

db2i4
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Table 3. DB2 Information (continued)

Name

Description

Form Number

PDF File Name

HTML
Directory

DB2 Query Patroller

Installation Guide

Provides installation information about

DB2 Query Patroller.

GC09-2959

db2iwx70

db2iw

DB2 Warehouse Manager

Installation Guide

Catalog Manager.

Provides installation information for
warehouse agents, warehouse
transformers, and the Information

GC26-9998

db2idx70

db2id

Cross-Platform Sample Programs in HTML

Sample programs in

HTML

Provides the sample programs in HTML
format for the programming languages
on all platforms supported by DB2. The
sample programs are provided for
informational purposes only. Not all

samples are available in all

programming languages. The HTML
samples are only available when the DB2
Application Development Client is

installed.

For more information on the programs,
refer to the Application Building Guide.

No form number

db2hs

Release Notes

DB2 Connect Release

Notes

Connect books.

Provides late-breaking information that
could not be included in the DB2

See note #2.

db2cr

DB2 Installation Notes

Provides late-breaking
installation-specific information that
could not be included in the DB2 books.

Available on
product
CD-ROM only.

DB2 Release Notes

Provides late-breaking information about See note #2.

all DB2 products and features that could
not be included in the DB2 books.

db2ir

Notes:

1. The character x in the sixth position of the file name indicates the
language version of a book. For example, the file name db2d0e70 identifies
the English version of the Administration Guide and the file name db2d0f70
identifies the French version of the same book. The following letters are
used in the sixth position of the file name to indicate the language version:

Language
Brazilian Portuguese

Identifier

b
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Bulgarian
Czech
Danish
Dutch
English
Finnish
French
German
Greek
Hungarian
Italian
Japanese
Korean
Norwegian
Polish
Portuguese
Russian
Simp. Chinese
Slovenian
Spanish
Swedish
Trad. Chinese
Turkish

B""VJN’_'GH<“US7\‘“_“"“:F'WOQ"“‘<(D»QQ-><C

2. Late breaking information that could not be included in the DB2 books is
available in the Release Notes in HTML format and as an ASCII file. The
HTML version is available from the Information Center and on the
product CD-ROMs. To view the ASCII file:

* On UNIX-based platforms, see the Release.Notes file. This file is located
in the DB2DIR/Readme/%L directory, where %L represents the locale name
and DB2DIR represents:

— /Jusr/1pp/db2_07_01 on AIX
— /opt/IBMdb2/V7.1 on HP-UX, PTX, Solaris, and Silicon Graphics IRIX
— /usr/IBMdb2/V7.1 on Linux.

* On other platforms, see the RELEASE.TXT file. This file is located in the
directory where the product is installed. On OS/2 platforms, you can
also double-click the IBM DB2 folder and then double-click the Release
Notes icon.

Printing the PDF Books
If you prefer to have printed copies of the books, you can print the PDF files
found on the DB2 publications CD-ROM. Using the Adobe Acrobat Reader,
you can print either the entire book or a specific range of pages. For the file
name of each book in the library, see
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You can obtain the latest version of the Adobe Acrobat Reader from the
Adobe Web site at http:/ /www.adobe.com.

The PDF files are included on the DB2 publications CD-ROM with a file
extension of PDF. To access the PDF files:

1. Insert the DB2 publications CD-ROM. On UNIX-based platforms, mount
the DB2 publications CD-ROM. Refer to your Quick Beginnings book for
the mounting procedures.

2. Start the Acrobat Reader.

3. Open the desired PDF file from one of the following locations:

* On OS/2 and Windows platforms:

x:\doc\language directory, where x represents the CD-ROM drive and
language represent the two-character country code that represents your
language (for example, EN for English).

* On UNIX-based platforms:

/cdrom/doc/%L directory on the CD-ROM, where /cdrom represents the
mount point of the CD-ROM and %L represents the name of the desired
locale.

You can also copy the PDF files from the CD-ROM to a local or network drive
and read them from there.

Ordering the Printed Books

You can order the printed DB2 books either individually or as a set (in North
America only) by using a sold bill of forms (SBOF) number. To order books,
contact your IBM authorized dealer or marketing representative, or phone
1-800-879-2755 in the United States or 1-800-1BM-4Y0U in Canada. You can
also order the books from the Publications Web page at

http:/ /www.elink.ibmlink.ibm.com/pbl/pbl.

Two sets of books are available. SBOF-8935 provides reference and usage
information for the DB2 Warehouse Manager. SBOF-8931 provides reference
and usage information for all other DB2 Universal Database products and
features. The contents of each SBOF are listed in the following table:

Appendix. Using the DB2 Library 199



Table 4. Ordering the printed books

SBOF Number

Books Included

Information Catalog Manager
Administration Guide

Information Catalog Manager User’s
Guide

Information Catalog Manager
Programming Guide and Reference

SBOF-8931 ¢ Administration Guide: Planning * OLAP Integration Server
* Administration Guide: Implementation Administration Guide
e Administration Guide: Performance ° OLA,P Inte.z(giration Server Metaoutline
* Administrative API Reference gii; IGul ¢ on'S Model User
* Application Building Guide Guide ntegration Server Model User's
) Apphca.tlon Development Guide ¢ OLAP Integration Server User’s Guide
* CLI Guide and Reference * OLAP Setup and User’s Guide
» Command Reference * OLAP Spreadsheet Add-in User’s
* Data Movement Utilities Guide and Guide for Excel
Reference * OLAP Spreadsheet Add-in User’s
* Data Warehouse Center Administration Guide for Lotus 1-2-3
Guide o * Replication Guide and Reference
* Data We}rehous.e Center Application * Spatial Extender Administration and
Integration Guide Programming Guide
 DB2 Cor.mect User’s C’;mde. - SQL Getting Started
¢ Installation and Configuration - SQL Reference, Volumes 1 and 2
Supplement S Monitor Guide and Ref.
¢ Image, Audio, and Video Extenders ystem Monitor u.1 .e an. elerence
Administration and Programming . gext Extenfier Administration and
* Message Reference, Volumes 1 and 2 rogramming
* Troubleshooting Guide
* What’s New
SBOF-8935 . .

Query Patroller Administration Guide

Query Patroller User’s Guide

DB2 Online Documentation

Accessing Online Help

Online help is available with all DB2 components. The following table
describes the various types of help.

200 OLAP Spreadsheet Add-in User’s Guide for Excel




Type of Help

Contents

How to Access...

Command Help

Explains the syntax of
commands in the command
line processor.

From the command line processor in interactive
mode, enter:

? command

where command represents a keyword or the entire
command.

For example, ? catalog displays help for all the
CATALOG commands, while ? catalog database
displays help for the CATALOG DATABASE
command.

Client Configuration
Assistant Help

Command Center Help
Control Center Help

Data Warehouse Center
Help

Event Analyzer Help

Information Catalog
Manager Help

Satellite Administration
Center Help

Script Center Help

Explains the tasks you can
perform in a window or
notebook. The help includes
overview and prerequisite
information you need to
know, and it describes how
to use the window or
notebook controls.

From a window or notebook, click the Help push
button or press the F1 key.

Message Help

Describes the cause of a
message and any action you
should take.

From the command line processor in interactive
mode, enter:

? XXXnnnnn

where XXXnnnnn represents a valid message
identifier.

For example, ? SQL30081 displays help about the
SQL30081 message.

To view message help one screen at a time, enter:

? XXXnnnnn | more

To save message help in a file, enter:

? XXXnnnnn > filename.ext

where filename.ext represents the file where you
want to save the message help.
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Type of Help Contents How to Access...

SQL Help Explains the syntax of SQL ~ From the command line processor in interactive
statements. mode, enter:

help statement
where statement represents an SQL statement.

For example, help SELECT displays help about the
SELECT statement.
Note: SQL help is not available on UNIX-based

platforms.
SQLSTATE Help Explains SQL states and From the command line processor in interactive
class codes. mode, enter:

? sqlstate or ? class code

where sglstate represents a valid five-digit SQL
state and class code represents the first two digits
of the SQL state.

For example, ? 08003 displays help for the 08003
SQL state, while ? 08 displays help for the 08 class
code.

Viewing Information Online

The books included with this product are in Hypertext Markup Language
(HTML) softcopy format. Softcopy format enables you to search or browse the
information and provides hypertext links to related information. It also makes
it easier to share the library across your site.

You can view the online books or sample programs with any browser that
conforms to HTML Version 3.2 specifications.

To view online books or sample programs:
* If you are running DB2 administration tools, use the Information Center.

* From a browser, click File —>Open Page. The page you open contains
descriptions of and links to DB2 information:

— On UNIX-based platforms, open the following page:
INSTHOME/sq11ib/doc/%L/htm1/index.htm

where %L represents the locale name.
— On other platforms, open the following page:
sq11ib\doc\html\index.htm

The path is located on the drive where DB2 is installed.
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If you have not installed the Information Center, you can open the page
by double-clicking the DB2 Information icon. Depending on the system
you are using, the icon is in the main product folder or the Windows
Start menu.

Installing the Netscape Browser
If you do not already have a Web browser installed, you can install Netscape

from the Netscape CD-ROM found in the product boxes. For detailed
instructions on how to install it, perform the following:

1. Insert the Netscape CD-ROM.

2. On UNIX-based platforms only, mount the CD-ROM. Refer to your Quick
Beginnings book for the mounting procedures.

3. For installation instructions, refer to the CDNAVnn.txt file, where nn
represents your two character language identifier. The file is located at the
root directory of the CD-ROM.

Accessing Information with the Information Center
The Information Center provides quick access to DB2 product information.

The Information Center is available on all platforms on which the DB2
administration tools are available.

You can open the Information Center by double-clicking the Information
Center icon. Depending on the system you are using, the icon is in the
Information folder in the main product folder or the Windows Start menu.

You can also access the Information Center by using the toolbar and the Help
menu on the DB2 Windows platform.

The Information Center provides six types of information. Click the
appropriate tab to look at the topics provided for that type.

Tasks Key tasks you can perform using DB2.

Reference DB2 reference information, such as keywords, commands, and
APIs.

Books DB2 books.

Troubleshooting

Categories of error messages and their recovery actions.

Sample Programs
Sample programs that come with the DB2 Application
Development Client. If you did not install the DB2
Application Development Client, this tab is not displayed.

Web DB2 information on the World Wide Web. To access this
information, you must have a connection to the Web from
your system.
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When you select an item in one of the lists, the Information Center launches a
viewer to display the information. The viewer might be the system help
viewer, an editor, or a Web browser, depending on the kind of information
you select.

The Information Center provides a find feature, so you can look for a specific
topic without browsing the lists.

For a full text search, follow the hypertext link in the Information Center to
the Search DB2 Online Information search form.

The HTML search server is usually started automatically. If a search in the
HTML information does not work, you may have to start the search server
using one of the following methods:

On Windows
Click Start and select Programs —> IBM DB2 —> Information —>
Start HTML Search Server.

On 0S/2
Double-click the DB2 for OS/2 folder, and then double-click the Start
HTML Search Server icon.

Refer to the release notes if you experience any other problems when
searching the HTML information.

Note: The Search function is not available in the Linux, PTX, and Silicon
Graphics IRIX environments.

Using DB2 Wizards

Wizards help you complete specific administration tasks by taking you
through each task one step at a time. Wizards are available through the
Control Center and the Client Configuration Assistant. The following table
lists the wizards and describes their purpose.

Note: The Create Database, Create Index, Configure Multisite Update, and
Performance Configuration wizards are available for the partitioned
database environment.

Wizard Helps You to... How to Access...
Add Database Catalog a database on a client workstation. From the Client Configuration
Assistant, click Add.
Back up Database Determine, create, and schedule a backup From the Control Center, right-click
plan. the database you want to back up

and select Backup —> Database
Using Wizard.
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Wizard

Helps You to...

How to Access...

Configure Multisite
Update

Configure a multisite update, a distributed
transaction, or a two-phase commit.

From the Control Center, right-click
the Databases folder and select
Multisite Update.

Create Database

Create a database, and perform some basic
configuration tasks.

From the Control Center, right-click
the Databases folder and select
Create —> Database Using
Wizard.

Create Table

Select basic data types, and create a primary
key for the table.

From the Control Center, right-click
the Tables icon and select Create
—> Table Using Wizard.

Create Table Space

Create a new table space.

From the Control Center, right-click
the Table Spaces icon and select
Create —> Table Space Using
Wizard.

Create Index

Advise which indexes to create and drop for
all your queries.

From the Control Center, right-click
the Index icon and select Create
—> Index Using Wizard.

Performance
Configuration

Tune the performance of a database by
updating configuration parameters to match
your business requirements.

From the Control Center, right-click
the database you want to tune and
select Configure Performance
Using Wizard.

For the partitioned database
environment, from the Database
Partitions view, right-click the first
database partition you want to
tune and select Configure
Performance Using Wizard.

Restore Database

Recover a database after a failure. It helps
you understand which backup to use, and
which logs to replay.

From the Control Center, right-click
the database you want to restore
and select Restore —> Database
Using Wizard.

Setting Up a Document Server

By default, the DB2 information is installed on your local system. This means
that each person who needs access to the DB2 information must install the
same files. To have the DB2 information stored in a single location, perform
the following steps:

1. Copy all files and subdirectories from \sql11ib\doc\html on your local
system to a Web server. Each book has its own subdirectory that contains
all the necessary HTML and GIF files that make up the book. Ensure that

the directory structure remains the same.

Appendix. Using the DB2 Library

205



2. Configure the Web server to look for the files in the new location. For
information, refer to the NetQuestion Appendix in the Installation and
Configuration Supplement.

3. If you are using the Java version of the Information Center, you can
specify a base URL for all HTML files. You should use the URL for the list
of books.

4. When you are able to view the book files, you can bookmark commonly
viewed topics. You will probably want to bookmark the following pages:

* List of books

* Tables of contents of frequently used books

* Frequently referenced articles, such as the ALTER TABLE topic
* The Search form

For information about how you can serve the DB2 Universal Database online
documentation files from a central machine, refer to the NetQuestion
Appendix in the Installation and Configuration Supplement.

Searching Information Online
To find information in the HTML files, use one of the following methods:

* Click Search in the top frame. Use the search form to find a specific topic.
This function is not available in the Linux, PTX, or Silicon Graphics IRIX
environments.

* Click Index in the top frame. Use the index to find a specific topic in the
book.

* Display the table of contents or index of the help or the HTML book, and
then use the find function of the Web browser to find a specific topic in the
book.

* Use the bookmark function of the Web browser to quickly return to a
specific topic.

* Use the search function of the Information Center to find specific topics. See
- . - - . 7 for
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Index

Special Characters
? wildcard character 77

* wildcard character 77

#Missing strings, suppressing 46
#NoAccess strings, suppressing 46

A

access
to databases 25, 85
to Essbase data 25, 85
to linked partitions 145
to linked reporting objects 137
to multiple databases 144
to online help 17
using Essbase commands 23
with Hyperion Integration Server
Drill-Through 171
Acrobat Reader vi
ad hoc reports 1, 27, 105, 158
Add button 183
add database wizard 204, 205
Add-in Manager 12
adding members 75
adjusting columns 24, 103
administrators 2
Adobe Acrobat Reader vi
advanced interpretation engine 121
Advanced Interpretation mode 121,
128
aliases
definition of 56
displaying
process of 56
with member names 58
with Query Designer
results 74
in tables 56
alternate dimensions 5
alternate names 56
ancestors, definition of 8
AND operators 75
API 4
application designer 2
application partitions 145
application programming
interface 4
applications/databases
Sample Basic 11, 24, 26, 86

© Copyright IBM Corp. 1998, 2000

applications/databases (continued)
sample for Hyperion Integration
Server Drill-Through 170
Sample Interntl 156
Sample Xchgrate 156
ascending sort order
with Hyperion Integration Server
Drill-Through 180
with Query Designer
asymmetric reports
definition of 99
pivoting 100
retrieving data into 99
Attach Linked Object dialog
box 132,134, 136
attaching reporting objects to
cells 131
attaching to databases 25
attributes, drill down 31
auditing updates 149
auto logouts 84
Auto Sort Rows option 124

B

back up database wizard 204
blank

columns 101

rows 101
blocks, locking data 148
books 189, 199
Boolean operators 75, 78

C

Calculation command 150
Calculation dialog box 150
calculations
database status 150
databases 115, 150
dynamic 115
reducing calculation time 115
scripts 150
specifying latest time period 117
substitution variables 120
with Dynamic Time Series 117
with EssCell 114
canceling data retrievals 29
Cascade command 151
Cascade Information page 151
Cascade Options dialog box 151

97, 99

cascading sheets
creating table of contents 154
destination 152
format 154
level of detail 151
names 153
output type 152
cell notes
accessing linked 139
linking to cells 134
cell ranges
keeping 40
removing 42
retrieving 109
selecting nonadjacent 41
with Hyperion Integration Server
Drill-Through 174

cells
accessing linked partitions 145
applying styles 49, 54

attaching reports 131
attaching URLs 136
EssCell function in 112
formatting 49, 54, 133
in data cells 54
of dimension members 52
of Dynamic Calculation
members 116
of parent members 49
formulas in 101, 103, 106, 112
linked reporting objects 131, 136
linking files to 131
linking notes to 134
linking URLs to 136
retrieving a range 109
retrieving single values 112
selecting nonadjacent 41
with nondatabase values 101
Change Password dialog box 27
changing
passwords 27
row and column orientation 36
spreadsheet format 49
styles 49
children (defined) 8
Clear All button 186
Clear button 186
Clear command 29
clearing styles 55
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click (defined) 18
client
components 2
software 11
upgrading with server ix
client-server environment 2
collapsing data views 33
colors, setting 49
columns
adjusting width 24, 103
blank 101
displaying as rows 36
displaying selected 40
filtering by 93
keeping selected 40
nested 30
pivoting 36
removing selected 42
retrieving into 31
columns, Hyperion Integration
Server Drill-Through
choosing 178

selecting display order 178, 179

selecting for retrieval from
relational source 178

sorting 180

sorting multiple columns 182
commands

Calculation 150

Cascade 151

Clear 29

Connect 25, 85, 145

Currency Report 156, 159

Disconnect 83

FlashBack 29

Keep Only 40

Linked Objects 131, 136

Lock 148

Member Selection 76

Navigate Without Data 43, 45

new in release 6 ix

Pivot 36

Remove Only 42

Retrieve 28

Retrieve & Lock 148

Send 148

Undo 29

Unlock 148

Zoom In 30

Zoom Out 33
comparison operators 75, 93
computing environment v
concurrent

database access 26, 144

updates to server 148

conditional retrievals 92
configure multisite update
wizard 204
Connect button 15
Connect command 25, 85, 145
connecting 25
to a database 25, 85

to a relational data source 161,

171, 175

to Essbase 26, 86

to Hyperion Integration
Server 171,175

to multiple databases 144

viewing current connections 145

Connection Information text
box 145, 150
consolidations (defined) 9
conversions, currency 155
create database wizard 205
create table space wizard 205
create table wizard 205
creating queries 62
creating reports 27
Currency Conversion product 4
currency conversions
modifying exchange rates 159
reporting 158
sample databases 156
settings 159
Currency Report command 156,
159
Currency Report dialog box 159
current time period 117
cursors (Essbase) 28
custom applications 4
Customize button 176
customizing Hyperion Integration

Server Drill-Through reports 163,

176

D

data
calculating 150
changing orientation 36
comparison operators 93
displaying 5, 28
dynamically calculating 115
filtering 92
filtering, with Hyperion
Integration Server
Drill-Through 186
formatting 49
locking 148
missing 46
modifying 147
navigating 9, 43
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pivoting 36

relational, with Hyperion
Integration Server
Drill-Through 161
removing subsets 42
retaining subsets 40
retrieving 24

sorting 92

unlocking 148
updating 147, 149

data sort order, with Hyperion
Integration Server
Drill-Through 180

data source, relational 175

databases

calculating 150
connecting 144
consolidations 9
defined 5

dimensions 8
disconnecting from 83
linked 145

loading 27, 87

locking 148

members 8
organization 7

outlines 9

queries 60

restoring previous views 29
rules 7

sample 24, 156, 170
selecting 86

switching 145

viewing connections 145

DB2 library

books 189
Information Center 203
language identifier for

books 197
late-breaking information 198
online help 200
ordering printed books 199
printing PDF books 198
searching online

information 206
setting up document server 205
structure of 189
viewing online information 202
wizards 204

deleting

filters, Hyperion Integration

Server Drill-Through 186
selected members 42
styles 55



descendants (defined) 8
descending sort order
with Hyperion Integration Server
Drill-Through 180
with Query Designer 97, 99
Destination Options page 152
destinations
cascaded sheets 152
Query Designer queries 69
detaching 83
dialog boxes, Help buttons 17
dimensions
alternate 5
applying styles 52
currency conversion and 156
described 5, 8
drilling down on 30, 31
drilling up on 33
naming elements 8
pivoting 36
disabling data retrieval 43
Disconnect
command 83
dialog box 83
disconnecting
forced logouts 84
from Essbase 83
from Hyperion Integration
Server 187
discontinuous rows and
columns 41
disk space, effect on Dynamic
Calculation 115
display
options 49
order of columns, Hyperion
Integration Server
Drill-Through 178
Display page (Essbase Options
dialog box) 20, 165
Display Unknown Member
option 103, 105
displaying data 5, 28
distributed sheets 151
double-clicking
defined 18
enabling
for drilling 18
for linked object
browsing 137, 146, 174
downloading Acrobat Reader vi
drag, defined 18
drag-and-drop operations 37
drill
by double-clicking 18

drill (continued)
down on attributes 31, 32
down on consolidations 9
Formula Fill 106
retain formulas during 106
to less detail 33
Drill-Through, Hyperion Integration
Server
accessing 162, 171
cells, defining styles for 171
described 161
Drill-Through Wizard 163
installing 164
multiple reports 162
requirements 164
sample
database 170
Drill-Through report 170

file 172
styles for cells 163
tasks 171
tutorial guidelines 165
using 171

Drill-Through Wizard
described 163
dialog box 176
introductory screen 176
duplicating sheets 151
Dynamic Calculation members,
applying styles to 116
Dynamic Time Series
defined 117
specifying latest time
period 118, 120

E

Edit Cell Note dialog box 140
Edit menu 29
Edit URL dialog box 142
editing

cell notes 139

linked files 139

URLs 141, 142
editing in cells 18
enabling

Essbase toolbar 14

FlashBack setting 30

mouse actions 18, 137, 146

Navigate Without Data 43
environment (computing) v
Essbase

API 4

architecture 2

Cascade Options dialog box 151

computing environment v

Essbase (continued)
connecting to 25
Disconnect dialog box 83
disconnecting from. See
disconnecting 83
Member Selection dialog
box 76, 81
Member Selection dialog box,
from Query Designer 64
menu 13
new features ix
Options dialog box 20, 87, 165
starting a session 13
System Login dialog box 25, 85
toolbar
described 15
installing 14
upgrades  ix
EssCell function 112
error messages 115
syntax 113
Excel
Add-in Manager, installing
Essbase menu 12
clearing formats 29, 56
manually adding Spreadsheet
Add-in 12
mouse actions 18
sample tutorial files 85
status bar 14
Excel Spreadsheet Add-in 12
exchange rates 156
Execute button 176
executing Hyperion Integration
Server Drill-Through reports 175,
176
expanding data views 30
expanding formulas when
drilling 107
external files 130

F

features, Spreadsheet Add-in ix
files
accessing linked 138
destinations
cascaded sheets 152
Query Designer queries 70
linking to data cells 131
sample for tutorial vii, 85
filtering data 92
filters
operators 184
with Hyperion Integration Server
Drill-Through 186
Find Member dialog box 77
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finding members 75, 77
FlashBack button 15
FlashBack command 29
font
formats 51
style list 51
Font dialog box 51
forced logouts 84
formatted sheets
pivoting in 105
retrieving data into 101
formatting
data cells
linked objects
read-only 54
read/write 54
dimension members 52
displaying aliases 56
displaying aliases and names 58
Dynamic Calculation
members 116
enabling styles 51
linked object cells 133, 146
options for cascaded sheets 154
parent members 49
repeating member labels 58
spreadsheets 49
text and cell styles 54
Formula Fill option 106, 109
Formula Preservation mode
Formula Fill 106
pivoting in 105
restrictions with 105, 106
Retain on Keep and Remove

133, 146

Only 106
Retain on Retrieval 103, 106
formulas

EssCell 112
expanding when drilling 107
in cells 101, 106
preservation
effects on other
operations 106
enabling 103, 106
restrictions with 105
free-form reporting
entering generation and level
names in 128
in Advanced Interpretation
mode 121
in Free-Form mode 124
retrieving data 121
Free-Form retrieval mode 124
guidelines 124
functions 17

G

generations
defined 9
entering names in
spreadsheet 128
Global page (Essbase Options dialog
box) 18

H

Help, accessing 17
Help buttons 17
HTML
sample programs 197
Hyperion Essbase
intended audience 1
migration information ix
products of 3
Hyperion Essbase Spreadsheet
Add-in
accessing Hyperion Integration
Server Drill-Through from 171
installing, manually adding 12
installing toolbar 14
logging data updates 149
retrieval cursors 28
starting 13
users, described 2
Hyperion Integration Server
Hyperion Integration Server
Drill-Through 161

in-cell editing 18
index wizard 205
Information Center 203
installation

4,161

Hyperion Integration Server
Drill-Through 164
manually adding Spreadsheet

Add-in 12
toolbar 14
installing

Netscape browser 203
Integration Server Drill-Through 4
Internet, linking cells to URLs 136
Interntl sample database 156

K

Keep Only button 15
Keep Only command
described 40
in Formula Preservation
mode 106
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labels
applying styles 52
displaying with aliases 58
entering in spreadsheet 121, 124
member names 101
repeating 58

LAN v
language identifier
books 197

late-breaking information 198
latest time period, specifying 117
Latest Time Period option 118
levels
cascading by 151
defined 9
drilling down 34
drilling in 34
entering names 128
linked objects
partitions 54
reporting objects 54
Linked Objects Browser dialog
box 144, 146, 174
LROs 131
Linked Objects command 131, 134,
136
linked partitions
access privileges 147
accessing from spreadsheet 145
cells, applying styles 146
Linked Reporting Objects
accessing from spreadsheet 137
applying styles 133
cell notes 134
creating 130
external files 131
URLs 136
linking
cell notes 134
external files 131
partitions 145
URLs to data cells 136
list, cascaded sheets 154
local area network v
Lock command 148
locking data blocks, with multiple
users 148
logging
off of Essbase 83
on to a relational data
source 175
on to Essbase 25
on to Hyperion Integration
Server 175



logging data updates from
spreadsheet 149
logical operators 79
logouts, forced or auto 84
Lotus 1-2-3
clearing formats 56
mouse actions 18
sample tutorial files 85
status bar 14

M

macro functions
EssCell 112
Spreadsheet Toolkit vi, 3, 17
main menu (Essbase) 13
manual calculation mode 115
Member Information dialog box 76
member names
aliases for 56
alternate 56
applying styles 49
displaying with aliases 58
entering in spreadsheet 121, 124
formatted sheets 101
indenting 9
repeating 58
with EssCell function 113
Member Preview dialog box 80
Member Retention option 34
Member Selection, with Query
Designer 64
Member Selection button 15
Member Selection command 76
Member Selection dialog box 76
Member Selection Preview dialog
box 67
members
adding 64
aliases for 56
ancestors 8
applying styles
children 8
collapsing 33
defined 8
deleting 42
descendants 8
deselecting 82
drilling down on 30, 31
drilling up on 33
Dynamic Calculation 115
Dynamic Time Series 117
finding 75, 77
generations 9
levels 9
names 9

49, 52

members (continued)
parents 8
retaining 40
selecting 64, 75
siblings 8
menu, Essbase 13
messages (Essbase)
database calculation status 150
display options 105
EssCell 115
unknown member 103
migrating to release 6 ix
missing values
suppressing 46
suppressing disabled 106
missing values, suppressing
in cascaded sheets 154
unavailable 106
Mode page (Essbase Options dialog
box) 21, 90, 106
money 155
mouse actions, enabling 17
Move Down button 179
Move Up button 179
moving
rows and columns 36
through worksheets 43
multidimensional databases 5
multiple filter conditions, with
Hyperion Integration Server
Drill-Through 185

N

Named Pipes protocol 3
names
alternate 9
applying styles 49
displaying with aliases 58
entering generation 128
entering level 128
repeating 58
Navigate With or Without Data
button 15
Navigate Without Data
command 43, 45
nested columns or rows 30
Netscape browser
installing 203
networks 3
Next Level option 34, 152
nonadjacent cells 41
notes, linking to data cells 134
null values 113
numeric values, preserving 102

O

Objects product 4
ODBC clients 3
OLAP
defined 1
server 2
online analytical processing 1
online help 200
displaying for spreadsheet 17
online information
searching 206
viewing 202
opening
Essbase 13
operating systems 2
operators, comparison 75, 93
options
Cascade 151
Display 20, 87, 165
Global 18, 22, 90, 169
Mode 21, 89, 106, 167
settings for advanced tutorial 87
settings for basic tutorial 19
settings for Drill-Through
tutorial 165
Style 50
Zoom 20, 34, 88, 166
Options button 15
Options dialog box 20, 165
OR operators 75
Order By button 182
Order By dialog box 182
ordering
columns, Hyperion Integration
Server Drill-Through 178, 179
rows, Hyperion Integration
Server Drill-Through 180
outlines
consolidations 9
described 7
dimensions 8
Dynamic Calculation
members 115
Dynamic Time Series
members 117
members 8
output, cascaded sheets 151
overlapping styles 54

P

parent members
applying styles to 49
defined 8
Partitioning product 3
partitions 3
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passwords
changing 27
entering 86
pattern matching 79
PDF 198
performance configuration
wizard 205
pivot
asymmetric reports and 100
by dragging 37
described 18, 36
effect on text 102
formatted sheets and 105
formula preservation and 105
rows or columns 36, 101
unavailable 102
without retrieving data 43
Pivot command 36
power loss 84
preferences 18
preserving formulas 103, 109
primary mouse button 17
printer destination, cascaded
sheets 152
printing PDF books 198
programming interface 4

Q

queries
applying styles 71
creating 62
defining 60
deleting 71
retrieving 60
saving 69
Query Designer
applying option settings 74
connecting to multiple
databases 73
creating queries 63
data filtering panel 93
data sorting panel 96
filtering data 92
hint panel 61
layout panel 63
messages 99
messages and confirmations 71
navigation panel 61
properties panel 61
save as query dialog box 69
sorting data 96
Query Designer icon 15

R

read-only cells 54
read/write cells 54

relational data source 175

relational databases, accessing with
Hyperion Integration Server
Drill-Through 161

release 6 (Essbase), new features ix

release notes 198
remote databases 145
Remove Only button 15
Remove Only command
described 42
in Formula Preservation
mode 106
Remove Unselected Groups
option 107
removing 42
Repeat Member Labels option 58
report script commands 124, 126
reports
ad hoc 27,105
ad hoc currency 158
asymmetric 99
creating multiple 151
formatted 101
free-form 121
methods of generating v
saving 83
reports, creating
ad hoc 27,158
Cascade 151
Member Selection 75
methods v
Query Designer 60

reports, Hyperion Integration Server

Drill-Through
accessing 171
customizing 163, 176
disconnecting from 187
executing 175
selecting to view or
customize 176
restore wizard 205
restoring database views 29
restrictions, with Formula
Preservation 106
Retain on Keep and Remove Only
option 106
Retain on Retrieval option
disabled 106
enabled 103, 106
Retain on Zooms option 106, 108
retaining
data subsets 40
formulas 101, 102
when drilling 106
when retaining data 106
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retaining (continued)
formulas 101, 102 (continued)
when retrieving 103, 106
selected members 40

Retrieve & Lock command 148
Retrieve button 15

Retrieve command 28
retrieving

Advanced Interpretation mode
and 121
canceling 29
conditional 92
currency conversion 156
cursors 28
data 24
Dynamic Calculation
members 115
formula preservation and 106
Free-Form mode and 124
functions 112
increasing speed 55, 100, 110,
115
into asymmetric reports 99
into columns 31
into formatted sheets 101
rules for 102
into rows 31
less detail 33
modes 121
more detail 30
performance impact 55, 100, 115
range of cells 109
retaining formulas and 103, 106
selected cells 109
starting process and 27
suppressing data and 43

reverting to previous database
view 29

Trows

blank 101

deleting during pivot 101
displaying as columns 36
displaying selected 40
filtering by 93

keeping discontinuous 41
nested 30

pivoting 36

removing selected 42
retrieving into 31

sorting within 97, 99
suppressing values in 46, 154



S

sample
databases
connecting to 26, 156
described vi, 24, 156
databases, in Hyperion
Integration Server
Drill-Though 170
files for tutorial, location 85
Sample Basic
connecting to 26
described 24
Sample directory 85
sample programs
cross-platform 197
HTML 197
Save As command 83
Save command 83
saving
queries 69
worksheets 83
searching
online information 204, 206
secondary mouse button 17
select (defined) 18
Select Calc Script option 150
Select Columns and Display Order
dialog box 178
Select Data Filters dialog box 183
Select Data Sort Order dialog
box 180
Select Drill-Through Report dialog
box 175, 176
Select Filter Values from the List
dialog box 184, 185
selecting
cells to keep 40
cells to remove 42
latest time period 117
members 75
nonadjacent cells 41
range of cells for retrieval 109
Send command 148
sending
data to server 147
log file 149
server 2
changing password 27
client-server environment 2
connecting to 26, 86
described 2
disconnecting from 83
Essbase OLAP, described 2
Hyperion Integration Server 4,
161

server 2 (continied)
logging updates to 147
migrating to release 5, with
client ix
name 26, 86
on network 3
sending data to 147
Set Filter on Column dialog
box 183
setting up document server 205
shared members, applying styles
to 50
sheet destination, Cascade
option 152
sheets 27
shortcuts, mouse actions 18
shortcuts, toolbar buttons 15
siblings (defined) 8
SmartGuides
wizards 204
sort order
with Hyperion Integration Server
Drill-Through 180
sorting multiple columns 182
with Query Designer 96
sorting criteria 92
Spreadsheet Toolkit product 3
spreadsheets
applying styles 49
cascading 151
creating multiple 151
data update log file 149
described 5
displaying aliases 56, 58
displaying member names 58
distributing 151
drilling options 34
global options 18, 30, 105
mode options 106, 121
preserving formulas 106
repeating member labels 58
retrieving data 24
saving 83
setting options 20
style options 49
suppressing missing and zero
values 46
zoom options 34
SQL Interface 3
starting
data retrieval 28
Hyperion Essbase 13
Hyperion Essbase Spreadsheet
Add-in 13

starting (continued)
Hyperion Integration Server
Drill-Through 171
status bar, enabling and
disabling 14
status of database connections 145
Style page (Essbase Options dialog
box) 50
styles
applying
to data cells 54
to dimension members 52
to dimensions 52
to Hyperion Integration
Server Drill-Through
cells 171
to linked partition cells 146
to linked reporting object
cells 133
to members 49
to parent members 49
to Query Designer results 74
to shared members 50
clearing 56
defining 49, 50
hierarchy of 54
overlapping 54
removing 55
selecting members 50
stored in ESSBASE.INI 53
turning off 56
turning on 51
Subset dialog box 78, 80
subsets
defining members 78
removing 42
retaining 40
substitution variables
suppressing
data retrieval 43
disabled 106
missing and zero values 46
underscore characters 46
symmetric reports 99
system administrator 2
system failure 84

T

table of contents, with Cascade 154

TCP/IP protocol 3

terminating database

connections 83

termination, abnormal 84

text
entering free-form 121
formatting 51

120, 121
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text (continued)

hierarchy of styles 54

pivoting 36

preserving formatted 102
time periods 117
title members, with drill-down 31
to-date calculations, specifying 117
toolbar (Essbase) 15

buttons on 15

installing 14
tracking data updates 149
transaction-level data, accessing with

Hyperion Integration Server
Drill-Through 161

transparent partitions 146
transport protocol 3
tutorial

basic tasks 11

guidelines 23

preparing for 19

U
UDA 78
underscore characters,
suppressing 48
Undo command 29
undoing actions 29
Unlock command 148
unlocking data blocks 148
up-to-date calculations 117
Update Mode 148
updating
data 147
log file 149
upgrading ix
URLs
accessing linked 141
editing 142
length limits 137
linking to data cells 136
Use Aliases option 56
Use Both Member Names and
Aliases option 58
Use Sheet Options with Query
Designer option 74
Use Styles option 51
User-Defined Attributes 78
username, entering 86
users 2

Vv

V2.x mode 124
VBA functions vi

viewing
active connections 145
aliases 56

viewing (continued)
aliases and names 58
data in spreadsheet 27
Dynamic Calculation
members 116
Essbase menu 13
Essbase toolbar 14

Zoom commands, customizing 34
Zoom In button 15
Zoom In command
drilling down options 30
selecting levels 34
Zoom Out button 15
Zoom Out command, drilling up

fewer members 33 options 33
linked partitions 145 Zoom page (Essbase Options dialog
linked reporting objects 137 box) 20, 34

more members 30
multidimensional data 5
online help 17
online information 202
repeated member labels 58
spreadsheet without data 43
styles 51
toolbar 14
views, restoring 29
Visual Basic for Applications vi
visual cues 49, 101

W

Web Gateway product 4
Web resources, linking to data
cells 136
wildcard characters 77
Windows NT Registry, changes
to 12
Within Selected Group option 35,
100
wizard
restore database 205
wizards
add database 204, 205
back up database 204
completing tasks 204
configure multisite update 204
create database 205
create table 205
create table space 205
index 205
performance configuration 205
worksheets
formatting 49
navigating without data in 43
World Wide Web, linking to data
cells 136

X

Xchgrate sample database 156

Z

zero values
suppressing 46, 48
suppressing disabled 106
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Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
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be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM Corporation
J74/G4

555 Bailey Avenue,

P.O. Box 49023

San Jose, CA 95161-9023
US.A

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Trademarks

DB2 OLAP Server IBM 0S/390
OpenEdition DB2 AIX
DB2 Universal Database

Lotus and 1-2-3 are trademarks of Lotus Development Corporation in the
United States, or other countries, or both.

UNIX is a registered trademark in the United States and other countries
licensed exclusively through X/Open Company Limited.

Microsoft, Windows, and Windows NT are registered trademarks of Microsoft
Corporation.

Other company, product, and service names may be trademarks or service
marks of others.
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Contacting IBM

If you have a technical problem, please review and carry out the actions
suggested by the Troubleshooting Guide before contacting DB2 Customer
Support. This guide suggests information that you can gather to help DB2
Customer Support to serve you better.

For information or to order any of the DB2 Universal Database products
contact an IBM representative at a local branch office or contact any
authorized IBM software remarketer.

If you live in the U.S.A., then you can call one of the following numbers:
* 1-800-237-5511 for customer support
+ 1-888-426-4343 to learn about available service options

Product Information

If you live in the U.S.A., then you can call one of the following numbers:
* 1-800-IBM-CALL (1-800-426-2255) or 1-800-31BM-OS2 (1-800-342-6672) to
order products or get general information.

* 1-800-879-2755 to order publications.

http://www.ibm.com/software/data/
The DB2 World Wide Web pages provide current DB2 information
about news, product descriptions, education schedules, and more.

http://www.ibm.com/software/data/db2/library/
The DB2 Product and Service Technical Library provides access to
frequently asked questions, fixes, books, and up-to-date DB2 technical
information.

Note: This information may be in English only.

http://www.elink.ibmlink.ibm.com/pbl/pbl/
The International Publications ordering Web site provides information
on how to order books.

http://www.ibm.com/education/certify/
The Professional Certification Program from the IBM Web site
provides certification test information for a variety of IBM products,
including DB2.

© Copyright TBM Corp. 1998, 2000 217



ftp.software.ibm.com
Log on as anonymous. In the directory /ps/products/db2, you can
find demos, fixes, information, and tools relating to DB2 and many
other products.

comp.databases.ibm-db2, bit.listserv.db2-1
These Internet newsgroups are available for users to discuss their
experiences with DB2 products.

On Compuserve: GO IBMDB2
Enter this command to access the IBM DB2 Family forums. All DB2
products are supported through these forums.

For information on how to contact IBM outside of the United States, refer to
Appendix A of the IBM Software Support Handbook. To access this document,
go to the following Web page: http://www.ibm.com/support/, and then
select the IBM Software Support Handbook link near the bottom of the page.

Note: In some countries, IBM-authorized dealers should contact their dealer
support structure instead of the IBM Support Center.
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