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About this Handbook

This Installation and User’s Handbook provides installation and setup information for th
SYMplicity™ Storage Management software in a networked Microsoft® Windows NT™, 
Windows 95, or Windows 98 environment. Use this Installation and User’s Handbooto 
do the following:

• Determine the hardware and software required to install this softwar

• Install the software

• Identify features unique to the networked operating environment

• Set up software parameters

• Troubleshoot the installation and networked operation

This guide is accompanied by the SYMplicity Storage Manager User’s Handboo. The 
User’s Handbook describes how to use the storage management software after installa
Some parts of that book may be affected by information given in this book. 

You should use this Installation and User’s Handbook after installing the RAID Controller 
hardware. After you install and set up the software, go to the User’s Handbook for furthe
information on using the software and maintaining the RAID Controllers.

New Software Features

This release of the storage management software contains the following new feature

• Windows 98 support. The storage management software now supports the netwo
Windows 98 operating environment.

• Faster LUN creation. The controller now performs background formatting to creat
logical unit numbers (LUNs) faster.

• SMART/PFA support. Through the use of Self-Monitoring Analysis and Reporting
Technology (SMART), the storage management software now reports predictive 
failure analysis (PFA) flags on drives.
© Copyright IBM Corp. 1998, 1999                                                          Second Edition, Part Number 37L7050  1
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• Firmware autosynch. When you replace a controller with firmware level 3.00.X or 
higher, the firmware on the new controller automatically synchronizes with the 
firmware on the remaining controller.

• Fibre Channel Loop ID. For Fibre Channel topologies, a new nvutil option allows y
to set the Fibre Channel Loop ID for the controller.

• Backup log redirection. When the threshold limit is reached, you now can set the 
location for your old log file.

• Windows NT Event Log capability. You can use the new putntlog command-line ut
to write the contents of a RAID event to the Windows NT Event Log.

Understanding the Restrictions

Table 1 "Restrictions and Notes" on page 2 details the restrictions and important notes th
apply to using the storage management software in the Windows environment.

NOTE Always check for a readme file on any installation media. This file ma
contain important information that was not available at the time this 
Installation and User’s Handbook was prepared.

Table 1: Restrictions and Notes 

Restriction/Note Application Workaround

Do not use Microsoft’s Network 
Monitor™ service with the storage 
management software. Monitoring 
the network connections with this 
service can result in problems, such 
as blue screens.

Installation and 
Setup

Stop the Network Monitor Service if you have 
it installed before using the storage 
management software:

1 Select Control Panel → Services.

2 Highlight the Network Monitor Service.

3 Select Stop.

Do not install the RDAC driver 
before installing the storage 
management software. This driver 
is available for installation on a 
Windows NT host machine 
connected to the RAID Controllers 
with Fibre Channel connection. 

Installation and 
Setup

None. Do not install the RDAC driver 
before upgrading or installing the storage 
management software. The installation 
procedure will remove any version of the 
RDAC driver. The RDAC driver will need 
to be installed from this software’s 
installation CD. See "Installing the Driver" on 
page 46 for more information.
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raidutil does not always generate 
an error message even when an 
operation fails. For example, using 
raidutil -R to reset the controller 
battery age without LUN 0 created 
causes the operation to fail. 
However, there is no error 
message. 

General

Anytime you use raidutil to perform an 
operation, it is a good idea to verify that it 
completes successfully. For example, after 
creating LUNs, you might want to use lad to 
verify your configuration. 

The networked storage 
management software does not 
have any knowledge of the I/O data 
path; therefore, the following 
restrictions apply:

• Configuration  — cannot check 
for I/Os before deleting LUNs.

• Recovery/Status — Recovery 
Guru/Health Check does not 
detect any problems with the 
data path/connection. If any Data 
Path Failure is displayed, it 
indicates that there are problem
with the network connection or 
one of the controllers in the 
affected RAID Controller.

• Maintenance/Tuning — does 
not check for I/Os or verify 
LUNs are Optimal before 
upgrading firmware, balancing 
LUNs, or changing controller 
mode.

All 
Applications

Configuration  — make sure you stop I/Os and 
no other users are on the system before 
selecting Delete LUN.

Recovery/Status — make certain there are no 
network problems before proceeding with the 
Data Path Failure recovery procedure. 
Proceeding with the recovery procedure could 
cause an operational controller to be failed 
when the problem may be with the network or 
its connection.

Maintenance/Tuning 

• Firmware Upgrade — the Online method 
for Firmware Upgrade is grayed out. Before 
selecting the Offline method of Firmware 
Upgrade, you must stop I/Os.

• LUN Balancing/Controller Mode — make 
sure you stop I/Os because they could fail. 
Also, if the host machine (connected to your 
RAID Controllers via I/O data connection) 
does not have RDAC installed, you may have
to make changes to mounted filesystem
(UNIX only).

• Caching Parameters — Before saving 
changes to your caching parameters, you 
must stop
I/Os.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
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The host’s operating system could 
hang and I/Os could fail if a host 
machine (connected to your RAID 
Controllers via I/O data 
connection) is issuing I/Os to the 
modules when you use the software 
to:

• Delete or format LUNs.

• Change controller mode or LUN 
assignments between controllers.

• Upgrade controller firmware.
Configuration, 
Recovery
Maintenance/
Tuning 

Configuration

Make sure that you stop I/Os and that no other 
users are on the host machine’s operating 
system before deleting logical units (Delete) or 
using File → Reset Configuration.

Recovery

Make sure you stop I/Os and that no other user
are on the host machine’s operating system 
before performing any procedure that will 
format a LUN (such as Options → Manual 
Recovery → Logical Unit → Format).

Maintenance/Tuning

Make sure that you stop I/Os and that no other 
users are on the host machine’s operating 
system before performing tasks that transfer 
LUN ownership between controllers, such as 
using Controller Mode, using LUN Balancing, 
or upgrading controller firmware (Firmware 
Upgrade, Offline method).

If you have more than one station 
with this software installed, you 
should open only one 
Configuration session at a time.

Operations could fail or hang if
I/Os are occurring and LUN 
creation or deletion will fail for all 
but one station.

Configuration

You must be very careful not to use more than 
one Configuration Application at a time. Also, 
be sure to stop I/Os before deleting or 
formatting logical units.

When creating multiple LUNs that 
will use the full capacity of the 
drive group, the last LUN is not 
created.

Configuration

Do one of the following:

• Specify 10 LUNs (or less) in the Create LUN 
panel.

• Recreate the last LUN individually after the 
failure message.

• Determine what size of the remaining drive 
group capacity to allocate to each of the 
LUNs, and create the LUNs one at a time.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
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Hardware and Software Requirements

Check to make sure you have the following components installed:

• Windows 95, Windows 98, Windows NT Server 4.0, Windows NT 4.0 Enterprise 
Edition Operating System, or Windows NT Workstation 4.0 installed on each Rem
Management Station (RMS) where you intend to install the storage management
software.

• Microsoft Service Pack 4 or newer for Windows NT 4.0.

• A BOOTP or DHCP server (se"Appendix A. Specifications" for further information).

• RAID Controllers with Series 4 controllers.

• The network enable bit (an NVSRAM setting) is set to on (default).

• At least an 800 x 600 resolution graphics card and mouse.

When a LUN is Dead and ALL its 
drives are Failed (for example, 2 
drive Raid 1), Recovery Guru 
reports that the first replaced drive 
is still Failed.

CAUTION If the controllers in the 
module containing the Dead LUNs 
are reset (bus reset or turning the 
module off and on again), the dead 
LUNs will be lost. In this instance, 
use the Configuration Application 
or raidutil to re-create them.

Recovery Guru

You should select OK when asked, “Are you 
certain you have replaced it and that it has 
enough capacity?” and continue the recovery 
process.

Manual Recovery → LUN → 
Format does not work while new 
LUNs are formatting on different 
drive groups.

Recovery
Wait for LUNs on other drive group to 
complete formatting before starting manual 
recovery.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
Chapter 1. Introduction 5
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Selecting the Correct Installation Procedur

The procedure you need to use to install the storage management software depends
whether this is an upgrade to a previously installed version or whether you are instal
the software for the first time.

Upgrade Installation First Time Installation

Continue with "Chapter 2. Upgrading 
the Software".

Continue with "Chapter 3. Installing the 
Software for the First Time".
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This chapter gives the following procedures for installing an upgrade version of the 
storage management software. 

If you have not installed this software before, go to "Chapter 3. Installing the Software for
the First Time".

Preparing for an Upgrade Installation

This section provides the following procedures for preparing for your upgrade installa

Retaining Your Previous Configuration Information

During the upgrade/installation procedure, your current rmparams and rmscript.bat f
will be saved as rmparams.ori and rmscript.ori. You can refer to these old files after 
installation to determine if you want to customize the new files. 

Upgrading the RDAC Driver

Do not install the RDAC driver before upgrading the storage management software. 
installation procedure will remove any version of the RDAC driver. The new version o
the RDAC driver will need to be installed from this software’s installation C. See 
"Installing the Driver" on page 46 for more information.

Preparing for an Upgrade Installation.........................................................................page 7

Installing the Software ................................................................................................pag

What’s Next?.............................................................................................................page2

Retaining Your Previous Configuration Information ..................................................page 7

Upgrading the RDAC Driver ......................................................................................pag

Downloading the NVSRAM Files ..............................................................................page

Upgrading the Controller Firmware............................................................................pag

Installing the Software ................................................................................................pag
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Downloading the NVSRAM Files

IMPORTANT In most cases, you have to download a new NVSRAM file befor
upgrading controller firmware, especially if you are upgrading from on
major firmware release to another. The NVSRAM file specifies certain
default settings for the controller (it will be part of the controller 
firmware’s release media). 

1. Select Maintenance/Tuning → Firmware Upgrade.

2. Be sure to specify the NVSRAM file on the Path line because the fwcompat.def fil
does not recognize NVSRAM files and will not place them in the Compatible Files
Versions list.

3. When finished, run nvutil -vf from the command line to ensure the controller recei
the new settings.

4. Turn power off, then back on to the affected RAID Controllers to ensure the new 
NVSRAM settings take effect.

5. Continue with "Upgrading the Controller Firmware."

Upgrading the Controller Firmware

1. Determine if you need to upgrade to the required controller firmware version:

a. Select RAID Controlle → Module Profile → Controllers.

b. Verify the boot and firmware levels meet the minimum requirement (seTable 19 
on page 85).

c. Select OK when finished viewing.

2. Upgrade your controller firmware now.

a. Select Maintenance/Tuning → Firmware Upgrade.

b. Select Offline.

c. Download the firmware files from this software’s CD-ROM. For example, at the
path line (assuming d: is your CD-ROM drive) type: 
d:\networkd\firmware\03000105.apd + 03000103.bwd 
where the numbers match the firmware level to which you need to upgrade.
8 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook
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Installing the Software

Use the following procedure to install the storage management software.

IMPORTANT You must have administrator privileges to access this software. This 
installation procedure requires you to restart the operating system. 
Therefore, make sure that other users are not on the system when 
installing this software.

CAUTION Do not install the RDAC driver before upgrading the storage managem
software. The installation procedure will remove any version of the 
RDAC driver. The storage management software’s installation CD 
contains a new version of the RDAC driver, which you will need to ins
after upgrading the software.

1. Insert the Installation CD into your CD-ROM drive. 

NOTE In the following examples, c:\ is designated as your boot drive and d:\
designated as the CD-ROM device drive. Be sure to select the correc
drives for your system. 

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs.

b. Select Install, and then browse. 

c. When you see d:\networkd\netsymsm\setup.ex , select Finish. 

3. Follow the instructions on screen to complete the installation procedure.

IMPORTANT During installation, you will be prompted to define the directory path 
where you want this software installed. If you are defining your own 
directory path, do not use special characters for the directory name (su
as, #, $, or +). The default path is c:\Program Files\NetSYMsm. For th
purpose of providing examples of the installation requirements, this 
Installation Guide will refer to the default directory. 

4. When the installation is completed, remove the CD and restart the system.

5. After your system restarts, continue with "Verifying the Installation" on page 10.
Chapter 2. Upgrading the Software 9
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Verifying the Installation

Verify the storage management software is installed, and that the Disk Array Monitor
service is running.

1. Select Start → Programs. Networked SYMplicity Storage Manager appears in the 

2. To verify that the Disk Array Monitor is running:

3. Continue with "Editing the RAID Controller Information" on page 10.

Editing the RAID Controller Information

Your existing RAID Controller configuration has been retained.

Use the following procedure to add or change information about your RAID Controlle

1. Select the Recovery Application.

The Select Module main screen appears.

Figure  1. Select Module Main Screen

Windows NT Windows 95 and Windows 98

Select Start → Settings → Control 
Panel → Services. The Disk Array 
Monitor is running if this service’s 
status is Started.

An icon appears in the service tray in the 
lower right corner of your screen. Move 
your cursor over the icon. A status message 
pops up indicating that the Disk Array 
Monitor is Running.
10 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook
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2. Verify that this screen contains the correct number of RAID Controllers. You may 
to refer to the table (similar to Table 4 on page 16) you created when you originally 
installed the software.

3. If you want to add or change information for a RAID Controller, highlight that mod
and select Edit.

The Edit screen appears.

4. In the Edit screen, make the following changes:

• Change the module name if desired. Remember, there is a 1 6character limit. The 
new name might include the host machine’s name, the module’s location, and
unique number for the module.

Figure  2. Edit Screen
Chapter 2. Upgrading the Software 1
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• For RAID Controllers using the independent controller configuration, click the b
next to Independent Controllers. This indicates the RAID Controllers are using the 
independent controller configuration. (Two different Fibre hosts are each connected 
to both controllers in a RAID Controller.)

• In the Comment field, add information that might help you identify the module. 
You may want to add location details, host-RAID Controller configuration type,
machine type, or other unique information to further clarify the module for futur
identification.

5. Select OK when done.

The Select Module main screen now reflects any changes you made.

6. Repeat Step 3. through Step 5. until you have added/changed information for each 
RAID Controller you want to change.

7. Continue with "What’s Next?" on page 12.

What’s Next?

The remainder of the book contains information that you may need to review after y
have completed your upgrade installation. 

If you want to Continue with

Read background information relating to 
operating the storage management 
software in the Windows environment

"Chapter 4. Operating System Support"

Customize the installation to run on your 
system

"Chapter 5. Customizing the Installation"

Ensure that the storage management 
software operates properly and determine 
if the system configuration meets your 
needs

"Chapter 6. Initial Startup Procedures"
12 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook



Chapter 3. Installing the Software for the First Time
r the 

rver 

rver 

d
 host 
 
the 
n 

2

This chapter gives the procedures for installing the storage management software fo
first time. If you have a previously installed version of the software, go to "Chapter 2. 
Upgrading the Software".

Sample Network

Figure 3 shows a sample setup of two networks. Each network contains a BOOTP se
and at least one host machine connected to two or more RAID Controller modules. 
Remember that if the network spans multiple subnets, you may need one BOOTP se
for each subnet that has a networked RAID Controller Unit.

Also in Figure 3, the host machines are connected to the RAID Controllers via an I/O ata 
connection (Fibre Channel). This storage management software is unaware of these
machines, the operating system installed on them, and the I/O data connection. The
software management station has no way to talk with the host system or to monitor 
connection. Therefore, you need to follow the operating system’s documentation whe

Sample Network page 13

Summary of Preparation Task page 14

Determining the Hardware Ethernet Address page 17

Determining Names for RAID Controller Units and Controllers page 18

Obtaining IP Addresses page 19

Setting Up the BOOTP Server page 19

Verifying the TCP/IP Protocol and Setting Up the Host or DNS Table page 3

Installing the Software page 33
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using the host’s operating system with your controllers. Furthermore, you do not see
messages displayed on the host’s console, nor does this software receive or display
messages from the host. They are entirely independent systems.

Figure 3.  Sample Network System and Hardware Components

Summary of Preparation Tasks

Before you install the storage management software, you must perform the tasks des
in Table 2 to ensure the components on the network are set up and operating properl
you have all the controller information needed for the software to operate correctly.
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Perform the tasks in  Step 1 through  Step 7 and use Table 4 on page 16 to record 
information such as RAID Controller and controller names, hardware ethernet and IP
addresses, and host machine configuration type.

Table 2: Summary of Tasks for Configuring Controllers on the Network 

Task To Perform Why Perform This Task? For More Details, See: 

1 Install all hardware components 
(host machines, RAID 
Controllers, cables, etc.) that you 
want connected to the network.

NOTE You need the proper type 
of transceiver when connecting your 
RAID Controllers to the network.

To ensure the network 
hardware is present.

The Installation Guide specific 
to your hardware components.

2 Determine the hardware ethernet 
address for each controller in all 
the RAID Controllers connected 
to the network.

To configure the BOOTP 
server on the network.

"Determining the Hardware 
Ethernet Address" on page 17.

3 Establish and record a naming 
scheme for each RAID Controller 
and for each controller in the 
RAID Controllers connected to 
the network.

To help when assigning 
names and addresses to your 
controllers and host 
machines.

"Determining Names for RAI
Controller Units and 
Controllers" on page 18.

4 Obtain IP addresses from your 
network administrator for each 
controller in all the RAID 
Controllers connected to the 
network.

To configure the BOOTP 
server on the network and to 
set up the host (or DNS) 
table.

"Obtaining IP Addresses" on 
page 19.

5 Configure the hardware and I
addresses on the BOOTP server 
on the network.

To set up the network address 
information for the BOOTP 
server.

"Setting Up the BOOT
Server" on page 19.

6 Verify the TCP/IP Protocol i
installed and set up the host (or 
DNS) table.

To verify your Windows 
machine is configured to 
reach the controllers over the 
network.

"Verifying the TCP/IP Protocol 
and Setting Up the Host or DNS 
Table" on page 32.

7 Power up the component
connected to the network.

To ensure all devices and 
links are operational.

The Installation Guide specific 
to your hardware components. 
Chapter 3. Installing the Software for the First Time 15
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Table 3 provides samples for both a single and a dual-controller RAID Controller. 

Table 4 provides a place for you to record controller and controller information. Keepi
this record will help you properly set up the BOOTP table for the network server and
host or DNS (Domain Name Server) table to use the storage management software.
also help you correctly add additional RAID Controllers after initial installation. The f
four column headings show a reference to the page where you can go for detailed 
instructions on obtaining this information.

Table 3: Sample Table for Recording Controller Addresses, Names, and Information

RAID Controller Name
Hardware 

Ethernet Addres
IP Address

Controller 
Name

Host Machine 
Configuration 

Type

Example: 

(The first RAID Controller 
on host machine socrates.)
RAID Controller Name: 

socrates_ks_001

00a0b802042c 153.79.144.17 soc_7 Single-host

Example:

(The first RAID Controller 
on host machine beatrice.)
RAID Controller Name: 

beatrice_fl_001

00a0b8020420 153.79.144.13 beatr_1 Single-host

00a0b80000d8 153.79.144.14 beatr_2

Table 4:  Table for Recording Controller Addresses, Names, and Information 

RAID Controller 
Name

(See page 19)

Hardware Ethernet 
Addres

(See page 17)

IP Address
(See page 19)

Controller 
Name

(See page 19)

Host Machine 
Configuration 

Type

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:
16 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook
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Determining the Hardware Ethernet Address

Use the following procedure to record the correct hardware ethernet address for eac
controller in all RAID Controllers connected to the network.

1. Turn the power off to all the RAID Controllers on the network.

IMPORTANT Consult the manual shipped with your RAID Controller Unit for specific 
procedures on removing/replacing controllers.

2. Remove the controller (one at a time for redundant controllers) from the RAID 
Controller.

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

Table 4:  Table for Recording Controller Addresses, Names, and Information  

RAID Controller 
Name

(See page 19)

Hardware Ethernet 
Addres

(See page 17)

IP Address
(See page 19)

Controller 
Name

(See page 19)

Host Machine 
Configuration 

Type
Chapter 3. Installing the Software for the First Time 17
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3. Record the ethernet address as it appears on the label on the controller back und
the canister.

The Ethernet ID (or hardware ethernet address) is shown in Figure 4. Use Table 4 on 
page 16 to record the IDs. 

Figure 4.  Location of Ethernet Address on the Back of the Controller 

4. Replace the controller in the RAID Controller Unit.

5. Repeat  Step 2 through  Step 4 for each controller in ever  RAID Controller Unit.

6. Continue with "Determining Names for RAID Controller Units and Controllers" on 
page 18.

Determining Names for RAID Controller Units and 
Controllers

When you open any storage management application for the first time after installation, 
you will be required to add information about the controllers in each RAID Controller
Unit to allow the software to recognize them. You will also be able to provide a uniqu
name for each RAID Controller Unit and controller. Use the information below and Table 
4 on page 16 to record the information you will need to add the RAID Controller Units
18 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook
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RAID Controller Unit Names

The RAID Controller Unit name can be anything you want; however, the software all
only 16 characters. You can provide a unique name for each controller (see Example
Names in Table 3), or you can accept the default name which will be Net Module xxx 
(where xxx is a sequential number). If you choose to rename the controllers, the new
might include the name of the host machine, an indication of its location, and a uniqu
number.

Controller Names

• The controller names can also be anything you want; however, the name should b
meaningful to you in the first eight characters because the software only displays
first eight characters in its device-name display. 

• Furthermore, you need to provide a unique name for each controller in all RAID 
Controller Units (see Example Names in Table 3). Therefore, we suggest that the nam
identifies the name of the host machine (connected to your RAID Controllers via 
data connection) and a number representing the controller or its host-side ID. How
keep in mind the eight-character display limit. Because names for host machines
be much longer than the character limit allows, you may need to be creative when
creating or abbreviating them.

Obtaining IP Addresses

Each controller in every RAID Controller Unit on the network needs a unique IP addr
Contact your network administrator to get the IP addresses you need and record the
Table 4 on page 16. You can also use Table 4 to provide a list for your network 
administrator.

Setting Up the BOOTP Server

Regardless of whether BOOTP is UNIX or DHCP, you have some required and optio
settings to consider. Review Table 5, then select the correct procedure for the type of 
BOOTP Server you are using.
Chapter 3. Installing the Software for the First Time 19
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Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description
Format /(Example) In 

BOOTP Server

Required Entries

subnet mask Mask used to route packets to defined subnets. dot notation 
(sm=255.255.248.0)

router IP address of machine that routes packets to other 
locations or networks.

dot notation

(gw=153.79.144.2)

controller 
name

Controller name you created for the controller (such as 
beatr_1 and soc_ks9). (Refer to Table 4 on page 16.)

controller name

(beatr_1)

IP address IP address of controller. (Refer to Table 4 on page 16.) dot notation

(ip=153.79.144.13)

ethernet 
address

Hardware ethernet address of controller. (Refer to Table 
4 on page 16.) 

hexadecimal notation

(ha=00a0b8020420)
20 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook



tag 164 The remote management station (RMS) tag; includes a 
tag and IP address for each Windows station where you 
are installing the storage management software.

I MPORTANT You may have a maximum of four remote 
management and SNMP network management stations 
(NMS); that is, the combined total of tags 164 (T164=) 
and 165 (T165=).

1 From each station, select Start → Settings → Control 
Panel→ Network → Protocols → TCP/IP Protocol → 
IP Address to locate this IP address.

NOTE If the IP address information is blank and 
Obtain An IP Address From A DHCP Server is selected, 
you will need to go to either your network administrator 
or to the DHCP Server to obtain the IP address. 
Remember, this IP address must be reserved for only this 
station.

2 You must then convert the dot notation (IP address) to 
a hexadecimal notation (see example below).

NOTE Select Start → Program → Accessories → 
Calculator. Use the Scientific view to assist with 
numerical conversion. This is not required for DHCP.

Figure 5.  Sample Conversion of Dot to Hexadecimal 
Notation

3 Enter the hexadecimal notation in the BOOTP server.

hexadecimal notation
(T164=0x994F9006)

Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description
Format /(Example) In 

BOOTP Server
Chapter 3. Installing the Software for the First Time 21



Select the correct procedure for setting up your BOOTP server.

Optional Entries

vm=rfc 1084 Some BOOTP servers require this vendor tag in order to 
return vendor-specific configuration information for 
controller operations.

vm=rfc 1084

tag 163 The network timeout tag sets a value on the controller 
for the amount of time (in seconds) it will wait for a 
reply from this software. The default is 30.

T163=30

tag 165 The Simple Network Management Protocol (SNMP) 
tag; includes a tag and the IP address of the Network 
Management Station (NMS).

Set this tag if you want the controller to send traps 
directly to the designated NMS. You can also enable the 
storage management software to send traps to the 
designated NMS. This procedure is explained later in 
"Enabling SNMP" on page 3-8.

1 Contact your network administrator or use the 
operating system on the NMS to locate this IP address. 
Consult your operating system documentation for 
directions.

2 You must then convert the dot notation (IP address) to 
a hexadecimal notation (see Figure 5 on page 21 for an 
example).

3 Enter the hexadecimal notation in the BOOTP table.

hexadecimal notation

(T165=0x994F8004)

UNIX DHCP

Continue with "Using a UNIX 
BOOTP Server" on page 23

Go to "Using a DHCP Server" on 
page 24.

Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description
Format /(Example) In 

BOOTP Server
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Using a UNIX BOOTP Server 

1. Use Table 4 on page 16 and Table 5 on page 20 to set up the BOOTP table and mak
the required entries for supporting the controllers in the RAID Controllers connect
the network.

A sample entry for editing the BOOTP table follows.

NOTE To set up this BOOTP server, you would use a text editor to edit the 
bootptab file in the /etc directory.

2. Turn on power, or cycle power to the RAID Controllers on the network in order for
parameters in the BOOTP table to take effect.

3. Continue with "Verifying the TCP/IP Protocol and Setting Up the Host or DNS Tabl
on page 32.

EXAMPLE The following sample entry for a BOOTP table assumes you are 
configuring a UNIX BOOTP server, such as a server on network 1 as 
shown in Figure 3 on page 14. The s3.default:\ entry denotes settings th
are common to all controllers. The tc=s3.default:\ entry associates thi
common setting group to a specific controller.

s3.default:\ (common settings)

ht=ether:\

sm=255.255.248.0:\

gw=153.79.144.2:\

T164=0x994F9006:\

T165=0x994F8004:\ 

hn:

beatr_1:\

tc=s3.default:\ (refers to common settings)

ip=153.79.144.13:\

ha=00a0b8020420:

beatr_2:\

tc=s3.default:\
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ip=153.79.144.14:\

ha=00a0b80000d8:

beatr_3:\

tc=s3.default:\

ip=153.79.144.11:\

ha=00a0b80000e5:

beatr_4:\

tc=s3.default:\

ip=153.79.144.12:\

ha=00a0b802007c:

beatr_5:\

tc=s3.default:\

ip=153.79.144.15:\

ha=00a0b80200d7:

beatr_6:\

tc=s3.default:\

ip=153.79.144.16:\

ha=00a0b802008e:

Using a DHCP Server

You must have a DHCP Manager installed before you can set up the DHCP Server. 
have this installed, continue with "Setting Up a DHCP Server." If a DHCP Manager is not 
installed, you need to install it now.

NOTE The following steps and screen examples assume you are configurin
Windows NT DHCP Server using its DHCP Manage .

Installing the DHCP Manager

Use the following procedure to install the DHCP Manager.

1. Select Start → Settings → Control Panel.
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2. Select the Network icon.

3. Select the Services tab.

4. Select DHCP Server Network Services → Add.

5. Re-install the service pack.

6. Continue with "Setting Up a DHCP Server" on page 25.

Setting Up a DHCP Server

Refer to Table 5 on page 20 and Table 4 on page 16 when using the following steps to se
up your DHCP/BOOTP server:

1. Select Start → Programs → Administrative Tools → DHCP Manager. 

The DHCP Manager Screen appears. 

2. Create a scope.

A scope defines a group of controllers you want to configure using the DHCP/BO
server.

a. Double-click Local Machine.

b. Select Scope → Create (Figure 6 displays).

Figure 6.  Create Scope Screen

c. Enter the starting and ending IP addresses of the controllers you are configurin
your network.
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For example, if you are configuring 50 controllers on a 153.79.144.0 subnet, yo
starting address should be set to 153.79.144.1 and your ending address should
to 153.79.144.50.

NOTE If each field does not contain a least three characters, you must press th
period key to advance to the next field. If you have only one controller
you still must add its address for both the starting and ending address

d. Enter your subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection perma

f. If you wish, you can add a Scope Name and Comment.

g. Select OK.

h. When you see that the scope has been successfully completed, select Yes to 
activate.

You are returned to the DHCP Manager screen.

3. Create vendor unique option entries. 

You will need to add all controller configuration options that are vendor specific in
DHCP Server's options list.

a. Select DHCP Options → Defaults. The Default Value screen displays.

b. Select New (Figure 7 displays). 

Figure 7.  Add Option Type Screen

c. Fill in the option's Name, Data Type, and Identifier fields. 
26 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook



 
le. 

); 

ress.

lue 
For example, the following options should be added:

NOTE Typically, the entries listed above will be all that you need to configure
the controllers. However, there are other configuration options availab
Consult th Table 5 on page 20 for a list of required and optional entries 
for the BOOTP server. Remember, you may have a maximum of four 
remote management and SNMP network management stations (NMS
that is, the combined total of tags 164 and 165.

d. Make sure the Array box is checked whenever the option you add is an IP add

e. Select OK. You are returned to Default Value screen. 

f. Repeat  Step b through  Step e until all options are added.

g. When you have added all Vendor Unique Options, select OK at the Default Va
screen.

You are returned to the DHCP Manager screen.

Name Data Type Identifier (Tag)

Remote Management Station IP address 164

Network Management Station IP address 165
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4. Configure global scope options. 

The scope options will allow you to configure settings that will be applicable to all
your controllers. Refer to Table 5 on page 20 to determine what parameters you want 
apply to the entire group.

  NOTE You can apply some options to specific controllers later using  Step 6 on 
page 30.

a. Select DHCP Options → Global (Figure 8 displays).

Figure 8.  Global Options Screen

b. Highlight any entry in th Unused Options list and select Add to move it to the 
Activ  Options list.

NOTE Each option is preceded by its tag number. A typical installation may 
include the following Global Options:

003 Router
164 Remote Management Station (RMS
165 Network Management Station (NMS)

c. Select Value to assign a value to the active option.

The Value option greys out and the Edit Array option box appears in the lower
of the screen.
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d. Select Edit Array if the value you need to add is an IP address (such as for a r
RMS, or NMS) (Figure 9 displays).

Figure 9.  IP Address Array Editor Screen

e. Enter the unique IP address for the option you added. Figure 9 shows an example o
adding the IP Address for an RMS.

NOTE If you do not know the IP address, but you know the Server name, yo
can use this field and the Resolve option to determine the correct IP 
address. 

f. Select Add to move it to the IP Address list.

g. Select OK. You are returned to the DHCP Options: Glo balscreen.

h. Repeat  Step b through  Step g until all global options are added.

i. When you have added all Global Scope Options, select OK at the DHCP Optio
Global screen. 

You are returned to the DHCP Manager screen.

5. Create a reservation for each controller. 

Use Table 4 on page 16 to make sure you include all the controllers for every RAID 
Controller in your network. This table contains your controller names and IP addre

a. Select Scope → Add Reservations.

b. In the IP Address field, enter the IP address for the first controller (in your table

c. In the Unique Identifier field, enter the hardware ethernet address for the sam
controller.

d. In the Client Name field, enter the controller's eight-character name.

e. Select Add. The screen resets and is ready for the next entry. 
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f. Repeat  Step b through  Step e for each controller in Table 3.

g. When all controllers have been entered, select Close.

You are returned to the DHCP Manager screen.

6. Configure Controller Specific Options. 

Creating a controller specific option allows you to associate a controller configura
entry with a specific controller added in Step 5. 

IMPORTANT If you already set an option as Global Scope, it applies to every contr
in this group and does not need to be added again here.

a. Select Scope → Active Leases Figure 10 displays). 

Figure 10.  Active Leases Screen
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b. Highlight any controller in the list.

c. Select Properties (Figure 11 displays).

Figure 11.  Client Properties Screen

d. Select Options. The DHCP Options: Reservations screen displays.

e. Highlight an entry in the Unused Options list and select Add to move it to the 
Activ  Options list.

f. Select Value to assign a value to the active option.

IMPORTANT You must add Option 012 Host Name for each controller, and enter th
controller’s name for the value.

g. Enter the information for the value of the option.

For example, for Host Name enter the controller name from Table 3 on page 16 in 
the String box. Or, select Edit Array if the value you need to add is an IP addre
(such as for a router, RMS, or NMS).

h. Repeat  Step e through  Step g until all specific options for this controller are adde

i. Select OK. 

You are returned to the Client Properties screen.

j. Select OK. 

You are returned to the Active Leas esscreen.

k. Repeat Step b through  Step h until all Controller Specific Options for every 
controller are added.

l. When you selected all controllers you want and added specific options, select OK at 
the Active Leases screen. 

You are returned to the DHCP Manager screen.
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7. Continue with "Verifying the TCP/IP Protocol and Setting Up the Host or DNS Tabl
on page 32.

Verifying the TCP/IP Protocol and Setting Up the Host 
or DNS Table

Use the following procedure to verify the TCP/IP Protocol is installed and to set up th
host or DNS (Domain Name Service) table. This is necessary to correspond your ne
controller name for the controllers with their IP addresses.

1. Verify the TCP/IP Protocol is installed and configured properly.

NOTE If the TCP/IP Protocol software is not installed, load it from your 
Windows N , Windows 95, or Windows 98 CD-ROM. Select Start → 
Settings → Control Panel → Network→ Protocols → Add Programs.

2. You must edit either the DNS (Domain Name Service) or your host table to add th
address and controller name for each controller on the network. Edit the two host 
found in the following directory/paths:

For example, to set up the host tables for the controllers connected to network 1 
(Figure 3 on page 14), use a text editor to create the following controller name and 
address entries:

Windows NT Windows 95 and Windows 98

c:\winnt\system32\drivers\etc\hosts c:\windows\host

c:\winnt\system32\drivers\etc\lmhostsc:\windows\hosts\lmhosts

127.0.0.01 localhos

153.79.144.13 beatr_1

153.79.144.14 beatr_2

153.79.144.11 beatr_3

153.79.144.12 beatr_4

153.79.144.15 beatr_5

153.79.144.16 beatr_6
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3. Continue with "Installing the Software" on page 33. 

Installing the Software

Use the following procedure to install the storage management software.

IMPORTANT You must have administrator privileges to access this software. This 
installation procedure requires you to restart the operating system. 
Therefore, make sure that other users are not on the system when 
installing this software.

1. Insert the Installation CD into your CD-ROM drive. 

NOTE In the following examples, c:\ is designated as your boot drive and d:\
designated as the CD-ROM device drive. Be sure to select the correc
drives for your system. 

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs.

b. Select Install, and then browse. 

c. When you see d:\networkd\netsymsm\setup.ex , select Finish. 

3. Follow the instructions on screen to complete the installation procedure.

IMPORTANT During installation, you will be prompted to define the directory path 
where you want this software installed. If you are defining your own 
directory path, do not use special characters for the directory name (su
as, #, $, or +). The default path is c:\Program Files\NetSYMsm. For th
purpose of providing examples of the installation requirements, this 
Installation Guide will refer to the default directory. 

4. When the installation is completed, remove the CD and restart the system.

5. After your system restarts, continue with "Verifying the Installation" on page 34.
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Verifying the Installation

Verify that the storage management software is installed, and that the Disk Array Mo
service is running.

1. To verify that the software has been installed, select Start → Programs. Networked 
SYMplicity Storage Manager appears in the list.

2. To verify that the Disk Array Monitor is running:

3. Continue with "Adding RAID Controller Information" on page 34.

Adding RAID Controller Information 

Since you are installing the storage management software for the first time, there are
RAID Controllers defined at this point. When you first select an application, you are 
prompted to add RAID Controllers. Using the information you compiled in Table 4 on 
page 16, define the RAID Controllers on your network by performing the following 
procedure:

1. Select the Maintenance/Tuning Application.

The No RAID Controllers Are Currently Defined screen appears.

2. Select OK to add RAID Controllers.

The Add screen appears (SeFigure 12).

Windows NT Windows 95 and Windows 98

Select Start → Settings → Control 
Panel → Services. The Disk Array 
Monitor is running if this service’s 
status is Started.

An icon appears in the service tray in the 
lower right corner of your screen. Move 
your cursor over the icon. A status message 
pops up indicating that the Disk Array 
Monitor is Running.
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Figure 12.  Add Module Screen

3. Enter the controller names for the first RAID Controller you defined in Table 4 on page 
16.

NOTE Now is also a good time to add information in the Comment field for e
RAID Controller. You may want to add location details, host-RAID 
Controller configuration, machine type, or other unique information to
further clarify the controller for future identification.

4. Select OK when the information is complete.

The Add Name screen appears (See Figure 13). The first RAID Controller will show 
the default name, Net Module 001.
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Figure 13.  Add Module Name Screen

5. Do one of the following:

After selecting OK, the Add screen appears again.

6. Repeat  Step 3 through  Step 5 for all the RAID Controllers on your network until you
have completed the list in Table 4 on page 16.

NOTE If you receive an error message when adding a new controller, you sh
use the symping utility to display possible reasons and suggestions fo
correcting the problem. 

7. When you have entered all controller and controller names from Table 4, select Cancel 
at the final Add screen.

To accept the default name, select OK
To define a new name for the module, enter 
the name (up to 16 characters) and select 
OK. Refer to Table 4 on page 16.
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The Select Module main screen appears (SeFigure 14).

8. Verify that this screen contains the correct number of RAID Controllers (usTable 4).

9. Continue with "Upgrading the Controller Firmware" on page 37.

Upgrading the Controller Firmware

1. Determine if you need to upgrade to the required controller firmware version:

a. Select RAID Controlle → Module Profile → Controllers.

b. Verify the boot and firmware levels meet the minimum requirement (seTable 19 
on page 85).

c. Select OK when finished viewing.

Figure 14.  Select Module Main Screen
Chapter 3. Installing the Software for the First Time 37



ath 

atch 
2. Do you have the minimum firmware version?

3. Upgrade your controller firmware now.

a. Select Maintenance/Tuning → Firmware Upgrade.

b. Select Offline.

c. Download the firmware files from this software CD-ROM. For example, at the p
line (assuming d: is your CD-ROM drive) type 
d:\networkd\firmware\03000105.apd + 03000103.bwd WHERE the numbers m
the firmware level to which you need to upgrade.

4. Continue with Chapter 4, “Operating System Support.”

Yes No

Go to  Step 4 on page 
38.

Continue with  Step 3 on 
page 38.
38 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook



Chapter 4. Operating System Support
cal 

). 

 a 

 

s 
eter 

 the 

er 
32 
This section contains information related to operating this software in the Windows 
operating environment.

Logical Units Supported

Understanding Logical Unit Support

The networked storage management software supports the creation of up to 32 logi
units per RAID Controller. However, in most cases, not all of them will be visible to th
I/O host machine (connected to the RAID Controllers with Fibre Channel connection
The actual number of logical units (LUNs) you can configure on a RAID Controller 
depends on two separate limits:

• Operating System — The operating system installed on the I/O host machine has
maximum number of logical units (LUNs) per RAID Controller that it supports. Fo
example, Windows NT limits the maximum number of LUNs per RAID Controller 
Unit to 32 (whether the module has a single controller or redundant controllers). 
Therefore, if you have a RAID Controller Unit with two active controllers, the total
number of LUNs between them cannot be more than 32. 

This limit is set with the System_MaxLunsPerController parameter in the rmparam
file and is set to support 32 LUNs by default. You should NOT change this param
setting unless every I/O host is limited to eight LUNs.

CAUTION Remember that with the System_MaxLunsPerController parameter in
rmparams file set to 32, the Configuration Application (Create LUN 
option) allows you to configure up to 32 LUNs for every RAID Controll
configured on the network whether the I/O host machine can support 
LUNs or not. 

Logical Units Supported page 39

Creating and Deleting Logical Unit page 40

Background Monitor page 41

Terms to Know page 42

Command Line Interface page 44

What’s Next? page 44
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If you have more than one I/O host machine connected to your modu
and any of them do not support 32 LUNs, you must be careful not to 
configure more LUNs on those modules than the host machine allows
you do, the host machine cannot send or receive data from those LUN

• Host Adapter — The host adapter (in the host machine) also has a maximum num
of LUNs it can support. For example, if you have four RAID Controllers and an eig
LUN-per-module limit, your host adapter needs to be able to support the total num
of LUNs (32 in this example).

Supporting 32 Logical Units

You need to first determine how many logical units are supported by the operating sy
on the I/O host machines connected to your RAID Controllers. Second, you need to 
determine how many LUNs are supported by the type of host adapters in the system

NOTE If you have another operating system on your host machine (other tha
Windows NT), consult the documentation appropriate to that operatin
system to determine the maximum number of LUNs supported.

Creating and Deleting Logical Units

After creating or before deleting logical units (LUNs) using the Configuration Applicat
in the networked storage management software, the I/O host operating system need
recognize the changes. For example, with Windows NT, a reboot is necessary.

Creating Logical Units

After creating LUNs you have to make them part of the I/O host operating system. S
your I/O host documentation for details on adding a drive. Remember each logical u
(not a drive group) is seen by the operating system as one drive.

CAUTION Remember that the Configuration Application (Create LUN option) 
allows you to configure up to 32 LUNs for every RAID Controller 
configured on the network whether the I/O host machine can support 
LUNs or not. If you have more than one I/O host machine connected 
your modules and any of them do not support 32 LUNs, you must be 
careful not to configure more LUNs on those modules than the host 
machine allows. If you do, the host machine cannot send or receive d
from those LUNs. 
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Deleting Logical Units

Before deleting LUNs with this software or using File → Reset Configuration, stop I/Os 
to the affected RAID Controller. Then, unmount any filesystems, delete any partitions
deassign any drive letters associated with the LUNs on your I/O host.

Background Monitor

The storage management software has a background monitor that automatically pol
RAID Controllers and checks for problems/events at a specified interval. If any probl
or events are detected, the information is written to the default log file. This become
historical record of past component failures, general status changes, and configurati
changes.

The checking interval can be changed from the default of every five minutes. For be
results, use the default value or smaller to ensure that you are notified about problem
events as close as possible to when they occur.

CAUTION Setting this value (Status → Options → Log Settings) too small could 
cause the check to affect system I/O performance. However, setting 
value too large could delay notification of serious problems.

Stopping the Disk Array Monitor Service

CAUTION You should only stop this monitoring service if you are specifically 
instructed to do so by Recovery Guru, the troubleshooting documenta
or your Customer Services Representative. However, doing so means
none of the RAID Controllers connected to the host will be checked 
during this time. Be sure to restart the monitor when instructed.

Windows NT Windows 95 and Windows 98

1 Select Start → Settings → Control 
Panel → Services.

2 Highlight the Disk Array Monitor 
Service 

3 Select Stop. When the status changes 
to Stopped, close the Services 
Application.

1 Double-click the icon in the service tray 
in the lower right corner of your screen. 

The icon changes and will now have the 
universal no symbol indicating that the 
monitoring service has been stopped.
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Starting the Disk Array Monitor Service

This background monitor automatically starts when you run the storage managemen
software. However, it will be necessary to manually start this process if you have stopped 
it for some reason. 

When you have manually stopped the background monitor, you have not been monit
for some period of time. We recommend that you run Recovery Guru/Heath Check to
make sure that no problems have occurred while you had the disk array monitor sto

Terms to Know

BOOTP Server

A network machine running the service that provides startup information. See "Setting Up 
the BOOTP Server" on page 19 for the required and optional entries.

Controller Name/ID

Also known as the device name, the controller name/ID is the controller name you cr
after the software installation procedure. The software uses these names to gain acc
each controller in the RAID Controllers connected to the network. Because each controller 
name must be unique, you can record its correspondence to a specific controller in a
Controller. See "Determining Names for RAID Controller Units and Controllers" on pa
18 for specific details and examples of creating these names.

Windows NT Windows 95 and Windows 98

1 Select Start → Settings → Control 
Panel → Services

2 Highlight the Disk Array Monitor 
Service. 

3 Select Start. When the status changes 
to Started, close the Services 
Application.

1 Double-click the icon in the service tray 
in the lower right corner of the screen. 

When you move your cursor over the icon, 
a message will pop up indicating that the 
Disk Array Monitor Service is Running.
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Hardware Ethernet Address

The hardware identification assigned by the manufacturer, also known as the MAC 
address. This number is located on the back of the controller (see Figure 4 on page 18). 
This unique address is required for configuring the BOOTP Server on your network. Se
"Determining the Hardware Ethernet Address" on page 17 for specific details on obtaining 
this address.

IP Address

The 32-bit identification defined by the Internet Protocol. It is usually represented in 
dotted decimal notation and can be obtained from your network administrator. This u
address is required for configuring the BOOTP Server on your network and setting u
host (or DNS) table. Se"Setting Up the BOOTP Server" on page 19 and "Verifying th
TCP/IP Protocol and Setting Up the Host or DNS Table" on page 32 for more information 
on using this address.

Module Names

By default, module names are assigned in the order in which the system detects th
module. The default name displayed is Net Module xxx, where xxx is a sequential 
number. You can choose to rename the modules; however, the software allows only 
characters, and each name must be unique. See "Determining Names for RAID Controller 
Units and Controllers" on page 18 for specific details and examples of creating these 
names.

NMS

Network Management Station, also known as a target. A remote network manager y
assign to receive SNMP traps.

RMS

Remote Management Station. The Windows N , Windows 95, or Windows 98 system
where the storage management software is installed and executed for the configurin
monitoring of RAID devices.

SNMP

The Simple Network Management Protocol (SNMP) notification is an option you ma
enable when installing this software. It allows this software to send remote notificatio
RAID events to a designated NMS using SNMP traps.
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SNMP Traps

An SNMP message type sent to an assigned NMS.

Command Line Interface

Certain text files were copied to the default installation directory (\netsymsm) during this 
software installation. These files provide supplementary information for storage 
management and administration. Some tasks are carried out automatically by servic
processes that run from system startup to system shutdown. There are also comma
utilities that make it possible to embed customized and/or interactive operations.

You can access these text files by typing (from the installation directory) help <filena
or by using any text editor to open and read them. For example, to read the file on th
drivutil command, from the installation directory, type: help drivutil.

For a list of these files and a description of the utility or program they describe, see th
User’s Handboo.

What’s Next?

Continue with "Chapter 5. Customizing the Installation" to make specific changes to the 
storage management software.
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This chapter describes how to customize your installation to run on your system.

Protecting Data with RDAC over the I/O Data 
Connection

It is possible to have failover protection over the I/O data connection if your host mac
is running Windows NT, is connected to the RAID Controller Units by Fibre Channel 
connection, and has the Redundant Disk Array Controller (RDAC) Driver installed. T
RDAC driver is available for installation from the software CD-ROM.

IMPORTANT RDAC protection is only available on host machines running 
Windows NT.

For RAID Controllers with redundant controllers, this host-based driver manages the
data path. If a component fails on the data path (interface cable/terminator, controlle
adapter, etc.) that causes the host to lose communication with a controller, the RDAC
driver automatically reroutes all I/O operations to the other controller.

CAUTION Do not install the RDAC driver before upgrading or installing the stora
management software. The installation procedure will remove any 
version of the RDAC driver. The RDAC driver will need to be installed
from this software installation CD.

Setting Up the Fibre Channel Host Adapters

If you are using a Fibre Channel connection to your RAID Controllers, you must set u
host adapters using the following procedure:

Protecting Data with RDAC over the I/O Data Connection page 45

Setting Up Scriptable Notification Options page 48

Understanding SNMP Notification page 48

Changing the rmparams File page 50

What’s Next? page 52
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1. Go to the HBA directory on this software installation CD.

2. Consult any readme file in that folder.

This file will give specific instructions on what you need to do to set up your Fibre 
Channel host adapter as well as the latest information on supported host adapter
drivers.

3. Continue with "Installing the Driver."

Installing the Driver

To provide RDAC failover protection, you need to install the RDAC driver on any Fib
Channel host machine (using either the single-host or multi-host RAID Controller 
configuration) that is connected to the RAID Controller. This host machine must have 
Windo wsNT installed.

IMPORTANT Close all other applications, and make sure that other users are not on the 
system when installing this driver.

1. Insert the installation CD into your CD-ROM drive on the host machine attached
via I/O data path connection to the RAID Controllers. (Depending on your networ
configuration, this machine may not be the same place where you installed the 
Networked storage management software.)

NOTE In the following examples, c:\ is designated as the boot drive and d:\ i
designated as the CD-ROM drive. Be sure to select the correct drive 
your system.

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs

b. Type d:\networkd\rdac\SETUP.EXE

c. Select Finish.

3. Follow the screen instructions.

4. Remove the CD when you see the Restart screen and select YES.

5. Select Start → Settings → Control Panel → Devices to verify the RDAC driver is 
installed.

The RDAC driver (symarray) is installed if this driver status is Started.
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IMPORTANT Before changing any NVSRAM values, it is a good idea to record the 
existing values for the offsets you are changing. Should you ever unin
the RDAC driver, you may need to refer to these values.

6. Use the Networked storage management software to change several NVSRAM se
after you install the RDAC driver. (Remember that this station may not be the same as 
the host where you installed the RDAC driver.) Type the following from the comm
line:

a. nvutil -n rdacon.def -vf <device_name>

WHERE

<device_name> is the name for the controller you designated when you added
RAID Controller to the Select Module list.

b. Make sure to issue this command to every controller in each module connected to 
the host where you installed the RDAC driver.

c. Turn off power to each RAID Controller, then turn it back on again for these 
settings to take effect.

d. Repeat this procedure for every host machine (running Windows NT) where you 
want the RDAC driver installed.

Uninstalling the Driver

Use the following procedure only if you want to remove the RDAC driver from your hos
machine.

IMPORTANT Close all other applications and make sure that other users are not on the 
system when uninstalling this driver.

1. If you do not intend to re-install this software and are not removing the RAID 
Controller from the network, you may need to restore your controller NVSRAM 
configuration. Refer to the values you recorded before installing the RDAC driver
download them to the controllers in your RAID Controller using fwutil.

2. To begin the uninstall program:

a. Select Start → Settings → Control Panel → Add/Remove Programs and scroll th
list to find SYMplicity RDAC Driver.

b. With SYMplicity RDAC Driver highlighted, select Add/Remove.

c. At the Uninstall Application screen, select OK to remove the software.
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You will see screens indicating the uninstall program is removing the appropria
service, registry information, and files.

3. At the Restart screen, select OK to shutdown and to restart the Windows NT sys

Setting Up Scriptable Notification Options 

The rmscript.bat file is accessed by the status monitor and automatic parity check 
whenever these utilities find an exception. By default, no action is taken. You can ed
file to specify a set of actions to take when an error is found.

For example, if you want to install third-party notification software to perform various
events (such as faxing or paging), you would add the appropriate script for each eve
the end of this file. Consult the third party software documentation for specific details

NOTE If you installed an upgrade of the storage management software, you
want to refer to the rmscript.ori file to determine if you want to make 
additional customized changes to the new file. Remember, the new fi
contains new script for this version, so you must not replace it with th
old file.

For more information, read the text file about rmscript.bat. From this software installa
directory, type: help rmscript.

Understanding SNMP Notification

Enabling SNMP

This software can provide remote notification of RAID events to a designated networ
management station (NMS) using Simple Network Management Protocol (SNMP) tr

Use the following procedure to set up the NMS, to understand the contents of an SN
trap message, and to enable or disable this notification option for each host.

1. Set up the NMS.

You only need to set up your designated NMS one time. Use the following procedure to
compile this software Management Information Base (MIB) into your NMS.

You want to enable SNMP
You do not want to enable SNMP at 

this time

Continue with Step 1. Go to "Changing the rmparams File" on 
page 50.
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NOTE The MIB was written to standard version 1 SNMP syntax. It was desig
specifically for the storage management software. It is not applicable to 
other vendors' RAID products.

a. Copy the \netsymsm\rm6traps.mib file to the network management station.

b. Follow the steps required by your specific network management station to com
the MIB.

NOTE For details on the required steps, consult your network administrator 
the documentation specific to the NMS product you are using.

2. Make sure the host system is connected to the network that has the NMS station

3. Enable this notification on your host. You must edit three parameters in th
\netsymsm\rmparams file so that the software will know where to direct the SNMP tr
messages when a RAID Event has occurred. 

4. Continue with "Changing the rmparams File" on page 50. 

Contents of an SNMP Trap Message

Refer to Table 6 for a description of the contents of an SNMP trap message.

IMPORTANT If the trap type is anything other than informational, you should use th
Status or Recovery Applications to get more information or specifi
instructions on how to remedy the problem. Do not remove the SNMP 
message until the problem has been corrected since most trap 
notifications associated with this software are not persistent.

Table 6: Contents of an SNMP Trap Message 

Item Description

Storage Management 
Software Station IP 
Address

The standard IP address dot notation for the storage management software
station.

Host Name The text name assigned to the host.
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Disabling SNMP 

Perform the following steps to disable this notification on your host and stop this soft
from sending SNMP traps:

1. In the \netsymsm\rmparams file, change the value of the SNMP_Action_Number line
to 0.

2. Save the rmparams file and copy it to the backup directory. It is critical that you ha
backup copy of this file.

3. Continue with "Changing the rmparams File" on page 50. 

Changing the rmparams File 

The \netsymsm\rmparams file is used to store several configurable options available 
through this software. Review Table 7 on page 51 for a list of the parameters in the file 
that you may need to change after initial installation.

IMPORTANT Most of these options (other than the ones shown in Table 7) should not 
be changed and many of the other options should only be changed 
through the graphical user interface (GUI). For more information, read

Trap Type There are four trap types:

• Informational  — No failure has occurred. Information is provided that an 
event, such as a logical unit creation, has occurred.

• Degraded Array — A subsystem component failure has occurred. The 
module is still operational but now lacks redundancy in some area. (For 
example, a drive failure resulting in a degraded logical unit, a power supp
failure, or a failure of one controller in a controller pair.)

• Failed Array  — A failure has occurred that leaves a module or logical unit
unable to communicate. (For example, a failure of the controller in a single
controller RAID Controller or a multiple drive failure resulting in a dead 
logical unit.)

• Critical  — This is a small category of failures that may require timely 
intervention to correct. (For example, the two-minute warning from an 
uninterruptible power supply or a warning that write-back cache has been
disabled due to a low battery.)

Affected RAID 
Controller

Indicates which RAID Controller had the event (for example, sonne_001).

Condition Description A brief description of the event that has occurred.

Table 6: Contents of an SNMP Trap Message  (continued)

Item Description
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the help file about rmparams. From this software installation directory
type: help rmparams.

You must edit the rmparams file to increase logical unit support and to
enable/disable SNMP notification.

Because of the critical nature of the rmparams file, you should make a
backup copy of the file in a directory other than the installation directo
If this file becomes corrupted or missing, you should copy the backup 
rmparams file to the installation directory to resume normal operation
Furthermore, if you make any changes to this file directly or use the 
options in the GUI that write to this file (such as log settings), always 
copy the new version of the file to the backup directory.

1. Make any necessary changes to the \netsymsm\rmparams file using Table 7.

2. Save the rmparams file, and copy it to a backup directory.

3. Continue with "What’s Next?" on page 52.

Table 7: Changeable Parameters in rmparams File 

Description When To Change How To Change

SNMP_Target_IP_Address=127.0.0.1 

Provides the SNMP IP Address 
for remote notification.

If you want to enable SNMP.

Edit the rmparams file and 
change this value to the dotted 
notation IP address of the 
network management system 
where the MIB has been 
compiled. On most systems, this 
IP address can also be a dotted 
notation multicast address or 
broadcast address.

SNMP_Community_Name=NONE

Provides the community name to 
be used for SNMP remote 
notification.

If you want to enable SNMP.

Edit the rmparams file and add 
the community name.

The most commonly used 
community name is public; 
however, your network 
environment may require 
another name.
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What’s Next?

Continue with "Chapter 6. Initial Startup Procedures" to ensure that the software operate
correctly and to determine if the current configuration meets your needs.

SNMP_Action_Number=0

Indicates the SNMP trap 
notification option you want to 
use.

If you want to enable SNMP.

Edit the rmparams file and 
change this value to either 1 or 2.

Value 1 will send SNMP traps to 
the designated NMS station. 
Value 2 means that all the 
relevant data is written to the file 
trap.dat.

IMPORTANT Setting this 
parameter to 0 will completely 
disable the SNMP option.

System_DefaultModuleSelect=TRUE

Determines whether or not the 
Select Module main screen 
displays each time you open an 
application.

If you want to change the 
default so that the Select 
Module main screen doenot 
display each time you open an 
application.

Edit the rmparams file and 
change TRUE to FALSE.

System_MaxControllers=200

Determines the maximum number 
of RAID Controllers supported by 
the software.

If you have more than 200 
RAID Controllers.

Edit the rmparams file and 
change the 200 to the 
appropriate number.

Table 7: Changeable Parameters in rmparams File  (continued)

Description When To Change How To Change
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This chapter contains the following procedures to ensure that the storage managem
software operates properly and to determine if your system configuration meets your
needs:

Setting the Preferred Fibre Channel Loop ID

If you are using a fibre channel arbitrated loop configuration, you can use the nvutil u
to set the preferred loop IDs for the controllers on the loop.

IMPORTANT You must specify a device name for the controller for which you want
set the preferred loop ID. Otherwise, the loop ID you specify will be 
assigned to every controller on the loop.

To set the preferred loop ID, type the following on the command line:

nvutil -i <Loop ID number> <device name>

Notes:

1 The <Loop ID number> is the preferred loop ID you want to set.

2 The <device name> is the device name for the controller.

You can select a value between 0 and 125 in hexadecimal. Loop ID 126 is reserved
FL Port or an N/FL Port. Loop ID 127 indicates that the device does not have a hard
preferred address. The loop ID is assigned an arbitration priority with 0 being lowest
126 being highest. Note that the loop ID is not the same thing as the Arbitrated Loop
Physical Address (AL PA), but rather an index to valid AL PAs.

Setting the Preferred Fibre Channel Loop ID page 53

Starting the Software page 54

Verifying Component Status page 54

Determining the Current Configuration page 56

Determining if Configuration Changes are Needed page 60

Changing Your Hardware Configuration page 63

What’s Next? page 64
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Bit 7 of Byte 3 is used to indicate one of two modes of operation. If bit 7 is set to 0, th
bits 6-0 specify a base value that is added to the Host Bus SCSI ID to create the Lo
If bit 7 is set to 1, then bits 6-0 indicate the loop ID.

Table 8: Fibre Channel Loop ID Byte Definition

Starting the Software

IMPORTANT You must have administrator privileges to access this software.

Start Windows if it is not already running. Select Start → Programs → Networked 
SYMplicity Storage Manager.

The application names appear in the Start menu. For a description of some key term
in the applications, se"Terms to Know" on page 42.

Continue with "Verifying Component Status" on page 54.

Verifying Component Status

Run Recovery Guru/Health Check

Use the following steps to ensure that the RAID Controllers (connected to the netwo
are all operational.

1. In the Select Module main screen, highlight All RAID Controllers and select OK.

Bit 7 6 5 4 3 2 1 0 Result 

Value

0 0x00 - 0x7f Loop ID Base 
(added to Host Bus 

SCSI ID)

1 0x00 - 0x7d Loop ID (Host Bus 
SCSI ID ignored)

1 0x7e No Loop operation 
(initializes as Point-
to-Point or Fabric 

only) 

1 0x7f No preferred address
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The main Status screen appears (see Figure 15) showing All RAID Controllers and 
Message Log selected.

NOTE With a new installation, you will be prompted to create a message log
Your default log file is new and no messages will appear until after an
event has occurred.

Figure  15.  Main Status Screen

2. Select Recovery Guru/Health Check.

The display area (see Figure 16) shows the summary results of the Recovery Guru/
Health Check on all of the RAID Controllers.

• If all of the RAID Controllers report an Optimal status, you are finished with thi
procedure. Go to "Determining the Current Configuration" on page 56.

• If any of the RAID Controllers report a status other than Optimal, continu
with Step 3.

3. Highlight that RAID Controller and select Show Details to determine the appropria
action to take. 

4. After correcting any problems, reselect Recovery Guru/Health Check until all RAID 
Controllers are Optimal. 

5. Continue with "Determining the Current Configuration" on page 56. 
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Figure  16.  Health Check Screen

Determining the Current Configuration

Now that you have successfully installed the software, you need to use it to identify 
RAID Controller connected to the network and determine the current modul
configuration (number of drives, number of controllers, logical units, etc.).

The software has assigned a name for each RAID Controller connected to the netwo
based on the information you supplied after installation. These designations are sho
the RAID Controller selection list near the top of each application screen (see Figure 17 on 
page 57).

Perform the following steps for each RAID Controller to identify the module and 
determine its current configuration. 

1. Use the following steps to view the current drive groups and logical units in a RAI
Controller.

a. Select the Configuration Application.

The Select Module Main screen appears. If you have more than one RAID 
Controller connected to the network, each RAID Controller appears in the list.

b. Make sure that the first RAID Controller is highlighted and select OK.
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The main configuration screen appears (seFigure 17 on page 57). The main 
configuration screen is composed of the following major areas:

• Module Information Area  — a directory tree structure showing RAID 
Controllers, controllers, drive groups, and LUNs. Clicking on the different ite
changes the display in the detailed information area on the right of the scre

• Detailed Information Area — provides information about the drive groups an
logical units in the RAID Controller. The information displayed depends on 
what is highlighted in the Module Information area.

 

Figure  17.  Main Configuration Screen
Figure 0-1

• Logical Unit (LUN) Information Area  — provides a summary of the logical 
units configured on the selected RAID Controller Unit. The Device Nam
column shows the controller name you assigned after installation.

c. At the main Configuration screen, view the current drive groups and logical un

As you highlight a drive group in the list on the left side of the main screen, the
corresponding logical units are highlighted in the Logical Unit Information area
the right side of the screen. You can only highlight one drive group at a time. Y
cannot select or highlight any item in the logical unit information list (it is 
information only).

2. Use the following steps to locate and label a RAID Module.

a. Select Locate Module → Start.

The activity lights flash on the appropriate drive modules. 
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b. Physically locate the RAID Module that has its activity lights flashing. Once yo
have identified the RAID Module, place a sticker label on it for future reference

For best results, have the module label include both the controller name (see Table 4 
on page 16) and the IP address for each controller in the module. For example,
RAID Controller called sonne_002 with two controllers might have the following
label:

sonne_002
son_ks1; 153.79.144.13
son_ks2; 153.79.144.14

c. Select Stop to stop the flashing of the activity lights.

3. Use the following steps to save and print RAID Controller profile information.

a. Select the desired RAID Controlle→ File → Save Module Profile. 

A screen shows the different types of information you can save.

b. Make sure All is selected (all of the buttons should be depressed), and select O
save all of the types of information.

A screen display prompts you to enter a filename.

CAUTION When using the Save Module Profile option in Step c., save the file to the 
same disk drive where the storage management software is installed
example, c:\). This is important because saving to a different disk driv
causes that disk drive to remain “open” which can cause the applicat
you are using to terminate or return error messages.

c. Enter an appropriate path and filename on the Selection line, and select OK.

d. The information is saved to the path and filename you specified.

e. Print the Module Profile information you saved in Step c. using your host system's 
printer utility.

4. Use the following steps to view a RAID Controller profile. (Optional)

a. Select the desired RAID Controlle→ Module Profile. 

A summary information screen appears (see Figure 18 on page 59) showing 
information about the controllers, drives, and logical units in the RAID Controll

b. Select Controllers, Drives, or LUNs for more detailed information on these 
components. 
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c. Select OK to exit the profile information.

5. Use the following steps to view details on specific drives in a drive group. (Option

a. If you want to know which specific drives comprise a particular drive group, 
highlight the drive group (in the Drive Groups area on the main screen) and se
List/Locate Drives.

b. Use the drive location information [x,y] provided in the list to physically locate 
individual drives in the module.

Remember that [x,y] corresponds to a specific drive in the RAID Controller, an
indicates the channel number and host-side ID for that drive, where the chann
number is always listed first. You can also select Locate to flash the drive activ
lights in the RAID Controller. 

c. Select OK to exit the drive information. 

Figure  18.  Main Module Profile Screen

6. Repeat Steps 1. through 3. (then 4. and 5. if desired) for each RAID Controller 
connected to the network.

7. You should have enough information to understand the current configuration for e
RAID Controller.

8. Continue with "Determining if Configuration Changes are Needed" on page 60. 
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Using the putntlog Utility

The putntlog command line utility included in the storage management software lets
write RAID events to the Windows NT Event Log. Use the following procedure to ena
putntlog:

1. Open the rmscript.bat file using a text editor.

2. Scroll down through the file until you find the following line:

rem putntlog %1

3. Delete the rem comment line.

4. Save and close the file

Determining if Configuration Changes are Needed

In the previous section (“Determining The Current Configuration) you should have 
performed the following tasks for each RAID Controller connected to the network:

Now, you need to determine if you need to make any changes to the configuration to
the requirements of your environment.

Use Table 9: and the Module Profile information you saved and printed to assist you in
determining if any changes are necessary.

Reviewed each module's current configuration (controllers, drives, and 
logical units/drive groups).

Step 1. on page 56.

Identified each RAID Controller using Locate Module, and placed a 
sticker label on it.

Step 2. on page 57.

Saved the Module Profile information to a file using
File → Save Module Profile, and printed the information.

Step 3. on page 58.

Table 9: Possible Parameters to Change 

Parameter Description Why Change? For More Details

General Parameters

Controller Mode

Maintenance/ 
Tuning 

Applicable controller 
modes are single active, 
active/passive, or active/
active.

If you have an active/
passive controller pair, 
you should consider 
changing it to active/
active for best 
performance.

• See the Maintenance/
Tuning chapter in the 
User’s Handbook.

• Use the online help for 
the Maintenance/
Tuning Application.
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Auto Parity 
Check/Repair

Maintenance/ 
Tuning → 
Options

An automatic parity check/
repair process runs each 
day at a specific time, or 
once a week.

Default is auto parity 
disabled.

If you want to enable the 
check/repair or change 
the time when it runs

• See the Maintenance/
Tuning chapter in the 
User’s Handbook.

• Use the online help for 
the Maintenance/
Tuning Application.

Monitoring 
Interval

Status → 
Options → Log 
Settings

The array monitor checks 
the RAID Controllers 
periodically looking for 
events and failures.

The default is to check 
every 5 minutes. 

If you want to increase or 
decrease the frequency 
of the checking interval. 
If you have a lot of 
modules, you may need 
to increase this interval 
because the amount of 
time needed to check and 
return results can 
increase.

• See the Status chapter 
in the User’s 
Handbook.

• Use the online help for 
the Status Application.

Hot Spare Drives

Configuration → 
Create Hot Spare

A hot spare drive is a drive 
containing no data that acts 
as a standby in case a drive 
fails in a RAID 1, 3, or 5 
logical unit.

The hot spare adds another 
level of redundancy to 
your RAID Controller.

If you want to create new 
or additional hot spare 
drives for added 
protection.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Logical Unit Parameter

RAID Level Or 
Number Of 
Drives

Configuration → 
Modify Group/
LUN → RAID 
Level 

or

Configuration → 
Delete, then 
Create LUN

Specifies how the data is 
striped across the drive
and how many drives 
comprise a drive group/
LUN.

If the current RAID 
Level is not appropriate 
for your environment, or 
you need to change the 
number of drives.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Table 9: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Segment Size

Configuration → 
Modify Group/
LUN → Segment 
Size

or

Configuration → 
Delete, then 
Create LUN → 
Options

Specifies in 512-byte 
blocks how much data is 
written to one drive before 
data is written to another 
drive in the group.

If the segment size is not 
appropriate for your 
environment.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Capacity

Configuration → 
Modify Group/
LUN → Capacity 

or

Configuration → 
Delete, then 
Create LUN → 
Options

Specifies in megabytes 
how much capacity is 
available on the logical 
unit.

If you want to increase or 
decrease the capacities.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Caching 
Parameters

Configuration → 
Create LUN → 
Options

Maintenance/
Tuning

Specifies the caching 
parameters for each logical 
unit.

If you want to enable or 
disable any of these 
parameters.

• See the Configuration 
chapter in the User’s 
Handbook if you are 
creating new logical 
units, or use the online 
help.

• See the Maintenance/
Tuning chapter in the 
User’s Handbook to 
change caching 
parameters on existing 
logical units, or use the 
online help.

Table 9: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Changing Your Hardware Configuration

Adding RAID Controllers

When you add a new RAID Controller to the network, you must follow many of the s
procedures you would use when installing the software for the first time. These tasks
include setting up the module and controller information for your BOOTP server and 
host table, and adding this information to the storage management software module
See the software online help for the procedure to follow.

Removing RAID Controllers

Be sure to remove the RAID Controllers using the storage management software be
physically removing them from the network. Otherwise, the software will continue try
to contact the controllers in that module. This is especially important because missin
modules could cause the software to have long delays or even system hangs while tr
contact the removed module. Also, if you are permanently removing a module from y
network, you should edit your BOOTP server and host (or DNS) table to remove this
module. See the software online help for the procedure to follow.

LUN Assignment 
and LUN 
Balancing

Configuration → 
Create LUN → 
Options

Maintenance/
Tuning 

Determines what controller 
owns which logical units/
drive groups.

To reassign or balance 
the logical units/drive 
groups between 
controllers in an active/
active pair.

• See the Configuration 
chapter in the User 
Guide if you are 
creating new logical 
units, or use the online 
help.

• See the Maintenance/
Tuning chapter in the 
User Guide to change 
LUN Assignments on 
existing logical units, 
or use the online help.

Reconstruction 
Rate

Maintenance/
Tuning

Determines how quickly 
reconstruction occurs on a 
logical unit when a failed 
drive is replaced.

To increase or decrease 
the reconstruction 
performance.

• See the Maintenance/
Tuning chapter in the 
User Guide.

• Use the online help for 
the Maintenance/
Tuning Application.

Table 9: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Adding Controllers

Always set up new RAID Controllers and their controllers in the BOOTP server and 
(or DNS) table. See "Summary of Preparation Tasks" on page 14 for the procedure to 
follow. Physically connect the new module to your network system and use Select Modul
→ Add to enter the required information for the module. See the software online help
the procedure to follow.

Removing Controllers

Before you remove any RAID Controller Unit (and its controllers) from the network, u
Select Module → Remove to remove the module information from the softwar
configuration. If you are permanently removing this module from your network, you 
should edit your BOOTP server and host (or DNS) table to remove this module. See
software online help for the procedure to follow.

Replacing Controllers

If you replace a failed controller, you need to determine its unique hardware etherne
address and replace only this entry in the BOOTP table. You should keep the same 
controller name and IP address to ensure that the host table remains correct. See th
software online help for the procedure to follow.

What’s Next? 

Troubleshooting

You can continue with "Chapter 7. Troubleshooting" for troubleshooting tips or common 
problems you may encounter as you use this software in the Windows operating 
environment.

User’s Handbook/Online Help

Now that you have successfully completed the installation of the software, refer to th
User’s Handboo and the online help for detailed information on how to use each 
application, and to make any changes that you determined are necessary in the pre
sections.
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This chapter contains the following sections:

Troubleshooting 

The troubleshooting tables that follow provide probable cause and action to take fo
specific problems you may have as you use the storage management software in th
networked operating environment. 

IMPORTANT If you cannot find the problem you are looking for, consult the Online 
Help for additional troubleshooting information. Also, see 
"Understanding the Restrictions" on page 2 for additional information.

Locating Solutions 

To quickly find the problem-solution you are looking for, use the following tables to loc
the problem you are having. It is possible for an entry to appear in more than one ta

• Category — organizes problems into general use or specific option groups page 66).

• Component — organizes problems by hardware components, such as controllers
drives, modules, etc. (page 66).

• Application — organizes problems for each storage management application, 
including a group for options common to all applications (page 68).

• Software — organizes problems by operating system, storage management softw
command line options (page 70).

Troubleshooting page 65

Replacing Controllers (Networked) page 82

Uninstalling the Software page 84
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Category

Groups problems into sections for general use or specific options. 

Component Search 

Organizes individual problems by hardware components, such as controllers, drives
LUNs, RAID Controllers, and so on. 

Table 10: Troubleshooting Entries by Category

Category See Page

"Configuration Application" 70

"Firmware Upgrade" 72

"General" 73

"Networked Troubleshooting Only" 79

"Recovery Guru/Health Check" 76

Table 11: Troubleshooting Entries Organized by Component 

Componen Problem See Details 

Controllers

Failed during alternate replacement 73

Firmware upgrade failed 72

LUN creation error after deleting all LUNs or using 
Reset configuration

71

Not visible to storage management software 74

Passive, no LUNs owned after replacement 78

Verify the network enable bit setting

Fans Failure detected after replacement 76
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Drives

 

Activity lights don’t flash (Configuration → List/
Locate Drives)

71

All drives failed in a drive group 78

Failed status, but LUN is Optimal 77

Fault light comes on after replacing failed drive 77

Fault lights lit (drives continue to fail) 77

Missing information in Manual Recovery → Drives 
screen

78

Number of drives incomplete or wrong during LUN 
creation

70

Removed drive; no failure reported 76

Status other than Optimal 77

LUN

Error message during LUN creation after deleting all 
LUNs or using Reset Configuration

71

Less capacity shows than selected during configuration 71

Missing information in Manual Recovery → LUNs 
screen

79

Not visible to storage management software 74

Number of drives incomplete or wrong during LUN 
creation

70

Optimal LUN status with failed drives 77

Reconstructing status appears, but no drives replaced 77

Status other than Optimal 77

Status remains Reconstructing 78

NVSRAM Settings Verify the network enable bit setting

Table 11: Troubleshooting Entries Organized by Component  (continued)

Componen Problem See Details 
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Application Search

Organizes individual problems for each storage management application, including a
group for options common to all applications. 

RAID Controllers

Failure detected after replacing fan or power supply 76

Listed after being removed 74

Network station cannot talk to the Module 79

Status other than Optimal 75

Status does not update after a recovery procedure 79

Power Supplies Failure detected after replacement 76

Table 12: Troubleshooting Entries Organized by Application 

Application Problem See Details On

Common To Any 
Application

Cannot select some options 74

“Cannot secure access to LUNs” message 75

Select Module lists a RAID Controller removed 
from the system

74

Status does not update after a recovery procedure 79

Configuration

Less capacity shows than selected during 
configuration

71

List/Locate Drives does not work 71

LUN creation error after deleting all LUNs or 
using Reset Configuration

71

Number of drives incomplete or wrong during 
LUN creation

70

Reset Configuration does not work 71

Status

Reconstructing status appears, but no drives 
replaced

77

Status remains Reconstructing 78

Table 11: Troubleshooting Entries Organized by Component  (continued)

Componen Problem See Details 
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Recovery

All drives failed in a drive group 78

Controller mode is Passive, no LUNs owned after 
replacement

78

Drive fault lights lit (drives continue to fail) 77

Drive status other than Optimal 76

Failed status, but LUN is Optimal 77

Fault light comes on after replacing failed drive 77

Failure detected after replacing fan or power 
supply

76

LUN status other than Optimal 77

Missing information in Manual Recovery → 
Drives screen

78

Missing information in Manual Recovery → 
Logical Units screen

79

Reconstructing status appears, but no drives 
replaced

77

Recovery Guru takes a long time 76

Removed drive, but Recovery Guru does not report 
a failure 

76

Status does not update after a recovery procedure 79

Status other than Optimal 75

Status remains Reconstructing 78

Maintenance/Tuning

Controller mode is Passive, no LUNs owned after 
replacement

78

Firmware upgrade failed 72

Table 12: Troubleshooting Entries Organized by Application  (continued)

Application Problem See Details On
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Software Search 

Organizes individual problems by operating system, storage management software,
command line options. 

Configuration Application 

Includes problems you may have as you use options in the Configuration Application

Table 13: Troubleshooting Entries Organized by Software 

Software Problem See Details On

Storage Management

“Cannot secure access to LUNs” message 75

Cannot select some options 74

Cannot start the software 73

Controllers/LUNs not visible 74

Failure detected after replacing fan or power 
supply

76

Network station cannot talk to the Module 79

“Not all files removed” message when uninstalling 
the software

73

RAID Controller listed after being removed 74

Command Line 
Batch file commands fail 73

Battery age does not reset for both controllers 75

Table 14: Configuration Changes Troubleshooting 

Number of Drives field (in the main Create LUN screen) show less than the number of drives in the 
unassigned drive group.

CAUSE There are two main reasons this number could be different than expected:

• This list shows only the maximum number allowed, which is a maximum of 30 drives in a drive grou

• There could be failed or unresponsive drives in the unassigned drive group. Failed drives are not
available for configuration; therefore, they are not displayed in this list.
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Less capacity shows than I selected during configuration.

When using 5+ drives to create a LUN, you could see a capacity slightly less than you selected dur
configuration; for example, you see 1.97 GB instead of 2 GB on a RAID 5, 9-drive LUN. This can oc
because the capacity you select is based on stripe size which depends on segment size times the n
of drives.

List/Locate Drives → Locate does not work.

CAUSE It is not possible to flash the drive activity lights for a particular drive group if any of the drive
has a status other than Optimal. For an explanation of possible drive statuses and recommended a
take, see the Online help.

ACTION Use Module Profile to verify that all drives are Optimal and try again. If any of the drives a
not Optimal, select Recovery Guru/Health Check (in the Recovery Application) to correct the proble

Reset Configuration does not work.

CAUSE If this software detects any drives as removed or unresponsive, Reset Configuration will no
work. Also, if the selected RAID Controller has an Independent Controller configuration, this option 
grayed out.

ACTION Use Module Profile to verify that all drives are Optimal and that the controller is not in an 
Independent Controller configuration (neither controller is marked Inaccessible). Try File → Reset 
Configuration again.

CAUTION Any time you use Reset Configuration, you will lose all data on your drives. Only select this 
option as a last resort if your configuration is inaccessible or you want to start over. You will need to u
Create LUN to re-configure your drive groups/LUNs.

LUN Creation error message is displayed after deleting all LUNs or using File → Reset 
Configuration.

CAUSE Most likely, the controller has 256 MB cache and requires a reset after deleting all LUNs/dri
groups before re-creating new LUNs/drive groups.

ACTION Turn off power to the affected RAID Controller. Turn power back on and try the LUN creat
procedure again.

Table 14: Configuration Changes Troubleshooting  (continued)
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Firmware Upgrade

Problems you may have in upgrading firmware. 

Table 15: Controller Firmware Upgrade Troubleshooting 

Firmware upgrade does not complete successfully

CAUSE This should not happen unless you try to perform some other activity on the module while 
upgrading controller firmware. If you are upgrading firmware to a redundant controller pair, the prog
bar reaches 50% very quickly after downloading a file to the first controller. However, it may take 
another couple of minutes to reach 100% if it is downloading to a second controller in the module. Dnot 
assume the controller has hung unless the firmware upgrade has not completed after ten minutes o

ACTION

• To avoid this problem, wait for the controller firmware upgrade to be completed before selecting an
other option or exiting Maintenance/Tuning.

• If it occurs, turn off power to the RAID Controller and turn it back on; then, immediately try to upgr
the firmware again.

IMPORTANT If you are not upgrading the firmware again immediately, check the firmware version o
the module controllers using Module Profile. The controller firmware could be in an unusable state i
some files completed the download process before the controller hung. In this case, your module w
perform properly until the firmware is upgraded.
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General 

General problems you could have in all applications. 

Table 16: Troubleshooting Generally Applicable to All Applications 

Cannot start the software.

CAUSE If the software does not load when you try to start it, the rmparams file may be corrupted or
missing from the installation directory (\program files\netsymsm).

ACTION

You may want to view the Windows NT Event Log (“Applications” log). This log might contain specif
information about missing files and/or executables.

1 Start Windows NT and try to start the software again. (See "Starting the Software" on page 54 if you 
need more information on starting this software.) 

2 If you had previously saved a backup rmparams file, copy it to the installation directory (default is 
\program files\netsymsm – be sure to select the appropriate directory on your system) and try to sta
the software again. 

IMPORTANT The rmparams file is required for normal operation of this software applications. 
Therefore, it is strongly advised that if you make any changes to this file, you should make a backu
copying the edited file to another directory.

3 If you still cannot start the software, run the clean.bat -all script to delete certain files that could be
hiding information from this software.

4 If you still cannot start the software, reinstall the software. 

Controller failed while bringing its alternate Online.

CAUSE You have a RAID Controller with two controllers, one is Offline and the other is Online 
(Optimal). When you bring the offline controller online, you could see the alternate controller Fail or
Offline. 

ACTION Bring the newly failed controller Online using the same procedure.

While uninstalling this software, “not all files were removed” message is displayed.

CAUSE If you see this message after performing the uninstall procedure (page 64), the auto parity check/
repair service was probably running. The software has been successfully uninstalled; however, ther
be some files that were not removed from the installation directory.

ACTION Delete any remaining files from the installation directory, then delete the directory.

Commands run in a batch file fail unexpectedly

CAUSE Utility commands such as fwutil or rdacutil -u that require a controller reboot may return bef
the controller is ready to accept commands. If the next command is executed before the controller i
ready to accept commands, the controller will return an error status.

ACTION Include a delay command in the batch file to allow enough time for the controller to finish 
action.
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Some controllers/logical units are not visible to storage management software, but are visible to the
host

CAUSE  It is possible that controllers or logical units might not be visible to the storage management 
software, but will remain visible to Windows NT. Any time an operation is being performed that requ
exclusive access to the logical units (LUNs), these LUNs may not appear on the screen except in the 
application where the operation was initiated. The software uses a file (\program 
files\netsymsm\lunlocks) to hide these LUNs from the other applications, so that no other operations c
be performed on them until the current operation is complete. 

IMPORTANT For example, if you started a format in the Recovery Application, these LUNs show a 
“Formatting” status in Recovery, but may not appear in any other application. Operations that requi
exclusive access include Delete for LUNs and Reset Configuration (Configuration); formatting a LU
with Options → Manual Recovery → Logical Units (Recovery); and Firmware Upgrade → Offline 
method (Maintenance/Tuning).

Should the utility/application holding the LUN lock come to an abnormal termination, these LUNs m
remain hidden from the other applications. 

ACTION

1 Wait for the operation to be completed, or perform operations on a different RAID Controller. 

2 If you still do not see controllers or LUNs that you know exist, do the following:

a Close all your applications and exit the storage management software completely.

b Run the clean.bat script to delete certain files that could be hiding information from this software

3 Restart the application where you had the problem and verify that the controller/LUNs are now vis

A RAID Controller is listed that I have removed from my system.

CAUSE The storage management software does not automatically remove modules from configuration; 
thus, a module you remove will continue to be listed in the RAID Controller Selection box and the 
Module Selection screen.

ACTION Use Select Module → Remove before physically removing the Module. See the online help
for the specific procedure to follow.

I Cannot select some options.

CAUSE Some options are grayed out or are unavailable because:

• The selected RAID Controller does not support that option.

• The option cannot be performed for the item you selected.

• The option is not active until you select some ite.

• The option is no longer applicable because a maximum has been reached.

ACTION Recheck your selection and try again.

For more specific information, see the Procedures section in the User Guide that describes the particular 
option, or consult Online Help, “Why Are Some Options Grayed Out?”

Table 16: Troubleshooting Generally Applicable to All Applications  (continued)
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Battery age did not reset for both controllers.

CAUSE When using raidutil to reset the battery age, this command affects only one controller at a ti

ACTION Perform the battery reset command (with raidutil) for each controller in a RAID Controller 
needed.

“Cannot secure access to the LUNs” message is displayed (operations won’t run for a selected 
RAID Controller).

CAUSE Most likely a second application has requested exclusive access to the selected RAID Cont
when some other application has already secured access. Many operations require exclusive acces
affected drive group/LUNs until its operation is completed (this software “locks” these components t
secure this access). 

ACTION Wait for any operation that has secured exclusive access to the LUNs to be completed be
performing another operation on the same RAID Controller.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration 
(Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and 
Firmware Upgrade → Offline method (Maintenance/Tuning). 

CAUTION If you are using more than one network management station, you must use caution whe
performing the tasks that need exclusive access to ensure that the two hosts do not send conflicting
commands to the controllers in the RAID Controllers.

Component/module status other than Optimal.

CAUSE Statuses other than Optimal can indicate many things and usually warrant attention becaus
module is not operating in a normal condition.

The most common causes are:

• At least one drive has failed.

• A drive has been replaced and is reconstructing.

• A logical unit is formatting.

• A controller has been placed offline or has failed.

• A module component had failed, such as a power supply or fan.

ACTION For Failed or Offline drives, Dead or Degraded logical units, or Dead controllers (or Offline
controllers that you did not place offline), select Recovery Guru/Health Check and follow the step-by
step procedure it provides. For an explanation of the possible drive, LUN, or controller statuses and
recommended action to take, see the online help.

IMPORTANT Do not rely only on logical unit (LUN) status information to determine if a recovery 
procedure is necessary. For example, if you have hot spares configured for a RAID Controller and a
fails, the hot spare takes over for the failed drive. Therefore, you have an Optimal LUN with a failed
drive. Depending on how many hot spares you have configured for the module, you can have multip
failed drives and still have an Optimal LUN or only a Degraded LUN.

Table 16: Troubleshooting Generally Applicable to All Applications  (continued)
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Recovery Guru/Health Check

Problems you may have in running Recovery Guru/Health Check or the Manual Rec
Options in the Recovery Application. 

Table 17: Recovery Guru/Health Check Troubleshooting 

Recovery Guru/Health Check results take a long time to display.

CAUSE Normally you see Recovery Guru/Health Check results in a few seconds. However, if you h
selected All RAID Controllers or there are I/O operations running, you might notice a delay. Also, th
could be instances where an unresponsive component or other status change affects the controller's
to provide a result in Recovery Guru/Health Check, although such occurrences are rare.

ACTION If you experience long delays in performing Recovery Guru/Health Check, you might try 
checking one RAID Controller at a time or selecting Recovery Guru/Health Check at a time of low 
system I/O.

NOTE A background check occurs at regular intervals for all RAID Controllers (results are logged 
Message Log); the default setting is five minutes. You can change the frequency of this check by us
Options → Log Settings.

Recovery Guru/Health Check does not report a drive failure when I remove a drive.

 If there is no I/O occurring for that drive, Recovery Guru/Health Check reports an Unresponsive Dr
If there is I/O occurring, the controller will fail the drive (and Recovery Guru/Health Check report
this, too).

CAUTION You should never remove drives from a module unless the controller has marked them as
failed. Doing so could result in data loss for the affected logical unit/drive group. If you suspect prob
with a drive, it is best to select Recovery Guru/Health Check and follow the instructions provided. 

Software detects a failure even after I replaced a fan or power supply (recover from a Module 
Component Failure).

CAUSE The software continues to report the condition as a failure for approximately ten minutes aft
replacing a fan or power supply due to the controller polling interval. 

ACTION Wait for the controller to poll the module (default is ten minutes) after performing this 
recovery procedure before reselecting Recovery Guru.

Drive status other than Optimal.

CAUSE You have a Failed, Offline, or Replaced drive (which is reconstructing), or a logical unit is be
formatted. For an explanation of possible drive statuses and any recommended action to take, see 
online help.

ACTION For Failed or Offline drives, select Recovery Guru/Health Check and follow the step-by-st
procedures provided. No action is required if the drives are Replaced or the LUN is Reconstructing
Formatting. However, if the drives remain Replaced and the LUN status was Dead, Recovery Guru/
Health Check may report the RAID Controller as Optimal. If this occurs, you need to manually begin
format process for the LUN/drive group (Options → Manual Recovery → LUN → Format).
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Drives continue to fail (fault lights lit). 

CAUTION It is possible that a drive channel has failed. A drive channel failure is indicated when al
drives on the same channel are Failed and/or Unresponsive. Depending how the logical units have
configured across these drives, the status of the logical units may be Dead, Degraded, or Optimal (
spare drives are in use).

ACTION Select Recovery Guru/Health Check and follow the step-by-step procedure given. 

Drive fault light came on after I replaced a failed drive.

CAUSE This light may come on momentarily when a drive in a RAID 1, 3, or 5 LUN begins 
reconstruction.

ACTION Wait a few minutes for the fault light to go off and the drive activity lights to begin flashing 
steadily. This indicates that reconstruction is occurring. The drive status changes to Replaced and t
logical unit status changes to Reconstructing.

However, if the fault remains on, select Recovery Guru/Health Check and follow the procedure prov

Failed Drive status appears, but logical unit status is still Optimal.

CAUSE A drive on the logical unit has failed and a hot spare has taken over for it.

NOTE To see if a hot spare is being used, use List/Locate Drives in the Configuration Application.
hot spare drive status is either In Use or Standby (not being used).

ACTION Select Recovery Guru/Health Check and follow the procedure provided.

Logical unit status other than Optimal.

CAUSE You have a Failed drive or a Replaced drive which is reconstructing, a logical unit is being 
formatted. For an explanation of possible logical unit statuses and any recommended action to take
the online Help. 

ACTION For Dead or Degraded logical units, select Recovery Guru/Health Check and follow the s
by-step procedures it provides for restoring the logical units. However, if the drives remain Replace
the LUN status was Dead, Recovery Guru may report the RAID Controller as Optimal. If this occurs
need to manually begin the format process for the LUN/drive group (Options → Manual Recovery → 
LUN → Format).

LUN status changed to Reconstructing, but no drives have been replaced.

CAUSE A hot spare has taken over for a failed drive and the data is being reconstructed on it. The l
unit status returns to Optimal as soon as reconstruction is completed.

Table 17: Recovery Guru/Health Check Troubleshooting  (continued)
Chapter 7. Troubleshooting 77
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LUN status does not change from Reconstructing.

CAUTION This could occur after a Manual Recovery task is completed, especially LUN 
Reconstruction, or because data was reconstructed on a hot spare (the hot spare drive becomes In 
LUN status changes to Reconstructing, but may not return to Optimal when reconstruction is comple

IMPORTANT If reconstruction was interrupted on a hot spare drive because another drive failed in th
same drive group/LUN, the LUN is probably Dead (with two Failed drives) and you have lost data. Y
should select Recovery Guru/Health Check and follow the procedure provided to replace the newly
failed drive.

ACTION Wait for the background monitor to run (default is five minutes) and to update the status, or

To update immediately, do one of the following:

• Reselect the RAID Controller. 

• Exit and re-enter the application.

All  Drives in a Drive Group fail.

CAUSE If all the drives in a configured drive group fail and are then physically replaced, Recovery 
Guru/Health check will still show the replaced drives as failed. Their status is not upgraded to Repla
although the LUN status will show Dead LUN.

ACTION In this case, follow the Recovery Guru/Health Check procedure to reformat the LUNs in th
drive group. 

IMPORTANT If you turn the power to the RAID Controller off and then on again, the LUNs in the driv
group are deleted, and the replaced drives are returned to the unassigned drive group, still failed. F
the procedure given in Recovery Guru/Health Check to recreate the deleted LUNs.

Controller mode is Passive and it does not own any LUNs after replacing a Failed controller.

CAUSE After using Recovery Guru/Health Check to replace the failed controller and Options → 
Manual Recovery → Controller Pairs to place it back Online, the controller is Optimal but in the Pass
mode rather than Active. This is most likely to occur for controller B. 

ACTION With the newly replaced controller Optimal, use Controller Mode → Change To Active/
Active (Maintenance/Tuning Application) to make the controller Active. You can either redistribute dr
groups/LUNs during this mode change, or later you can use LUN Balancing (Maintenance/Tuning 
Application) to assign specific drive group/LUNs to each active controller. 

Information is missing in the Options → Manual Recovery → Drives screen. 

CAUSE The drives for the selected RAID Controller are unassigned (that is, they are not part of a 
configured drive group). For these drives, there is no LUN, RAID Level, or logical unit status to repo
However, you should still see information for the drives’ location and status.

ACTION Select another module, or use the Configuration Application to create logical units using t
unassigned drives.

Table 17: Recovery Guru/Health Check Troubleshooting  (continued)
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Networked Troubleshooting Only

Problems related to working in the networked environment

No LUN information appears in the Options → Manual Recovery → Logical Units screen. 

CAUSE There are no configured logical units for the selected RAID Controller (that is, all the drives
unassigned). There is no LUN, drive group, RAID Level, or logical unit status to report.

ACTION Select another module, or use the Configuration Application to create logical units using t
unassigned drives.

Component status isn’t updated after a recovery procedure has been performed.

CAUSE A configuration change may not be detected yet. For example, a drive is failed, then replac
and its status becomes Replaced, but does not return to Optimal after reconstruction is completed.

ACTION Try selecting a different RAID Controller, then switching back and reselecting Option→ 
Manual Recovery, or exit, then reselect the Recovery Application.

Table 18: Troubleshooting Applicable to Working in the Networked Environment

The storage management software from a particular Remote Management Station (RMS) cannot 
make the connection to a RAID Controller.

CAUSE Remember that you can have a maximum of four RMS and SNMP stations. Each controller 
allows only four connections at once, and these connections last 24 hours since the last time the 
connection was used. Therefore, if a controller has already been contacted by four remote manage
stations, a fifth station requesting access within 24 hours would be rejected.

ACTION Turn off and turn on the RAID Controller. Remember, it is best to only configure a total of 
four RMS and NMS stations for any RAID Controller. 

Table 17: Recovery Guru/Health Check Troubleshooting  (continued)
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Takes a long time to start the software, and/or screens do not display any information for the 
selected RAID Controller.

CAUSE In the network environment, response time may be slower, so be patient. However, if it take
several minutes to load the program group or launch an application, then it is likely that some contro
Offline, Failed, or not configured properly in the network setup.

• If you do not see any information provided on screen, a controller in the selected module is not se
properly for the network.

• If you see information provided, some other module controller is not set up properly.

IMPORTANT If you ever physically remove a RAID Controller (and its controllers) from the network, 
make sure you also use Select Module → Remove to remove the module information from the software
configuration.

ACTION Verify that both controllers are present (controller names appear in Module Profile):

• If they are not present, verify the network path, and ensure the BOOTP table and host (or DNS) ta
are set up correctly for the network. See page 19 for detailed procedures.

• If they are present, run Recovery Guru/Health Check (Recovery Application) on All RAID Controll
to determine the status of the modules’ components.

A connect error message displays when trying to add a RAID Controller, such as, “Could not 
connect to the selected RAID Controller. Verify your host names and/or check your network 
connection.”

CAUSE  The remote management station is unable to connect to the specified controller.

ACTION Use symping (the network connection verification utility) to attempt to contact the RAID 
Controller or controller. The symping utility will display possible reasons for, or actions to take to res
these problems.

1 From the command line, type:

symping beatr_1

WHERE

beatr_1 is the name of the controller you designated when you added the RAID Controller to th
Select Module list.

2 If symping does not help resolve connecting the module, check the physical network connections
correct any associated problems.

Table 18: Troubleshooting Applicable to Working in the Networked Environment 
80 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook



 

otice 
 that 

 

be 

t 

fy 
the 

k 

ns that 
The system takes a long time to complete some operations, or you receive error messages that the
operation failed.

CAUSE In the network environment, response time may be slower, so be patient. However, if you n
many error messages (indicating that operations are not completing successfully), you should verify
a controller is not Offline or Failed, and that it is configured properly for the network (set up in the 
BOOTP table and host tables).

IMPORTANT If you ever physically remove a RAID Controller (and its controllers) from the network, 
make sure you also use Select Module → Remove to remove the module information from the software
configuration.

ACTION

1 Allow sufficient time for operations to complete. Remember that the network response time may 
slower, especially if you have 24 or more LUNs configured on the RAID Controller.

2 If you receive operation-failed error messages, use Message Log to verify there are no componen
problems on your modules.

3 Verify the controller is present (controller name appears in Module Profile). If it is not present, veri
the network path, and ensure the BOOTP table and host (or DNS) tables are set up correctly for 
network. See page 19 for detailed procedures.

4 If no other problems are indicated, try increasing the System_NetworkTimeout parameter in the 
rmparams file (this parameter determines the amount of time allowed for operations to complete 
successfully before the operation is failed):

• Edit the rmparams file to increase the amount of time allowed for operations to complete.

• Save the rmparams file and copy it to a backup directory.

NOTE If you change the System_NetworkTimeout parameter, you may want to change the networ
timeout tag (tag=163) set for the controller in the BOOTP table as well (see Table 5 on page 20).

“Another application has failed to release locked resources” message.

CAUSE If a storage management application has an abnormal termination while performing an 
operation, it is possible that the operation did not complete and resources remain locked. This mea
drive groups/LUNs or even controllers might not be visible or might have unknown states.

ACTION If you see this message, exit all applications and restart Windows.

Table 18: Troubleshooting Applicable to Working in the Networked Environment 
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Replacing Controllers (Networked)

General Guidelines

Use Recovery Guru/Health Check (Recovery Application) to diagnose and correct 
problems with your RAID Controller components. 

If you are replacing a failed controller, you need to determine the unique hardwar
ethernet address of the new controller and replace only this entry for the BOOTP Server. 
You should keep the same controller name and IP Address to ensure that the host (o
table remains correct.

Incompatible Firmware Detected 

You have replaced a controller and saw a message after the new controller was brou
Online telling you that incompatible firmware has been detected and to consult this 
section. 

Controller names disappear from the Active Leases window when the Reservation becomes 
Reservation in use. 

CAUSE Normally, when an administrator has set up a reservation for a BOOTP controller on a DHC
server, the Active Leases list includes the IP address, controller name, and Reservation. When a BO
controller gets an IP address, the Reservation changes to Reservation in Use, and the controller na
removed from the list. As a result, there is no identifier in the list to differentiate which IP address 
belongs to which controller.

ACTION Call Microsoft Technical Support to obtain the fix for this problem (Article ID: Q167708). O
you can refer to Table 4 on page 16 where you recorded the controller name and IP address.

An operation failed.

CAUSE If you have more than one network management station trying to gain exclusive access at t
same time to the same drive group/LUN, one operation will fail.

ACTION Wait for any operation that has secured exclusive access to the LUNs to be completed be
performing another operation on the same RAID Controller.

To prevent the problem, before beginning an operation that requires exclusive access, make sure th
stop all I/Os going to the RAID Controller and that no other users are on the system.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration 
(Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and 
Firmware Upgrade → Offline method (Maintenance/Tuning).

Table 18: Troubleshooting Applicable to Working in the Networked Environment 
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Problem Summary

The correct procedure for upgrading the controller firmware depends on the controlle
firmware versions of both controllers and the controller slot location of the replaced 
controller. Use the following steps to determine the correct procedure.

1. Using the Recovery Application, select Module Profile → Controllers and do the 
following:

• Record the controller name/ID for both controllers. Be sure to note which is 
currently controller A and which is controller B. You will need this information t
identify the controllers during this procedure.

• Record the firmware version of both controllers. Be sure to note which version
applies to the old controller and which to the new, replaced controller. You will 
need this information to determine the correct procedure to follow for upgradin
controller firmware.

• Record the ethernet and IP addresses for both controllers. You can use Select
Module if you have this information in the Comments field, or you can use the t
where you recorded this information during this software installation. You may 
want to record all other comments added for this module because this procedu
requires you to remove and add the module. 

2. Which controller slot location is the new, replaced controller placed in

In Slot A In Slot B

You may want to call your 
Customer Services Representative 
for additional support on this 
procedure.

Select only the replaced controller to 
upgrade the 3.X firmware using the 
normal procedure (Maintenance/
Tunin → Firmware Upgrade → 
Offline method).

Consult the User Handbook or online 
help for further details.
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Uninstalling the Software

Use the following procedure only if you want to remove the storage management sof
from your system.

IMPORTANT Close all other applications and make sure that other users are not on
system when uninstalling this software.

1. To begin the uninstall program:

a. Select Start Settings Control Panel Add/Remove Programs and scroll the list to find 
Networked SYMplicity Storage Manager.

b. With Networked SYMplicity Storage Manager highlighted, select Add/Remove

c. At the Uninstall Application screen, select OK to remove the software.

You will see screens indicating the uninstall program is removing the appropria
service, registry information, and files.

2. At the Uninstall Complete screen, select Yes to shutdown and restart the Window
system.
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Appendix A. Specifications
See 

g 
This appendix contains the following information: 

Hardware Specifications

This software has been tested with the following BOOTP servers:

• Microsoft DHCP BOOTP for Windows NT Server 4.0 with Service Pack 3 or later. 
"Using a DHCP Server" on page 24.

• A UNIX BOOTP Server (most of the examples and terminology in this book relatin
to a BOOTP server assume the UNIX Example).

Firmware Specifications

The storage management software requires a minimum controller firmware version 
depending on your controller model.

Hardware Specifications page 85

Firmware Specifications page 85

Table 19: Controller Firmware Requirements

Controller Type Required Firmware Level

4766 3.0 or later
© Copyright IBM Corp. 1998, 1999 85
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Notices

References in this publication to IBM products, programs, or services do not imply th
IBM intends to make these available in all countries in which IBM operates. Any 
reference to an IBM product, program, or service is not intended to state or imply tha
that IBM product, program, or service may be used. Subject to IBM’s valid intellectua
property or other legally protectable rights, any functionally equivalent product, progr
or service may be used instead of the IBM product, program, or service. The evalua
and verification of operation in conjunction with other products, except those express
designated by IBM, are the responsibility of the user.

IBM may have patents or pending patent applications covering subject matter in this
document. The furnishing of this document does not give you any license to these p
You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
N. Castle Drive
Armonk, NY 10504-1785
U.S.A.

Licensees of this program who wish to have information about it for the purpose of 
enabling: (i) the exchange of information between independently created programs a
other programs (including this one) and (ii) the mutual use of the information which h
been exchanged, should contact IBM Corporation, Department 80D, P.O. Box 12195
3039 Cornwallis, Research Triangle Park, NC 27709, U.S.A. Such information may b
available, subject to appropriate terms and conditions, including in some cases, pay
of a fee.

Trademarks

The following terms are trademarks of the IBM Corporation in the United States or o
countries or both:

IBM
Netfinity

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the
United States, other countries, or both.
© Copyright IBM Corp. 1998, 1999 87



 others.
Intel is a registered trademark of Intel Corporation.

Other company, product, and service names may be trademarks or service marks of
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Index 

A
automatic parity check/repair, described 61

B
background monitor

starting 42
stopping 41

batch file
delay command 73
fails unexpectedly 73

battery age reset
restriction 3
troubleshooting 75

blank screen
manual recovery

drives 78
logical units 79

BOOTP server
configuring 15
defined 42

BOOTP table
pre-installation task 15
sample entry 23

C
cannot secure access to LUNs message 75
capacity

less than expected 71
changes to support this softwar 13
changing

caching parameters 3
configuration parameters 60
rmparams file 50

channel failure 77
checking

hardware and softwar 5
clean.bat script

when to use 73, 74
command line interface 44

fwutil  73
raidutil 3, 5, 75

rdacutil 73
symping 80

component failures
unexpected 76

component status
unexpected 79

components required 5
configuration

changing parameters 60
resetting 71

Configuration Application
list/locate drives

locate won’t work 71
main screen illustrated 57
reset won’t work 71
restrictions 3, 4
troubleshooting 70

connect error message 80
controller name

editing 11
pre-installation task 15

controllers
firmware mismatch 82
incompatible software 82
IP address 15
LUN limits 39
mode

passive after replacing 78
not active after replacing 78
not visible 74
replacing notes 82
resetting battery ag 75
troubleshooting 73

D
deleting logical units

restrictions 4
directory, installation naming restriction 9, 33
disk array monito

starting 42
stopping 41
see also background monitor

DNS (Domain Name Service)
see host table

drives
failed 70
failures
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all in drive group 78
keep failing 77

fault light on 77
number for drive group

unexpected 70
removing 76
status

non-optimal 76
unresponsive 70, 71, 76

E
editing module and controller names 11
exclusive access 74, 75, 82

multi-host configuration and 75

F
failed drives 70

all in drive group 78
failed to create LUN 4
failed to release locked resources message 81
fans, replacing 76
fault light, drives 77
files

batch, failed 73
clean.bat 73, 74
lunlocks 74
see rmscript.bat

firmware
mismatch detected 82
online method restricted 3
upgrading

unsuccessful 72
fwutil command

restriction 73
see also command line interface

H
hardware ethernet address

defined 43
pre-installation task 15

hardware requirements 5
Health Check

how long it takes 76
main screen illustrated 56
see also Recovery Guru

host nam

labeling RAID Modules and 58
host table

pre-installation tasks 15
hot spare

described 61
in use 77
logical unit status and 77
troubleshooting 78

I
identifying module configuration 16
incompatible software detected 82
installation

before beginning 5
directory naming restriction 9, 33

IP address
defined 43
for SNMP 51
pre-installation tasks 15

L
locating solutions for problems 65
logical unit

balancing 3
cannot secure access messag 75
capacity

less than expected 71
changing parameters 60
fails to create 4
limit per module/controller 39
manual format restriction 5
not visible to software 74
parameters 70
status

non-optimal 75, 77
remains at reconstructing 78
shows reconstructing 77

lunlocks file 74

M
MAC address

see hardware ethernet address
Maintenance/Tuning Application

restrictions 3, 4
manual recovery

drives
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blank screen 78
logical units

blank screen 79
manually format LUNs 5
messages

cannot secure access to LUNs 75
connect erro 80
failed to release locked resources 81
not all files removed 73
see also trap messages

MIB file  48
mismatch firmware detected 82
module names

defined 43
Module Profile

main screen illustrated 59
module status

non-optimal 75
unexpected 79

N
network

slow 81
Network Monitor 2
NMS

defined 43
not all files removed message during uninstall 

73
notification

see rmscript.bat
number of drives

limitation 70
NVSRAM

changing setting for RDAC 47

O
online firmware upgrade, restricted 3

P
parameters

changing configuration 60
changing in rmparams fil 51
logical unit 60

parity check/repair, default auto setting 61
power supplies

replacing 76

preparing to install 5
problems, finding help 65

R
RAID Module

labeling 58
LUN limit per 39
removing configuration 74

raidutil
restriction 3

RDAC driver
installing 46

rdacutil command
restriction 73
see also command line interfac

reboot, required when 48
reconstruction

drive fault light 77
Recovery Application

restrictions 3, 4, 5
Recovery Guru 77, 78

removing modules 74
takes a long tim 76
troubleshooting 76

replacing controllers 82
firmware mismatch or incompatible soft

ware 82
reset configuration 71

doesn’t work 71
response time, slow 81
restrictions

batch file failed 73
can’t see controllers 74
cannot secure access to LUNs 75
LUN formatting 5
LUNs not visible 74
Save Module Profile 58
using Manual Recovery 5
with RDAC driver 46

rmparams
backup copy 50
changeable parameters 51

rmparams file
backup copy 73
missing 73

RMS
defined 43
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rmscript.bat
scriptable notification 48

S
Save Module Profile restriction 58
screen displays no information 80
screen illustrations

Configuration Application 57
Health Check 56
Module Profile 59
Status Application 55

scriptable notification
see rmscript.bat

Select Module
remove module restriction 80, 81

slow response tim 81
SNMP

defined 43
disabling 50
IP address 51
set up NMS and MIB 48
traps

defined 44
message contents 49

software
can’t view LUNs 74
doesn’t start 73
exclusive access required 74, 75, 82
incompatible versions detected 82
options grayed out 74
requirements 5
starting 54
support changes 13
takes a long time to start 80

solutions, locating 65
special characters, restriction 9, 33
starting

the software 54
status

non-optimal 76
unexpected 79

Status Application
main screen illustrated 55
troubleshooting

see also Health Check
see also Message Log

symping

see command line interface
System_NetworkTimeout parameter 81

T
task summary

changeable parameters in rmparams fil 51
configuring controllers on network 15
determining the current configuration 60
recording module and controller informa

tion 16
tasks for configuring controllers 15

trap messages
contents 49
defined 44
see also SNMP

troubleshooting
Configuration Application 70
failed drives 77
general for all applications 73
list/locate won’t work 71
locating solutions 65
replacing controllers 82

firmware mismatch 82
incompatible software 82

resetting battery ag 75
second controller fails 73
uninstalling 73
Windows NT 65

U
unassigned drives

failed 70
uninstalling

not all files removed message 73
unresponsive drives 70, 71, 76
User Guide, when to us 64
utilities

see command line interface

W
Windows NT

event log 73
LUN limits 39
troubleshooting 65
versions supported 5
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